Subject: Re: [Teas] [mpls] Generic LSP Yang

From: Lou Berger <[email-masked]>
Date: Thu, 05 Mar 2015 12:18:24 -0500

Hi Dhruv,
    Good stuff!  There's already some related work going on based on the
TE LSP drafts/work started in MPLS and now in the TEAS WG.  -- This was
mentioned at the TEAS interim too, see
http://www.ietf.org/proceedings/interim/2014/12/18/teas/minutes/minutes-interim-2014-teas-1

It looks like you don't completely overlap as you are also considering
non-TE LSPs. 

So I guess a basic question to answer is what is the relationship of the
models of TE and non-TE LSPs. e.g,
- a generic LSP model with parallel TE and non-TE sub models
- a generic LSP model with protocol specific models
- a generic LSP model with some mix of the above (which I think you are
proposing)
- no generic LSP model, and separate  TE and non-TE sub models
- etc

It's not clear to me how much value a generic model brings, but details
always help to clarify the situation.  

My preference would be to have more details on the non-TE models (to
compare against the TE model) before deciding on the need for / value of
a generic LSP model.

Lou

On 3/5/2015 11:48 AM, Dhruv Dhody wrote:
> Hi,
>
> Xian and I have created generic base yang model for LSPs. This model
> is expected to be augmented by seperate data model with specific
> signalling protocol and technology.
>
> See https://tools.ietf.org/html/draft-zhang-mpls-lspdb-yang-00
>
> Comments / Suggestions ?
>
> We need to work out the relationship with the rest of MPLS yang model
> which can be hashed out in Dallas.
>
> Regards,
> Dhruv / Xian
>
> Excuse the obvious nit with the LSP abbreviation expansion :P
>
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls
>

---

From: Lou Berger <[email-masked]>
Date: Thu, 05 Mar 2015 12:27:38 -0500

I should have made clear that my previous mail and stated preference was
as an individual. 

As TEAS co-chair: if you need a place to discuss the generic model in
Dallas, we're happy to have you in TEAS, and will complement our planned
TE model related discussion.  Clearly non-te LSP model specifics should
be discussed in their respective WGs. 

Lou

---

From: Dhruv Dhody <[email-masked]>
Date: Fri, 6 Mar 2015 12:00:29 +0000

Hi Lou,

> -----Original Message-----
> From: Teas [mailto:[email-masked]] On Behalf Of Lou Berger
> Sent: 05 March 2015 22:48
> To: Dhruv Dhody; [email-masked]
> Cc: [email-masked]; Zhangxian (Xian); TEAS WG
> Subject: Re: [Teas] [mpls] Generic LSP Yang
> 
> Hi Dhruv,
>     Good stuff!  There's already some related work going on based on the TE
> LSP drafts/work started in MPLS and now in the TEAS WG.  -- This was
> It looks like you don't completely overlap as you are also considering non-TE
> LSPs.

[Dhruv]: Yes, our aim is to go one level up and see if we can have a generic LSP yang model including TE and non-TE, as well any signaling protocol or lack thereof (static, SR).  

> - no generic LSP model, and separate  TE and non-TE sub models

[Dhruv]: Our aim is to explore and see if we have attributes common to all LSP irrespective of TE/non-TE; signaling protocol, Segment Routing and even PCEP to warrant such a generic LSP model. 

A possible overall relationship with the model is in the draft - 
                 +---------------+
                 | Generic LSPDB |
                 |   ietf-lspdb  |
                 +-------^-------+
                         |
         ---------------------------------------------
        |                |                |           |
        |                |                |           |
   +----+----+   +-------+-------+   +----+----+   +--+--+
   | LDP-LSP |   |    BGP-LSP    |   |  TE-LSP |   | SR  |
   |         |   |               |   |         |   |     |
   +---------+   +---------------+   +----^----+   +--^--+
                                          |           |
                                           -----------
                                          |           |
                                          |           |
                                     +----+----+   +--+--+
                                     | RSVP-TE |   | SR- |
                                     |         |   | TE  |
                                     +----^----+   +--^--+
                                          |           |
                                          |           |
                                           -----------
                                          |
                                     +----+----+
                                     |  PCEP   |
                                     |         |
                                     +---------+

> My preference would be to have more details on the non-TE models (to compare
> against the TE model) before deciding on the need for / value of a generic
> LSP model.

[Dhruv]: Yes, I think that would surely help. 
IMHO the ease of augmentation and having a generic base model is one of the key advantages of YANG, so we hope its a worthwhile exercise to explore the need for such a generic model instead of separate TE and non-TE models. 

Regards,
Dhruv

> Teas mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teas

---

From: "Susan Hares" <[email-masked]>
Date: Fri, 6 Mar 2015 07:06:30 -0500

Dhruv, Xian and Lou:

Thank you for working on the genric LSP work.  After the TEAS WG, could the
I2RS WG get a summary of your discussion.  

Sue Hares

-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of Dhruv Dhody
Sent: Friday, March 06, 2015 7:00 AM
To: 'Lou Berger'; Dhruv Dhody; [email-masked]
Cc: [email-masked]; Zhangxian (Xian); TEAS WG
Subject: Re: [Teas] [mpls] Generic LSP Yang

Hi Lou,

>     Good stuff!  There's already some related work going on based on 
> the TE LSP drafts/work started in MPLS and now in the TEAS WG.  -- 
> This was mentioned at the TEAS interim too, see
> http://www.ietf.org/proceedings/interim/2014/12/18/teas/minutes/minute
> s-
> interim-2014-teas-1
> 

[Dhruv]: Yes, our aim is to go one level up and see if we can have a generic
LSP yang model including TE and non-TE, as well any signaling protocol or
lack thereof (static, SR).  

> 
> So I guess a basic question to answer is what is the relationship of 
> the models of TE and non-TE LSPs. e.g,

[Dhruv]: Our aim is to explore and see if we have attributes common to all
LSP irrespective of TE/non-TE; signaling protocol, Segment Routing and even
PCEP to warrant such a generic LSP model. 

> 
> It's not clear to me how much value a generic model brings, but 
> details always help to clarify the situation.
> 
> compare against the TE model) before deciding on the need for / value 
> of a generic LSP model.

[Dhruv]: Yes, I think that would surely help. 
IMHO the ease of augmentation and having a generic base model is one of the
key advantages of YANG, so we hope its a worthwhile exercise to explore the
need for such a generic model instead of separate TE and non-TE models. 

Regards,
Dhruv

> > We need to work out the relationship with the rest of MPLS yang 
> > model which can be hashed out in Dallas.
> >
> > Regards,
> > Dhruv / Xian
> >

---

From: Lou Berger <[email-masked]>
Date: Fri, 06 Mar 2015 09:05:09 -0500

Dhruv,

On 03/06/2015 07:00 AM, Dhruv Dhody wrote:
> [Dhruv]: Yes, our aim is to go one level up and see if we can have a
> generic LSP yang model including TE and non-TE, as well any signaling
> protocol or lack thereof (static, SR).
> 

Understood.  BTW non-signaled TE is still part of TE architecture and
the yang model work underway in TEAS. (TP, and to some degree PCE really
made this point clear.)

> [Dhruv]: Our aim is to explore and see if we have attributes common
> to all LSP irrespective of TE/non-TE; signaling protocol, Segment
> Routing and even PCEP to warrant such a generic LSP model.
> 

Sure. PCE driven TE LSPs are in scope of the generic TE YANG models
being developed.   PCEP protocol specifics belong to PCE.

> A possible overall relationship with the model is in the draft - 

Glad to hear we're in agreement.

> IMHO the ease of augmentation and having a generic base model is one
> of the key advantages of YANG, so we hope its a worthwhile exercise
> to explore the need for such a generic model instead of separate TE
> and non-TE models.
> 
The details of each will certainly demonstrate the degree of overlap.

Thanks,
Lou

---

From: Igor Bryskin <[email-masked]>
Date: Fri, 6 Mar 2015 13:11:28 +0000

Druv,

IMHO TE-LSP, LDP-LSP and SPRING-LSP have nothing in common. They should have totally independent models each being developed in respective WG.

Igor

-----Original Message-----
From: mpls [mailto:[email-masked]] On Behalf Of Dhruv Dhody
Sent: Friday, March 06, 2015 7:00 AM
To: 'Lou Berger'; Dhruv Dhody; [email-masked]
Cc: [email-masked]; Zhangxian (Xian); TEAS WG
Subject: Re: [mpls] [Teas] Generic LSP Yang

Hi Lou,

Regards,
Dhruv

---

From: Robert Raszuk <[email-masked]>
Date: Sat, 7 Mar 2015 12:47:44 +0100

I would agree with Igor.

Other then name overlap those are completely different technologies and
artificially putting them under "LSP" umbrella just does not bring any
value, but only confuses things even more.

Q: What SPRING-LSP has anything in common with "label" when you use v6
header ?

If you want to search for some commonalities let's remove LDP-LSPs from
this mix (as the is not relevant) and leave TE-LSP & SPRING + maybe also
add BIER as well as change the name to Generic-EP (Engineered Paths).

I see no value of goruping based on the fact that data plane uses mpls
labels, but rather I would see reasonable to provide models based on the
transport path characteristics for the traffic it is to carry.

Best,
r.

On Fri, Mar 6, 2015 at 2:11 PM, Igor Bryskin <[email-masked]>
wrote:

> Druv,
>
> IMHO TE-LSP, LDP-LSP and SPRING-LSP have nothing in common. They should
> have totally independent models each being developed in respective WG.
>
> Igor
>

---

From: Loa Andersson <[email-masked]>
Date: Sat, 7 Mar 2015 21:18:23 +0800

Robert,

From one perspective I agree with you and Igor, however if you think about MPLS LSPs, from a data plane perspective - and that is where OAM operates, there almost no difference between a TE-LSP a LDP-LSP and a SPRING MPLS LSP come very close. 

If you the other hand think of LSPs for other data planes the "nothing in common" is an almost true statement. From that point of view I think different models are where we will end up, but I also think that we need "separation with moderation". 

 But nothing is so simple that we can capture it in one very simple statement, we have hacking away on this for 30 years now, I'd advice taking architecture and history into consideration, as well as viewing the sky from a different perspective than from the bottom of a deep well.

Let me also say that I'm very supportive of all the good work going on in this area. 

/Loa

Sent from my iPad

> On 07 Mar 2015, at 19:47, Robert Raszuk <[email-masked]> wrote:
> 
> 
> I would agree with Igor.
> 
> Other then name overlap those are completely different technologies and artificially putting them under "LSP" umbrella just does not bring any value, but only confuses things even more. 
> 
> Q: What SPRING-LSP has anything in common with "label" when you use v6 header ? 
> 
> If you want to search for some commonalities let's remove LDP-LSPs from this mix (as the is not relevant) and leave TE-LSP & SPRING + maybe also add BIER as well as change the name to Generic-EP (Engineered Paths).
> 
> I see no value of goruping based on the fact that data plane uses mpls labels, but rather I would see reasonable to provide models based on the transport path characteristics for the traffic it is to carry.  
> 
> Best,
> r.
> 
> 
>> On Fri, Mar 6, 2015 at 2:11 PM, Igor Bryskin <[email-masked]> wrote:
>> Druv,
>> 
> Rtg-yang-coord mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtg-yang-coord

---

From: "Shah, Himanshu" <[email-masked]>
Date: Sat, 7 Mar 2015 10:19:13 -0500

I agree with Robert and Igor, putting everything in the same bucket because of common data plane & OAM does not justify.
We wouldn’t consider doing same for IP data plane..
I think we need to separate these models and as mentioned earlier, there is already work going on in respective WGs.

Thanks,
himanshu

From: mpls [mailto:[email-masked]] On Behalf Of Loa Andersson
Sent: Saturday, March 07, 2015 8:18 AM
To: [email-masked], [email-masked], [email-masked]
Subject: Re: [mpls] [Rtg-yang-coord] [Teas] Generic LSP Yang

Robert,

/Loa

Sent from my iPad

On 07 Mar 2015, at 19:47, Robert Raszuk <[email-masked]<mailto:[email-masked]>> wrote:

I would agree with Igor.

Best,
r.

On Fri, Mar 6, 2015 at 2:11 PM, Igor Bryskin <[email-masked]<mailto:[email-masked]>> wrote:
Druv,

Igor

_______________________________________________
Rtg-yang-coord mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtg-yang-coord

---

From: Loa Andersson <[email-masked]>
Date: Sun, 08 Mar 2015 17:27:54 +0800

Himanshu, et.al.,

I think there are two issues here and if sorting them out corrrectly
we are very close.

The first issue is similarities between different types of LSPs.

Here I said that, at least for a MPLS PSN, there are similarities,
e.g. the data plane is (nearly) the same. This was said in reaction
to Igor's statement "IMHO TE-LSP, LDP-LSP and SPRING-LSP have nothing
in common." I still don't think that Igor's statement is really correct.
If he had said "IMHO there are not enough similarites between TE-LSP,
LDP-LSP and SPRING-LSP to motivate a common model". I think that we be
a much more accurate statement.

And that is the other issue - Is it reasonable to model TE-LSP,
LDP-LSP and SPRING-LSP in the same model? I don't not think it is,
but that we need an overlap of people working with the different models.

Hope this is clear enough.

/Loa

On 2015-03-07 23:19, Shah, Himanshu wrote:
> /I agree with Robert and Igor, putting everything in the same bucket
> because of common data plane & OAM does not justify./
>
> /We wouldn’t consider doing same for IP data plane../
>
> /I think we need to separate these models and as mentioned earlier,
> there is already work going on in respective WGs./
>
> //
>
> /Thanks,/
>
> /himanshu/
>
> //
>
> //
>
> //
>
> *From:*mpls [mailto:[email-masked]] *On Behalf Of *Loa Andersson
> *Sent:* Saturday, March 07, 2015 8:18 AM
> *To:* [email-masked], [email-masked], [email-masked]
> *Subject:* Re: [mpls] [Rtg-yang-coord] [Teas] Generic LSP Yang
>
> Robert,
>
>  From one perspective I agree with you and Igor, however if you think
> about MPLS LSPs, from a data plane perspective - and that is where OAM
> operates, there almost no difference between a TE-LSP a LDP-LSP and a
> SPRING MPLS LSP come very close.
>
> If you the other hand think of LSPs for other data planes the "nothing
> in common" is an almost true statement. From that point of view I think
> different models are where we will end up, but I also think that we need
> "separation with moderation".
>
>   But nothing is so simple that we can capture it in one very simple
> statement, we have hacking away on this for 30 years now, I'd advice
> taking architecture and history into consideration, as well as viewing
> the sky from a different perspective than from the bottom of a deep well.
>
>     Other then name overlap those are completely different technologies
>     and artificially putting them under "LSP" umbrella just does not
>     bring any value, but only confuses things even more.
>
>     If you want to search for some commonalities let's remove LDP-LSPs
>     from this mix (as the is not relevant) and leave TE-LSP & SPRING +
>     maybe also add BIER as well as change the name to Generic-EP
>     (Engineered Paths).
>
>     I see no value of goruping based on the fact that data plane uses
>     mpls labels, but rather I would see reasonable to provide models
>     based on the transport path characteristics for the traffic it is to
>     carry.
>
>     Best,
>
>     r.
>
>     On Fri, Mar 6, 2015 at 2:11 PM, Igor Bryskin
>     <[email-masked] <mailto:[email-masked]>> wrote:
>
>     Druv,
>
>     IMHO TE-LSP, LDP-LSP and SPRING-LSP have nothing in common. They
>     should have totally independent models each being developed in
>     respective WG.
>
>     Igor
>
>     [email-masked] <mailto:[email-masked]>

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: Robert Raszuk <[email-masked]>
Date: Sun, 8 Mar 2015 11:58:12 +0100

Hi Loa,

The way I read Igor statement and agreed with it in a sense of "nothing in
common" was that it was referring to the control plane.

The subject of this thread is "Generic LSP YANG" and to me Yang model
describes control aspect of protocol or functionality not the choice of
forwarding header in the data plane.

So if you and others agree we should be all in sync and perhaps we could
consider as proposed before Generic Engineered Path model branching at the
lower layer between unicast and multicast.

However if you still think that Yang is about data plane and OAM then
perhaps we have a bigger issue here ....

Cheers,
R.

---

From: Igor Bryskin <[email-masked]>
Date: Sun, 8 Mar 2015 13:29:11 +0000

Hi guys,

Robert, your interpretation is spot on. Considering the context (the statement was made in response to Druv's email) I don't see how it could be read differently.

LSP model defines how we configure, manipulate an LSP, interpret its parameters, stuff like that. This means the management and control planes.
It is important to keep in perspective why do we do this modelling in IETF. In his presentation on MPLS/SDN 2014 conference Kireeti said that in MPLS networks we have achieved full interoperability in data plane and sufficient one in control plane. The problem and perpetual pain for operators is that each vendor exposes very different interfaces and tools to configure and manage the services. Contemporary management protocols like NETCONF in conjunction with standardized models will solve this.
 However, we do not attempt to (re-)model the data plane, right?

Cheers
Igor
________________________________________
From: mpls [[email-masked]] on behalf of Robert Raszuk [[email-masked]]
Sent: Sunday, March 8, 2015 6:58 AM
To: Loa Andersson
Cc: [email-masked]; [email-masked]
Subject: Re: [mpls] [Teas]  [Rtg-yang-coord] Generic LSP Yang

Hi Loa,

The way I read Igor statement and agreed with it in a sense of "nothing in common" was that it was referring to the control plane.

The subject of this thread is "Generic LSP YANG" and to me Yang model describes control aspect of protocol or functionality not the choice of forwarding header in the data plane.

So if you and others agree we should be all in sync and perhaps we could consider as proposed before Generic Engineered Path model branching at the lower layer between unicast and multicast.

However if you still think that Yang is about data plane and OAM then perhaps we have a bigger issue here ....

Cheers,
R.

On Sun, Mar 8, 2015 at 10:27 AM, Loa Andersson <[email-masked]<mailto:[email-masked]>> wrote:
Himanshu, et.al<http://et.al>.,

/Loa

//

/Thanks,/

/himanshu/

//

//

//

*From:*mpls [mailto:[email-masked]<mailto:[email-masked]>] *On Behalf Of *Loa Andersson
*Sent:* Saturday, March 07, 2015 8:18 AM
*To:* [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>
*Subject:* Re: [mpls] [Rtg-yang-coord] [Teas] Generic LSP Yang

Robert,

Let me also say that I'm very supportive of all the good work going on
in this area.

/Loa

Sent from my iPad

On 07 Mar 2015, at 19:47, Robert Raszuk <[email-masked]<mailto:[email-masked]>
<mailto:[email-masked]<mailto:[email-masked]>>> wrote:

    I would agree with Igor.

    Q: What SPRING-LSP has anything in common with "label" when you use
    v6 header ?

    Best,

    r.

    On Fri, Mar 6, 2015 at 2:11 PM, Igor Bryskin
    <[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>> wrote:

    Druv,

    Igor

    _______________________________________________
    Rtg-yang-coord mailing list
    [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>
    https://www.ietf.org/mailman/listinfo/rtg-yang-coord

_______________________________________________
Teas mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/teas

--

Loa Andersson                        email: [email-masked]<mailto:[email-masked]>
Senior MPLS Expert                          [email-masked]<mailto:[email-masked]>
Huawei Technologies (consultant)     phone: +46 739 81 21 64<tel:%2B46%20739%2081%2021%2064>

---

From: Lou Berger <[email-masked]>
Date: Sun, 08 Mar 2015 09:56:53 -0400

>  However, we do not attempt to (re-)model the data plane, right?

Really?  I don't see a TP LSP that is managed without control plane as
out of scope...

Lou

---

From: Loa Andersson <[email-masked]>
Date: Sun, 08 Mar 2015 22:01:27 +0800

Lou,

> Really?  I don't see a TP LSP that is managed without control plane as

No it is not out of scope - at least not until we decide so - but the
crue here that the mpls-tp data plane and mpls data plane are identical,
so the mpls data plane is also in scope.

So there is sure something to discuss around the the different types of
LSPs and the differences and commonalities.

/Loa

--

---

From: Robert Raszuk <[email-masked]>
Date: Sun, 8 Mar 2015 16:15:09 +0100

Hi Lou,

TP-LSP have a real control plane. It is a centralized one.

You don't need distributed control plane to call it as such.

However tht is still far from data plane which I hope this discussion has
really nothing in common with.

Best,
R.

---

From: Loa Andersson <[email-masked]>
Date: Sun, 08 Mar 2015 23:24:02 +0800

Robert,

The jury is not out on this - if you want to split hair do that -
but RFC 5654 says:

    22  MPLS-TP MUST support the capability for network operation via the
        management plane (without the use of any control-plane
        protocols).  This includes the configuration and control of OAM
        and recovery functions.

The odd thing about this is that I'm not particulary fond of running my
networks without a control plane :) ! But I must live with what is out
there.

/Loa

On 2015-03-08 23:15, Robert Raszuk wrote:
> However tht is still far from data plane which I hope this discussion
> has really nothing in common with.
>
> Best,
> R.
>
> On Mar 8, 2015 2:57 PM, "Lou Berger" <[email-masked]
> <mailto:[email-masked]>> wrote:
>

--

---

From: Robert Raszuk <[email-masked]>
Date: Sun, 8 Mar 2015 16:29:15 +0100

Loa,

The quote you brought says "control-plane protocols" not "control-plane".

That is here a big difference.

Rgs,
R.

---

From: Igor Bryskin <[email-masked]>
Date: Sun, 8 Mar 2015 15:31:50 +0000

Neither do I. But what this has to do with the data plane?
________________________________________
From: Lou Berger [[email-masked]]
Sent: Sunday, March 8, 2015 9:56 AM
To: Igor Bryskin; Robert Raszuk; Loa Andersson
Cc: [email-masked]; [email-masked]
Subject: Re: [mpls] [Teas]  [Rtg-yang-coord] Generic LSP Yang

Lou

---

From: Igor Bryskin <[email-masked]>
Date: Sun, 8 Mar 2015 15:39:57 +0000

Exactly
________________________________________
From: [email-masked] [[email-masked]] on behalf of Robert Raszuk [[email-masked]]
Sent: Sunday, March 8, 2015 11:15 AM
To: Lou Berger
Cc: [email-masked]; Loa Andersson; Igor Bryskin; [email-masked]
Subject: Re: [mpls] [Teas] [Rtg-yang-coord] Generic LSP Yang

Hi Lou,

However tht is still far from data plane which I hope this discussion has really nothing in common with.

Best,
R.

On Mar 8, 2015 2:57 PM, "Lou Berger" <[email-masked]<mailto:[email-masked]>> wrote:

Lou

---

From: Loa Andersson <[email-masked]>
Date: Sun, 08 Mar 2015 23:46:30 +0800

Robert,

I will rest the case now, just two more points

- if you have protocols that constitute a control plane, why aren't
   they control plane protocols

- Same RFC as before "Note that it MUST be possible to operate an
   MPLS-TP network without using a control plane."

/Loa

On 2015-03-08 23:29, Robert Raszuk wrote:
> On Mar 8, 2015 4:24 PM, "Loa Andersson" <[email-masked] <mailto:[email-masked]>>
> wrote:
>
>     Robert,
>
>         <mailto:[email-masked]>
>         <mailto:[email-masked] <mailto:[email-masked]>>> wrote:
>
>         _________________________________________________
>         Teas mailing list
>         [email-masked] <mailto:[email-masked]>
>         https://www.ietf.org/mailman/__listinfo/teas
>         <https://www.ietf.org/mailman/listinfo/teas>
>
>
>     --
>
>
>     <mailto:[email-masked]>
>     Senior MPLS Expert [email-masked] <mailto:[email-masked]>
>     <tel:%2B46%20739%2081%2021%2064>
>

--

---

From: Lou Berger <[email-masked]>
Date: Sun, 08 Mar 2015 13:06:05 -0400

Sure.  The details will show the overlap. ..

Lou

---

From: Lou Berger <[email-masked]>
Date: Sun, 08 Mar 2015 13:10:22 -0400

> TP-LSP have a real control plane. It is a centralized one.

Agreed.

> You don't need distributed control plane to call it as such.

No disagreement, the function is the same. But I don't think your 
definition  is commonly  understood or agreed upon.

Lou

---

From: Gregory Mirsky <[email-masked]>
Date: Sun, 8 Mar 2015 18:48:39 +0000

Hi Robert, et. al,
if I interpret the “LSP YANG model”, then it reads as YANG model of MPLS data plane, not control protocol, be it RSVP-TE, LDP, PCEP, or IGP-TE of SPRING. And, since the MPLS data plane is indeed common and in fact the one and only, such LSP YANG model rightfully can be characterized as “Generic”.
But if authors intended to describe common set among listed above control protocols pertaining to signaling of an MPLS LSP, then, IMO, such common set first must be discussed and identified to demonstrate that it does exist and is sufficient to have YANG model of its own rather than YANG models that describe LSP control by each signaling protocols. That to me looks very much like what LIME WG is working on, investigating whether common model of IP, IP/MPLS, MPLS-TP, and TRILL OAM exists and its extent is sufficient to be of interest.

                Regards,
                                Greg

From: Teas [mailto:[email-masked]] On Behalf Of Robert Raszuk
Sent: Sunday, March 08, 2015 3:58 AM
To: Loa Andersson
Cc: [email-masked]; [email-masked]; Shah, Himanshu
Subject: Re: [Teas] [mpls] [Rtg-yang-coord] Generic LSP Yang

Hi Loa,

Cheers,
R.

/Loa

//

/Thanks,/

/himanshu/

//

//

//

Robert,

/Loa

Sent from my iPad

    I would agree with Igor.

    Best,

    r.

    Druv,

    Igor

--

---

From: Robert Raszuk <[email-masked]>
Date: Sun, 8 Mar 2015 20:03:00 +0100

Whow .. i think we are discovering that we all have no clue what Yang model
is :)

That is in fact I think great discussion to have sooner then later.

To me Yang model is a way to represent unified (across inplementations)
picture of control plane for a given network application.

It has nothing to do with data plane to the extend of avoiding lock-in to
mpls or ipv4 or ipv6.

The attempt to generalize LSP would be equivalent to generalize Routing
regardless if this is IGP or BGP or TRILL ... the outcome of that would be
rather poor I suppose ...

Cheers,
R.
On Mar 8, 2015 7:48 PM, "Gregory Mirsky" <[email-masked]>
wrote:

>  Hi Robert, et. al,
>
> if I interpret the “LSP YANG model”, then it reads as YANG model of MPLS
> data plane, not control protocol, be it RSVP-TE, LDP, PCEP, or IGP-TE of
> SPRING. And, since the MPLS data plane is indeed common and in fact the one
> and only, such LSP YANG model rightfully can be characterized as “Generic”.
>
> But if authors intended to describe common set among listed above control
> protocols pertaining to signaling of an MPLS LSP, then, IMO, such common
> set first must be discussed and identified to demonstrate that it does
> exist and is sufficient to have YANG model of its own rather than YANG
> models that describe LSP control by each signaling protocols. That to me
> looks very much like what LIME WG is working on, investigating whether
> common model of IP, IP/MPLS, MPLS-TP, and TRILL OAM exists and its extent
> is sufficient to be of interest.
>
>
>
>                 Regards,
>
>                                 Greg
>
>
>
> *From:* Teas [mailto:[email-masked]] *On Behalf Of *Robert Raszuk
> *Sent:* Sunday, March 08, 2015 3:58 AM
> *To:* Loa Andersson
> *Cc:* [email-masked]; [email-masked]; Shah, Himanshu
> *Subject:* Re: [Teas] [mpls] [Rtg-yang-coord] Generic LSP Yang
>
>
>
> Hi Loa,
>
>
>

---

From: Gregory Mirsky <[email-masked]>
Date: Sun, 8 Mar 2015 19:06:17 +0000

Hi Robert,
early in MPLS, I think, we all played with what’s called Static LSP. Later they came back as LSP in MPLS-TP without a control plane. To me that is how one sets the MPLS data plane without any control protocol but configuring cross-connects LSR by LSR.

                Regards,
                                Greg

From: [email-masked] [mailto:[email-masked]] On Behalf Of Robert Raszuk
Sent: Sunday, March 08, 2015 12:03 PM
To: Gregory Mirsky
Cc: Himanshu Shah; [email-masked]; Loa Andersson; [email-masked]
Subject: RE: [Teas] [mpls] [Rtg-yang-coord] Generic LSP Yang

Whow .. i think we are discovering that we all have no clue what Yang model is :)

To me Yang model is a way to represent unified (across inplementations) picture of control plane for a given network application.

It has nothing to do with data plane to the extend of avoiding lock-in to mpls or ipv4 or ipv6.

The attempt to generalize LSP would be equivalent to generalize Routing regardless if this is IGP or BGP or TRILL ... the outcome of that would be rather poor I suppose ...

Cheers,
R.
On Mar 8, 2015 7:48 PM, "Gregory Mirsky" <[email-masked]<mailto:[email-masked]>> wrote:
Hi Robert, et. al,
if I interpret the “LSP YANG model”, then it reads as YANG model of MPLS data plane, not control protocol, be it RSVP-TE, LDP, PCEP, or IGP-TE of SPRING. And, since the MPLS data plane is indeed common and in fact the one and only, such LSP YANG model rightfully can be characterized as “Generic”.
But if authors intended to describe common set among listed above control protocols pertaining to signaling of an MPLS LSP, then, IMO, such common set first must be discussed and identified to demonstrate that it does exist and is sufficient to have YANG model of its own rather than YANG models that describe LSP control by each signaling protocols. That to me looks very much like what LIME WG is working on, investigating whether common model of IP, IP/MPLS, MPLS-TP, and TRILL OAM exists and its extent is sufficient to be of interest.

                Regards,
                                Greg

From: Teas [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Robert Raszuk
Sent: Sunday, March 08, 2015 3:58 AM
To: Loa Andersson
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Shah, Himanshu
Subject: Re: [Teas] [mpls] [Rtg-yang-coord] Generic LSP Yang

Hi Loa,

Cheers,
R.

/Loa

//

/Thanks,/

/himanshu/

//

//

//

Robert,

/Loa

Sent from my iPad

    I would agree with Igor.

    Best,

    r.

    Druv,

    Igor

--

---

From: Gregory Mirsky <[email-masked]>
Date: Sun, 8 Mar 2015 19:34:46 +0000

Hi Robert,
are you suggesting that an LSP, i.e. Label Switched Path, can be realized over IPv4 or IPv6 data plane:
It has nothing to do with data plane to the extend of avoiding lock-in to mpls or ipv4 or ipv6.

                Regards,
                                Greg

Cheers,
R.

                Regards,
                                Greg

Hi Loa,

Cheers,
R.

/Loa

//

/Thanks,/

/himanshu/

//

//

//

Robert,

/Loa

Sent from my iPad

    I would agree with Igor.

    Best,

    r.

    Druv,

    Igor

--

---

From: Robert Raszuk <[email-masked]>
Date: Sun, 8 Mar 2015 20:40:11 +0100

I beg you pardon but i have never seen static LSPs really in production use
.. that means being configured hop by hop by cli.

For the recird I have started my MPLS days with TDP in around 1997 :)

So what it means for this duscussion? Are you proposing say for RSVP-TE to
push labels hop by hop or you would rather see Yang representing ERO as
part of it ?

I think no one says we can not have Yang model for static labels and
centralize everything but the question is this all we need to have here
.... i do not think so.

Best,
R.
 On Mar 8, 2015 8:06 PM, "Gregory Mirsky" <[email-masked]>
wrote:

 Hi Robert,

early in MPLS, I think, we all played with what’s called Static LSP. Later
they came back as LSP in MPLS-TP without a control plane. To me that is how
one sets the MPLS data plane without any control protocol but configuring
cross-connects LSR by LSR.

                Regards,

                                Greg

*From:* [email-masked] [mailto:[email-masked]] *On Behalf Of *Robert
Raszuk
*Sent:* Sunday, March 08, 2015 12:03 PM
*To:* Gregory Mirsky
*Cc:* Himanshu Shah; [email-masked]; Loa Andersson; [email-masked]
*Subject:* RE: [Teas] [mpls] [Rtg-yang-coord] Generic LSP Yang

Cheers,
R.

Hi Robert, et. al,

                Regards,

                                Greg

Hi Loa,

Cheers,
R.

Himanshu, et.al.,

/Loa

//

/Thanks,/

/himanshu/

//

//

//

Robert,

/Loa

Sent from my iPad

On 07 Mar 2015, at 19:47, Robert Raszuk <[email-masked]
<mailto:[email-masked]>> wrote:

    I would agree with Igor.

    Best,

    r.

    Druv,

    Igor

--

---

From: Robert Raszuk <[email-masked]>
Date: Sun, 8 Mar 2015 20:42:02 +0100

I suggest that today we know (well we knew even in 2000) how to do TE with
IP without MPLS ...

Thx,
R.
On Mar 8, 2015 8:34 PM, "Gregory Mirsky" <[email-masked]>

---

From: Gregory Mirsky <[email-masked]>
Date: Sun, 8 Mar 2015 20:11:37 +0000

I think that in SPRING we’ve been around that discussion and had concluded that IPv4 is out of scope for an explicitly routed path. You propose to re-open that discussion?

                Regards,
                                Greg

From: [email-masked] [mailto:[email-masked]] On Behalf Of Robert Raszuk
Sent: Sunday, March 08, 2015 12:42 PM
To: Gregory Mirsky
Cc: [email-masked]; Himanshu Shah; Loa Andersson; [email-masked]
Subject: RE: [Teas] [mpls] [Rtg-yang-coord] Generic LSP Yang

I suggest that today we know (well we knew even in 2000) how to do TE with IP without MPLS ...

Thx,
R.
On Mar 8, 2015 8:34 PM, "Gregory Mirsky" <[email-masked]<mailto:[email-masked]>> wrote:
Hi Robert,
are you suggesting that an LSP, i.e. Label Switched Path, can be realized over IPv4 or IPv6 data plane:
It has nothing to do with data plane to the extend of avoiding lock-in to mpls or ipv4 or ipv6.

                Regards,
                                Greg

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Robert Raszuk
Sent: Sunday, March 08, 2015 12:03 PM
To: Gregory Mirsky
Cc: Himanshu Shah; [email-masked]<mailto:[email-masked]>; Loa Andersson; [email-masked]<mailto:[email-masked]>
Subject: RE: [Teas] [mpls] [Rtg-yang-coord] Generic LSP Yang

Cheers,
R.

                Regards,
                                Greg

Hi Loa,

Cheers,
R.

/Loa

//

/Thanks,/

/himanshu/

//

//

//

Robert,

/Loa

Sent from my iPad

    I would agree with Igor.

    Best,

    r.

    Druv,

    Igor

--

---

From: Robert Raszuk <[email-masked]>
Date: Mon, 9 Mar 2015 09:34:04 +0100

Gregory,

> I think that in SPRING we’ve been around that discussion and
> had concluded that IPv4 is out of scope for an explicitly routed
> path. You propose to re-open that discussion?

Who says anything of SPRING and IPv4 ?

I can use IPv4 for path engneering with:

A) automated metric tuning

B) BGP Vector Routing
https://tools.ietf.org/html/draft-patel-raszuk-bgp-vector-routing-04

C) BGP SDN
https://tools.ietf.org/html/draft-lapukhov-bgp-sdn-00

Those are neither SPRING nor TE-LSP nor LDP related. Are those technologies
out of scope of general idea of "Engineered Paths" ?

Thx,
R.

On Sun, Mar 8, 2015 at 9:11 PM, Gregory Mirsky <[email-masked]>
wrote:

>  I think that in SPRING we’ve been around that discussion and had
> concluded that IPv4 is out of scope for an explicitly routed path. You
> propose to re-open that discussion?
>
>
>
>                 Regards,
>
>                                 Greg
>
>
>
> *Sent:* Sunday, March 08, 2015 12:42 PM
> *To:* Gregory Mirsky
> *Cc:* [email-masked]; Himanshu Shah; Loa Andersson; [email-masked]
>

---

From: "Zhangxian (Xian)" <[email-masked]>
Date: Tue, 10 Mar 2015 08:52:22 +0000

Hi, Greg, all,

Your interpretation is exactly what we have in mind and tried to explain in the draft. Your point/suggestion is well taken and we hope that the discussions planned in TEAS will help to address it.

If we have not made it clearly in the draft, we want to emphasize that :  this model is only for the LSP operational state (LSP-DB) and NOT a generic signaling-protocol yang model, which act as a basis for configuring and managing all signaling protocols.  It meant to be a helper-module for signaling/technology-specific ones, as represented in the graph Dhruv mentioned before (http://www.ietf.org/mail-archive/web/mpls/current/msg13867.html), since we/the authors believe there is a set of common elements/information.

Regards,
Xian and Dhruv

From: Teas [mailto:[email-masked]] On Behalf Of Gregory Mirsky
Sent: 2015年3月9日 2:49
To: Robert Raszuk; Loa Andersson
Cc: [email-masked]; Shah, Himanshu; [email-masked]
Subject: Re: [Teas] [mpls] [Rtg-yang-coord] Generic LSP Yang

Hi Robert, et. al,

                Regards,
                                Greg

Hi Loa,

Cheers,
R.

/Loa

//

/Thanks,/

/himanshu/

//

//

//

Robert,

/Loa

Sent from my iPad

    I would agree with Igor.

    Best,

    r.

    Druv,

    Igor

--