Subject: [Teas] draft-liu-teas-yang-te-topo-01

From: Hariharan Ananthakrishnan <[email-masked]>
Date: Thu, 26 Mar 2015 19:39:13 +0000

Hi Authors,

Couple of comments:

[1] “import ted”: It would be good to provide reference from where ‘ted’ module is being picked up from (draft-clemm-i2rs-yang-l3-topo ?)
[2] Importing ‘ted’ in te-topo module will make this module ’not’ generic, since ted has ipv4/ipv6 references. Similar issues with usage of inet:ipv4-addres and inet:ipv6-address.
[3] I am not sure having 'is-abstract' in node and link helps as te-topology itself is suppose to be generic (or abstract). If there is really a use-case then we should move this to “generic network-topology” (draft-clemm-i2rs-yang-network-topo), assuming this topology is going to be derived from draft-clemm-i2rs-yang-network-topo.

Thanks,
- Hari

---

From: Xufeng Liu <[email-masked]>
Date: Wed, 1 Apr 2015 01:37:49 +0000

Hi Hari,

Thanks for the comments. These issues will be addressed, among others.

- Xufeng

From: Teas [mailto:[email-masked]] On Behalf Of Hariharan Ananthakrishnan
Sent: Thursday, March 26, 2015 3:39 PM
To: [email-masked]
Subject: [Teas] draft-liu-teas-yang-te-topo-01

Hi Authors,

Couple of comments:

Thanks,
- Hari