Subject: [Teas] Doubts for draft-lam-teas-usage-info-model-net-topology-01

From: "Wunan (Eric)" <[email-masked]>
Date: Thu, 23 Jul 2015 20:52:33 +0000

Hi co-authors of draft-lam-teas-usage-info-model-net-topology-01,

I didn't get the meaning for this draft after reading it.

So is it trying to define the information model for current TE topology model or describe the use case for it?

In section 2. Background and Motivation:

"Information Models (IM) and Data Models (DM) are related but  different."

For the difference of IM and DM, it has been covered by RFC3444, suggesting to reference it.

" This draft describes an existing information model relevant to
   Network Topology [ONF TR-512], which is part of the Common
   Information Model (ONF-CIM) of network resources (as described in [I-
   D.betts]), that can be leveraged to assess the consistency and
   completeness of related YANG modules under development.  Being part
   of a Common Information Model, it will not lead to development of
   incompatible/uncoordinated models that can be difficult to maintain
   as other purpose-specific interfaces are developed."

I didn't get the motivation behind these sentences.

How this will benefit current TE topology model by introducing a completely new information model?

I even not sure why this information model is related to TE topology model instead of network topology model in I2RS.

Hope the co-authors of this draft can clarify.

Thanks.

Regards

Eric

---

From: "Lam, Hing-Kam (Kam)" <[email-masked]>
Date: Mon, 27 Jul 2015 13:13:50 +0000

Hi Eric,

Thank you for the comments. Please see some clarification <k> ... </k> inline below.

Regards,
Kam

From: Teas [mailto:[email-masked]] On Behalf Of Wunan (Eric)
Sent: Thursday, July 23, 2015 4:53 PM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: [Teas] Doubts for draft-lam-teas-usage-info-model-net-topology-01

<k> This draft describes a normalized/rationalized information model of topology from which other relevant topology information model views can be derived (through pruning & refactoring), and then could be further translated into YANG data models. </k>

<k> RFC3444 is already cited in the draft. We will add it in the reference section. </k>

<k> The motivation is to facilitate coordinated/compatible Data Model developments. </k>

<k> We do not introduce a "new information model". We just describe the information model ( you could think as an RFC 5511 RBNF description for data model expression) from "which" you could derive a "data model" as expressed in a Yang tree. The draft does not pretend to substitute the TE-topology Yang model, but just describe an "information set of objects and relationship between them" that could help to "improve" the Yang TE-topology model. </k>

<k> The information model described is encompassing both "general" agnostic topology model and TE information, so the answer is both drafts are addressed. </k>

Thanks.

Regards

Eric