Subject: [Teas] actn requirements draft

From: Leeyoung <[email-masked]>
Date: Tue, 21 Jul 2015 11:52:23 +0000

Hi,

It will be good to get some discussion going on the ACTN requirements even before the WG meeting, especially by the authors of ACTN use-cases if the current requirements document reflects correctly and rightly your use-cases' requirements in a level you want. Here's the link:
https://datatracker.ietf.org/doc/draft-lee-teas-actn-requirements/

Just a thought.

Thanks.
Young

---

From: "Takuya Miyasaka" <[email-masked]>
Date: Wed, 22 Jul 2015 13:11:20 +0900

Hi Young and WG,

I checked your ACTN requirement document and I would like to add a security or confidentiality requirement on 2. High-level ACTN requirements section.
In our use-case of multitenant virtual network operator, one network provider may provide virtual network to many customers, so following security requirements must be guaranteed.
 -A customer MUST not control other customer's virtual network
 -A customer MUST not see any routing information (e.g. IGP database, TE database) on other customer's virtual network

Thanks,
Takuya

> -----Original Message-----
> 
> Hi,
> 
> 
> 
> It will be good to get some discussion going on the ACTN requirements even before the WG meeting, especially by the authors
> of ACTN use-cases if the current requirements document reflects correctly and rightly your use-cases' requirements in
> a level you want. Here's the link:
>

---

From: Zhenghaomian <[email-masked]>
Date: Wed, 22 Jul 2015 06:11:28 +0000

Hi, Takuya,

In the current framework one customer is not aware of the existence of other customers, let along 'control' their network. I assume your proposal is true by default. 

I do think security should be an important issue, but it mainly occurs between CNC and MDSC. 

Best wishes,
Haomian

-----邮件原件-----
发件人: Teas [mailto:[email-masked]] 代表 Takuya Miyasaka
发送时间: 2015年7月22日 12:11
收件人: Leeyoung; [email-masked]
主题: Re: [Teas] actn requirements draft

Hi Young and WG,

I checked your ACTN requirement document and I would like to add a security or confidentiality requirement on 2. High-level ACTN requirements section.
In our use-case of multitenant virtual network operator, one network provider may provide virtual network to many customers, so following security requirements must be guaranteed.
 -A customer MUST not control other customer's virtual network  -A customer MUST not see any routing information (e.g. IGP database, TE database) on other customer's virtual network

Thanks,
Takuya

> It will be good to get some discussion going on the ACTN requirements 
> even before the WG meeting, especially by the authors of ACTN 
> use-cases if the current requirements document reflects correctly and rightly your use-cases' requirements in a level you want. Here's the link:
> 

_______________________________________________
Teas mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/teas

---

From: Leeyoung <[email-masked]>
Date: Wed, 22 Jul 2015 06:42:49 +0000

Hi Takuya,

Thanks for your good comments on the ACTN requirements draft.

Yes, I agree with you on security/confidentiality requirement. Will add this in the high-level requirements section. 

Best regards,
Young

-----Original Message-----
From: Takuya Miyasaka [mailto:[email-masked]] 
Sent: Tuesday, July 21, 2015 11:11 PM
To: Leeyoung; [email-masked]
Subject: RE: [Teas] actn requirements draft

Hi Young and WG,

Thanks,
Takuya

---

From: Kwangkoog Lee <[email-masked]>
Date: Wed, 22 Jul 2015 08:51:59 +0200

Dear authors,

As we have updated for our draft about "end-to-end connectivity over multi vendor domains" we want to change "on-demand end-to-end service" to "end-to-end service" in section 3 because our scope covers both cases. 

In addition, we think that fault and performance management perspectives of an end-to-end service over multi vendor islands should be added in the requirement contents where they currently mention just connection perspective. Please, modify the contents as follows;

-  Coordination of signal flow for E2E service connections and management

Finally, please add following contents in service specific requirements of sec. 3.1.
"on-demand and long-lived end-to-end service provisioning and monitoring"

Thanks,
Kwangkoog Lee

Sent from my iPhone

> On 2015. 7. 21., at 오후 1:52, Leeyoung <[email-masked]> wrote:
> 
> Hi,
>  
> It will be good to get some discussion going on the ACTN requirements even before the WG meeting, especially by the authors of ACTN use-cases if the current requirements document reflects correctly and rightly your use-cases’ requirements in a level you want. Here’s the link:

---

From: Leeyoung <[email-masked]>
Date: Wed, 22 Jul 2015 07:26:27 +0000

Hi Kangkook,

Thanks for addressing your comments.  Yes, we can reflect your comment on Section 3. Under your use-case [KLEE] in Section 3, it says currently:

Coordination of signal flow for E2E connections.

You wanted to changed to

Do you think “management” can be narrowed down to “fault and performance management” in particular?

I can add your comments in Section 3.1.

Thanks.
Young
From: Kwangkoog Lee [mailto:[email-masked]]
Sent: Wednesday, July 22, 2015 1:52 AM
To: Leeyoung
Cc: [email-masked]
Subject: Re: [Teas] actn requirements draft

Dear authors,

Thanks,
Kwangkoog Lee

Sent from my iPhone

On 2015. 7. 21., at 오후 1:52, Leeyoung <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Just a thought.

Thanks.
Young

_______________________________________________
Teas mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/teas

---

From: Dhruv Dhody <[email-masked]>
Date: Wed, 22 Jul 2015 13:05:33 +0200

HI,

>From the point of view of the POI usecase[1], the requirement document
covers it well!

Thanks!

Regards,
Dhruv

[1] https://datatracker.ietf.org/doc/draft-dhody-actn-poi-use-case/

On Tue, Jul 21, 2015 at 1:52 PM, Leeyoung <[email-masked]> wrote:

>  Hi,
>
>
>
> It will be good to get some discussion going on the ACTN requirements even
> before the WG meeting, especially by the authors of ACTN use-cases if the
> current requirements document reflects correctly and rightly your
> use-cases’ requirements in a level you want. Here’s the link:
>

---

From: Leeyoung <[email-masked]>
Date: Wed, 22 Jul 2015 11:06:54 +0000

Dhruv,

Thanks for your comment.

Young

From: [email-masked] [mailto:[email-masked]] On Behalf Of Dhruv Dhody
Sent: Wednesday, July 22, 2015 6:06 AM
To: Leeyoung
Cc: [email-masked]
Subject: Re: [Teas] actn requirements draft

HI,

From the point of view of the POI usecase[1], the requirement document covers it well!

Thanks!

Regards,
Dhruv

On Tue, Jul 21, 2015 at 1:52 PM, Leeyoung <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Just a thought.

Thanks.
Young

---

From: Zhenghaomian <[email-masked]>
Date: Wed, 22 Jul 2015 11:20:37 +0000

Hi, All,

I think the current version of requirement draft covers the requirement from our use case in draft-xu-actn-perf-dynamic-service-control.

Thanks a lot.

Best wishes,
Haomian

发件人: Teas [mailto:[email-masked]] 代表 Leeyoung
发送时间: 2015年7月21日 19:52
收件人: [email-masked]
主题: [Teas] actn requirements draft

Hi,

Just a thought.

Thanks.
Young

---

From: KwangKoog Lee <[email-masked]>
Date: Wed, 22 Jul 2015 13:44:01 +0200

Hi,

I think it doesn't need the mentioned service management only focuses on
fault and performance monitoring for individual services.. Rather it should
cover whole management operations such as service deployments from MDSC or
CNC, management of the deployed services' network topology and service
hierarchies (between MDSC and CNC).
The fault and performance management is just one example.

Thank you for your considerations.

Kwang-koog Lee

On Wed, Jul 22, 2015 at 9:26 AM, Leeyoung <[email-masked]> wrote:

>  Hi Kangkook,
>
>
>
> Thanks for addressing your comments.  Yes, we can reflect your comment on
> Section 3. Under your use-case [KLEE] in Section 3, it says currently:
>
>
>
> *From:* Kwangkoog Lee [mailto:[email-masked]]
> *Sent:* Wednesday, July 22, 2015 1:52 AM
> *To:* Leeyoung
> *Cc:* [email-masked]
> *Subject:* Re: [Teas] actn requirements draft
>
>
>
> Dear authors,
>
>
>
> As we have updated for our draft about "end-to-end connectivity over multi
> vendor domains" we want to change "on-demand end-to-end service" to
> "end-to-end service" in section 3 because our scope covers both cases.
>
>
>
> In addition, we think that fault and performance management perspectives
> of an end-to-end service over multi vendor islands should be added in the
> requirement contents where they currently mention just connection
> perspective. Please, modify the contents as follows;
>
>
>

---

From: Leeyoung <[email-masked]>
Date: Wed, 22 Jul 2015 12:30:56 +0000

Thanks for your clarification.

Young

From: KwangKoog Lee [mailto:[email-masked]]
Sent: Wednesday, July 22, 2015 6:44 AM
To: Leeyoung
Cc: [email-masked]
Subject: Re: [Teas] actn requirements draft

Hi,

I think it doesn't need the mentioned service management only focuses on fault and performance monitoring for individual services.. Rather it should cover whole management operations such as service deployments from MDSC or CNC, management of the deployed services' network topology and service hierarchies (between MDSC and CNC).
The fault and performance management is just one example.

Kwang-koog Lee

On Wed, Jul 22, 2015 at 9:26 AM, Leeyoung <[email-masked]<mailto:[email-masked]>> wrote:
Hi Kangkook,

You wanted to changed to

Thanks.
Young
From: Kwangkoog Lee [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Wednesday, July 22, 2015 1:52 AM
To: Leeyoung
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Teas] actn requirements draft

Dear authors,

Thanks,
Kwangkoog Lee

Sent from my iPhone

Just a thought.

Thanks.
Young