Subject: [Teas] RtgDir review of draft-ietf-teas-interconnected-te-info-exchange-04

From: Stewart Bryant <[email-masked]>
Date: Thu, 21 Apr 2016 11:47:00 +0100

Hello,

I have been selected as the Routing Directorate reviewer for this draft. 
The Routing Directorate seeks to review all routing or routing-related 
drafts as they pass through IETF last call and IESG review. The purpose 
of the review is to provide assistance to the Routing ADs. For more 
information about the Routing Directorate, please see​ 
http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir

Although these comments are primarily for the use of the Routing ADs, it 
would be helpful if you could consider them along with any other IETF 
Last Call comments that you receive, and strive to resolve them through 
discussion or by updating the draft.

Document:draft-ietf-teas-interconnected-te-info-exchange-04.txt
Reviewer: Stewart Bryant
Review Date: 21 April 2016
IETF LC End Date: Not yet sent to IETF LC AFAICS
Intended Status: Best Current Practice

*Summary:*
I have some minor concerns about this document that I think should be 
resolved before publication.
*
Comments:*
This is an exceptionally well written document that will serve community 
well in understanding this problem.

The first two minor comments are in many ways optional, but I think 
addressing them would be appreciated by those new to the subject.
*
Major Issues:*
No major issues found.
*
Minor Issues:*

In section 1.1.2 TE Metrics and TE Attributes, there appears to be no 
definition of either term (either by reference of by value). A 
definition and in particular a distinction would be helpful to the 
reader less familiar with the subject.

Regarding Section 1.1.8.  Abstract Node or Virtual Node. It is unclear 
whether these are synonyms, or if there is a distinction between them.

Section 5.2
The text "(i.e., completely separate instances using different address)" 
is incomplete. I think that you have omitted the word "spaces".

*
Nits:*
"2.4.  Requesting Connectivity

"   This relationship between domains can be entirely under the control"

I think that should be "The relationship"

=======
Section 6 the text "are arranged a set of small domains" I think should be
"are arranged as a set of small domains"

======
Section 10.1 para 3 duplicate word "the the"

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 21 Apr 2016 12:34:54 +0100

Stewart,

Many thanks for your time and kind words.

Responses in line.

Deborah, when in the process do you want to see an update?

Cheers,
Adrian

> Summary: 
> I have some minor concerns about this document that I think should be resolved 
> before publication.
>
> Comments: 
> This is an exceptionally well written document that will serve community well in
> understanding this problem.
>
> The first two minor comments are in many ways optional, but I think addressing
> them would be appreciated by those new to the subject.
>
> Major Issues: 
> No major issues found.
>
> Minor Issues: 
>
> In section 1.1.2 TE Metrics and TE Attributes, there appears to be no definition of
> either term (either by reference of by value). A definition and in particular a 
> distinction would be helpful to the reader less familiar with the subject.

I think that you're right that some clarity could be added. The general description of the combination of the two terms looks fine to me, but by presenting two terms we do need to distinguish them and explain. I suspect that some examples and a little more description will do the job. Mainly we need to characterise a TE metric as a quantifiable value (including measurement) describing some property of a link or node that can be used as part of TE routing or planning, while a TE attribute is a wider term (i.e. including TE metric) that refers to any property or characteristic of a link or node that can be used as part of TE routing or planning.

> Regarding Section 1.1.8.  Abstract Node or Virtual Node. It is unclear whether these
> are synonyms, or if there is a distinction between them.

Hmmm. During WG last call we were asked to add 1.1.8 to give a root for use of these terms, although I chose to point at 3.5 and 4.2.2.1 for more details. But I think I can add a distinction between the very similar terms.

> Section 5.2
> The text "(i.e., completely separate instances using different address)" is
> incomplete. I think that you have omitted the word "spaces". 

Yes. Thanks.

> Nits: 

Ack

> "are arranged as a set of small domains"

Ack

> Section 10.1 para 3 duplicate word "the the"

Ack

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 21 Apr 2016 12:38:02 +0100

Re-send with correct RTG-DIR address

> -----Original Message-----
> From: Adrian Farrel [mailto:[email-masked]]
> Sent: 21 April 2016 12:35
> To: 'Stewart Bryant'; [email-masked]
> Cc: [email-masked]; draft-ietf-teas-interconnected-te-info-
> [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]; 'BRUNGARD, DEBORAH A'
> Subject: RE: RtgDir review of draft-ietf-teas-interconnected-te-info-exchange-04
> 
> Stewart,
> 
> I think that you're right that some clarity could be added. The general description
> of the combination of the two terms looks fine to me, but by presenting two
> terms we do need to distinguish them and explain. I suspect that some examples
> and a little more description will do the job. Mainly we need to characterise a TE
> metric as a quantifiable value (including measurement) describing some property
> of a link or node that can be used as part of TE routing or planning, while a TE
> attribute is a wider term (i.e. including TE metric) that refers to any property or
> characteristic of a link or node that can be used as part of TE routing or planning.
> 
> Hmmm. During WG last call we were asked to add 1.1.8 to give a root for use of
> these terms, although I chose to point at 3.5 and 4.2.2.1 for more details. But I
> think I can add a distinction between the very similar terms.
> 
> > Section 5.2