Subject: [Teas] Benjamin Kaduk's No Objection on draft-ietf-teas-actn-info-model-09: (with COMMENT)

From: Benjamin Kaduk <[email-masked]>
Date: Wed, 20 Jun 2018 13:56:08 -0700

Benjamin Kaduk has entered the following ballot position for
draft-ietf-teas-actn-info-model-09: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-teas-actn-info-model/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I echo the comments questioning the archival value for publishing a document like this.
I think it's a good intermediate point to have, including the security considerations text
(thank you for the quick update after the secdir review!), but am unsure what portion(s)
of it could not be easily folded into successor documents.

Section 2

   This section provides an ACTN common interface information model to
   describe in terms of primitives, objects, their properties
   (represented as attributes), their relationships, and the resources
   for the service applications needed in the ACTN context.

nit: The grammar here is a bit odd -- as-is, it says we have a model "to
describe in terms of [a list of things]", but don't say what is being
described.  I'm not entirely sure what the intended text would be, though.

Section 3.2, 3.4

Do I understand correctly that Modify is for CNC-to-MDSC commmunication and
Update is for MDSC-to-CNC communication?  Perhaps this could be made more
explicit.

Section 5.7.2

      [...] For example, permission
      the correct selection from the network of the destination related
      to the indicated VNF It is e.g. the case of VM migration among
      data center and CNC can enforce specific policy that can permit
      MDSC/PNC to calculate the correct path for the connectivity
      supporting the data center interconnection required by
      application.

There seems to be an editing error around "indicated VNF It is e.g.", maybe
just a missing full stop and commas around "e.g."?

Section 9

   The ACTN information model does not directly introduce security
   issues. Rather, it defines a set of interfaces for traffic

I would hope that no product of the IETF directly introduces security
*issues* (problems)!  Maybe "is not directly relevant when considering
potential security issues" is some better wordsmithing.

   Implementations of the ACTN framework will have distributed
   functional components that will exchange this information model.

nit: Perhaps this is overly pedantic, but are they exchanging this
information model, or a concrete instantiation that adheres to this model?

---

From: Leeyoung <[email-masked]>
Date: Wed, 20 Jun 2018 22:43:10 +0000

Hi Benjamin,

Thanks for proving valuable comments and suggestions.

Please see inline for my response.

Thanks.

Young

-----Original Message-----
From: Benjamin Kaduk [mailto:[email-masked]]
Sent: Wednesday, June 20, 2018 3:56 PM
To: The IESG <[email-masked]>
Cc: [email-masked]; Vishnu Beeram <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Subject: Benjamin Kaduk's No Objection on draft-ietf-teas-actn-info-model-09: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

COMMENT:

I think it's a good intermediate point to have, including the security considerations text (thank you for the quick update after the secdir review!), but am unsure what portion(s) of it could not be easily folded into successor documents.

YL>> Please see my comment to Ben on the archival value of this document.

Section 2

nit: The grammar here is a bit odd -- as-is, it says we have a model "to describe in terms of [a list of things]", but don't say what is being described.  I'm not entirely sure what the intended text would be, though.

YL>> I agree. I would change as follows:

NEW: This section provides an ACTN common interface information model to

   describe primitives, objects, their properties

Section 3.2, 3.4

Do I understand correctly that Modify is for CNC-to-MDSC commmunication and Update is for MDSC-to-CNC communication?  Perhaps this could be made more explicit.

YL>> Yes, your understanding is correct. We will add explicit text that says: Modify is for CNC-to-MDSC communication in Section 3.2 and Update is for MDSC-to-CNC communication in Section 3.4.

Section 5.7.2

      application.

There seems to be an editing error around "indicated VNF It is e.g.", maybe just a missing full stop and commas around "e.g."?

YL>> Yes, there is an editing error here.

OLD: For example, permission

      application.

NEW: For example, CNC can enforce client-specific preferences, e.g.,

      selection of a destination data center from the set of candidate data

      centers based on some criteria in the context of VM migration.

      MSDC/PNC should then provide the data center interconnection that

      supports the client-specific preference.

Section 9

*issues* (problems)!  Maybe "is not directly relevant when considering potential security issues" is some better wordsmithing.

YL>> Agree. Will change the sentence as you suggest.

nit: Perhaps this is overly pedantic, but are they exchanging this information model, or a concrete instantiation that adheres to this model?

YL>> Agree. How about:

NEW:

   functional components that will exchange a concrete instantiation

   that adheres to this information model.

---

From: Benjamin Kaduk <[email-masked]>
Date: Fri, 22 Jun 2018 09:27:57 -0500

Hi Young,

These proposed changes look good to me.

Thanks,

Benjamin

---

From: Leeyoung <[email-masked]>
Date: Fri, 22 Jun 2018 14:30:34 +0000

Hi Benjamin,

Thanks a lot for your quick acknowledgment. 

Best regards,
Young

-----Original Message-----
From: Benjamin Kaduk [mailto:[email-masked]] 
Sent: Friday, June 22, 2018 9:28 AM
To: Leeyoung <[email-masked]>
Cc: The IESG <[email-masked]>; [email-masked]; Vishnu Beeram <[email-masked]>; [email-masked]; [email-masked]
Subject: Re: Benjamin Kaduk's No Objection on draft-ietf-teas-actn-info-model-09: (with COMMENT)

Hi Young,

Thanks,

Benjamin