Subject: [Teas] Update and Request to Adopt draft-dong-teas-enhanced-vpn

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Thu, 18 Oct 2018 09:50:58 +0000

Hi all, 

A new revision of draft-dong-teas-enhanced-vpn is submitted to solve the comments received recently. 

This document specifies a framework for using existing, modified and potential new networking technologies as components to provide an enhanced VPN (VPN+) service. The major changes in this version are: 

  1) In Introduction section, add references to network slicing related works in the industry. 

  2) In section 2, update the description of the isolation requirement.

  3) In section 4 “Candidate Technologies”, reduce the introduction about segment routing.

  4) In section 4 “Candidate Technologies”, update the control plane subsection and add a new sub-section for management plane

  5) Add references to the candidate technologies.

  6) Editorial changes to improve the readability.

This document was initially submitted in last year as draft-bryant-rtgwg-enhanced-vpn, and was presented and discussed several times in RTGWG. According to the consensus between the chairs of RTGWG and TEAS, this draft was moved to TEAS WG, and presented in TEAS on IETF 102. 

Currently there are several enhanced VPN related drafts:

  draft-dong-spring-sr-for-enhanced-vpn, which describes the Segment Routing based mechanism for enabling enhanced VPN services.

  draft-dong-lsr-sr-enhanced-vpn, which specifies the IGP extensions needed for SR based enhanced VPN.

  draft-lee-rtgwg-actn-applicability-enhanced-vpn, which describes the applicability of ACTN to enhanced VPN.

This framework document plays an important role as it builds the foundation for the above documents. 

After several rounds of update, the content of this document is getting stable, the co-authors believe it is ready for the WG to adopt it, and would like to solicit to initiate the adoption poll on this document.

Best regards,
Jie (on behalf of coauthors)

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, October 18, 2018 5:25 PM
To: Dongjie (Jimmy) <[email-masked]>; Stewart Bryant <[email-masked]>; Takuya Miyasaka <[email-masked]>; Zhenqiang Li <[email-masked]>
Subject: New Version Notification for draft-dong-teas-enhanced-vpn-02.txt

A new version of I-D, draft-dong-teas-enhanced-vpn-02.txt
has been successfully submitted by Jie Dong and posted to the IETF repository.

Name:		draft-dong-teas-enhanced-vpn
Revision:	02
Title:		A Framework for Enhanced Virtual Private Networks (VPN+)
Document date:	2018-10-18
Group:		Individual Submission
Pages:		27
URL:            https://www.ietf.org/internet-drafts/draft-dong-teas-enhanced-vpn-02.txt
Status:         https://datatracker.ietf.org/doc/draft-dong-teas-enhanced-vpn/
Htmlized:       https://tools.ietf.org/html/draft-dong-teas-enhanced-vpn-02
Htmlized:       https://datatracker.ietf.org/doc/html/draft-dong-teas-enhanced-vpn
Diff:           https://www.ietf.org/rfcdiff?url2=draft-dong-teas-enhanced-vpn-02

Abstract:
   This document specifies a framework for using existing, modified and
   potential new networking technologies as components to provide an
   enhanced VPN (VPN+) service.  The purpose is to enable virtual
   private networks (VPNs) to support the needs of new applications,
   particularly applications that are associated with 5G services.  A
   network enhanced with these properties can form the underpinning of
   network slicing, but will also be of use in its own right.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: "Aijun Wang" <[email-masked]>
Date: Tue, 23 Oct 2018 12:21:49 +0800

Hi, Jie:

I have just read through briefly the related drafts that you mentioned, and have the following comments, please whether they are appropriate or not.

I think this draft is useful. It analyzes the requirements of VPN+ and the insufficient of the current related technologies. The key points may be that the physical resources allocation and its integration with the SR technologies.
As described within the draft, such solution is needed to meet the emerge critical services in 5G era. 

>From my understandings, the extension to the IGP protocol is necessary, as described in the draft (https://tools.ietf.org/html/draft-dong-lsr-sr-enhanced-vpn-00), but the most challenge works to fulfill the requirements mentioned in https://tools.ietf.org/html/draft-dong-teas-enhanced-vpn-02 is how to integrate the candidate technologies/solutions seamlessly. For example, ACTN provides the architecture for coordination between the controller in different layer/domain and the communication models among them, SR provides the flexibility to program the packet path on demand and the FlexE/Dedicated Queues etc provides the assured delivery service in each segment/node.

Then, is it better to combine the draft  https://tools.ietf.org/html/draft-dong-teas-enhanced-vpn-02 with draft https://tools.ietf.org/html/draft-dong-spring-sr-for-enhanced-vpn-01 to focus on the above aim?
And, draft https://tools.ietf.org/html/draft-lee-rtgwg-actn-applicability-enhanced-vpn-03 analyses the gap between ACTN and the requirements of VPN+, can it also be integrated together?

After doing the above work, the structure of the draft may be the followings:
1.  Overview of the Requirements(as that in current draft)
2.  Candidate Solutions(not technology) (as that in current draft, but simplified)
3.  Gap with the ACTN architecture.(as that in draft from Lee/Daniel)
4.  Proposed VPN+ framework and solution(as that in current draft, but more pertinences to the integration descriptions as that in https://tools.ietf.org/html/draft-dong-spring-sr-for-enhanced-vpn-01 )
5.  Proposed protocol extension(individual draft, as that in https://tools.ietf.org/html/draft-dong-lsr-sr-enhanced-vpn-00)

We can also seek the responses from the experts after your introduction on the coming TEAS meeting, or the feedbacks on this thread.

Best Regards.

Aijun Wang
Network R&D and Operation Support Department
China Telecom Corporation Limited Beijing Research Institute,Beijing, China.

-----邮件原件-----
发件人: Dongjie (Jimmy) [mailto:[email-masked]] 
发送时间: 2018年10月18日 17:51
收件人: TEAS WG
主题: [Teas] Update and Request to Adopt draft-dong-teas-enhanced-vpn

Hi all, 

Best regards,

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, October 18, 2018 5:25 PM
To: Dongjie (Jimmy) <[email-masked]>; Stewart Bryant <[email-masked]>; Takuya Miyasaka <[email-masked]>; Zhenqiang Li <[email-masked]>
Subject: New Version Notification for draft-dong-teas-enhanced-vpn-02.txt

Abstract:

The IETF Secretariat

_______________________________________________
Teas mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/teas

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Tue, 23 Oct 2018 08:43:11 +0000

Hi Aijun, 

Thanks a lot for your review and comments. Please see some replies inline:

> From: Teas [mailto:[email-masked]] On Behalf Of Aijun Wang
> Sent: Tuesday, October 23, 2018 12:22 PM
> To: Dongjie (Jimmy) <[email-masked]>; 'TEAS WG' <[email-masked]>
> Subject: [Teas] 答复: Update and Request to Adopt
> draft-dong-teas-enhanced-vpn
> 
> Hi, Jie:
> 
> I have just read through briefly the related drafts that you mentioned, and
> have the following comments, please whether they are appropriate or not.
> 
> I think this draft is useful. It analyzes the requirements of VPN+ and the
> insufficient of the current related technologies. The key points may be that
> the physical resources allocation and its integration with the SR technologies.

Yes the key point is to integrate the network resources with VPN services which have strict performance requirement. As you said SR is one of the candidate technologies, this document also describes other candidates. 

> >From my understandings, the extension to the IGP protocol is necessary, as
> described in the draft
> (https://tools.ietf.org/html/draft-dong-lsr-sr-enhanced-vpn-00), but the
> most challenge works to fulfill the requirements mentioned in
> https://tools.ietf.org/html/draft-dong-teas-enhanced-vpn-02 is how to
> integrate the candidate technologies/solutions seamlessly. For example,
> ACTN provides the architecture for coordination between the controller in
> different layer/domain and the communication models among them, SR
> provides the flexibility to program the packet path on demand and the
> FlexE/Dedicated Queues etc provides the assured delivery service in each
> segment/node.

You just gave a good example of candidate technologies in different layers: management plane, centralized/distributed control plane and data plane. All this together build the architecture of enhanced VPN.

> 
> Then, is it better to combine the draft
> https://tools.ietf.org/html/draft-dong-teas-enhanced-vpn-02 with draft
> https://tools.ietf.org/html/draft-dong-spring-sr-for-enhanced-vpn-01 to
> focus on the above aim?
> And, draft
> https://tools.ietf.org/html/draft-lee-rtgwg-actn-applicability-enhanced-vpn-0
> 3 analyses the gap between ACTN and the requirements of VPN+, can it also
> be integrated together?

Our intention was to describe the framework, mechanism and protocol extension in separate WGs which are most suitable for each piece of the work. Your suggestion of combining the drafts makes sense in helping people to understand the relationship between these works. This may also be done by adding references to relevant drafts in the framework draft. We'd like to collect more opinions on how to organize this work efficiently.

> 1.  Overview of the Requirements(as that in current draft) 2.  Candidate
> Solutions(not technology) (as that in current draft, but simplified) 3.  Gap
> with the ACTN architecture.(as that in draft from Lee/Daniel) 4.  Proposed
> VPN+ framework and solution(as that in current draft, but more pertinences
> to the integration descriptions as that in
> https://tools.ietf.org/html/draft-dong-spring-sr-for-enhanced-vpn-01 ) 5.
> Proposed protocol extension(individual draft, as that in
> https://tools.ietf.org/html/draft-dong-lsr-sr-enhanced-vpn-00)
> 
> We can also seek the responses from the experts after your introduction on
> the coming TEAS meeting, or the feedbacks on this thread.

Yes, more feedbacks are welcome. 

Many thanks, 
Jie

> 
> Best Regards.
> 
> Aijun Wang
> Network R&D and Operation Support Department China Telecom Corporation
> Limited Beijing Research Institute,Beijing, China.
> 
> 
> -----邮件原件-----
> enhanced VPN (VPN+) service. The major changes in this version are:
> 
>   4) In section 4 “Candidate Technologies”, update the control plane
> subsection and add a new sub-section for management plane
> 
> This document was initially submitted in last year as
> draft-bryant-rtgwg-enhanced-vpn, and was presented and discussed several
> times in RTGWG. According to the consensus between the chairs of RTGWG
> and TEAS, this draft was moved to TEAS WG, and presented in TEAS on IETF
> 102.
> 
>   draft-dong-spring-sr-for-enhanced-vpn, which describes the Segment
> Routing based mechanism for enabling enhanced VPN services.
> 
> After several rounds of update, the content of this document is getting stable,
> the co-authors believe it is ready for the WG to adopt it, and would like to
> solicit to initiate the adoption poll on this document.
> 
> Best regards,
> To: Dongjie (Jimmy) <[email-masked]>; Stewart Bryant
> <[email-masked]>; Takuya Miyasaka <[email-masked]>;
> Zhenqiang Li <[email-masked]>
> URL:
> https://www.ietf.org/internet-drafts/draft-dong-teas-enhanced-vpn-02.txt
> Status:
> https://datatracker.ietf.org/doc/draft-dong-teas-enhanced-vpn/
> Htmlized:
> https://tools.ietf.org/html/draft-dong-teas-enhanced-vpn-02
> Htmlized:
> https://datatracker.ietf.org/doc/html/draft-dong-teas-enhanced-vpn
> Diff:
> https://www.ietf.org/rfcdiff?url2=draft-dong-teas-enhanced-vpn-02
> 
> Abstract:
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
>