Subject: [Teas] Proposed enhancement to draft-ietf-teas-yang-path-computation

From: Italo Busi <[email-masked]>
Date: Wed, 31 Oct 2018 16:19:50 +0000

Dear TEAS WG,

Following-up mailing list discussions after IETF 102, we would like to discuss the proposal for a possible enhancement to the path computation RPC defined in draft-ietf-teas-yang-path-computation-03

The stateless path computation solution  requires that the YANG DS server (e.g., a PNC)  computes a path twice before setting up an LSP: at time T1, when its client (e.g., an MDSC) sends a path computation RPC request, and later, at time T2, when the same client (MDSC) creates a te-tunnel requesting the setup of the LSP.

The underlying assumption is that, if network conditions have not changed, the same path that has been computed at time T1 is also computed at time T2, by the server (PNC) and therefore the path that is setup at time T2 is exactly the same path that has been computed at time T1

From the mailing list discussion after IETF 102, it seems that some people think that it is not necessary to guarantee that the path setup at time T2 is exactly the same as the path computed at time T1 but only that it has the same or better metrics, while other people would like to be able to setup at time T2 the path computed at time T1, if still available

One possibility to achieve the latter behavior is to use the stateful path computation solution described in section 3.3.1 of draft-ietf-teas-yang-te-17. However, this approach has some drawbacks as described in section 3.3 of draft-ietf-teas-yang-path-computation-03

We think that it is also possible to define some extensions to the path computation RPC where the server (PNC), after having received a path computation RPC request, maintains some “temporary state” associated to the path computed at time T1 and allows the client (MDSC) to request, at time T2, the setup of that path, if still available.

The solution we are considering is similar to the compute-only mode but, to avoid a stateful approach, is leveraging the path computation RPC and the separation between config and state DS, in line with the NMDA architecture.

At time T1, after having computed a path, as requested by a path computation RPC request, the server (PNC) also creates a compute-only te-tunnel in the state DS reporting the computed path. This would be similar to the stateful solution with the only difference that there is no te-tunnel in the config DS.

At time T2, the client (e.g., MDSC) can request to setup that path by creating a te-tunnel (not in compute-only mode) in the config DS using the same tunnel-name of the existing te-tunnel  in the state datastore: this will trigger the server (PNC) to setup the path that has been computed at time T1, if still available.

Question for the TEAS WG: do you think that a solution that allows requesting the setup a path previously computed, as described above, would be useful?

Thanks, Carlo, Francesco, Sergio and Italo

Italo Busi
Principal Optical Transport Network Research Engineer
____________________________________________________________________________
Huawei Technologies Italia S.r.l.
Address：Centro Direzionale Milano 2, Palazzo Verrocchio, 3° Floor, 20090 Segrate (MI), Italy
Tel：+39 02 399948 32    Fax：   Mobile：+39 345 4721946
_____________________________________________________________________________
Huawei Technologies Italia S.r.l. is a company registered in Italy at the Company Registration Office of Milan, with registered number 04501190963 and equity capital €3,000,000 fully paid up, whose registered office is in Milan, Via Lorenteggio 257, Tower B, 20152 Milan. Huawei Technologies Italia S.r.l. is 100% owned by Huawei Technologies Cooperatief U.A
_____________________________________________________________________________
This e-mail and its attachments contain confidential information from HUAWEI, which is intended only for the person or entity whose address is listed above. Any use of the information contained herein in any way (including, but not limited to, total or partial disclosure, reproduction, or dissemination) by persons other than the intended recipient(s) is prohibited. If you receive this e-mail in error, please notify the sender by phone or email immediately and delete it!

---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
PRIVACY NOTICE: Pursuant to Art. 13 of the General Data Protection Regulation 2016/679 (GDPR), Huawei Technologies Italia S.r.l. informs you that the personal data contained in this email will be collected and treated for the acquisition of information preliminary to the conclusion of contracts, for the definition of the contractual relationship, as well as for the fulfillment of legal requirements related to civil, tax and accounting law or any other legal obligation to which Huawei may be subject. Personal data will not be subject to disclosure and spread unless otherwise required by law. Huawei will take appropriate security measures to protects personal data against loss, misuse disclosure or destruction of the information. Personal Data held may be transferred to countries outside the European Union, however Huawei Italia has put in place appropriate safeguards for the transfer of personal data to third countries by adopting the standard data protection clauses of the EU Commission. Personal Data are kept for a period necessary for the fulfillment of contract obligations unless otherwise required by law. You can exercise your rights under Art. 15 and following of  the GDPR (i.e. right of access, rectification, erasure, restriction, portability, object) by contacting Huawei at this email address: [email-masked]<mailto:[email-masked]> or through the following channel: www.huawei.com/en/personal-data-request<http://www.huawei.com/en/personal-data-request>. You have also the right to lodge a complaint with the competent supervisory authorities. If you need any further information or have any queries on how Huawei process your personal data, please send an email to our Data Protection Officer at [email-masked]<mailto:[email-masked]>.The Data Controller is Huawei Technologies Italia S.r.l. with registered office in Milan, Via Lorenteggio 257 Tower B, 20152.

---

From: Igor Bryskin <[email-masked]>
Date: Wed, 31 Oct 2018 21:03:09 +0000

Not a bad idea, provided that the server is smart when supporting compute-only tunnels. For example it can use the "sticky" approach - project CO tunnel paths onto auto-discovered topology.

Igor
From:Italo Busi
To:TEAS WG,
Cc:Francesco Lazzeri,Belotti, Sergio (Nokia - IT/Vimercate),Carlo Perocchio,
Date:2018-10-31 12:20:35
Subject:[Teas] Proposed enhancement to draft-ietf-teas-yang-path-computation

Dear TEAS WG,

Italo Busi

---

From: Dhruv Dhody <[email-masked]>
Date: Thu, 1 Nov 2018 01:14:58 +0000

Hi Italo,

Overall it make sense, but…

(1)  What are your thoughts on the state (compute-only) created at T1. And maybe the request (at T2) never comes? Would this live forever? Some mechanism to clear this would be nice!

(2)   Also let’s consider a case where MDSC asks a PNC to compute bunch of paths from various IN branch nodes to EXIT branch nodes (common in case of H-PCE like computations on transit domain) and based on the path computation at MDSC (or parent PCE) it determines that one of them needs to be setup. So in this cases should we stay away from this? Or is there a way to use this still!

I remember ages ago this was discussed in PCE WG as well (but that was before we had stateful PCE), maybe a good idea to think about it again!

Thanks!
Dhruv

From: Teas [mailto:[email-masked]] On Behalf Of Italo Busi
Sent: 31 October 2018 21:50
To: TEAS WG <[email-masked]>
Cc: Francesco Lazzeri <[email-masked]>; Belotti, Sergio (Nokia - IT/Vimercate) <[email-masked]>; Carlo Perocchio <[email-masked]>
Subject: [Teas] Proposed enhancement to draft-ietf-teas-yang-path-computation

Dear TEAS WG,

Italo Busi