Subject: [Teas] WG adoption poll - draft-dong-teas-enhanced-vpn-03

From: Vishnu Pavan Beeram <[email-masked]>
Date: Mon, 17 Dec 2018 02:26:54 -0500

All,

This is start of a *three* week poll on making
draft-dong-teas-enhanced-vpn a TEAS working group document.
Please send email to the list indicating "yes/support" or "no/do not
support". If indicating no, please state your reservations with the
document. If yes, please also feel free to provide comments you'd
like to see addressed once the document is a WG document.

The poll ends Jan 7th 2019 (extra week to account for the holidays).

Thanks,
Pavan and Lou

---

From: li zhenqiang <[email-masked]>
Date: Mon, 17 Dec 2018 09:47:49 +0000

yes/support as a coauthor.

Thanks,
Zhenqiang Li
________________________________
[email-masked]

From: Vishnu Pavan Beeram<mailto:[email-masked]>
Date: 2018-12-17 15:26
To: TEAS WG<mailto:[email-masked]>
CC: TEAS WG Chairs<mailto:[email-masked]>
Subject: [Teas] WG adoption poll - draft-dong-teas-enhanced-vpn-03
All,

Thanks,
Pavan and Lou

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Mon, 17 Dec 2018 10:06:01 +0000

Yes/support as a coauthor.

Best regards,
Jie

From: Teas [mailto:[email-masked]] On Behalf Of Vishnu Pavan Beeram
Sent: Monday, December 17, 2018 3:27 PM
To: TEAS WG <[email-masked]>
Cc: TEAS WG Chairs <[email-masked]>
Subject: [Teas] WG adoption poll - draft-dong-teas-enhanced-vpn-03

All,

Thanks,
Pavan and Lou

---

From: Leeyoung <[email-masked]>
Date: Mon, 17 Dec 2018 15:16:32 +0000

Yes/support.

Thanks.
Young (as a co-author)

Sent: Monday, December 17, 2018 1:27 AM

All,

Thanks,
Pavan and Lou

---

From: Mach Chen <[email-masked]>
Date: Tue, 18 Dec 2018 01:24:45 +0000

Yes/support.

Best regards,
Mach

All,

Thanks,
Pavan and Lou

---

From: "Aijun Wang" <[email-masked]>
Date: Tue, 18 Dec 2018 10:25:27 +0800

Yes/Support.

I think this documents gives us the overall description/analysis about the gap between the requirements of VPN+ service and the existing technologies and solution.

My  concern are the followings:

1) In section https://tools.ietf.org/html/draft-dong-teas-enhanced-vpn-03#section-4.6.2, it is said :”This section discusses how the features of ACTN can fulfill the enhanced VPN requirements described earlier in this document.”. 

    We need further analysis about the implementation/deployment/protocol extension etc. that ACTN has not covered.

2) We should focus on the packet network, that is to say, the  “Pragmatic Isolation” or dynamic isolations/assurances for enhanced VPN services. 

Best Regards.

Aijun Wang

Network R&D and Operation Support Department

China Telecom Corporation Limited Beijing Research Institute,Beijing, China.

发件人: Vishnu Pavan Beeram [mailto:[email-masked]] 
发送时间: 2018年12月17日 15:27
收件人: TEAS WG
抄送: TEAS WG Chairs
主题: [Teas] WG adoption poll - draft-dong-teas-enhanced-vpn-03

All,

Thanks,
Pavan and Lou

---

From: "Zhenghaomian (Zhenghaomian, Optical &Microwave Technology Research Dept)" <[email-masked]>
Date: Tue, 18 Dec 2018 06:54:27 +0000

Yes, Support.

Best wishes,
Haomian

发件人: Teas [mailto:[email-masked]] 代表 Vishnu Pavan Beeram
发送时间: 2018年12月17日 15:27
收件人: TEAS WG <[email-masked]>
抄送: TEAS WG Chairs <[email-masked]>
主题: [Teas] WG adoption poll - draft-dong-teas-enhanced-vpn-03

All,

Thanks,
Pavan and Lou

---

From: Loa Andersson <[email-masked]>
Date: Tue, 18 Dec 2018 17:44:30 +0800

Working Group,

I'm finally through reading the the document, I think it is very good
starting point for the working group process, including the discussion
Aijun point to as necessary.

/Loa

On 2018-12-18 10:25, Aijun Wang wrote:
> Yes/Support.
> 
> I think this documents gives us the overall description/analysis about 
> the gap between the requirements of VPN+ service and the existing 
> technologies and solution.
> 
> 1) In section 
> https://tools.ietf.org/html/draft-dong-teas-enhanced-vpn-03#section-4.6.2, 
> it is said :”This section discusses how the features of ACTN can fulfill 
> the enhanced VPN requirements described earlier in this document.”.
> 
>      We need further analysis about the 
> implementation/deployment/protocol extension etc. that ACTN has not covered.
> 
> 2) We should focus on the packet network, that is to say, the 
>   “Pragmatic Isolation” or dynamic isolations/assurances for enhanced 
> VPN services.
> 
> Best Regards.
> 
> Aijun Wang
> 
> *发件人:*Vishnu Pavan Beeram [mailto:[email-masked]]
> *发送时间:*2018年12月17日15:27
> *收件人:*TEAS WG
> *抄送:*TEAS WG Chairs
> *主题:*[Teas] WG adoption poll - draft-dong-teas-enhanced-vpn-03
> 
> All,
> 
> _______________________________________________
> Teas mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teas
> 

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert
Bronze Dragon Consulting             phone: +46 739 81 21 64

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 18 Dec 2018 09:38:11 -0500

Yes/support. This is a scalable approach for network slicing and enhanced
VPNs that builds on a body of existing work.

Cheers,
Andy

---

From: Daniele Ceccarelli <[email-masked]>
Date: Tue, 18 Dec 2018 22:53:55 +0000

TEAS is the right place where to continue this discussion as i believe this is extremely connected to traffic engineering and a lot of TEAS work can be reused, hence I support the adoption of the document.
BR

Daniele  

-----Original Message-----
From: Teas <[email-masked]> On Behalf Of Loa Andersson
Sent: den 18 december 2018 10:45
To: [email-masked]
Subject: Re: [Teas] 答复: WG adoption poll - draft-dong-teas-enhanced-vpn-03

Working Group,

I'm finally through reading the the document, I think it is very good starting point for the working group process, including the discussion Aijun point to as necessary.

/Loa

On 2018-12-18 10:25, Aijun Wang wrote:
> https://tools.ietf.org/html/draft-dong-teas-enhanced-vpn-03#section-4.
> 6.2, it is said :”This section discusses how the features of ACTN can 
> fulfill the enhanced VPN requirements described earlier in this 
> document.”.
> 
> document. If yes, please also feel free to provide comments you'd like 
> to see addressed once the document is a WG document.
> 

--

---

From: Qin Wu <[email-masked]>
Date: Wed, 19 Dec 2018 01:29:04 +0000

Yes/Support.

-Qin
发件人: Teas [mailto:[email-masked]] 代表 Vishnu Pavan Beeram
发送时间: 2018年12月17日 15:27
收件人: TEAS WG <[email-masked]<mailto:[email-masked]>>
抄送: TEAS WG Chairs <[email-masked]<mailto:[email-masked]>>
主题: [Teas] WG adoption poll - draft-dong-teas-enhanced-vpn-03

All,

Thanks,
Pavan and Lou

---

From: Lizhenbin <[email-masked]>
Date: Wed, 19 Dec 2018 01:30:44 +0000

Yes/ Support.

Best Regards,
Zhenbin(Robin)

Thanks,
Pavan and Lou

---

From: Takuya Miyasaka <[email-masked]>
Date: Wed, 19 Dec 2018 11:06:12 +0900

Regards,
Takuya

---

From: John E Drake <[email-masked]>
Date: Wed, 19 Dec 2018 16:45:59 +0000

Andy,

Network slicing is very different from what is described in this draft.  Network slicing envisions a small number of logical networks built using the same physical network, each of which is designed for a specific type of overlay network and a given VPN, depending upon its requirements, would be assigned to one or more of these network slices.  This draft, in contrast, is describing assignment of resources from the physical network to individual VPNs.

This is clearly absurd, and its characterization as a ‘scalable approach’ seems ill-considered.

This draft is also not a framework draft in any of the normally used definitions of that word (https://www.merriam-webster.com/dictionary/framework).  Rather, I would characterize it as a set of semi-random musings.

Yours Irrespectively,

John

From: Teas <[email-masked]> On Behalf Of Andrew G. Malis
Sent: Tuesday, December 18, 2018 9:38 AM
To: [email-masked] <[email-masked]>
Cc: TEAS WG Chairs <[email-masked]>; [email-masked]
Subject: Re: [Teas] WG adoption poll - draft-dong-teas-enhanced-vpn-03

Yes/support. This is a scalable approach for network slicing and enhanced VPNs that builds on a body of existing work.

Cheers,
Andy

On Mon, Dec 17, 2018 at 2:27 AM Vishnu Pavan Beeram <[email-masked]<mailto:[email-masked]>> wrote:
All,

Thanks,
Pavan and Lou
_______________________________________________
Teas mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/teas<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_teas&d=DwMFaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=CRB2tJiQePk0cT-h5LGhEWH-s_xXXup3HzvBSMRj5VE&m=jfPzAk6KYMTzEcjux7ADyZR5qPrxoPYBDdzWSlkedyw&s=uXdPvThk8MvzKASbv-H0_ekBtni_GK-xqPKnIbJ6ek4&e=>

---

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 19 Dec 2018 12:51:19 -0500

John,

Did you read the text in section 1 and elsewhere in the draft?
Specifically, the draft says "The general concept of network slicing in a
TE network is a larger  problem space than is addressed by VPN+ or VN, but
those concepts are tools to address some aspects or realizations of network
slicing." My comment was that is an approach for slicing, but I didn't
claim that it's a total solution. As far as scalability goes, see the
discussion in section 5 regarding the scalability benefits of using an
approach based on SR.

Once this becomes a WG draft, you're welcome to propose new text to address
any particular concerns you have with the current text.

Cheers,
Andy

On Wed, Dec 19, 2018 at 11:46 AM John E Drake <[email-masked]> wrote:

> Andy,
>
>
>
> Network slicing is very different from what is described in this draft.
> Network slicing envisions a small number of logical networks built using
> the same physical network, each of which is designed for a specific type of
> overlay network and a given VPN, depending upon its requirements, would be
> assigned to one or more of these network slices.  This draft, in contrast,
> is describing assignment of resources from the physical network to
> individual VPNs.
>
>
>
> This draft is also not a framework draft in any of the normally used
> definitions of that word (
> https://www.merriam-webster.com/dictionary/framework).  Rather, I would
> characterize it as a set of semi-random musings.
>
>
>
> Yours Irrespectively,
>
>
>
> John
>
>
>
> *From:* Teas <[email-masked]> *On Behalf Of * Andrew G. Malis
> *Sent:* Tuesday, December 18, 2018 9:38 AM
> *To:* [email-masked] <[email-masked]>
> *Cc:* TEAS WG Chairs <[email-masked]>; [email-masked]
> *Subject:* Re: [Teas] WG adoption poll - draft-dong-teas-enhanced-vpn-03
>
>
>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_teas&d=DwMFaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=CRB2tJiQePk0cT-h5LGhEWH-s_xXXup3HzvBSMRj5VE&m=jfPzAk6KYMTzEcjux7ADyZR5qPrxoPYBDdzWSlkedyw&s=uXdPvThk8MvzKASbv-H0_ekBtni_GK-xqPKnIbJ6ek4&e=>
>
>

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 19 Dec 2018 12:42:36 -0500

Vishnu and Lou:

I have read the document.  Support adoption as a good starting point for this work. 

Susan Hares 

From: Teas [mailto:[email-masked]] On Behalf Of Vishnu Pavan Beeram
Sent: Monday, December 17, 2018 2:27 AM
To: TEAS WG
Cc: TEAS WG Chairs
Subject: [Teas] WG adoption poll - draft-dong-teas-enhanced-vpn-03

All,

Thanks,
Pavan and Lou

---

From: John E Drake <[email-masked]>
Date: Thu, 20 Dec 2018 14:45:52 +0000

Hi,

Comments inline

Yours Irrespectively,

John

From: Andrew G. Malis <[email-masked]>
Sent: Wednesday, December 19, 2018 12:51 PM
To: John E Drake <[email-masked]>
Cc: [email-masked] <[email-masked]>; TEAS WG Chairs <[email-masked]>; [email-masked]
Subject: Re: [Teas] WG adoption poll - draft-dong-teas-enhanced-vpn-03

John,

Did you read the text in section 1 and elsewhere in the draft? Specifically, the draft says "The general concept of network slicing in a TE network is a larger  problem space than is addressed by VPN+ or VN, but those concepts are tools to address some aspects or realizations of network slicing." My comment was that is an approach for slicing, but I didn't claim that it's a total solution.

[JD]  My point was that network slicing may be a solvable problem but allocating network resources per-VPN is not.
As far as scalability goes, see the discussion in section 5 regarding the scalability benefits of using an approach based on SR.

[JD]  Right, provisioning O(10**5) SIDs on each router in a network should work just fine..

Once this becomes a WG draft, you're welcome to propose new text to address any particular concerns you have with the current text.

[JD]  Thanks, that’s most generous!  How about:  It is widely understood that allocating network resources per-VPN is an intractable problem.  However, this draft addresses this issue
through the innovative use of an emerging technology known as ‘willing suspension of disbelief’.  It should also be noted that this draft eliminates statistical multiplexing which has
always been considered nettlesome.

Cheers,
Andy

On Wed, Dec 19, 2018 at 11:46 AM John E Drake <[email-masked]<mailto:[email-masked]>> wrote:
Andy,

This draft is also not a framework draft in any of the normally used definitions of that word (https://www.merriam-webster.com/dictionary/framework<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.merriam-2Dwebster.com_dictionary_framework&d=DwMFaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=CRB2tJiQePk0cT-h5LGhEWH-s_xXXup3HzvBSMRj5VE&m=tx8VLwW48E24vAXzFHxga-Sln5NMNbiAgGUM1QslKvo&s=ISagHC0UOewkaxFSUV8HXurslTvq4C2S_G0IjNIKUiY&e=>).  Rather, I would characterize it as a set of semi-random musings.

Yours Irrespectively,

John

From: Teas <[email-masked]<mailto:[email-masked]>> On Behalf Of Andrew G. Malis
Sent: Tuesday, December 18, 2018 9:38 AM
To: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Cc: TEAS WG Chairs <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Teas] WG adoption poll - draft-dong-teas-enhanced-vpn-03

Cheers,
Andy

Thanks,
Pavan and Lou

---

From: Igor Bryskin <[email-masked]>
Date: Thu, 20 Dec 2018 14:54:46 +0000

Hi John,

Do you see any differences between a logical network and a network topology? Specifically, would you define network slices as produced by the same physical network sufficiently separated network topologies, each of which designed for specific class(es) of clients/overlays, with network resources available for the overlays limited by the resource pools allocated to the corresponding topologies? Another question: could network slices in your opinion be built hierarchically, i.e. higher level slices comprised of lower level ones?

Thanks,
Igor

From: Teas [mailto:[email-masked]] On Behalf Of John E Drake
Sent: Wednesday, December 19, 2018 11:46 AM
To: Andrew G. Malis; [email-masked]
Cc: TEAS WG Chairs; [email-masked]
Subject: Re: [Teas] WG adoption poll - draft-dong-teas-enhanced-vpn-03

Andy,

Yours Irrespectively,

John

Cheers,
Andy

Thanks,
Pavan and Lou

---

From: John E Drake <[email-masked]>
Date: Thu, 20 Dec 2018 15:13:34 +0000

Igor,

I am not convinced that network slicing is a good idea because it assumes that logical networks w/ vastly different characteristics can be built out of a set of common network resources.  I am convinced that allocating network resources on a per-VPN basis is a bad idea because of the scaling issues.

Yours Irrespectively,

John

From: Igor Bryskin <[email-masked]>
Sent: Thursday, December 20, 2018 9:55 AM
To: John E Drake <[email-masked]>; Andrew G. Malis <[email-masked]>; [email-masked] <[email-masked]>
Cc: TEAS WG Chairs <[email-masked]>; [email-masked]
Subject: RE: [Teas] WG adoption poll - draft-dong-teas-enhanced-vpn-03

Hi John,

Thanks,
Igor

From: Teas [mailto:[email-masked]] On Behalf Of John E Drake
Sent: Wednesday, December 19, 2018 11:46 AM
To: Andrew G. Malis; [email-masked]<mailto:[email-masked]>
Cc: TEAS WG Chairs; [email-masked]<mailto:[email-masked]>
Subject: Re: [Teas] WG adoption poll - draft-dong-teas-enhanced-vpn-03

Andy,

This draft is also not a framework draft in any of the normally used definitions of that word (https://www.merriam-webster.com/dictionary/framework<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.merriam-2Dwebster.com_dictionary_framework&d=DwMGaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=CRB2tJiQePk0cT-h5LGhEWH-s_xXXup3HzvBSMRj5VE&m=n9sCWh1x8RH083BAlFMqUZfK0blyu7AEqTYj5kopZ1I&s=o2aQfkCcHYaq6v8_OptqlhDqzYAgs1OiHS3JnOcuXtY&e=>).  Rather, I would characterize it as a set of semi-random musings.

Yours Irrespectively,

John

Cheers,
Andy

Thanks,
Pavan and Lou

---

From: Igor Bryskin <[email-masked]>
Date: Thu, 20 Dec 2018 16:25:05 +0000

John,

>… I am convinced that allocating network resources on a per-VPN basis is a bad idea because of the scaling issues.

I agree with that.
Igor

From: John E Drake [mailto:[email-masked]]
Sent: Thursday, December 20, 2018 10:14 AM
To: Igor Bryskin; Andrew G. Malis; [email-masked]
Cc: TEAS WG Chairs; [email-masked]
Subject: RE: [Teas] WG adoption poll - draft-dong-teas-enhanced-vpn-03

Igor,

Yours Irrespectively,

John

Hi John,

Thanks,
Igor

Andy,

Yours Irrespectively,

John

Cheers,
Andy

Thanks,
Pavan and Lou

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 20 Dec 2018 18:42:26 -0000

Hi,

I did a pretty substantive review of the previous version of this document, and the updates addressed my concerns.

This is work that is within the TEAS charter, in my opinion, and I think it is important to have a foundation/framework document as an anchor before people run off and invent protocol extensions.

I support adopting this as a working group document.

Best,

Adrian

From: Teas <[email-masked]> On Behalf Of Vishnu Pavan Beeram
Sent: 17 December 2018 07:27
To: TEAS WG <[email-masked]>
Cc: TEAS WG Chairs <[email-masked]>
Subject: [Teas] WG adoption poll - draft-dong-teas-enhanced-vpn-03

All,

Thanks,
Pavan and Lou

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Fri, 21 Dec 2018 02:46:53 +0000

Hi John,

This draft does not suggest to allocate network resources to each individual VPN, only the VPNs which require particular level of SLA need to be integrated with underlay network resources, thus the number of enhanced VPN would be much less than the number of traditional overlay VPNs. Also it is possible that several VPNs with similar characteristics could be assigned with a set of aggregated resources,  and would share the same logical network.

Best regards,
Jie

From: Teas [mailto:[email-masked]] On Behalf Of John E Drake
Sent: Thursday, December 20, 2018 11:14 PM
To: Igor Bryskin <[email-masked]>; Andrew G. Malis <[email-masked]>; [email-masked] <[email-masked]>
Cc: TEAS WG Chairs <[email-masked]>; [email-masked]
Subject: Re: [Teas] WG adoption poll - draft-dong-teas-enhanced-vpn-03

Igor,

Yours Irrespectively,

John

From: Igor Bryskin <[email-masked]<mailto:[email-masked]>>
Sent: Thursday, December 20, 2018 9:55 AM
To: John E Drake <[email-masked]<mailto:[email-masked]>>; Andrew G. Malis <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Cc: TEAS WG Chairs <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: [Teas] WG adoption poll - draft-dong-teas-enhanced-vpn-03

Hi John,

Thanks,
Igor

Andy,

Yours Irrespectively,

John

Cheers,
Andy

Thanks,
Pavan and Lou

---

From: John E Drake <[email-masked]>
Date: Fri, 21 Dec 2018 13:14:39 +0000

Hi,

Comment inline

Yours Irrespectively,

John

From: Dongjie (Jimmy) <[email-masked]>
Sent: Thursday, December 20, 2018 9:47 PM
To: John E Drake <[email-masked]>; Igor Bryskin <[email-masked]>; Andrew G. Malis <[email-masked]>; [email-masked] <[email-masked]>
Cc: TEAS WG Chairs <[email-masked]>; [email-masked]
Subject: RE: [Teas] WG adoption poll - draft-dong-teas-enhanced-vpn-03

Hi John,

[JD]  I don’t recall any such discussion in the draft.  Further, what is the maximum # of VPN+ instances supported in a given network such that that network does not implode?

Best regards,
Jie

To: Igor Bryskin <[email-masked]<mailto:[email-masked]>>; Andrew G. Malis <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>

Igor,

Yours Irrespectively,

John

Hi John,

Thanks,
Igor

Andy,

Yours Irrespectively,

John

Cheers,
Andy

Thanks,
Pavan and Lou

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Mon, 24 Dec 2018 09:45:46 +0000

Hi John,

Please see inline.

Best regards,
Jie

From: John E Drake [mailto:[email-masked]]
Sent: Friday, December 21, 2018 9:15 PM
To: Dongjie (Jimmy) <[email-masked]>; Igor Bryskin <[email-masked]>; Andrew G. Malis <[email-masked]>; [email-masked] <[email-masked]>
Cc: TEAS WG Chairs <[email-masked]>; [email-masked]
Subject: RE: [Teas] WG adoption poll - draft-dong-teas-enhanced-vpn-03

Hi,

Comment inline

Yours Irrespectively,

John

From: Dongjie (Jimmy) <[email-masked]<mailto:[email-masked]>>
Sent: Thursday, December 20, 2018 9:47 PM
To: John E Drake <[email-masked]<mailto:[email-masked]>>; Igor Bryskin <[email-masked]<mailto:[email-masked]>>; Andrew G. Malis <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Cc: TEAS WG Chairs <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: [Teas] WG adoption poll - draft-dong-teas-enhanced-vpn-03

Hi John,

[Jie] Such discussion happened during the presentation on previous IETF meetings, the current draft doesn't mandate the mapping of each individual VPN to dedicated logical network with resources allocated. That said, we could add some clarification in future version. The number of enhanced VPNs would depend on the number of services and customers which have such level of SLA requirement.

Best regards,
Jie

Igor,

Yours Irrespectively,

John

Hi John,

Thanks,
Igor

Andy,

Yours Irrespectively,

John

Cheers,
Andy

Thanks,
Pavan and Lou

---

From: John E Drake <[email-masked]>
Date: Mon, 24 Dec 2018 12:48:57 +0000

Comments inline

Sent from my iPhone

On Dec 24, 2018, at 5:46 AM, Dongjie (Jimmy) <[email-masked]<mailto:[email-masked]>> wrote:

Hi John,

Please see inline.

Best regards,
Jie

To: Dongjie (Jimmy) <[email-masked]<mailto:[email-masked]>>; Igor Bryskin <[email-masked]<mailto:[email-masked]>>; Andrew G. Malis <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>

Hi,

Comment inline

Yours Irrespectively,

John

Hi John,

[Jie] Such discussion happened during the presentation on previous IETF meetings, the current draft doesn't mandate the mapping of each individual VPN to dedicated logical network with resources allocated.

JD. I am going to compile a list of statements
that the draft makes that would lead one to a
different conclusion

That said, we could add some clarification in future version. The number of enhanced VPNs would depend on the number of services and customers which have such level of SLA requirement.

JD  So, you have no guidance to offer?

Best regards,
Jie

Igor,

Yours Irrespectively,

John

Hi John,

Thanks,
Igor

Andy,

Yours Irrespectively,

John

Cheers,
Andy

Thanks,
Pavan and Lou

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 24 Dec 2018 09:33:49 -0500

John,

Does RFC 3209 have any guidance on how many RSVP-TE sessions you can run
simultaneously in a network, or a node? It's obviously both implementation
and deployment dependent. Why is this draft any different?

Cheers,
Andy

On Mon, Dec 24, 2018 at 7:49 AM John E Drake <[email-masked]> wrote:

> Comments inline
>
> Sent from my iPhone
>
> On Dec 24, 2018, at 5:46 AM, Dongjie (Jimmy) <[email-masked]> wrote:
>
> Hi John,
>
>
>
> Please see inline.
>
>
>
> Best regards,
>
> Jie
>
>
>
> *From:* John E Drake [mailto:[email-masked] <[email-masked]>]
> *Sent:* Friday, December 21, 2018 9:15 PM
> *To:* Dongjie (Jimmy) <[email-masked]>; Igor Bryskin <
> [email-masked]>; Andrew G. Malis <[email-masked]>;
> [email-masked] <[email-masked]>
> *Subject:* RE: [Teas] WG adoption poll - draft-dong-teas-enhanced-vpn-03
>
>
>
> Hi,
>
>
>
> Comment inline
>
>
>
> Yours Irrespectively,
>
>
>
> John
>
>
>
> *From:* Dongjie (Jimmy) <[email-masked]>
> *Sent:* Thursday, December 20, 2018 9:47 PM
> *To:* John E Drake <[email-masked]>; Igor Bryskin <
> [email-masked]>; Andrew G. Malis <[email-masked]>;
> [email-masked] <[email-masked]>
> *Subject:* RE: [Teas] WG adoption poll - draft-dong-teas-enhanced-vpn-03
>
>
>
> Hi John,
>
>
>
> This draft does not suggest to allocate network resources to each
> individual VPN, only the VPNs which require particular level of SLA need to
> be integrated with underlay network resources, thus the number of enhanced
> VPN would be much less than the number of traditional overlay VPNs. Also it
> is possible that several VPNs with similar characteristics could be
> assigned with a set of aggregated resources,  and would share the same
> logical network.
>
>
>
> *[JD]  I don’t recall any such discussion in the draft.  Further, what is
> the maximum # of VPN+ instances supported in a given network such that that
> network does not implode?*
>
>
>
> [Jie] Such discussion happened during the presentation on previous IETF
> meetings, the current draft doesn't mandate the mapping of each individual
> VPN to dedicated logical network with resources allocated.
>
>
> That said, we could add some clarification in future version. The number
> of enhanced VPNs would depend on the number of services and customers which
> have such level of SLA requirement.
>
>
>
>
> *From:* Teas [mailto:[email-masked] <[email-masked]>] *On
> Behalf Of *John E Drake
> *Sent:* Thursday, December 20, 2018 11:14 PM
> *To:* Igor Bryskin <[email-masked]>; Andrew G. Malis <
> [email-masked]>; [email-masked] <[email-masked]>
> I am not convinced that network slicing is a good idea because it assumes
> that logical networks w/ vastly different characteristics can be built out
> of a set of common network resources.  I am convinced that allocating
> network resources on a per-VPN basis is a bad idea because of the scaling
> issues.
>
>
>
> Yours Irrespectively,
>
>
>
> John
>
>
>
> *From:* Igor Bryskin <[email-masked]>
> *Sent:* Thursday, December 20, 2018 9:55 AM
> *To:* John E Drake <[email-masked]>; Andrew G. Malis <
> [email-masked]>; [email-masked] <[email-masked]>
> *Subject:* RE: [Teas] WG adoption poll - draft-dong-teas-enhanced-vpn-03
>
>
>
> Hi John,
>
>
>
> Do you see any differences between a logical network and a network
> topology? Specifically, would you define network slices as produced by the
> same physical network sufficiently separated network topologies, each of
> which designed for specific class(es) of clients/overlays, with network
> resources available for the overlays limited by the resource pools
> allocated to the corresponding topologies? Another question: could network
> slices in your opinion be built hierarchically, i.e. higher level slices
> comprised of lower level ones?
>
>
>
> Thanks,
>
> Igor
>
>
>
> *From:* Teas [mailto:[email-masked] <[email-masked]>] *On
> Behalf Of *John E Drake
> *Sent:* Wednesday, December 19, 2018 11:46 AM
> *To:* Andrew G. Malis; [email-masked]
> *Cc:* TEAS WG Chairs; [email-masked]
> https://www.merriam-webster.com/dictionary/framework
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.merriam-2Dwebster.com_dictionary_framework&d=DwMGaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=CRB2tJiQePk0cT-h5LGhEWH-s_xXXup3HzvBSMRj5VE&m=n9sCWh1x8RH083BAlFMqUZfK0blyu7AEqTYj5kopZ1I&s=o2aQfkCcHYaq6v8_OptqlhDqzYAgs1OiHS3JnOcuXtY&e=>).
> Rather, I would characterize it as a set of semi-random musings.
>
>
>
> Yours Irrespectively,
>
>
>
> John
>
>
>
> *From:* Teas <[email-masked]> *On Behalf Of *Andrew G. Malis

---

From: John E Drake <[email-masked]>
Date: Mon, 24 Dec 2018 15:06:03 +0000

Andy,

The difference is that the RFC 3209 control plane overhead is per-network where here it is per-VPN and the per-VPN overhead appears to be arbitrarily large.

Thanks,

John

Sent from my iPhone

On Dec 24, 2018, at 10:34 AM, Andrew G. Malis <[email-masked]<mailto:[email-masked]>> wrote:

John,

Does RFC 3209 have any guidance on how many RSVP-TE sessions you can run simultaneously in a network, or a node? It's obviously both implementation and deployment dependent. Why is this draft any different?

Cheers,
Andy

On Mon, Dec 24, 2018 at 7:49 AM John E Drake <[email-masked]<mailto:[email-masked]>> wrote:
Comments inline

Sent from my iPhone

Hi John,

Please see inline.

Best regards,
Jie

Hi,

Comment inline

Yours Irrespectively,

John

Hi John,

Best regards,
Jie

Igor,

Yours Irrespectively,

John

Hi John,

Thanks,
Igor

Andy,

Yours Irrespectively,

John

Cheers,
Andy

Thanks,
Pavan and Lou

---

From: John E Drake <[email-masked]>
Date: Mon, 24 Dec 2018 15:55:39 +0000

It’s also the case that RFC3209 is a bad example for you to use because of the many subsequent drafts that attempt to improve its scalabity

Sent from my iPhone

On Dec 24, 2018, at 11:06 AM, John E Drake <[email-masked]<mailto:[email-masked]>> wrote:

Andy,

Thanks,

John

Sent from my iPhone

John,

Cheers,
Andy

Sent from my iPhone

Hi John,

Please see inline.

Best regards,
Jie

Hi,

Comment inline

Yours Irrespectively,

John

Hi John,

Best regards,
Jie

Igor,

Yours Irrespectively,

John

Hi John,

Thanks,
Igor

Andy,

Yours Irrespectively,

John

Cheers,
Andy

Thanks,
Pavan and Lou
_______________________________________________
Teas mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/teas<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_teas&d=DwMFaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=CRB2tJiQePk0cT-h5LGhEWH-s_xXXup3HzvBSMRj5VE&m=jfPzAk6KYMTzEcjux7ADyZR5qPrxoPYBDdzWSlkedyw&s=uXdPvThk8MvzKASbv-H0_ekBtni_GK-xqPKnIbJ6ek4&e=>
_______________________________________________
Teas mailing list
[email-masked]<mailto:[email-masked]>
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_teas&d=DwICAg&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=CRB2tJiQePk0cT-h5LGhEWH-s_xXXup3HzvBSMRj5VE&m=7q7Sy9mXUL7vBxkH5ULTOz4idsbbCsUJ_xpR01oLUQU&s=aCFHn4WsPSFFoVQOHJYfaYoLfXNlndixBrCnjoluO00&e=