Subject: Re: [Teas] I-D Action: draft-ietf-teas-actn-vn-yang-03.txt

From: Lou Berger <[email-masked]>
Date: Sun, 3 Feb 2019 15:40:30 -0500

young/authors,

     I think this is a good start.  My suggestions to finish what you've 
started here and make the model and the document generally applicable to 
any mode of VN operation

1) Do a global replace s/ACTN VN/VN/g

2) Reframe the informative material to to be focused on general VN 
Operation and use ACTN as the primary example.  I think this mainly 
impacts moving the 1st three paragraphs to later in the section an 
stating that ACTN is an example (context).  It also make section 2 and 3 
need to be updated to state that ACTN is being used to illustrate the 
general usage of the VN yang model.

3) container actn, ap as vn can be top level nodes.

Thanks!

Lou

On 12/30/2018 11:20 PM, Leeyoung wrote:
> Hi,
>
> This is to update per comments raised up in IETF 103 meeting to make this model applicable not only in an ACTN context but also in generic context outside of ACTN context as an independent VN model in and of itself.
>
> Please see the below diff pointer to see the difference from the previous version. Please let us know in case you have any question or comment.
>
> Thanks & Best regards,
> Young (on behalf of other co-authors)
>
>
> -----Original Message-----
> From: Teas [mailto:[email-masked]] On Behalf Of [email-masked]
> Sent: Sunday, December 30, 2018 10:11 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Teas] I-D Action: draft-ietf-teas-actn-vn-yang-03.txt
>
>
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the Traffic Engineering Architecture and Signaling WG of the IETF.
>
>          Title           : A Yang Data Model for ACTN VN Operation
>          Authors         : Young Lee
>                            Dhruv Dhody
>                            Daniele Ceccarelli
>                            Igor Bryskin
>                            Bin Yeong Yoon
>                            Qin Wu
>                            Peter Park
> 	Filename        : draft-ietf-teas-actn-vn-yang-03.txt
> 	Pages           : 54
> 	Date            : 2018-12-30
>
> Abstract:
>     This document provides a YANG data model for the Abstraction and
>     Control of Traffic Engineered (TE) networks (ACTN) Virtual Network
>     Service (VNS) operation.
>
>
>
>
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-teas-actn-vn-yang/
>
> There are also htmlized versions available at:
> https://tools.ietf.org/html/draft-ietf-teas-actn-vn-yang-03
> https://datatracker.ietf.org/doc/html/draft-ietf-teas-actn-vn-yang-03
>
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-ietf-teas-actn-vn-yang-03
>
>
> Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
> _______________________________________________
> Teas mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teas
>
> _______________________________________________
> Teas mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teas
>

---

From: Lou Berger <[email-masked]>
Date: Mon, 4 Feb 2019 07:29:36 -0500

one correction below...

> 3) container actn, ap as vn can be top level nodes.
3) drop container actn, as ap and vn can be top level nodes (containers)

Lou

---

From: Leeyoung <[email-masked]>
Date: Mon, 4 Feb 2019 19:16:27 +0000

Hi Lou,

Thanks for further comments on the VN Yang draft. The revision has been published (please see the attachment) with all your comments having been incorporated. 
Please let us know if this is good to go (and therefore, we can also move TE-service mapping draft to the WG poll); if not, please provide further comments. 

Thanks & Best regards,
Young (on behalf of co-authors) 

-----Original Message-----
From: Lou Berger [mailto:[email-masked]] 
Sent: Monday, February 4, 2019 6:30 AM
To: Leeyoung <[email-masked]>; [email-masked]
Subject: Re: [Teas] I-D Action: draft-ietf-teas-actn-vn-yang-03.txt

one correction below...

On 2/3/2019 3:40 PM, Lou Berger wrote:
> young/authors,
> 
>       I think this is a good start.  My suggestions to finish what 
> you've started here and make the model and the document generally 
> applicable to any mode of VN operation
> 
> stating that ACTN is an example (context).  It also make section 2 and 
> 3 need to be updated to state that ACTN is being used to illustrate 
> the general usage of the VN yang model.
> 

Lou

>> ftp://ftp.ietf.org/internet-drafts/

Subject: [Teas] I-D Action: draft-ietf-teas-actn-vn-yang-04.txt
From: "[email-masked]" <[email-masked]>
To: "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Date: Mon, 4 Feb 2019 19:04:57 +0000

        Title           : A Yang Data Model for VN Operation
        Authors         : Young Lee
                          Dhruv Dhody
                          Daniele Ceccarelli
                          Igor Bryskin
                          Bin Yeong Yoon
                          Qin Wu
                          Peter Park
	Filename        : draft-ietf-teas-actn-vn-yang-04.txt
	Pages           : 54
	Date            : 2019-02-04

Abstract:
   This document provides a YANG data model generally applicable to any
   mode of Virtual Network (VN) operation.

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-teas-actn-vn-yang-04
https://datatracker.ietf.org/doc/html/draft-ietf-teas-actn-vn-yang-04

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-teas-actn-vn-yang-04

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

---

From: Lou Berger <[email-masked]>
Date: Mon, 4 Feb 2019 17:20:03 -0500

Young,

     You're quick!  I'll take a look and follow up as needed.

WRT service mapping, do you want to respin the document now or address 
further alignment post adoption?

Thanks,

Lou

---

From: Leeyoung <[email-masked]>
Date: Mon, 4 Feb 2019 23:12:52 +0000

Hi Lou,

Thanks. WRT service mapping, I think we can address further alignment after adoption.  

Best regards,
Young

-----Original Message-----
From: Lou Berger [mailto:[email-masked]] 
Sent: Monday, February 4, 2019 4:20 PM
To: Leeyoung <[email-masked]>; [email-masked]
Subject: Re: [Teas] I-D Action: draft-ietf-teas-actn-vn-yang-03.txt

Young,

WRT service mapping, do you want to respin the document now or address further alignment post adoption?

Thanks,

Lou

---

From: tom petch <[email-masked]>
Date: Tue, 5 Feb 2019 10:38:01 +0000

----- Original Message -----
From: "Leeyoung" <[email-masked]>
Sent: Monday, February 04, 2019 7:16 PM

> Hi Lou,
>
> Thanks for further comments on the VN Yang draft. The revision has
been published (please see the attachment) with all your comments having
been incorporated.
> Please let us know if this is good to go (and therefore, we can also
move TE-service mapping draft to the WG poll); if not, please provide
further comments.

Young

Not good to go IMHO.

The YANG module is wholy devoid of references; they are required for the
import statements and needed, by me at least, for the technicalities of
VN

No reference for YANG in the Introduction

connetivity-matrix-id
appears in many places - I suspect
connectivity-matrix-id
would be more helpful to users.

YANG module lacks copyright

YANG module lacks version statement

inconsistent use of YANG, Yang, yang

significant chunks of the YANG module are elided as comments with no
explanation.

many lines in the I-D are too long, as in the YANG diagram

abbreviations need expanding on first use e.g. L1CSM, L2SM, L3SM, CNC
(in the YANG module) and perhaps VN in the title

reference     "TBD";
perhaps
"RFC XXXX: A Yang Data Model for VN Operation"

       /*
       * Notifications - TBD
       */
!

Tom Petch

> >> This is to update per comments raised up in IETF 103 meeting to
make this model applicable not only in an ACTN context but also in
generic context outside of ACTN context as an independent VN model in
and of itself.
> >>
> >> Please see the below diff pointer to see the difference from the
previous version. Please let us know in case you have any question or
comment.