Subject: Re: [Teas] WG Adoption Poll - draft-king-teas-applicability-actn-slicing-10

From: Daniele Ceccarelli <[email-masked]>
Date: Mon, 30 Aug 2021 08:59:24 +0000

Hi WG,

while reviewing this draft and the network slice NBI YANG I find a major discrepancy between them.
While draft-king-teas-applicability-actn-slicing-10

  draft-wd-teas-ietf-network-slice-nbi-yang-04 says that:

“ACTN is a
   toolset capable of delivering network slice functionality.  This
   document outlines the application of ACTN and associated enabling
   technologies to provide network slicing in a network that utilizes
   IETF technologies such as IP, MPLS, or GMPLS.  It describes how the
   ACTN functional components can be used to support model-driven
   partitioning of resources into variable-sized bandwidth units to
   facilitate network sharing and virtualization.”

On the other side we have a network slicing NBI model completely detached from ACTN that says:

“The difference between the ACTN VN model and the IETF Network Slice

   NBI requirements is that the IETF Network Slice NBI is a technology-

   agnostic interface, whereas the VN model is bound to the IETF TE

   Topologies.  The realization of the IETF Network Slice does not

   necessarily require the slice network to support the TE technology.”

And

“However, the Network Slice SLO and Network Slice

   Endpoint are not clearly defined and there's no direct equivalent.”

So is ACTN applicable to network slicing or not? And if yes how? I was expecting to see the NBI model based on the ACTN models with some augmentation to cover the e.g. the non TE parts, the LSO and the endpoints…but we have two completely disjoint modules.
I would say that the two drafts are saying exactly the opposite thing, am I missing something?

Thanks,
Daniele

From: Teas <[email-masked]> On Behalf Of Vishnu Pavan Beeram
Sent: den 27 augusti 2021 14:49
To: TEAS WG <[email-masked]>
Cc: TEAS WG Chairs <[email-masked]>
Subject: [Teas] WG Adoption Poll - draft-king-teas-applicability-actn-slicing-10

All,

This is start of a *two* week poll on making
draft-king-teas-applicability-actn-slicing-10 a TEAS working group document.
Please send email to the list indicating "yes/support" or "no/do not support".
If indicating no, please state your reservations with the document. If
yes, please also feel free to provide comments you'd like to see
addressed once the document is a WG document.

The poll ends September 10th.

Thank you,
Pavan and Lou

---

From: Daniele Ceccarelli <[email-masked]>
Date: Tue, 31 Aug 2021 13:16:34 +0000

Hi Pavan, all,

Yes/Support,

BR
Daniele

All,

Thank you,
Pavan and Lou