Subject: [Teas] Some comments on draft-ali-teas-spring-ns-building-blocks

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Mon, 2 Aug 2021 09:07:02 +0000

Hi authors,

Thanks for the presentation in the TEAS session in last week. Here are some comments on this draft:

1.      As discussed on the TEAS meeting, the terminologies in several drafts related to network slicing realization will be aligned, thus it is suggested the terminology in this document also aligns with the "new term" to be proposed.

2.      As this document lists the SR technologies which can be used for network slice realization in SR networks, the suggestion is it should also describe and reference draft-ietf-spring-resource-aware-segments and draft-ietf-spring-sr-for-enhanced-vpn which specifies the extensions to SR segments and the mechanisms to provide SR based VTNs.

3.      Section 8 of this document describes the "stateless network slice ID" concept and the mechanisms with different data planes. The general mechanism of introducing dedicated VTN identifier in data packet for per-VTN packet processing was described in draft-dong-teas-enhanced-vpn-vtn-scalability, thus there is some overlap in this part which needs to be solved in future versions.

Best regards,
Jie

---

From: <[email-masked]>
Date: Mon, 2 Aug 2021 17:39:12 +0800 (CST)

Hi Dongjie,

Seeing that you openly mention VTN-ID, I have to remind you again that the VTN-ID is just the A-I-I of draft-peng-teas-network-slicing which analyzes the necessity of introducing slice identifier into underlay network. I believe you never thought about dealing with the overlap of VTN-ID and A-I-I, so how can you ask other drafts to do so?  
Again, you may say that the A-I-I related scheme described by draft-peng-teas-network-slicing has scalability problems ... ... so that VTN-ID is not A-I-I... ... 

Regards,
PSF

------------------原始邮件------------------
发件人：Dongjie(Jimmy)
收件人：[email-masked];
抄送人：TEAS WG;
日 期 ：2021年08月02日 17:07
主 题 ：[Teas] Some comments on draft-ali-teas-spring-ns-building-blocks
_______________________________________________
Teas mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/teas

Hi authors,

---

From: Huzhibo <[email-masked]>
Date: Mon, 2 Aug 2021 12:16:04 +0000

Hi PSF, 

The discussion Jie referred to was the about the terminology alignment between VTN, Slice Aggregate, etc. in several active network slice related drafts. With the "merging" of draft-peng-teas-network-slicing into draft-bestbar-teas-ns-packet, it is not clear whether the term "AII" has been totally replaced by "Slice Aggregate", or you still plan to work on it separately?

After the discussion among the authors of several drafts, the agreement is to find a common new term for network slice realization, so that those drafts could refer to that new term. This is also what we suggested to the authors of draft-ali-teas-spring-ns-building-blocks for better terminology alignment.

Best regards,
Zhibo

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, August 2, 2021 5:39 PM
To: Dongjie (Jimmy) <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re:[Teas] Some comments on draft-ali-teas-spring-ns-building-blocks

Hi Dongjie,

Regards,
PSF

------------------原始邮件------------------
发件人：Dongjie(Jimmy)

Hi authors,

---

From: <[email-masked]>
Date: Tue, 3 Aug 2021 12:37:29 +0800 (CST)

Hi Zhibo,

First, when aii was proposed in draft-peng-teas-network-slicing to introduce slice identifier to underlay network, it was not good just to change its name as vtn-id in redundant draft, for example, just open https://www.ietf.org/archive/id/draft-zch-lsr-isis-network-slicing-06.txt and https://www.ietf.org/archive/id/draft-dong-lsr-sr-enhanced-vpn-06.txt to see the repeat and overlap.
Second, SA-ID defined in draft-bestbar-teas-ns-packet has completely covered aii and vtn-id, especially when the mapping of slice and Slice-Aggregate is 1:1. 
So that there is not any reason for you to continue to update vtn-id concept, and even ask other proposals to be alignment with VTN.   

Regards,
PSF

------------------原始邮件------------------
发件人：Huzhibo
收件人：彭少富10053815;Dongjie (Jimmy);
抄送人：[email-masked];[email-masked];
日 期 ：2021年08月02日 20:21
主 题 ：RE: Re:[Teas] Some comments on draft-ali-teas-spring-ns-building-blocks
Hi PSF,
The discussion Jie referred to was the about the terminology alignment between VTN, Slice Aggregate, etc. in several active network slice related drafts. With the "merging" of draft-peng-teas-network-slicing into draft-bestbar-teas-ns-packet, it is not clear whether the term "AII" has been totally replaced by "Slice Aggregate", or you still plan to work on it separately?
After the discussion among the authors of several drafts, the agreement is to find a common new term for network slice realization, so that those drafts could refer to that new term. This is also what we suggested to the authors of draft-ali-teas-spring-ns-building-blocks for better terminology alignment.
Best regards,
Zhibo
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, August 2, 2021 5:39 PM
To: Dongjie (Jimmy) <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re:[Teas] Some comments on draft-ali-teas-spring-ns-building-blocks
Hi Dongjie,
------------------原始邮件------------------
发件人：Dongjie(Jimmy)

---

From: Huzhibo <[email-masked]>
Date: Tue, 3 Aug 2021 09:20:16 +0000

Hi PSF:

   Both the VTN and AII identify the underlay of the slice. However, the VTN-ID is not used as an identifier of the control plane topology. Instead, the topology of the slice is defined by referencing an existing multi-topology technology. VTN-ID defines the topology and resources of a slice by decoupling the topology and resources, which are different from AII. As mentioned in the previous email, the agreement is to find a common new term for network slice realization.

Best regards,
Zhibo
-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, August 3, 2021 12:37 PM
To: Huzhibo <[email-masked]>
Cc: Dongjie (Jimmy) <[email-masked]>; [email-masked]; [email-masked]
Subject: Re: [Teas] Some comments on draft-ali-teas-spring-ns-building-blocks

Hi Zhibo,

Regards,
PSF

------------------原始邮件------------------
发件人：Huzhibo
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, August 2, 2021 5:39 PM
To: Dongjie (Jimmy) <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re:[Teas] Some comments on draft-ali-teas-spring-ns-building-blocks
Hi Dongjie,
------------------原始邮件------------------
发件人：Dongjie(Jimmy)

---

From: <[email-masked]>
Date: Tue, 3 Aug 2021 18:48:55 +0800 (CST)

Hi Zhibo,

See in-line [PSF].

Regards,
PSF

------------------原始邮件------------------
发件人：Huzhibo
收件人：彭少富10053815;
抄送人：Dongjie (Jimmy);[email-masked];[email-masked];
日 期 ：2021年08月03日 17:20
主 题 ：RE: [Teas]  Some comments on draft-ali-teas-spring-ns-building-blocks
Hi PSF:

Both the VTN and AII identify the underlay of the slice. 
[PSF] that is right.

However, the VTN-ID is not used as an identifier of the control plane topology. Instead, the topology of the slice is defined by referencing an existing multi-topology technology.
VTN-ID defines the topology and resources of a slice by decoupling the topology and resources, which are different from AII. 
[PSF] Whether it is customizing slice's own topology (such as AII) or referencing an existing topology (such as VTN-ID), there is a logical topology for slice. So VTN-ID is also actually an identifier of logical topology. And, both AII and VTN-ID are used to identify resouce. So, the smallest difference for AII and VTN-ID is the flavor to create the logical topology. Note that draft-bestbar-teas-ns-packet contains both customizing and referencing flavor.

As mentioned in the previous email, the agreement is to find a common new term for network slice realization.
[PSF] Agree, alignment with some new term, but not VTN according to Dongjie's original mail.

Best regards,
Zhibo
-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, August 3, 2021 12:37 PM
To: Huzhibo <[email-masked]>
Cc: Dongjie (Jimmy) <[email-masked]>; [email-masked]; [email-masked]
Subject: Re: [Teas] Some comments on draft-ali-teas-spring-ns-building-blocks

Hi Zhibo,

Regards,
PSF

------------------原始邮件------------------
发件人：Huzhibo
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, August 2, 2021 5:39 PM
To: Dongjie (Jimmy) <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re:[Teas] Some comments on draft-ali-teas-spring-ns-building-blocks
Hi Dongjie,
------------------原始邮件------------------
发件人：Dongjie(Jimmy)

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Tue, 3 Aug 2021 13:05:00 +0000

Hi PSF,

See inline:

> Sent: Tuesday, August 3, 2021 6:49 PM
> Cc: Dongjie (Jimmy) <[email-masked]>; [email-masked];
> [email-masked]
> 抄送人：Dongjie
> (Jimmy);[email-masked];[email-masked];
> 日 期 ：2021年08月03日 17:20
> However, the VTN-ID is not used as an identifier of the control plane topology.
> Instead, the topology of the slice is defined by referencing an existing
> multi-topology technology.
> VTN-ID defines the topology and resources of a slice by decoupling the
> topology and resources, which are different from AII.
> [PSF] Whether it is customizing slice's own topology (such as AII) or referencing
> an existing topology (such as VTN-ID), there is a logical topology for slice. So
> VTN-ID is also actually an identifier of logical topology. And, both AII and
> VTN-ID are used to identify resouce. So, the smallest difference for AII and
> VTN-ID is the flavor to create the logical topology. Note that
> draft-bestbar-teas-ns-packet contains both customizing and referencing flavor.

[Jie] The key difference is that AII reinvents the wheel by defining a new topology identifier, while VTN refers to the well-defined MT or Flex-Algo for its topology attribute. This is why VTN allows the decoupling of topology and resource attributes to provide better scalability, while AII has limitation in the supported network scale. 

[Jie] Apparently you didn't read my mail carefully. Here is what I suggested in my email:

> 1. As discussed on the TEAS meeting, the terminologies in several drafts
> related to network slicing realization will be aligned, thus it is suggested the
> terminology in this document also aligns with the "new term"  to be
> proposed.

-Jie

> Cc: Dongjie (Jimmy) <[email-masked]>; [email-masked];
> [email-masked]
> First, when aii was proposed in draft-peng-teas-network-slicing to introduce
> slice identifier to underlay network, it was not good just to change its name as
> vtn-id in redundant draft, for example, just open
> https://www.ietf.org/archive/id/draft-zch-lsr-isis-network-slicing-06.txt and
> https://www.ietf.org/archive/id/draft-dong-lsr-sr-enhanced-vpn-06.txt to see
> the repeat and overlap.
> Second, SA-ID defined in draft-bestbar-teas-ns-packet has completely covered
> aii and vtn-id, especially when the mapping of slice and Slice-Aggregate is 1:1.
> So that there is not any reason for you to continue to update vtn-id concept,
> and even ask other proposals to be alignment with VTN.
> 
> Regards,
> PSF
> 
> The discussion Jie referred to was the about the terminology alignment
> between VTN, Slice Aggregate, etc. in several active network slice related
> drafts. With the "merging" of draft-peng-teas-network-slicing into
> draft-bestbar-teas-ns-packet, it is not clear whether the term "AII" has been
> totally replaced by "Slice Aggregate", or you still plan to work on it separately?
> After the discussion among the authors of several drafts, the agreement is to
> find a common new term for network slice realization, so that those drafts
> could refer to that new term. This is also what we suggested to the authors of
> draft-ali-teas-spring-ns-building-blocks for better terminology alignment.
> Best regards,
> Zhibo
> Seeing that you openly mention VTN-ID, I have to remind you again that the
> VTN-ID is just the A-I-I of draft-peng-teas-network-slicing which analyzes the
> necessity of introducing slice identifier into underlay network. I believe you
> never thought about dealing with the overlap of VTN-ID and A-I-I, so how can
> you ask other drafts to do so?
> Again, you may say that the A-I-I related scheme described by
> draft-peng-teas-network-slicing has scalability problems ... ... so that VTN-ID is
> not A-I-I... ...
> Regards,
> PSF
> 1.      As discussed on the TEAS meeting, the terminologies in several drafts
> related to network slicing realization will be aligned, thus it is suggested the
> terminology in this document also aligns with the "new term"  to be
> proposed.
> 2.      As this document lists the SR technologies which can be used for
> network slice realization in SR networks, the suggestion is it should also
> describe and reference draft-ietf-spring-resource-aware-segments and
> draft-ietf-spring-sr-for-enhanced-vpn which specifies the extensions to SR
> segments and the mechanisms to provide SR based VTNs.
> 3.      Section 8 of this document describes the "stateless network slice ID"
> concept and the mechanisms with different data planes. The general
> mechanism of introducing dedicated VTN identifier in data packet for per-VTN
> packet processing was described in
> draft-dong-teas-enhanced-vpn-vtn-scalability, thus there is some overlap in
> this part which needs to be solved in future versions.
> Best regards,
> Jie

---

From: <[email-masked]>
Date: Wed, 4 Aug 2021 08:58:24 +0800 (CST)

Hi Dongjie,

Please see inline [PSF2]

Regards,
PSF

------------------原始邮件------------------
发件人：Dongjie(Jimmy)
收件人：彭少富10053815;Huzhibo;
抄送人：[email-masked];[email-masked];
日 期 ：2021年08月03日 21:05
主 题 ：RE: Re:[Teas]  Some comments on draft-ali-teas-spring-ns-building-blocks
Hi PSF,

[PSF2] AII is not an IGP topology identifier in a narrow sense, instead, it represents the logical topology identification of an end-to-end slice, including the connection of intra/inter domains. Within IGP domian part of an E2E slice, the flavor of topology can be customized or referenced. Again, the difference between flavors is not the key to this concept, although the existing IGP MT/Flex-algo can indeed bring benefits in scalability. Just ask you several questions: 1) If IGP MT/Flex-algo are not deployed in the IGP domain, how to build slice ? 2) For inter-domain links, how to use referencing flavor to distinguish resource of slices ? 
[PSF2] So that it is limited to completely rely on IGP/Flex-algo to define the logical topology of slices. Note again that draft-bestbar-teas-ns-packet contains both customizing and referencing flavors.

> terminology in this document also aligns with the "new term"  to be

[PSF2] Thanks for reminding, but the 2nd and 3rd points ... ...

-Jie

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Wed, 4 Aug 2021 09:48:42 +0000

Hi PSF,

I'm afraid this discussion have deviated from the original comments I made on draft-ali-teas-spring-ns-building-blocks. Please see my brief replies inline to conclude this discussion. 

If you still want to talk about AII further, a separate thread would be a better choice. 

-Jie

> Sent: Wednesday, August 4, 2021 8:58 AM
> Cc: Huzhibo <[email-masked]>; [email-masked];
> > Instead, the topology of the slice is defined by referencing an
> > existing multi-topology technology.
> > [PSF] Whether it is customizing slice's own topology (such as AII) or
> > referencing an existing topology (such as VTN-ID), there is a logical
> > topology for slice. So VTN-ID is also actually an identifier of
> > logical topology. And, both AII and VTN-ID are used to identify
> > resouce. So, the smallest difference for AII and VTN-ID is the flavor
> > to create the logical topology. Note that draft-bestbar-teas-ns-packet
> contains both customizing and referencing flavor.
> 
> [Jie] The key difference is that AII reinvents the wheel by defining a new
> topology identifier, while VTN refers to the well-defined MT or Flex-Algo for its
> topology attribute. This is why VTN allows the decoupling of topology and
> resource attributes to provide better scalability, while AII has limitation in the
> supported network scale.
> 
> [PSF2] AII is not an IGP topology identifier in a narrow sense, instead, it
> represents the logical topology identification of an end-to-end slice, including
> the connection of intra/inter domains. Within IGP domian part of an E2E slice,
> the flavor of topology can be customized or referenced. Again, the difference
> between flavors is not the key to this concept, although the existing IGP
> MT/Flex-algo can indeed bring benefits in scalability. Just ask you several
> questions: 1) If IGP MT/Flex-algo are not deployed in the IGP domain, how to
> build slice ? 2) For inter-domain links, how to use referencing flavor to
> distinguish resource of slices ?
> [PSF2] So that it is limited to completely rely on IGP/Flex-algo to define the
> logical topology of slices. Note again that draft-bestbar-teas-ns-packet
> contains both customizing and referencing flavors.

[Jie] According to draft-peng-teas-network-slicing, AII is a topology identifier, no matter of inter- or intra- domain. And in that document, there is no such thing like "the flavor of topology can be customized or referenced".

> > 1. As discussed on the TEAS meeting, the terminologies in several
> > drafts related to network slicing realization will be aligned, thus it
> > is suggested the terminology in this document also aligns with the
> > "new term"  to be proposed.
> 

[Jie] The 2nd and 3rd comments are not related to the terminology alignment. 

> > First, when aii was proposed in draft-peng-teas-network-slicing to
> > introduce slice identifier to underlay network, it was not good just
> > to change its name as vtn-id in redundant draft, for example, just
> > open
> > Second, SA-ID defined in draft-bestbar-teas-ns-packet has completely
> > covered aii and vtn-id, especially when the mapping of slice and
> Slice-Aggregate is 1:1.
> > So that there is not any reason for you to continue to update vtn-id
> > concept, and even ask other proposals to be alignment with VTN.
> >
> > Regards,
> > PSF
> >
> > between VTN, Slice Aggregate, etc. in several active network slice
> > related drafts. With the "merging" of draft-peng-teas-network-slicing
> > into draft-bestbar-teas-ns-packet, it is not clear whether the term
> > "AII" has been totally replaced by "Slice Aggregate", or you still plan to work
> on it separately?
> > After the discussion among the authors of several drafts, the
> > agreement is to find a common new term for network slice realization,
> > so that those drafts could refer to that new term. This is also what
> > we suggested to the authors of draft-ali-teas-spring-ns-building-blocks for
> better terminology alignment.
> > Best regards,
> > Zhibo
> > Seeing that you openly mention VTN-ID, I have to remind you again that
> > the VTN-ID is just the A-I-I of draft-peng-teas-network-slicing which
> > analyzes the necessity of introducing slice identifier into underlay
> > network. I believe you never thought about dealing with the overlap of
> > VTN-ID and A-I-I, so how can you ask other drafts to do so?
> > draft-peng-teas-network-slicing has scalability problems ... ... so
> > that VTN-ID is not A-I-I... ...
> > Regards,
> > PSF
> > related to network slicing realization will be aligned, thus it is
> > suggested the terminology in this document also aligns with the "new
> > term"  to be proposed.
> > network slice realization in SR networks, the suggestion is it should
> > also describe and reference draft-ietf-spring-resource-aware-segments
> > and draft-ietf-spring-sr-for-enhanced-vpn which specifies the
> > extensions to SR segments and the mechanisms to provide SR based VTNs.
> > mechanism of introducing dedicated VTN identifier in data packet for
> > per-VTN packet processing was described in
> > draft-dong-teas-enhanced-vpn-vtn-scalability, thus there is some
> > overlap in this part which needs to be solved in future versions.
> > Best regards,
> > Jie

---

From: <[email-masked]>
Date: Wed, 4 Aug 2021 18:24:14 +0800 (CST)

Hi Jie,

Sorry to interfere with the subject of your original mail. : )
So let's suspend the debate, and I will not respond to your deliberate misinterpretation of AII. When we work on draft-bestbar-teas-ns-packet, AII is not important again, but the fact is that: VTN-ID IS AII.
I sugguest you remove the 2nd and 3rd points that is related with VTN but has no relationship with terminology alignment, if the purpose of this thread is for  terminology alignment.
End.

Regards,
PSF

------------------原始邮件------------------
发件人：Dongjie(Jimmy)
收件人：彭少富10053815;
抄送人：[email-masked];Huzhibo;[email-masked];
日 期 ：2021年08月04日 17:49
主 题 ：Re: [Teas] Some comments on draft-ali-teas-spring-ns-building-blocks
Hi PSF,
I'm afraid this discussion have deviated from the original comments I made on draft-ali-teas-spring-ns-building-blocks. Please see my brief replies inline to conclude this discussion.
If you still want to talk about AII further, a separate thread would be a better choice.
-Jie