Subject: Bandwidth Constraints model

From: "Francois Le Faucheur (flefauch)" <[email-masked]>
Date: Thu, 3 Oct 2002 15:06:11 +0100

Hello,
 
Quickly went through the thread we had on BC models before/during
Yokohama. My take on it is that:
 
1) There is some concensus on BC Model objectives:
    -i- it should be possible to disable preemption as some network may
not want to use preemption
    -ii- when preemption is disabled, the Model should still work
"reasonably" well.
    -iii- there should be effective use of bandwidth (ie good bandwidth
sharing among CTs).
    -iv- there should be some isolation (ie a CT cannot hogg the bw of
another CT).
    -v- there should be protection against QoS degradation (at least of
the premium CTs e.g Voice, Premium Data...).
    -vi- the BC model should be reasoanly simple and shouldn't require
additional IGP extensions.
 
2) Maximum Allocation Model (MAM) :
    - MAM is "intuitive"/easy to conceptualise
    - In environments where preemption is not to be used, MAM is
attractive because:
        * it is good at achieving isolation. 
        * if one doesn't worry too much about "QoS degradation" of
lower/medium classes, then MAM can achieve reasonable bw efficiency.
    - it cannot simultaneously achieve isolation, bw efficiency and
protection against QoS degradation
 
3) Russian Dolls Model (RDM):
    - In environments where preemption can be used, RDM is attractive
because it can simultaneously achieve Bw efficiency, isolation and
protection against QoS degradation (ie -iii-, -iv- and -v-)
    - in environments where preemption is not to be used, RDM cannot
achieve good isolation. 
 
4) Other Models:
    - Jerry indicated it is actually possible to achieve -iii-, -iv-,
-v- without preemption and will document another BC Model (maximum
allocation with reservation (MAR)) which achieves this.
 
Are we in synch?
 
Cheers
 
Francois

---

From: Dimitry Haskin <[email-masked]>
Date: Thu, 3 Oct 2002 14:12:16 -0400

To be more precise, I'd replace third bullet in 2) with following:
 
    "- it can simultaneously achieve isolation, bw efficiency and protection
against QoS degradation of the premium CTs. It can simultaneously achieve
isolation, bw efficiency but not QoS degradation of lower CTs in presence of
the premium/medium classes."
 
Dimitry

-----Original Message-----
From: Francois Le Faucheur (flefauch) [mailto:[email-masked]]
Sent: Thursday, October 03, 2002 10:06 AM
To: [email-masked]
Subject: Bandwidth Constraints model

Hello,
 
Quickly went through the thread we had on BC models before/during Yokohama.
My take on it is that:
 
1) There is some concensus on BC Model objectives:
    -i- it should be possible to disable preemption as some network may not
want to use preemption
    -ii- when preemption is disabled, the Model should still work
"reasonably" well.
    -iii- there should be effective use of bandwidth (ie good bandwidth
sharing among CTs).
    -iv- there should be some isolation (ie a CT cannot hogg the bw of
another CT).
    -v- there should be protection against QoS degradation (at least of the
premium CTs e.g Voice, Premium Data...).
    -vi- the BC model should be reasoanly simple and shouldn't require
additional IGP extensions.
 
    - In environments where preemption is not to be used, MAM is attractive
because:
 
    - in environments where preemption is not to be used, RDM cannot achieve
good isolation. 
 
4) Other Models:
    - Jerry indicated it is actually possible to achieve -iii-, -iv-, -v-
without preemption and will document another BC Model (maximum allocation
with reservation (MAR)) which achieves this.
 
Are we in synch?
 
Cheers
 
Francois

---

From: "Francois Le Faucheur (flefauch)" <[email-masked]>
Date: Fri, 4 Oct 2002 09:07:22 +0100

Dimitry,

-----Original Message-----
From: Dimitry Haskin [mailto:[email-masked]] 
Sent: 03 October 2002 20:12
To: Francois Le Faucheur (flefauch); [email-masked]
Subject: RE: Bandwidth Constraints model

	To be more precise, I'd replace third bullet in 2) with
following:

	    "- it can simultaneously achieve isolation, bw efficiency
and protection against QoS degradation of the premium CTs. It can
simultaneously achieve isolation, bw efficiency but not QoS degradation
of lower CTs in presence of the premium/medium classes."
	 
	Dimitry

Yes, thanks, that is more precise.
 
Just a small point. To me, it is not possible to guarantee protection of
the "medium" classes (when shooting for bw efficiency), so I would be
more comfortable with:
    "- it can simultaneously achieve isolation, bw efficiency and
protection against QoS degradation of the premium CTs. It can
simultaneously achieve isolation, bw efficiency but not QoS degradation
of lower CTs in presence of the premium CTs ."
 
Cheers
 
Francois

		-----Original Message-----
		From: Francois Le Faucheur (flefauch)
[mailto:[email-masked]]
		Sent: Thursday, October 03, 2002 10:06 AM
		To: [email-masked]
		Subject: Bandwidth Constraints model

		Hello,
		 
		Quickly went through the thread we had on BC models
before/during Yokohama. My take on it is that:
		 
		1) There is some concensus on BC Model objectives:
		    -i- it should be possible to disable preemption as
some network may not want to use preemption
		    -ii- when preemption is disabled, the Model should
still work "reasonably" well.
		    -iii- there should be effective use of bandwidth (ie
good bandwidth sharing among CTs).
		    -iv- there should be some isolation (ie a CT cannot
hogg the bw of another CT).
		    -v- there should be protection against QoS
degradation (at least of the premium CTs e.g Voice, Premium Data...).
		    -vi- the BC model should be reasoanly simple and
shouldn't require additional IGP extensions.
		 
		2) Maximum Allocation Model (MAM) :
		    - MAM is "intuitive"/easy to conceptualise
		    - In environments where preemption is not to be
used, MAM is attractive because:
		        * it is good at achieving isolation. 
		        * if one doesn't worry too much about "QoS
degradation" of lower/medium classes, then MAM can achieve reasonable bw
efficiency.
		    - it cannot simultaneously achieve isolation, bw
efficiency and protection against QoS degradation
		 
		3) Russian Dolls Model (RDM):
		    - In environments where preemption can be used, RDM
is attractive because it can simultaneously achieve Bw efficiency,
isolation and protection against QoS degradation (ie -iii-, -iv- and
-v-)
		    - in environments where preemption is not to be
used, RDM cannot achieve good isolation. 
		 
		4) Other Models:
		    - Jerry indicated it is actually possible to achieve
-iii-, -iv-, -v- without preemption and will document another BC Model
(maximum allocation with reservation (MAR)) which achieves this.
		 
		Are we in synch?
		 
		Cheers
		 
		Francois