Subject: RE: draft-srisuresh-ospf-te-04.txt

From: Jim Boyle <[email-masked]>
Date: Wed, 11 Dec 2002 20:08:20 -0500 (EST)

So it is more of a contribution to the OSPF WG, not the TEWG?
I'll ask ietf-secretary to make the corresponding changes.
You might want to forward the announce message to OSPF WG.

thanks,

Jim

On Wed, 11 Dec 2002, Pyda Srisuresh wrote:

> Hi Jim,
> 
> The draft was not on the OSPF agenda for 51st IETF (London) or the 55th
> IETF(Atlanta), as far as
> I can tell. Besides, I did not attend either of the two IETFs. I did attend
> the Utah IETF (52nd). But,
> there wasn't a slot for OSPF. Oh, well..
> 
> You are right, the above OSPF-TE draft is a competing draft to
> draft-katz-yeung.
> The OSPF-TE draft does more than TE topology discovery and restricted
> flooding along the
> topology.  The draft also covers inter-area TE and pre-engineered circuit
> path LSAs.
> A stand-alone TE-LSDB, independent of the native LSDB is generated for TE
> computations.
> 
> Please send in any comments you might have on the draft. Thanks.
> 
> Regards,
> suresh
> 
> 
> -----Original Message-----
> From: Jim Boyle [mailto:[email-masked]]
> Sent: Tuesday, December 10, 2002 6:52 AM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: draft-srisuresh-ospf-te-04.txt
> 
> 
> This was on the agenda for the 51st and 55th IETF, but no presentation
> (I think I remeber some discussion at the 51st, but it's not in the
> minutes).
> 
> Also, no discussion on the lists.
> 
> What's up with this?  Does anyone see a need to toss out
>         draft-katz-yeung-ospf-traffic-09.txt
> for draft-srisuresh-ospf-te-04.txt so that non TE nodes
> don't have to be bothered with the opaque LSA?  Or
> is there a grander scope to this?
> 
> If not, I'm not sure why we keep seeing this draft rev change
> as an individual contribution to tewg.
> 
> Jim
> ---------- Forwarded message ----------
> Date: Wed, 11 Dec 2002 08:12:35 -0500
> From: [email-masked]
> To: IETF-Announce:  ;
> Cc: [email-masked]
> Subject: I-D ACTION:draft-srisuresh-ospf-te-04.txt
> 
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> This draft is a work item of the Internet Traffic Engineering Working Group
> of the IETF.
> 
>         Title           : OSPF-TE: An experimental extension to OSPF for
> Traffic
>                           Engineering
>         Author(s)       : P. Srisuresh, P. Joseph
>         Filename        : draft-srisuresh-ospf-te-04.txt
>         Pages           : 45
>         Date            : 2002-12-9
> 
> This document defines OSPF-TE, an experimental traffic engineering
> (TE) extension to the link-state routing protocol OSPF. New TE
> LSAs are designed to disseminate TE metrics within an autonomous
> System (AS) - intra-area as well as inter-area. An Autonomous
> System may consist of TE and non-TE nodes. Non-TE nodes are
> uneffected by the distribution of TE LSAs. A stand-alone TE Link
> State Database (TE-LSDB), separate from the native OSPF LSDB, is
> generated for the computation of TE circuit paths. OSPF-TE is
> also extendible to non-packet networks such as SONET/TDM and
> optical networks. A transition path is provided for those
> currently using [OPQLSA-TE] and wish to adapt OSPF-TE.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-srisuresh-ospf-te-04.txt
> 
> To remove yourself from the IETF Announcement list, send a message to
> ietf-announce-request with the word unsubscribe in the body of the message.
> 
> Internet-Drafts are also available by anonymous FTP. Login with the username
> "anonymous" and a password of your e-mail address. After logging in,
> type "cd internet-drafts" and then
>         "get draft-srisuresh-ospf-te-04.txt".
> 
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> 
> Internet-Drafts can also be obtained by e-mail.
> 
> Send a message to:
>         [email-masked].
> In the body type:
>         "FILE /internet-drafts/draft-srisuresh-ospf-te-04.txt".
> 
> NOTE:   The mail server at ietf.org can return the document in
>         MIME-encoded form by using the "mpack" utility.  To use this
>         feature, insert the command "ENCODING mime" before the "FILE"
>         command.  To decode the response(s), you will need "munpack" or
>         a MIME-compliant mail reader.  Different MIME-compliant mail readers
>         exhibit different behavior, especially when dealing with
>         "multipart" MIME messages (i.e. documents which have been split
>         up into multiple messages), so check your local documentation on
>         how to manipulate these messages.
> 
> 
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
>

---

From: Rohit Dube <[email-masked]>
Date: Thu, 12 Dec 2002 08:38:04 -0500

FWIW,

The katz-yeung ospf-te draft is scheduled to go to ietf-wide last call
(if it hasn't already). 

The ospf-wg charter was recently debated on the ospf mailing wrt an 
update. It was also discussed extensively by me, Acee and the routing ADs
and at the ospf-wg meeting in atlanta. The charter agreed upon does not
include any work-item for alternate ospf-te proposals.

Regards,
--rohit.

On Wed, 11 Dec 2002 20:08:20 -0500 (EST) Jim Boyle writes:
=>
=>So it is more of a contribution to the OSPF WG, not the TEWG?
=>I'll ask ietf-secretary to make the corresponding changes.
=>You might want to forward the announce message to OSPF WG.
=>
=>thanks,
=>
=>Jim