Subject: RE: A proposal for moving ahead on BC models

From: "Ash, Gerald R (Jerry), ALASO" <[email-masked]>
Date: Fri, 20 Dec 2002 07:46:57 -0500

Francois,

Just to be clear:

>> Your proposal is assuming that vendors will support all of 
>> the 'reasonable number' (= 2) of BC models (RDM & MAM).  
 
> Yes. That is what I would expect.

>> That being the case, I don't see why we just don't mandate 
>> support of the 2 BC models.  
 
> In the short term, I think the practical result would effectively be the
> same whether we mandate them or not. The difference is that, if in the
> long run we realise that other models are better/more commonly used, we
> are not stuck with DSTE specs which mandate "older" BC models.

The suggestion is to specify 2 *default* BC models in the proto draft http://ietf.org/internet-drafts/draft-ietf-tewg-diff-te-proto-02.txt.  Recall that the requirements draft http://ietf.org/internet-drafts/draft-ietf-tewg-diff-te-reqts-06.txt calls for at least one BC model and allows for additional BC models to be specified later:

"The DS-TE technical solution must specify one default bandwidth constraint model which must be supported by any DS-TE implementation. However, additional bandwidth constraint models may also be specified. The purpose of such a default model is to ensure that there is at least one common Bandwidth Constraints model implementation across various vendors equipment and allows for easier deployment of DS-TE. However, this does not preclude a network operator to activate different Bandwidth Constraints models on different links in a network, if he/she wishes to do so."

So the suggestion is to specify 2 default BC models (RDM & MAM) in the proto draft and allow for additional BC models to be introduced in the future (e.g., MAR, or something else).  I suggest we try to get consensus on that since it will ensure interoperability in the near term and allow for improvements/extensions in the future. 

> Let's see if we hear more on this on the list and then we'll try
> converge soon onto one approach.

Yes, let's hear other views.

Wishing everyone a happy holiday season & great 2003,
Jerry

---

From: Jim Boyle <[email-masked]>
Date: Fri, 20 Dec 2002 09:15:51 -0500 (EST)

> Yes, let's hear other views.

Yes, let's.  C'mon folks.  I'm suprised by the lack of feedback we've
received on this.

Anyone planning on using diff-serv TE? any preference on this issue? (see 
my original mail on the subject)  

thanks,

Jim