Subject: Question about Maximum Allocation BC Model

From: "Geunhyung Kim" <[email-masked]>
Date: Mon, 9 Dec 2002 22:15:54 +0900

Hello all,

I have a question about MAM with preemption. (CT2 > CT1 > CT0 in terms of preemption prioirty)
For example, on a link of 100 unit of bandwidth where three CTs are used and the network administrator configures as follows.
BC2 = 40, BC1 = 70, BC0 = 100

For this configuration, when the bandwidth requests ars as follows
CT2 = 50, CT1 = 80, CT0 = 20 

How much bandwidth is allocated to each CT ? 

allocated bandwidth for CT2 = 40
allocated bandwidth for CT1 = 60
allocated bandwidth for CT0 = 0

Is the above allocation correct ?

Thanks in advance

Geunhyung Kim 

- None of us is as smart as all of us
==========================================
Geunhyung Kim

E-mail: [email-masked]

Tel: +82-54-279-5655
Fax: +82-54-279-5699

Networking & Distributed Systems Lab.
CSE
POSTECH
===========================================

---

From: "Francois Le Faucheur (flefauch)" <[email-masked]>
Date: Thu, 26 Dec 2002 14:07:20 -0000

Geunhyung and all,

>> -----Original Message-----
>> From: Geunhyung Kim [mailto:[email-masked]] 
>> Sent: 09 December 2002 14:16
>> To: Te-Wg
>> Subject: Question about Maximum Allocation BC Model
>> 
>> 
>> Hello all,
>> 
>> For example, on a link of 100 unit of bandwidth where three 
>> CTs are used and the network administrator configures as follows.

Quoting from draft-ietf-tewg-diff-te-reqts-06.txt:
"
For example, a model with one separate Bandwidth Constraint per CT 
   could be defined. This model is defined by: 
   - MaxBC= MaxCT 
   - All LSPs supporting Traffic Trunks from CTc use no more than BCc 
"
This is what we assume as the definition for MAM.

So as currently defined, MAM does not enforce any limit on the aggregate
across all CTs (which I believe your allocation above is implying). This
would be a sort of hybrid between MAM and RDM.

So, with MAM, the allocation would actually be:
 	allocated bandwidth for CT2 = 40 (ie BC2)
 	allocated bandwidth for CT1 = 70 (ie BC1)
 	allocated bandwidth for CT0 = 20 (ie demand for CT0 since it is
smaller than BC0).

Note that the above allocation does not depend on preemption priority.
With MAM, preemption is only effective across LSPs of the same CT, since
an LSP from one CT never competes with an LSP from another CT.

Cheers

Francois