Subject: RE: Reflecting new-MAM/SAM definition in diff-te drafts [[email-masked] in Pass-Through List]

From: "Dimitry Haskin" <[email-masked]>
Date: Tue, 20 May 2003 10:57:50 -0400

> 
> Use of "Max Reservable Bandwidth" appears to be OK without 
> per-CT Local Overbooking Multipliers (LOMs).  That is, when 
> there is only *one* LOM for the entire link, then the formula 
> you give appears to be correct:
> 
>     o SUM (Reserved (CTc)) <= Max Reservable Bandwidth, 
>         for all "c" in the range 0 <= c <= (MaxCT-1)
> 
> However, this formula is incorrect for DS-TE when per-CT 
> LOM's are used, since the above formula only reflects the Max 
> Reservable Bandwidth for the entire link, and does not 
> reflect the per-CT local overbooking factors.  So what 
> formula do you suggest when per-CT LOM's are used?
>

Wouldn't 'Reserved (CTc)' it the above formula already accounts for the
overbooking multiplier at CTc?  I don't see how this formula precludes
per-CT LOM's to be used. Please explain.

Regards,
  Dimitry

---

From: "Francois Le Faucheur (flefauch)" <[email-masked]>
Date: Tue, 20 May 2003 16:38:51 +0100

Hello Dimitry, Jerry, Waisum,

>> -----Original Message-----
>> From: Dimitry Haskin [mailto:[email-masked]] 
>> Sent: 20 May 2003 16:58
>> To: 'Ash, Gerald R (Jerry), ALABS'; Francois Le Faucheur (flefauch)
>> Cc: [email-masked]; Lai, Wai S (Waisum), ALABS; Dimitry Haskin
>> Subject: RE: Reflecting new-MAM/SAM definition in diff-te drafts
>> 
>> 
>> > 

I've been using "Reserved" and "Normalised" as per their definitions in
the proto draft, the RDM draft and the MAM draft.

Quoting from these drafts:

==================================
- "Reserved (CTc)": For a given Class-Type CTc ( 0 <= c <= MaxCT ) ,let
us define "Reserved(CTc)" as the sum of the bandwidth reserved by all
established LSPs which belong to CTc. 
- Normalised(CTc) : let us define "Normalised(CTc)" as
"Reserved(CTc)/LOM(c)", where LOM (c) is the Local Overbooking
Multiplier for CTc defined in [DSTE-PROTO].
=====================================

What that means is that "Reserved(CTc)" does factor in the overbooking
method which is refered to as "LSP/link size overbooking" method and is
the overbooking method commonly used in TE networks. However, it does
NOT factor in the optional "Local Overbooking Multiplier" method.

"Normalised (CTc)"  factors-in both the "LSP/link size overbooking" and
the optional "Local Overbooking Multiplier" method.

Definitions of the "LSP/link size overbooking" method and "Local
overbooking Multiplier" method can be found in section "4.1.2. per-CT
Local Overbooking Multipliers (LOMs) of the dste-proto draft.

Based on this, my proposal is to include the following condition to
reflect the aggregate constraint when both overbooking methods are used
(ie "LSP/link size overbooking" method and "Local overbooking
Multiplier" method):

    o SUM (Normalised (CTc)) <= Max Reservable Bandwidth, 
        for all "c" in the range 0 <= c <= (MaxCT-1)

where "Normalised (CTc) is equal to "Reserved(CTc)/LOM(c)" as currently
defined in RDM and MAM drafts.

Thanks

Francois

---

From: "Ash, Gerald R (Jerry), ALABS" <[email-masked]>
Date: Tue, 20 May 2003 10:35:16 -0500

Dimitry, Francois,

> per-CT LOM's to be used. Please explain.

Are you then proposing these formulas:

1. When per-CT LOMs are not used:

     o SUM (Reserved(CTc)) <= Max Reservable Bandwidth, 
         for all "c" in the range 0 <= c <= (MaxCT-1)

2. When per-CT LOMs are used:

     o SUM (Normalized(CTc)) <= Max Reservable Bandwidth, 
         for all "c" in the range 0 <= c <= (MaxCT-1)

Is that correct?  Please confirm, and/or give the formulas you propose.

Thanks,
Jerry

---

From: "Francois Le Faucheur (flefauch)" <[email-masked]>
Date: Tue, 20 May 2003 16:41:21 +0100

Jerry,

>> From: Ash, Gerald R (Jerry), ALABS [mailto:[email-masked]] 
>> Sent: 20 May 2003 17:35
>> To: Dimitry Haskin; Francois Le Faucheur (flefauch)
>> Cc: Ash, Gerald R (Jerry), ALABS; [email-masked]; Lai, 
>> Wai S (Waisum), ALABS

Yes, this is exactly what I propose.
I think this is similar to what you were proposing, only using "Max Res
Bw" instead of "Max Link Bw". 

Sorry I didn't make that very clear before.

Cheers

FRancois

---

From: "Francois Le Faucheur (flefauch)" <[email-masked]>
Date: Tue, 20 May 2003 17:31:33 +0100

Jerry,

>> 
>> Yes, we need a formula to make explicit the 'implicit' 
>> constraint (and for all the BC models, not just MAM).
>> 

That's a good point.

>>          for all "c" in the range 0 <= c <= (MaxCT-1)

already applies, since we have:
	- SUM (Normalised(CTc)) <= BC0, and
	- BC0=Max Reservable Bw

It would be nice to have exact same formula also apply to MAM.

Cheers

Francois