Subject: RE: draft-ietf-tewg-measure-05.txt comments

From: "Ash, Gerald R (Jerry), ALABS" <[email-masked]>
Date: Tue, 6 May 2003 08:40:59 -0500

Jim,

Your detailed comments and suggestions are very helpful, and should help improve the quality of the document.  

I have some comments below on Tom's and your comments.

Thanks,
Jerry

Jim> Flow measurement is a deep-hole, we should either defer to other
Jim> standardization efforts on this, or we need to be a lot more
Jim> concrete on what we need to know here.	

Tom> 	Defer to the IPFX WG that is tackling this problem right now.

Let's be more concrete in the TEM draft re flow measurement requirements.  I don't see a lot on TE measurement requirements in the IPFIX charter or requirements document http://ietf.org/internet-drafts/draft-ietf-ipfix-reqs-09.txt.  Let's be sure all the requirements get stated.

Jim> " Need for higher order statistics... "  push it to the offline hosts
Jim> "Need for packet-sampled..."  "Need for offline bulk file 
Jim> transfer..." The need needs to be better justified or removed.
 
Tom> 	I asked to have the offline stuff added. For the
Tom> collection of a traffic matrix, as you know, this 
Tom> entails the collection of a lot of data especially on
Tom> big core routers. It is preferable to use offline
Tom> bulk file transfer mechanisms such as NetFlow (being
Tom> standardized in IPFX now) or offline SNMP file transfers
Tom> of statistics snapshots.  This reduces the overhead of
Tom> the box having to service network management requests,
Tom> and also reduces the amount of network mgmt overhead
Tom> required to fetch the same amount of data if you 
Tom> collect your data as one big batch at some longer periodic
Tom> interval.

Quite unclear that moving massive amounts of data for offline processing is always 'preferable' to online statistics to meet all requirements.  Data collection/summarization in the 'big core routers', e.g., on a node-pair basis, is very desirable for traffic matrix derivation in some applications.

---

From: "Dr. Richard W. Tibbs" <[email-masked]>
Date: Tue, 06 May 2003 11:30:17 -0400

Jim, Jerry, etal:
Your comments are indeed helpful.  I have agreed with Wai to try a new 
version of our draft, based on the feedback we have had in the last 
couple of weeks.  It will take me  a while to do what is proposed -- 
which is significant "thinning" and re-organizing of the document --  in 
your comments, but I am willing.    As I do this, I may need to clarify 
some of your comments and I will mail the list to do so.  

Yours,
Dr. Richard W. Tibbs