Subject: Re: AD review of: draft-ietf-tewg-measure-05.txt

From: raymond zhang <[email-masked]>
Date: Thu, 01 May 2003 07:44:34 -0700

Hi Bert,
Sorry for the delayed response...

At 03:13 AM 4/25/2003 +0200, Wijnen, Bert (Bert) wrote:
>My summary:
>
>- a lot of text... but not very focused and to the point (or at least
>   I have trouble seeing the main points)
>- not a "framework", rather an exploration of TE measurement related topics
>   (more like  a summary-introduction)
>- I am not an operator, but I think if I were one, then
>   - if we were already doing TE measurement stuff (most likely) then
>     reading it seems a waste of time

Ray - Well, we have policies and implementations at different degrees for 
many of the areas touched upon by the draft but not all... It is indeed 
helpful to look at this as framework for any further work to refine our 
current processes.

>   - if we were not yet doing any of it... then I wonder if this would
>     be helpfull at all.
>- W.r.t. the TEM WG work item, it says:
>      The tewg interacts with the common control and measurement plane
>      working group to abstract and define those parameters, measurements,
>      and controls that traffic engineering needs in order to engineer
>      the network.
>   So I would expect a CRISP set of "requirements for additional measurements,
>   configurable/negotiable parameters/controls" ... but not the extensive
>   exploration and text that I now see. Why do people (or the WG) think
>   that this document meets the WG deliverable for TEM ??
>- W.r.t. review:
>   - 4 people from ATT support it. Waisum is one of them and is main editor.
>     Others (Nick Duffield, Bob Cole) have some of their material listed in
>     the doc.
>   - 3 EDU users commented, 2 said they found it a good doc
>     3rd one asked a few questions
>   - Raymond Zhang is positive. He is from info.net ??? is that an operator?

I am form INFONET ( a global SP).

>   - Richard Tibbs gave a thumbs up, he is from oakcitusolutions.com.
>     What role/function does he play/have? Operator, code/tool-developer?
>   - One hotmail user (Spyrokontigiogis) gave a thumbs up. Not that
>     he/she added any comment. Do we know him/her?
>     What role/function does he/she play/have? Operator, code/tool-developer?
>   - Dimitri Papadimitrou (Alcatel) asked a question/suggested some text.
>     I did not see if he likes the doc or not
>   - Blain Christian (uunet, so maybe a real operator?) withdrew as co-editor
>     That does not sound good (in my view)
>- So where are the real operators that support this?
>
>My thought is that I can do two things:
>
>- send back to WG and say that this is "not good enough" and that I do not
>   feel comforatable to present it to IESG for approval.
>   It does NOT meet (in my eyes) the WG deliverable for TEM.
>- send it to IESG with my recommendation to NOT approve for same reasons.
>
>So let me try the first option first and ask the WG what they have to say
>to my review.
>
>Bert

---

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Mon, 5 May 2003 15:51:53 +0200

Inline
> -----Original Message-----
> From: raymond zhang [mailto:[email-masked]]
> Sent: donderdag 1 mei 2003 16:45
> To: Wijnen, Bert (Bert); Tewg (E-mail)
> Subject: Re: AD review of: draft-ietf-tewg-measure-05.txt 
> 
> Hi Bert,
No problem.

> >- not a "framework", rather an exploration of TE measurement 
> >   related topics (more like  a summary-introduction)
> Ray - Well, we have policies and implementations at different 
> degrees for many of the areas touched upon by the draft but 
> not all... It is indeed helpful to look at this as framework for
> any further work to refine our current processes.
> 
Do you really mean "framework" or is it more 
a "pool of things to consider"?

.. snip ..

> I am form INFONET ( a global SP).
Thanks for informing me. And appology that I did not know.

.. snip ..

Bert

---

From: Jim Boyle <[email-masked]>
Date: Mon, 5 May 2003 22:21:34 -0400 (EDT)

So I think it is clear that we need to distill what is being recommended.

A bit of background - this WG item was intended to make the essential 
measurements needed well defined enough that the way these "entities" were 
measured across implementations (e.g. vendors) would be consistent.  There 
was some discussion about "chocolate ice cream" and consistency by an AD 
at one point but no-one understood the departed AD at that time - let 
alone now.  Suffice it to say that we are looking for a succinct enough 
set of definitions and recommendations that one could take a look at
an an instantiation of that (e.g. a mib) and know if we are measuring
things in the correct manner, and do we have a complete set of the
measurements we will need.

What we have at hand may or may not be a framework, however I think
at least some would agree that it is currently too abstract.  

I recommend we do the following clean up

- Somewhere provide a CRISP set of recommendations
- Remove all discussion which does not directly re-enforce a
  recommendation
- Run it back through WG last call
  - Maybe one option will be to remove the WG item completely

I have some specific feedback, but I'll do that separately.

thanks,

Jim

---

From: raymond zhang <[email-masked]>
Date: Tue, 06 May 2003 21:43:14 -0700

Hi Bert,

>a "pool of things to consider"?

You may have a point there.  Maybe more like a set of 
guidelines.  Important ones though in my view...

>Thanks for informing me. And appology that I did not know.

No problem at all...

Cheers,
Raymond