Subject: RE: I-D ACTION:draft-ietf-tewg-measure-06.txt

From: "Ash, Gerald R (Jerry), ALABS" <[email-masked]>
Date: Wed, 5 Nov 2003 07:55:20 -0600

Jim,

I'm sorry to hear your opinion.

I definitely agree that your comments should have been addressed.  Certainly they still can be.  There was *major* surgery on the I-D, and some comments apparently got lost in all the revisions.

I still hope to talk you out of it, not because I want to save an I-D but because I think that meeting the TEM milestone is critical:

1. Main comment:

I think the 06-draft http://ietf.org/internet-drafts/draft-ietf-tewg-measure-06.txt satisfies the TEM goal to 'document additional measurements needed for TE'.  There are clear requirements in the I-D not covered by any MIB or protocol.  

For example, in Section 2 "Conclusions & Recommendations", the very first requirement is:

'(1) Requirements for specific TE measurements 
    
. Node-pair-based traffic data to derive per-service-class traffic matrix statistics, including statistics of carried load and offered load (Sections 3.3 and Appendix A) 
. Statistics of achieved performance and throughput (Section 3.4)
. A standardized method to detect and record label binding changes for LDP-signaled label-switched paths, at the ingress-egress pair level (Section 3.5)'

Such a requirement is basic to operating any network, and allows a traffic matrix to be derived for purposes of engineering and management of the network.  Such a measurement *is not available in any MIB or protocol*.  It is a major problem in the engineering and management of IP-based networks today that such measurements are not available.  There are indirect work-arounds to this that are not altogether accurate or satisfactory, but there is no substitute for the actual measurements.  

If Jim or anyone thinks such measurements are available, please point out where, which MIB, which protocol? 

2. I think the 06-draft http://ietf.org/internet-drafts/draft-ietf-tewg-measure-06.txt well addresses Bert's comments:

'I would expect a CRISP set of "requirements for additional measurements, configurable/negotiable parameters/controls" ... but not the extensive exploration and text that I now see'.
 
The requirements are now clearly identified for additional measurements, configurable/negotiable parameters/controls, etc., and the main text has been greatly shortened.

Certainly the I-D can be made more crisp and shortened more, if needed, but that doesn't justify dropping the TEM milestone.

3. When Bert made his comments on the 05 version (April, 2003), there was a lengthy discussion on the list.  In that discussion many voiced their support for the draft, including Christian Jacquenet, Rüdiger Geib, Raymond Zhang, Merike Kaeo, Dimitri Papadimitriou, and others.  In that discussion, Bert was the *only* negative vote.  I invite you to look back at the thread.  Many strong supportive opinions were expressed, e.g., Merike Kaeo (former co-chair of IPPM) commented 'There is indeed a critical need for this sort of document', and Christian Jacquenet said 'I fully support this draft'.

4. The I-D is directed to satisfy a critical TEWG milestone ('TEM').  It gives requirements for essential extensions for TEM.  It should be used to drive protocol extensions and MIB extensions.  An excellent example is the node-to-node measurements to derive the traffic matrix as explained in #1 above.  Such measurements are not available today, and are vitally needed.  Jim argues that the TEM milestone is not needed since 'the need for this is potentially tempered by a good MIB, which I think we have now'.  With all due respect to the MIB, it *does not* satisfy the requirements (e.g., see point #1 above).  If all the requirements in the I-D are met, please point out where, specifically. 

5. It becomes an argument as to 
a. whether the TEM milestone is needed
b. there are essential requirements in the I-D that are not met.
I say definitely 'yes' to both.  Let's be sure we have valid arguments to drop TEM before we do that.  

6. TEWG needs to complete its milestones.  Other important TEWG milestones have been dropped (in effect), e.g., 'BCP documents on ISP uses, requirements, desires (TEBCPs)'.  There were several authors who contributed valuable input to satisfy this milestone, yet none of the I-Ds (4 or more) made it through the TEWG.  I do not ascribe the reason for this to any of the authors.  Let's not do this again with TEM.

Thanks,
Jerry

-----Original Message-----
From: Jim Boyle [mailto:[email-masked]]
Sent: Tuesday, November 04, 2003 11:13 PM
To: [email-masked]
Cc: Lai, Wai S (Waisum), ALABS; Wijnen, Bert (Bert)
Subject: RE: I-D ACTION:draft-ietf-tewg-measure-06.txt

After figuring out which sections had been moved where, I was able to
coorelate the new draft up against my previous comments.

http://ops.ietf.org/lists/te-wg/te-wg.2003/msg00256.html

Most the comments still hold.

My feeling is that we are not hitting the target on this, and I think we
should seriously consider just dropping this item :(

From my comments you can see I at least was looking for some
more tangible recomendations.  But truthfully, a lot of the need for this
is potentially tempered by a good MIB, which I think we have now.

If there are folks that disagree, as to whether -06.txt hits the
mark, or whether we should not give up, please do not hessitate to make
your point known.  Or if you in general agree, or have any comments on
this deliverable, or this draft, again, now is the time to make those
comments.

thanks

Jim

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Wed, 5 Nov 2003 09:55:22 -0500

>From: [email-masked] 
>[mailto:[email-masked]] On Behalf Of Ash, Gerald R 
>(Jerry), ALABS
>Sent: Wednesday, November 05, 2003 8:55 AM
>To: Jim Boyle; [email-masked]
>Cc: Ash, Gerald R (Jerry), ALABS; Lai, Wai S (Waisum), ALABS; 
>Wijnen, Bert (Bert)
>I definitely agree that your comments should have been 
>addressed.  Certainly they still can be.  There was *major* 
>surgery on the I-D, and some comments apparently got lost in 
>all the revisions.
>
>I still hope to talk you out of it, not because I want to save 
>an I-D but because I think that meeting the TEM milestone is critical:
>
>1. Main comment:
>
>I think the 06-draft 
>http://ietf.org/internet-drafts/draft-ietf-tewg-measure-06.txt 
>satisfies the TEM goal to 'document additional measurements 
>needed for TE'.  There are clear requirements in the I-D not 
>covered by any MIB or protocol.  
>
>. Node-pair-based traffic data to derive per-service-class 
>traffic matrix statistics, including statistics of carried 
>load and offered load (Sections 3.3 and Appendix A) 
>. A standardized method to detect and record label binding 
>changes for LDP-signaled label-switched paths, at the 
>ingress-egress pair level (Section 3.5)'
>
>Such a requirement is basic to operating any network, and 
>allows a traffic matrix to be derived for purposes of 
>engineering and management of the network.  Such a measurement 
>*is not available in any MIB or protocol*.  It is a major 
>problem in the engineering and management of IP-based networks 
>today that such measurements are not available.  There are 
>indirect work-arounds to this that are not altogether accurate 
>or satisfactory, but there is no substitute for the actual 
>measurements.  

	That is not entirely accurate. The IETF's IPFX WG is 
standardizing the NetFlow protocol which can be used for 
precisely this. It has been available in a proprietary form 
from my company and others for several years now.

	--Tom

>If Jim or anyone thinks such measurements are available, 
>please point out where, which MIB, which protocol? 
>
>2. I think the 06-draft 
>http://ietf.org/internet-drafts/draft-ietf-tewg-measure-06.txt 
>well addresses Bert's comments:
>
>'I would expect a CRISP set of "requirements for additional 
>measurements, configurable/negotiable parameters/controls" ... 
>but not the extensive exploration and text that I now see'.
> 
>The requirements are now clearly identified for additional 
>measurements, configurable/negotiable parameters/controls, 
>etc., and the main text has been greatly shortened.
>
>Certainly the I-D can be made more crisp and shortened more, 
>if needed, but that doesn't justify dropping the TEM milestone.
>
>3. When Bert made his comments on the 05 version (April, 
>2003), there was a lengthy discussion on the list.  In that 
>discussion many voiced their support for the draft, including 
>Christian Jacquenet, Rüdiger Geib, Raymond Zhang, Merike Kaeo, 
>Dimitri Papadimitriou, and others.  In that discussion, Bert 
>was the *only* negative vote.  I invite you to look back at 
>the thread.  Many strong supportive opinions were expressed, 
>e.g., Merike Kaeo (former co-chair of IPPM) commented 'There 
>is indeed a critical need for this sort of document', and 
>Christian Jacquenet said 'I fully support this draft'.
>
>4. The I-D is directed to satisfy a critical TEWG milestone 
>('TEM').  It gives requirements for essential extensions for 
>TEM.  It should be used to drive protocol extensions and MIB 
>extensions.  An excellent example is the node-to-node 
>measurements to derive the traffic matrix as explained in #1 
>above.  Such measurements are not available today, and are 
>vitally needed.  Jim argues that the TEM milestone is not 
>needed since 'the need for this is potentially tempered by a 
>good MIB, which I think we have now'.  With all due respect to 
>the MIB, it *does not* satisfy the requirements (e.g., see 
>point #1 above).  If all the requirements in the I-D are met, 
>please point out where, specifically. 
>
>6. TEWG needs to complete its milestones.  Other important 
>TEWG milestones have been dropped (in effect), e.g., 'BCP 
>documents on ISP uses, requirements, desires (TEBCPs)'.  There 
>were several authors who contributed valuable input to satisfy 
>this milestone, yet none of the I-Ds (4 or more) made it 
>through the TEWG.  I do not ascribe the reason for this to any 
>of the authors.  Let's not do this again with TEM.
>
>Thanks,
>Jerry
>