Subject: [therightkey] Fwd: [Technical Errata Reported] RFC6962 (3686)

From: Stephen Farrell <[email-masked]>
Date: Fri, 26 Jul 2013 13:40:04 +0100

Any comments on this erratum?

Thanks,
S.

-------- Original Message --------
Subject: [Technical Errata Reported] RFC6962 (3686)
Date: Fri, 26 Jul 2013 02:10:56 -0700 (PDT)
From: RFC Errata System <[email-masked]>
To: [email-masked], [email-masked], [email-masked], [email-masked]
CC: [email-masked], [email-masked]

The following errata report has been submitted for RFC6962,
"Certificate Transparency".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=6962&eid=3686

--------------------------------------
Type: Technical
Reported by: Eran Messeri <[email-masked]>

Section: 4.2

Original Text
-------------
chain:  An array of base64-encoded Precertificates.  The first
         element is the end-entity certificate; the second chains to the
         first and so on to the last, which is either the root
         certificate or a certificate that chains to a known root
         certificate.

Corrected Text
--------------
chain:  An array of base64-encoded Precertificate and certificates.
         The first element is the end-entity precertificate; the second
         chains to the first and so on to the last, which is either the
         root certificate or a certificate that chains to a known root
         certificate. Only the first element in the array may be
         a precertificate.

Notes
-----
The current description of Add PreCertChain implies the array may
consist of multiple Precertificates. In practice it only  makes sense
for the first element to be a Precertificate, the following elements
should be proper certificates.

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary.

--------------------------------------
RFC6962 (draft-laurie-pki-sunlight-12)
--------------------------------------
Title               : Certificate Transparency
Publication Date    : June 2013
Author(s)           : B. Laurie, A. Langley, E. Kasper
Category            : EXPERIMENTAL
Source              : IETF - NON WORKING GROUP
Area                : N/A
Stream              : IETF
Verifying Party     : IESG

---

From: Leif Johansson <[email-masked]>
Date: Fri, 26 Jul 2013 15:21:43 +0200

> Any comments on this erratum?

If we are being anal about this I suppose it might be a good idea
to clarify what "chains to" a precertificate means.
> _______________________________________________
> therightkey mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/therightkey

---

From: Ben Laurie <[email-masked]>
Date: Mon, 29 Jul 2013 17:29:44 +0100

> to clarify what "chains to" a precertificate means.

It means the same as chaining to a certificate. :-)

My only comment is the fix should perhaps make it clear that the leaf is a
pre-cert and the remainder are standard certs...

> From: RFC Errata System <[email-masked]> <[email-masked]>
> You may review the report below and at:http://www.rfc-editor.org/errata_search.php?rfc=6962&eid=3686
>
> Reported by: Eran Messeri <[email-masked]> <[email-masked]>
>
> Section: 4.2
>
> Original Text
> -------------
> therightkey mailing [email-masked]://www.ietf.org/mailman/listinfo/therightkey
>
>
>