Subject: RE: [TICTOC] Draft TICTOC WG charter

From: "Chris Calley" <[email-masked]>
Date: Thu, 8 Feb 2007 10:52:11 -0800

> -----Original Message-----
> From: Ron Cohen [mailto:[email-masked]] 
> Sent: Thursday, January 18, 2007 9:37 AM
> To: Stewart Bryant; [email-masked]
> Subject: RE: [TICTOC] Draft TICTOC WG charter
> 
> Stewart,
> 
> Can we add to the WG objectives to include the development of 
> the timing distribution solution (i.e. beyond the timing 
> distribution protocol)?
> This will include issues like discovery, management, 
> congestion control, and any other possible interaction with 
> other IETF work. The WG would than work with other WGs to 
> develop extension to protocols if required.
> Possible such extensions expected are for LDP, BGP, MPLS etc.
> 
> In addition I'm a bit nervous having the 'propose algorithms' 
> and 'research the influence of measurable networks.." 
> objectives. This may divert the focus of the WG into IRTF work. 
> 
> Best
> Ron
> 
> 

I am also concerned with the part about proposing algorithms.  The issue
I have is that in general, algorithm definition is an implementation
issue and is outside of the protocol.  It is not that proposing
algorithms is a problem in and of itself.  But that "propose" can
eventually become "specify" or "require".

Best regards,
Chris

_______________________________________________
TICTOC mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tictoc

---

From: Mark Townsley <[email-masked]>
Date: Fri, 09 Feb 2007 15:05:20 +0100

Relevant comment from Russ Housley when I asked him about this:
> In the security area we publish cryptographic algorithms all the 
> time.  The idea is to make them widely available to implementors.  
> They are in Informational documents, and then standards-track 
> documents reference the Informational algorithm description.  This is 
> one of the "normal" downrefs pointed out in the DOWNREF document.
- Mark