Subject: [TICTOC] preparatory material for new TICTOC charter

From: "Yaakov Stein" <[email-masked]>
Date: Mon, 22 Oct 2007 19:19:58 +0200

Hi all,

Today Stewart, Karen and I discussed Mark's request to
quickly focus on which of the "modules" need be in scope for the
potential WG.

We have come up with the following deliverables,
broken down into two phases
(times in parentheses are months from chartering of WG).

Phase 1:

0.  Architecture draft (based on modularization draft)       (INFO)
(6)
1.1 requirements for time/frequency distribution protocol(s) (INFO)
(9)
1.2 analysis of existing protocols in light of 1.1           (INFO)
(12)
1.3 selection and documentation of distribution protocol(s)  (STD)
(24)
2   Autodiscovery (including security aspects)               (STD)
(12)
3   Topology discovery (including security aspects)          (STD)
(24)

Phase 2:

4 OAM including SSM                                          (STD)
(30)
5 Performance measurement                                    (STD)
(33)
6 Ranging techniques                                         (BCP)
(36)
7 MIBs                                                       (STD)
(30)

Additional work, such as BCPs for various algorithms,
detailed requirements for specific applications (e.g. cellular
backhaul),
and research topics such as globally converging classless methods,
will be developed based on interest and participation.

We would appreciate feedback from the list on the choice of
milestones, and the times allotted.

Y(J)S

_______________________________________________
TICTOC mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tictoc

---

From: "Sasha Vainshtein" <[email-masked]>
Date: Mon, 22 Oct 2007 19:36:40 +0200

Yaakov and all,
Looks like a reasonable schedules with no targets left out.
 
Regards,
                    Sasha

________________________________

From: Yaakov Stein [mailto:[email-masked]] 
Sent: Monday, October 22, 2007 7:20 PM
To: [email-masked]
Subject: [TICTOC] preparatory material for new TICTOC charter

Hi all,

Phase 1:

Phase 2:

Y(J)S

---

From: [email-masked]
Date: Mon, 22 Oct 2007 11:13:06 -0700

I agree with Sasha. This looks very complete. Thanks for Mark for the prod 
and Stewart, Karen and Yaakov for the effort.

Pat Diamond

"Yaakov Stein" <[email-masked]> 
10/22/2007 10:27 AM

To
<[email-masked]>
cc

Subject
[TICTOC] preparatory material for new TICTOC charter

Hi all,

Today Stewart, Karen and I discussed Mark's request to
quickly focus on which of the "modules" need be in scope for the potential 
WG.

Phase 1:

0.  Architecture draft (based on modularization draft)       (INFO)    (6)
1.1 requirements for time/frequency distribution protocol(s) (INFO)    (9)
1.2 analysis of existing protocols in light of 1.1           (INFO)   (12)
1.3 selection and documentation of distribution protocol(s)  (STD)    (24)
2   Autodiscovery (including security aspects)               (STD)    (12)
3   Topology discovery (including security aspects)          (STD)    (24)

Phase 2:

4 OAM including SSM                                          (STD)    (30)
5 Performance measurement                                    (STD)    (33)
6 Ranging techniques                                         (BCP)    (36)
7 MIBs                                                       (STD)    (30)

Additional work, such as BCPs for various algorithms,
detailed requirements for specific applications (e.g. cellular backhaul),
and research topics such as globally converging classless methods,
will be developed based on interest and participation.

Y(J)S

---

From: "STUART VENTERS" <[email-masked]>
Date: Mon, 22 Oct 2007 13:18:05 -0500

Yaakov,

Looks great overall, I just have a couple of minor nits.

Is SSM about management, automatic clock routing, or more likely both?
  (Although I don't know how to handle it better,
    I'm wondering if mentioning SSM with 4, but not 2 and 3 is misleading.)

Should performance measurement be broken into 2 parts?
    1) Performance of the time/freq reference provided by TICTOC
    2) Performance required from the network TICTOC is running over.

Regards,

Stuart

-----Original Message-----
From: Yaakov Stein [mailto:[email-masked]]
Sent: Monday, October 22, 2007 12:20 PM
To: [email-masked]
Subject: [TICTOC] preparatory material for new TICTOC charter

Hi all,

Today Stewart, Karen and I discussed Mark's request to
quickly focus on which of the "modules" need be in scope for the potential WG.

Phase 1:

Phase 2:

Y(J)S

---

From: "Greg Dowd" <[email-masked]>
Date: Mon, 22 Oct 2007 11:45:24 -0700

Good work.  Timing looks great.

From: Yaakov Stein [mailto:[email-masked]] 
Sent: Monday, October 22, 2007 10:20 AM
To: [email-masked]
Subject: [TICTOC] preparatory material for new TICTOC charter

Hi all,

Phase 1:

Phase 2:

Y(J)S

---

From: "Yaakov Stein" <[email-masked]>
Date: Tue, 23 Oct 2007 11:15:08 +0200

Sasha
 
The idea was to identify a subset of topics.
 
If you believe that no targets are left out, 
then it is not a PROPER subset.  :)
 
Y(J)S

From: Sasha Vainshtein [mailto:[email-masked]] 
Sent: Monday, October 22, 2007 7:37 PM
To: Yaakov Stein
Cc: [email-masked]
Subject: RE: [TICTOC] preparatory material for new TICTOC charter

Yaakov and all,
 
Regards,
                    Sasha

Hi all,

Phase 1:

Phase 2:

Y(J)S

---

From: "Sasha Vainshtein" <[email-masked]>
Date: Tue, 23 Oct 2007 19:21:40 +0200

Yaakov,
I assumed that you have presented the complete list of expected
deliveries of the WG-to-be (split into 2 phases) and not a superset of
topics for short listing. Looks like I misunderstood your intention
(and, judging by the emails on the list, the misunderstanding was
common).
 
Can you please explain why do you want to reduce the list of targets?
(You can always cite "too much work to do" as the reason, of course:-).
As I see it, all the documents you've named are indeed required unless
we want to adopt a certain solution regardless of the problem. 
And I do not see alternative WGs in the IETF that could handle these
documents.
 
Regards,
                Sasha

 

From: Yaakov Stein [mailto:[email-masked]] 
Sent: Tuesday, October 23, 2007 11:15 AM
To: Sasha Vainshtein
Cc: [email-masked]
Subject: RE: [TICTOC] preparatory material for new TICTOC charter

Sasha

 
Y(J)S

Yaakov and all,
 
Regards,
                    Sasha

Hi all,

Phase 1:

Phase 2:

Y(J)S