Subject: [TICTOC] TICTOC scope: Public Internet or Provider scope

From: "STUART VENTERS" <[email-masked]>
Date: Thu, 25 Oct 2007 10:19:42 -0500

Ron,

Your proposed  initial TicToc scope limit of 

single administrative domain core to edge is certainly first on my list,

but I wonder if distribution in the single provider's core should be included as well?

Regards,

Stuart
_______________________________________________
TICTOC mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tictoc

---

From: "Ron Cohen" <[email-masked]>
Date: Fri, 26 Oct 2007 19:14:49 +0200

Stuart,

In my opinion distribution in the core/metro should be included.  The
scope should probably be 'within a single administrative domain'. 

Best,

Ron

From: STUART VENTERS [mailto:[email-masked]] 
Sent: Thursday, October 25, 2007 5:20 PM
To: Ron Cohen
Cc: [email-masked]
Subject: TICTOC scope: Public Internet or Provider scope

Ron,

but I wonder if distribution in the single provider's core should be
included as well?

Regards,

Stuart

-- 
This message was scanned by ESVA and is believed to be clean. 
Click here to report this message as spam.
<http://mailgw.resolutenetworks.com/cgi-bin/learn-msg.cgi?id=C355928082.
9ACCC>

---

From: "Yaakov Stein" <[email-masked]>
Date: Sun, 28 Oct 2007 21:50:16 +0200

Ron and everyone else,
 
We can certainly put single provider networks as a main focus for
TICTOC,
but this is the IETF. 
 
If we limit it to special hardware, 
then I doubt we are going to get anywhere here.
 
If we develop a protocol that can run over existing hardware
we have to assume that someone is going to run it over the public
Internet.
 
In any case, we did not specify that TICTOC would be optimized
for the public Internet. We used the term "general PSNs"
(i.e. IP or MPLS networks without special HW).
However, if run over the public Internet it needs to work,
and not to interfere with existing applications.
 
NTP indeed solves some problems quite well, 
but if does not address all applications specified
in the problem statement. For example, 
it does not have a pure frequency distribution mode,
as required in some of the TICTOC main application areas.

Y(J)S

---

From: "Stefano Ruffini" <[email-masked]>
Date: Tue, 30 Oct 2007 09:44:59 +0100

Hi Yaakov,
 
some considerations on the "frequency distribution mode" .
 
Please consider that NTP as well as other relevant protocols (RTP, PTP)
have been proven to be suitable to carry "frequency" reference for some
relevant applications (e.g. GSM, WCDMA FDD, which require to recover 50
ppb on the radio interface), and  without requiring additional
requirements on the packet network nodes.
Other aspects (than the actual protocol), are key factors in terms of
the achievable performance (i.e. characteristics of the Packet delay
variation in the network, oscillator characteristics in the end
equipment, etc. ). 
 
I expect that the efforts to define new protocols or new arrangements as
part of the TICTOC sope, will rather focus on the distribution of
accurate phase and time (e.g. in the microsecond - submicrosecond
level). The distribution of reference timing signals (frequency
distribution) fulfilling the "PRC interface" masks (see G.823 and G.824)
could also be of interest, but in this case I would also recommend to
consider the option of synchronous ethernet (please refer to the work
ongoing within ITU-T Q13). 
 
Best Regards
Stefano

________________________________

From: Yaakov Stein [mailto:[email-masked]] 
Sent: domenica 28 ottobre 2007 20.50
To: Ron Cohen; STUART VENTERS
Cc: [email-masked]
Subject: RE: [TICTOC] RE: TICTOC scope: Public Internet or Provider
scope

Ron and everyone else,

 

Y(J)S

---

From: "Yaakov Stein" <[email-masked]>
Date: Tue, 30 Oct 2007 15:16:53 +0200

Stefano
 
NTP and 1588 indeed distribute frequency, for their own (internal)
purposes,
and can do so pretty well.
 
However, this does not mean that they are optimized for this function.
 
Frequency distribution is a purely one-way function,
and thus can be fully multicast or broadcast.
 
Time distribution requires a two-way exchange for ranging,
and assumes symmetry (or some known asymmetry).
 
This difference can be very significant for many applications.
 
In the problem statement we have examples of applications
where only frequency is needed (e.g. TDM PWs, GSM mobile backhauling).
 
Y(J)S

From: Stefano Ruffini [mailto:[email-masked]] 
Sent: Tuesday, October 30, 2007 10:45 AM
To: Yaakov Stein
Cc: [email-masked]
Subject: RE: [TICTOC] RE: TICTOC scope: Public Internet or Provider
scope

Hi Yaakov,

 
 
Best Regards
Stefano

Ron and everyone else,

 

Y(J)S