Subject: Re: [TICTOC] draft-ietf-tictoc-1588overmpls-02.txt / Annex

From: [email-masked]
Date: Fri, 4 Nov 2011 10:03:38 -0400

Hi Manav et al,

In speaking with Stefano last week, it seems if the mapping is PTP over IP 
over MPLS, or PTP over Ethernet over MPLS then we may be able to re-use 
the existing IEEE 1588 Annexes for IPv4 and Ethernet mappings.  This may 
save some time to develop this IETF specification.

Regards, 
Microsemi Corporation
Peter Meyer
Timing & Synchronization
Communication and Medical Products Group
Office: +1-613-270-7203  |  Fax: +1-613-592-1010
[email-masked]  | www.zarlink.com

<[email-masked]> 
Sent by: <[email-masked]>
25/10/2011 12:39 PM

To
"Bhatia, Manav (Manav)" <[email-masked]>
cc
"[email-masked]" <[email-masked]>, <[email-masked]>
Subject
Re: [TICTOC] FW: I-D Action: draft-ietf-tictoc-1588overmpls-02.txt

Hi Manav et al, 

I'm also wondering if we need to fill out something similar to IEEE 
1588-2008 Annex D-F, or include such information in this document. 

For example, the protocol address used for the portAddress. 

The Annex D - F seem to have generally the same structure. 

Annex E Transport of PTP over UDP over IPv4 
D.1 General 
D.2 UDP port numbers 
D.3 IPv4 multicast addresses 
D.4 transportSpecific field values 
D.5 Optional values 
D.6 IPv4 Options 
D.7 Protocol addresses 

Annex E Transport of PTP over UDP over IPv6 
E.1 General 
E.2 UDP port numbers 
E.3 IPv6 multicast addresses 
E.4 transportSpecific field values 
E.5 Optional values 
E.6 Protocol addresses 

Annex F Transport of PTP over IEEE 802.3/Ethernet 
F.1 General 
F.2 Ethertype 
F.3 Multicast MAC Addresses 
F.4 transportSpecific field values 
F.5 Optional values 
F.6 Protocol addresses 

Microsemi Corporation
Peter Meyer
Timing & Synchronization
Communication and Medical Products Group
Office: +1-613-270-7203  |  Fax: +1-613-592-1010
[email-masked]  | www.zarlink.com

"Bhatia, Manav (Manav)" <[email-masked]> 
Sent by: <[email-masked]> 
07/10/2011 01:48 AM 

To
"[email-masked]" <[email-masked]> 
cc

Subject
[TICTOC] FW:  I-D Action: draft-ietf-tictoc-1588overmpls-02.txt

Hi Tictocers,

This version incorporates whatever comments we had recived till date. 
Would appreciate if the WG can review this updated version.

Cheers, Manav

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf 
Of [email-masked]
Sent: Friday, October 07, 2011 10:53 AM
To: [email-masked]
Cc: [email-masked]
Subject: [TICTOC] I-D Action: draft-ietf-tictoc-1588overmpls-02.txt

A New Internet-Draft is available from the on-line Internet-Drafts 
directories. This draft is a work item of the Timing over IP Connection 
and Transfer of Clock Working Group of the IETF.

                Title           : Transporting PTP messages (1588) over 
MPLS Networks
                Author(s)       : Shahram Davari
                         Amit Oren
                         Manav Bhatia
                         Peter Roberts
                         Laurent Montini
                Filename        : draft-ietf-tictoc-1588overmpls-02.txt
                Pages           : 34
                Date            : 2011-10-06

  This document defines the method for transporting PTP messages (PDUs)
  over an MPLS network.  The method allows for the easy identification
  of these PDUs at the port level to allow for port level processing of
  these PDUs in both LERs and LSRs.

  The basic idea is to transport PTP messages inside dedicated MPLS
  LSPs.  These LSPs only carry PTP messages and possibly Control and
  Management packets, but they do not carry customer traffic.

  Two methods for transporting 1588 over MPLS are defined.  The first
  method is to transport PTP messages directly over the dedicated MPLS
  LSP via UDP/IP encapsulation, which is suitable for IP/MPLS networks.
  The second method is to transport PTP messages inside a PW via
  Ethernet encapsulation, which is more suitable for MPLS-TP networks.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-tictoc-1588overmpls-02.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-ietf-tictoc-1588overmpls-02.txt
_______________________________________________
TICTOC mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tictoc
_______________________________________________
TICTOC mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tictoc

_______________________________________________
TICTOC mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tictoc

---

From: "Shahram Davari" <[email-masked]>
Date: Fri, 4 Nov 2011 08:09:51 -0700

Peter,

This is exactly what the spec says right now.

Thx
SD

From: [email-masked] [mailto:[email-masked]]
Sent: Friday, November 04, 2011 07:03 AM
Cc: [email-masked] <[email-masked]>
Subject: Re: [TICTOC] draft-ietf-tictoc-1588overmpls-02.txt / Annex

Hi Manav et al,

In speaking with Stefano last week, it seems if the mapping is PTP over IP over MPLS, or PTP over Ethernet over MPLS then we may be able to re-use the existing IEEE 1588 Annexes for IPv4 and Ethernet mappings.  This may save some time to develop this IETF specification.

Regards,

Microsemi Corporation
Peter Meyer
Timing & Synchronization
Communication and Medical Products Group
Office: +1-613-270-7203  |  Fax: +1-613-592-1010
[email-masked]<mailto:[email-masked]>  | www.zarlink.com<http://www.zarlink.com/>

25/10/2011 12:39 PM
To

Hi Manav et al,

I'm also wondering if we need to fill out something similar to IEEE 1588-2008 Annex D-F, or include such information in this document.

Microsemi Corporation
Peter Meyer
Timing & Synchronization
Communication and Medical Products Group
Office: +1-613-270-7203  |  Fax: +1-613-592-1010
[email-masked]<mailto:[email-masked]>  | www.zarlink.com<http://www.zarlink.com/>

07/10/2011 01:48 AM
To

Hi Tictocers,

This version incorporates whatever comments we had recived till date. Would appreciate if the WG can review this updated version.

Cheers, Manav

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, October 07, 2011 10:53 AM
To: [email-masked]
Cc: [email-masked]
Subject: [TICTOC] I-D Action: draft-ietf-tictoc-1588overmpls-02.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the Timing over IP Connection and Transfer of Clock Working Group of the IETF.

               Title           : Transporting PTP messages (1588) over MPLS Networks
               Author(s)       : Shahram Davari
                        Amit Oren
                        Manav Bhatia
                        Peter Roberts
                        Laurent Montini
               Filename        : draft-ietf-tictoc-1588overmpls-02.txt
               Pages           : 34
               Date            : 2011-10-06