Subject: [TICTOC] IEEE 1588v2 MIB

From: Hesham ElBakoury <[email-masked]>
Date: Thu, 19 Mar 2015 12:36:22 +0000

We're looking for an IEEE 1588 MIB.

The only thing I see is:

https://tools.ietf.org/html/draft-ietf-tictoc-ptp-mib-06<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dietf-2Dtictoc-2Dptp-2Dmib-2D06&d=AwMFAg&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=dJvsv8lKBodPgf8s_7fp0m5IeFlyCdOkQFoOfcxrbqg&s=ycihYgFS4XoNXC-QjQ19EGokENQ1sOLe3cijDlAl5Zk&e=>

Do you know if the IEEE has already done something in this area or is the IETF taking the lead for the MIB?

Thanks!

Hesham

---

From: Tim Frost <[email-masked]>
Date: Thu, 19 Mar 2015 12:50:25 +0000

Hi Hesham,
IEEE1588 is considering work in this area, but I don't know how far this has got.

There are several bodies that have produced MIBs for different profiles, e.g.

*         IETF (draft-ietf-tictoc-ptp-mib)

*         IEEE C37.238 - for the "Power Profile" (for smart grids etc.)

*         IEEE 802.1AS - for the  AVB profile (audio/video bridging)

IEEE1588 wants to bring all these together in a common MIB, then the various industry bodies and working groups could just produce extensions for their own profiles.
I think it will be a while before this is achieved; in the meantime the IETF draft is the most complete general document available to my knowledge.

(By the way, there will be a very minor revision in the next couple of weeks to fix some issues with the document. This is the last technical change that I know of before it goes to RFC).

Best regards,
Tim

Tim Frost   |   Calnex Solutions Ltd.   |   +44 (0) 7825 706 952   |   www.calnexsol.com<http://www.calnexsol.com/>

From: TICTOC [mailto:[email-masked]] On Behalf Of Hesham ElBakoury
Sent: 19 March 2015 12:36
To: [email-masked]
Subject: [TICTOC] IEEE 1588v2 MIB
Importance: High

The only thing I see is:

Thanks!

Hesham

---

From: Hesham ElBakoury <[email-masked]>
Date: Thu, 19 Mar 2015 18:09:50 +0000

Thanks Tim!

Are the other two MIBs available somewhere ?

Hesham

From: Tim Frost [mailto:[email-masked]]
Sent: Thursday, March 19, 2015 5:50 AM
To: Hesham ElBakoury; [email-masked]
Subject: RE: IEEE 1588v2 MIB

Hi Hesham,

Best regards,
Tim

The only thing I see is:

Thanks!

Hesham

---

From: Tim Frost <[email-masked]>
Date: Thu, 19 Mar 2015 18:18:31 +0000

Hi Hesham,

802.1AS is available from IEEE under the "Get802" program.
C37.238 is also available from IEEE, but I think you have to buy it.

Best regards,
Tim

Tim Frost  |  Calnex Solutions Ltd.  |  +44 7825 706952  |  www.calnexsol.com<http://www.calnexsol.com>

On 19 Mar 2015, at 18:10, "Hesham ElBakoury" <[email-masked]<mailto:[email-masked]>> wrote:

Thanks Tim!

Hesham

From: Tim Frost [mailto:[email-masked]]
Sent: Thursday, March 19, 2015 5:50 AM
To: Hesham ElBakoury; [email-masked]<mailto:[email-masked]>
Subject: RE: IEEE 1588v2 MIB

Hi Hesham,

Best regards,
Tim

From: TICTOC [mailto:[email-masked]] On Behalf Of Hesham ElBakoury
Sent: 19 March 2015 12:36
To: [email-masked]<mailto:[email-masked]>
Subject: [TICTOC] IEEE 1588v2 MIB
Importance: High

The only thing I see is:

Thanks!

Hesham