Subject: Re: [TICTOC] WGLC on draft-ietf-ntp-checksum-trailer-01.txt (Was: WGLC on draft-mizrahi-ntp-checksum-trailer-02.txt)

From: Tal Mizrahi <[email-masked]>
Date: Tue, 30 Jun 2015 13:15:33 +0000

Hi Anil,

Thanks for the prompt response.

> I support this draft, But how about more Bit incorporating in field type, Tal let me know your view.

The checksum trailer draft requests IANA to allocate an extension field type.
Note that:
(1) In unauthenticated mode, the checksum trailer extension field is the last one.
(2) In authenticated mode, the checksum trailer extension field is followed by the MAC / Autokey extension field.

The suggested M-bit in draft-choudharykumar-ntp-ntpv4-extended-extensions indicates whether the current extension field is the last or not.
So once the checksum trailer draft has an allocated extension field type, its most significant bit will be fixed to either 0 or 1, but cannot cover both case (1) and case (2) above.

A possible way to resolve this is to have two types allocated in the checksum trailer draft, one for case (1), and another for case (2). The two types would be identical, except for the most significant bit. This would allow future compatibility with the M-bit, if adopted.

A question to the WG: do we want to provision for the potential adoption of the M-bit?

Thanks,
Tal.

-----Original Message-----
From: ntpwg [mailto:ntpwg-bounces+talmi=[email-masked]] On Behalf Of Anil Kumar S N (VRP Network BL)
Sent: Tuesday, June 30, 2015 3:34 PM
To: Karen O'Donoghue; [email-masked]
Cc: [email-masked]
Subject: Re: [ntpwg] WGLC on draft-mizrahi-ntp-checksum-trailer-02.txt

I support this draft, But how about more Bit incorporating in field type, Tal let me know your view.

Thanks & Regards
Anil S N

"Be liberal in what you accept, and conservative in what you send" - Jon Postel

> -----Original Message-----
> From: ntpwg [mailto:ntpwg-bounces+anil.sn=[email-masked]] On 
> Behalf Of Karen O'Donoghue
> Sent: 30 June 2015 17:59
> To: [email-masked]
> Cc: [email-masked]
> Subject: [ntpwg] WGLC on draft-mizrahi-ntp-checksum-trailer-02.txt
> 
> Folks,
> 
> This begins a two week working group last call (WGLC) on 
> draft-mizrahi- ntp-checksum-trailer-02.txt Using UDP Checksum Trailers 
> in the Network Time Protocol (NTP)
> 
> This document has been proposed as an experimental RFC and has been 
> available for quite some time.
> 
> Please respond by 15 July 2015 to the mailing list with any comments 
> or objections to the draft.
> 
> https://tools.ietf.org/html/draft-mizrahi-ntp-checksum-trailer
> 
> Thanks!
> Karen
> _______________________________________________
> ntpwg mailing list
> [email-masked]
> http://lists.ntp.org/listinfo/ntpwg
_______________________________________________
ntpwg mailing list
[email-masked]
http://lists.ntp.org/listinfo/ntpwg

---

From: "Anil Kumar S N (VRP Network BL)" <[email-masked]>
Date: Tue, 30 Jun 2015 13:44:40 +0000

Hi All,

	Thanks Tal for considering the query.

	Yes, Even I would like to hear from WG. Please give your opinion on M-Bit.
	I hope, this is right time. I don't want to hold any drafts for adoption.

Thanks & Regards
Anil S N

> From: Tal Mizrahi [mailto:[email-masked]]
> Sent: 30 June 2015 18:46
> To: Anil Kumar S N (VRP Network BL); Karen O'Donoghue;
> [email-masked]; [email-masked]
> Subject: RE: [TICTOC] WGLC on draft-ietf-ntp-checksum-trailer-01.txt
> (Was: WGLC on draft-mizrahi-ntp-checksum-trailer-02.txt)
> 
> Hi Anil,
> 
> (2) In authenticated mode, the checksum trailer extension field is
> followed by the MAC / Autokey extension field.
> 
> The suggested M-bit in draft-choudharykumar-ntp-ntpv4-extended-
> extensions indicates whether the current extension field is the last or
> not.
> So once the checksum trailer draft has an allocated extension field
> type, its most significant bit will be fixed to either 0 or 1, but
> cannot cover both case (1) and case (2) above.
> 
> A possible way to resolve this is to have two types allocated in the
> checksum trailer draft, one for case (1), and another for case (2). The
> two types would be identical, except for the most significant bit. This
> would allow future compatibility with the M-bit, if adopted.
> 
> From: ntpwg [mailto:ntpwg-bounces+talmi=[email-masked]] On
> Behalf Of Anil Kumar S N (VRP Network BL)

---

From: Danny Mayer <[email-masked]>
Date: Tue, 30 Jun 2015 13:27:38 -0400

> A question to the WG: do we want to provision for the potential adoption of the M-bit?

No. It doesn't solve the problem for which they want it in a backward
compatible way.

Danny

---

From: Anil Kumar <[email-masked]>
Date: Tue, 30 Jun 2015 17:29:17 +0000

If issue is backward compatibility I will prove it, if new extensions Field
type is not conflicting with autokey. It has no issues.

On Tue, Jun 30, 2015, 10:55 PM Danny Mayer <[email-masked]> wrote:

> > The suggested M-bit in
> draft-choudharykumar-ntp-ntpv4-extended-extensions indicates whether the
> current extension field is the last or not.
> type, its most significant bit will be fixed to either 0 or 1, but cannot
> cover both case (1) and case (2) above.
> >
> checksum trailer draft, one for case (1), and another for case (2). The two
> types would be identical, except for the most significant bit. This would
> allow future compatibility with the M-bit, if adopted.
> >

---

From: Danny Mayer <[email-masked]>
Date: Tue, 30 Jun 2015 23:12:33 -0400

On 6/30/2015 1:29 PM, Anil Kumar wrote:
> If issue is backward compatibility I will prove it, if new extensions
> Field type is not conflicting with autokey. It has no issues.
> 

How are you intending to check ntpd, sntp, ntpdate, ntimed, Windows
Time, chrony, and a vast number of clients?

Let us solve the real problem rather than coming up with hacks that will
be almost impossible to do right.

Danny
> 
> On Tue, Jun 30, 2015, 10:55 PMÂ Danny Mayer <[email-masked]
> <mailto:[email-masked]>> wrote:
> 
>     draft-choudharykumar-ntp-ntpv4-extended-extensions indicates whether
>     the current extension field is the last or not.
>     > So once the checksum trailer draft has an allocated extension
>     field type, its most significant bit will be fixed to either 0 or 1,
>     but cannot cover both case (1) and case (2) above.
>     >
>     > A possible way to resolve this is to have two types allocated in
>     the checksum trailer draft, one for case (1), and another for case
>     (2). The two types would be identical, except for the most
>     significant bit. This would allow future compatibility with the
>     M-bit, if adopted.
>     >
>     [email-masked] <mailto:[email-masked]>

---

From: "Anil Kumar S N (VRP Network BL)" <[email-masked]>
Date: Wed, 1 Jul 2015 03:57:12 +0000

I believe RFC is not specific to ntpd, sntp, ntpdate, ntimed, Windows, Time, chrony etc...
All above has to follow RFC, So if conformance is with RFC is ultimate reasoning.

I will publish detailed analysis on behavior NTPv3/NTPv4 with respect to M-Bit. 
The problem is that while designing extension addition padding issue should have been taken care, 
We are trying to solve it. This is an honest attempt. 

I discussed with our network solution team, in real network most of devices use only NTPv3 and 
they are not even willing to move into NTPv4 as NTPv3 is serving their purpose. 
Moving into New version is not the only solution to all the issues. 
We need some improvements in current NTPv4 too.

Core network is easy to upgrade as there will be less device using NTP, if we move towards 
Access ring the number of devices are huge. 

The point is coustmer is willing to move NTPv5 if we can provide them only with very attractive/convincing 
features with integrated diagnostic tools, Since each server at the access ring is handling 
huge number of clients, if there is a flapping in server. Server receives burst of client 
requests. One of the requirements came for solution team is to find as many servers as possible 
dynamically (with out multicast) and narrow down to stable servers. Administrator should be able
select one of the best server.

Selecting server : histroy of stability, challenge is trustability & current load.

So I feel we need to solve issue by issue. Lets not differintiate small or big.

Thanks & Regards
Anil S N

> From: Danny Mayer [mailto:[email-masked]]
> Sent: 01 July 2015 08:43
> To: Anil Kumar; Tal Mizrahi; Anil Kumar S N (VRP Network BL); Karen
> O'Donoghue; [email-masked]; [email-masked]
> Subject: Re: [ntpwg] [TICTOC] WGLC on draft-ietf-ntp-checksum-trailer-
> 01.txt (Was: WGLC on draft-mizrahi-ntp-checksum-trailer-02.txt)
> 
> Let us solve the real problem rather than coming up with hacks that
> will be almost impossible to do right.
> 
> Danny
> >
> >     > The checksum trailer draft requests IANA to allocate an
> extension
> >     field type.
> >     > Note that:
> >     > (1) In unauthenticated mode, the checksum trailer extension
> field
> >     is the last one.