Subject: [ietf-tls] TLS roadmap, and spot for dns_name extension

From: "Joseph Hui" <[email-masked]>
Date: Wed, 2 May 2001 16:26:36 -0700

Hi everyone,

If you would indulge me, may I suggest we have a discussion on
plotting a TLS roadmap, at least for 1.1 and 1.2, based on the
extensions currently proposed, in the interest of ensuring their
timely roll-out?
I further suggest (to the group chairs and all) we make it the
primary goal that by the next IETF meeting timeline (August), 
we at least reach a consensus on some tangible dates for 1.1 ,
and what will be in it.  (Good luck!  Right? ;-)

Where I'm coming from is about the DNS Name Extension proposed
by Jan M, et al.  It's been, and still is, badly needed by CDNs
since yesteryears.  To my understanding, the original dns_name
thread started last August, and soon ended with general 
acceptance of the solution but without agreement on its TLS
revision#.  I then read indication that such extension might
get folded into a draft mainly for the wireless environment.
Of extensions, there're those that are needed and those that
are needed badly.  Lumping them together may have virtue of
its own, but I'm concerned that it may also make the long wait
for the dns_name solution even longer.  

My hope, and hopefully the same hope of many, is that a
roadmap would help us move things along faster, plan better,
and avoid unnecessary/inadvertant hold-ups.

Regards,

Joe

Joe Hui
Digital Island

---
You are currently subscribed to ietf-tls as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: Pete Chown <[email-masked]>
Date: Thu, 3 May 2001 13:48:31 +0100

> extensions currently proposed, in the interest of ensuring their

That sounds like a good idea to me.  If we set ourselves particular
target dates it will help to make things happen, because everyone will
know what they are working towards.

I will probably come to the next IETF meeting because it's in London,
and only about half an hour from where I live.  I would like to meet
the rest of you if you will be there for a TLS meeting.

-- 
Pete

---

---

From: [email-masked]
Date: Mon, 7 May 2001 08:00:40 -0500

I understand the pressing need for the DNS Name Extension, but I also feel
that the wireless extensions are very important.  I would like to see us
proceed with both for TLS 1.1.  The wireless extensions have been discussed
since last November.

I'm in agreement with you on getting a roadmap defined so that we know where
we are headed and to help us plan.  

My preference is to see the wireless extensions and DNS name extension in
TLS 1.1.  It was suggested that these come under the more general heading of
"extensions to TLS".  Simon Blake-Wilson said that he would be releasing an
updated internet draft soon on wireless extensions reflecting the earlier
discussions.  I'm hoping general consensus can be reached on this I-D so
that we can move forward.  The deadline that you mentioned for the August
meeting in London sounds reasonable.

-- maureen

Maureen Stillman
Nokia
Member of Scientific Staff             Voice: (607)273-0724 x62
Internet Commerce Enhancement  Fax: (607)275-3610
127 W. State Street                     Mobile: (607)227-2933
Ithaca, NY 14850
e-mail: [email-masked]
www.nokia.com

-----Original Message-----
From: ext Joseph Hui [mailto:[email-masked]]
Sent: Wednesday, May 02, 2001 7:27 PM
To: IETF Transport Layer Security WG
Subject: [ietf-tls] TLS roadmap, and spot for dns_name extension

Hi everyone,

Regards,

Joe

Joe Hui
Digital Island

---
You are currently subscribed to ietf-tls as: [email-masked]
To unsubscribe send a blank email to
[email-masked]

---

---

From: "Joseph Hui" <[email-masked]>
Date: Mon, 7 May 2001 09:23:38 -0700

Maureen,

Thanks for the echo.

As both of the dns_name problem and solution have been openly
discussed and reached a conclusive state, I'd like to suggest
we start the TLS 1.1 roadmap with the DNS Name Extension, if
that's also alright with the authors -- Jan M, et al.

Regards,

Joe

Joe Hui
Research Engineer
Digital Island  
(805) 370-2165
===================================================

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, May 07, 2001 6:01 AM
To: IETF Transport Layer Security WG
Subject: [ietf-tls] RE: TLS roadmap, and spot for dns_name extension

I understand the pressing need for the DNS Name Extension, but I also
feel
that the wireless extensions are very important.  I would like to see us
proceed with both for TLS 1.1.  The wireless extensions have been
discussed
since last November.

I'm in agreement with you on getting a roadmap defined so that we know
where
we are headed and to help us plan.  

My preference is to see the wireless extensions and DNS name extension
in
TLS 1.1.  It was suggested that these come under the more general
heading of
"extensions to TLS".  Simon Blake-Wilson said that he would be releasing
an
updated internet draft soon on wireless extensions reflecting the
earlier
discussions.  I'm hoping general consensus can be reached on this I-D so
that we can move forward.  The deadline that you mentioned for the
August
meeting in London sounds reasonable.

-- maureen

Maureen Stillman
Nokia

-----Original Message-----
From: ext Joseph Hui [mailto:[email-masked]]
Sent: Wednesday, May 02, 2001 7:27 PM
To: IETF Transport Layer Security WG
Subject: [ietf-tls] TLS roadmap, and spot for dns_name extension

Hi everyone,

Regards,

Joe

Joe Hui
Digital Island

---

---
You are currently subscribed to ietf-tls as: [email-masked]
To unsubscribe send a blank email to
[email-masked]

---