Subject: [TLS] OE + TLS support

From: "Facundo Barrera - GMail" <[email-masked]>
Date: Tue, 13 Feb 2007 14:06:53 -0800

Hi list:
         Does Outlook Express support TLS? cause i can't get it to
work, by now Mozilla Thunderbird works just fine with my TLS SMTP.
Any ideas?
Thanks in advance

-- 
_________________________
   Facundo Agustin Barrera
  --------------------------------------
     www.openlabs.com.ar
"Let the penguins do the work"
---------------------------------------------
   Buenos Aires - Argentina
_________________________

_______________________________________________
TLS mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tls

---

From: Mike <[email-masked]>
Date: Tue, 13 Feb 2007 14:32:33 -0800

> work....

I just tried it and it works (version 6).

Tools -> Accounts -> Mail -> Properties -> Advanced

Select "This server requires a secure connection (SSL)"

It used TLS 1.0 with RC4-MD5 when I sent a test message.

Mike

---

From: "tom.petch" <[email-masked]>
Date: Wed, 14 Feb 2007 10:10:36 +0100

----- Original Message ----- 
From: "Mike" <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, February 13, 2007 11:32 PM
Subject: Re: [TLS] OE + TLS support

> It used TLS 1.0 with RC4-MD5 when I sent a test message.

I note that for Internet Explorer there is an option to specify which of 
SSL2.0
SSL3.0
TLS1.0
is acceptable Tools -> Internet Options -> Advanced
One government body I know has this set to the default (for their OS) of 
SSL2 Yes
SSL3 Yes
TLS1 No
and can I get them to change it????? 

Tom Petch

---

From: Mike <[email-masked]>
Date: Wed, 14 Feb 2007 07:12:35 -0800

> and can I get them to change it????? 

Well if you try to connect to www.americanexpress.com using TLS 1.0,
it chokes, but SSLv3 works.  If they can be stuck in the past, there
are probably lots of others.

Mike

---

From: Martin Rex <[email-masked]>
Date: Wed, 14 Feb 2007 17:44:10 +0100 (MET)

> are probably lots of others.

On what in particular do they choke?
Choking if you send them a correct SSL Hello (3.0 record protocol version,
3.1 client version) would be a problem, aborting if you do not agree
to a server-asserted/chosen SSL v3.0 protocol should be OK.

-Martin

---

From: <[email-masked]>
Date: Wed, 14 Feb 2007 20:24:22 +0200

Martin Rex wrote:

> On what in particular do they choke?  Choking if you send them a
> correct SSL Hello (3.0 record protocol version, 3.1 client version)
> would be a problem, aborting if you do not agree to a
> server-asserted/chosen SSL v3.0 protocol should be OK.

For me, www.americanexpress.com:443 seems to work using TLS 1.0
(negotiates TLS 1.0, and seems to ignore the record protocol version).
However, if I propose TLS 1.1, the server just closes the connection
immediately.

Best regards,
Pasi

---

From: Mike <[email-masked]>
Date: Wed, 14 Feb 2007 14:21:58 -0800

> However, if I propose TLS 1.1, the server just closes the connection

If you try TLS 1.0 with extensions, it closes the connection also,
so I consider that broken.  If you omit extensions, it works.

Mike