Subject: [TLS] Certificate Hash Types extension supported

From: Mike <[email-masked]>
Date: Tue, 06 Feb 2007 10:56:52 -0800

I added support to my test server for the certificate
hash types extension.  Both www.mikestoolbox.net and
www.mikestoolbox.org have SHA-1 and SHA-256 certificate
chains.  They share an IP address, so you will need to
use a server name extension to get to .org.

The server returns the first matching certificate chain
based on the order of the HashTypes sent by the client.
Currently this is not specified in the draft spec.

Please let me know if you encounter any problems.

Thanks,

Mike

_______________________________________________
TLS mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tls

---

From: Mike <[email-masked]>
Date: Tue, 06 Feb 2007 11:04:26 -0800

Sorry I forgot to mention that it listens on port 443.

Mike