Subject: [TLS] Certificate Hash Types extension

From: Mike <[email-masked]>
Date: Mon, 05 Feb 2007 09:31:05 -0800

Somehow I missed this extension when I read the TLS 1.2
spec.  (I probably skipped it thinking they were the same
as the TLS extensions spec.)

Now I'm adding support for it in my server and I have a
question about it:  should the client order the list of
supported hash algorithms in its order of preference?
I would think this is a good idea, instead of leaving it
up to the server to decide.

Mike

_______________________________________________
TLS mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tls

---

From: Simon Josefsson <[email-masked]>
Date: Mon, 05 Feb 2007 22:18:02 +0100

> up to the server to decide.
...
> In TLS 1.2, a CertificateRequest message has a list
> of HashTypes specifying the acceptable hashes used
> in certificate signatures.  There is no guidance
> on the ordering of these values.  I would suggest
> that the server should specify them in the order
> that it prefers.  The client would scan the list
> in order, and return a certificate using the first
> matching hash algorithm.

I had the same reaction to both of these issues.  I agree that it
would be more useful if the lists are in preference order.

Generally, is there a reason the certificate hash type mechanism isn't
defined in a symmetrical way?  I mean, by using a new extension for
both directions.

/Simon