Subject: [TLS] draft-kato-tls-rfc4132bis-03 : get rid of unneeded prose

From: Alfred Hönes <[email-masked]>
Date: Wed, 4 Mar 2009 12:43:46 +0100 (MEZ)

Hello,

The 'Introduction' of draft-kato-tls-rfc4132bis-03 still contains
a lot of details regarding the Camellia cipher primitive proper,
which IMO are out of scope and not needed for this document
describing the use of that building block in TLS.

The fundamental reference, RFC 3713, already contains what needs
to be said, and it is not very useful to have every document
making use of that cipher repeat the same or similar verbiage.

I strongly suggest that the bulk of the 'marketing prose' in Section 1
(para 2 ff.) be removed from the draft -- in a similar manner as
it has been done now for the companion Camellia for IPsec draft.

Otherwise, I suggest that the WG consider the portfolio question
I already had raised in
   http://www.IETF.ORG/mail-archive/web/tls/current/msg03242.html
(combining Camellia-256 with SHA-384 instead of SHA-256)
and make a decision on whether that document should be adopted as
a WG document or recommended as an individual submission for PS.

Thoughts?  Opinions?

Kind regards,
  Alfred Hönes.

-- 

+------------------------+--------------------------------------------+
| TR-Sys Alfred Hoenes   |  Alfred Hoenes   Dipl.-Math., Dipl.-Phys.  |
| Gerlinger Strasse 12   |  Phone: (+49)7156/9635-0, Fax: -18         |
| D-71254  Ditzingen     |  E-Mail:  [email-masked]                     |
+------------------------+--------------------------------------------+

---

From: Mohamad Badra <[email-masked]>
Date: Wed, 04 Mar 2009 17:02:35 +0100

Hi,

I agree with Alfred, the document should avoid repeating details 
regarding Camellia block cipher. IMO, a pointer to RFC3713 is sufficient.

To help the reader, it may be better to separate SHA1 and SHA2 into two 
Sections. An application statement on using them with different TLS 
version should be useful.

Best regards,
Badra

>   Alfred H?nes.

---

From: Satoru Kanno <[email-masked]>
Date: Wed, 11 Mar 2009 12:27:52 +0900

Hi Alfred, Badra,

Thank you for useful comments.

On Wed, 04 Mar 2009 17:02:35 +0100

> regarding Camellia block cipher. IMO, a pointer to RFC3713 is sufficient.

We revised this document based on Alfred and Mohamad's comments.

> version should be useful.

We separate '3.3.  Hash and Pseudorandom Function'
to '3.3.1.  Hash and Pseudorandom Function for TLS 1.1' and
'3.3.2.  Hash and Pseudorandom Function for TLS 1.2'.

This revised document will appear after 23 March 2009 at midnight(PT).
Please check it later.

Best regards,
---
Satoru Kanno

> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls

--
Satoru Kanno

Security Business Unit
Mobile and Security Solution Business Group
NTT Software Corporation

e-mail: [email-masked]