Subject: [TLS] New Version Notification for draft-barrett-mobile-dtls-00

From: <[email-masked]>
Date: Thu, 5 Mar 2009 00:18:45 +0100

Hi All,

Jeremey and I have created a new I-D for consideration by the TLS WG. Your comments are more than welcome.

Kind Regards,
Michael
-----Original Message-----
From: ext IETF I-D Submission Tool [mailto:[email-masked]] 
Sent: 04 March, 2009 15:01
To: Barrett Jeremey (Nokia-S/MtView)
Cc: Williams Michael.G (Nokia-CIC/Dallas)
Subject: New Version Notification for draft-barrett-mobile-dtls-00 

A new version of I-D, draft-barrett-mobile-dtls-00.txt has been successfuly submitted by Jeremey Barrett and posted to the IETF repository.

Filename:	 draft-barrett-mobile-dtls
Revision:	 00
Title:		 Mobile DTLS
Creation_date:	 2009-03-04
WG ID:		 Independent Submission
Number_of_pages: 12

Abstract:
Mobile DTLS (Mobi-D) is an extension to DTLS that provides host mobility support.  After obtaining a new IP address or port, a DTLS client mobile host can continue sending to its DTLS server correspondent host.  The mobile host continues to use the existing set of security parameters, from the new address, without re- negotiation.  The correspondent host accepts packets from the new IP address or port, also without re-negotiation.  After receiving any valid DTLS packet from the mobile host's new address or port, the correspondent host uses the new address or port to send to the mobile host.

The IETF Secretariat.

---

From: Badra <[email-masked]>
Date: Sun, 8 Mar 2009 00:23:44 +0100

Hi Michael,

Cannot DTLS/TLS clients establish a full handshake using a first IP address
and then resume the same session using a second IP address?

Best regards,
Badra

On Thu, Mar 5, 2009 at 12:18 AM, <[email-masked]> wrote:

> A new version of I-D, draft-barrett-mobile-dtls-00.txt has been successfuly
> submitted by Jeremey Barrett and posted to the IETF repository.
>
> Mobile DTLS (Mobi-D) is an extension to DTLS that provides host mobility
> support.  After obtaining a new IP address or port, a DTLS client mobile
> host can continue sending to its DTLS server correspondent host.  The mobile
> host continues to use the existing set of security parameters, from the new
> address, without re- negotiation.  The correspondent host accepts packets
> from the new IP address or port, also without re-negotiation.  After
> receiving any valid DTLS packet from the mobile host's new address or port,
> the correspondent host uses the new address or port to send to the mobile
> host.
>
>
>
> The IETF Secretariat.
>
>
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls
>

---

From: <[email-masked]>
Date: Mon, 9 Mar 2009 14:54:52 +0100

Hi Badra, 

The latency of performing a handshake may not be acceptable in some
applications (e.g. real-time data), especially in the case of an unforeseen
move. Mobile DTLS allows an application on a mobile device to simply keep
working, and this fits particularly well with applications which are already
sending and receiving data very frequently.

Another problem with the handshake approach is that it forces the
application to constantly worry about whether it has moved or not. Mobile
DTLS shields the application from having to care; it can just make the
simple assumption that the OS has *some* address.

If the application isn't sending data, it could choose to send NOP at some
frequency.

Regards,
Jeremey.

On 3/7/09 5:23 PM, "ext Badra" <[email-masked]> wrote:

>> support.  After obtaining a new IP address or port, a DTLS client mobile host
>> can continue sending to its DTLS server correspondent host.  The mobile host
>> continues to use the existing set of security parameters, from the new
>> from 
>> the new IP address or port, also without re-negotiation.  After receiving any
>> valid DTLS packet from the mobile host's new address or port, the
>> correspondent host uses the new address or port to send to the mobile host.
>> 
>> 
>> 
>> The IETF Secretariat.
>> 
>>

---

From: Mohamad Badra <[email-masked]>
Date: Mon, 09 Mar 2009 16:41:25 +0100

Hi Jeremey,

 > move.

With the changes you propose to DTLS, I am not sure a "resumed 
handshake" will influence the performance of those applications, unless 
you have data to back that claim.

 > Mobile DTLS allows an application on a mobile device to simply keep

Hmmm, but this is already discussed in Section 4.1 of rfc4347-bis-02.
I believe the text of this Section is good enough to handle the 
situation you cited before.

 > simple assumption that the OS has *some* address.

But I don't see the benefits of managing the mobility at the DTLS layer 
for applications that will be happy to do that.

Best regards,
Badra

 >>> Jeremey and I have created a new I-D for consideration by the TLS 
WG. Your
 >>> comments are more than welcome.
 >>>
 >>> Kind Regards,
 >>> Michael