Subject: Re: [TLS] cipher suites for protecting client credentials

From: "Tschofenig, Hannes (NSN - FI/Espoo)" <[email-masked]>
Date: Wed, 21 Mar 2012 06:06:59 +0200

Hi Florian,

I have no problem with the proposed extension even if it is not the most widespread extension we have ever seen. I do think, however, that an accurate description of the provided privacy protection is important. I am happy to to propose text (after the IETF meeting).

A separate but related discussion is how authentication on the Web should look like and what role privacy protection plays there. I had written a doc about this topic but it isn't really focused on TLS...

Ciao
Hannes

Sent from my Windows Phone

-----Original Message-----
From: ext Florian Weimer
Sent: 3/20/2012 5:37 PM
To: Peter Gutmann
Cc: [email-masked]; [email-masked]
Subject: Re: [TLS] cipher suites for protecting client credentials

* Peter Gutmann:

> Hannes Tschofenig <[email-masked]> writes:
>
>>Just a thought that came to my mind: How often is client authentication via
>>certificates used in TLS in the real world?
>
> Use is practically nonexistent except for a small number of stovepipe
> applications, and certainly widespread public use is nonexistent.

What would qualify as "widespread use"?  Perhaps tens of thousands of
users in Germany who rely client certificate authentication in browsers
to access specific applications?

I recently had to debug a handshake issue, and even though the whole
service is wrapped in a quite different way, it does use Internet
Explorer, TLS and a client certificate underneath.  I was quite
surprised.

> So this approach is "solving" a problem that practically doesn't
> exist.

I'm not sure if the added complexity is worth the effort.  If this is
somehow addressed, the next thing on the list is the Server Name
Indication and the server certificate, I guess.

-- 
Florian Weimer                <[email-masked]>
BFK edv-consulting GmbH       http://www.bfk.de/
Kriegsstraße 100              tel: +49-721-96201-1
D-76133 Karlsruhe             fax: +49-721-96201-99

---

From: Anders Rundgren <[email-masked]>
Date: Wed, 21 Mar 2012 10:52:42 +0100

> Hi Florian,
<snip>
> to access specific applications?

There are millions of users of TLS c-c-a in Asia and Europe.
With mobile phones we will soon be counting them in billions.

At least if we get enrollment to work :-)

Anders
<snip>

---

From: Marsh Ray <[email-masked]>
Date: Wed, 21 Mar 2012 10:34:23 -0500

> At least if we get enrollment to work :-)

Per Wikipedia, there are about 3.5 million active smart card IDs issued 
by the US DoD:
https://en.wikipedia.org/wiki/Common_Access_Card

These cards include client certs for accessing secure websites via TLS.

Of course, they have a bit more of a supporting infrastructure for 
enrollment than your typical website!

- Marsh

---

From: Anders Rundgren <[email-masked]>
Date: Wed, 21 Mar 2012 20:51:16 +0100

> enrollment than your typical website!

Indeed, but now when they have decided supporting "Derived Credentials"

http://csrc.nist.gov/groups/SMA/ispab/documents/minutes/2012-02/feb1_nist-800-63-1_overview_enewton.pdf

they are in the same deep s**t as everybody else.

Anders