Subject: Re: [TLS] RFC 5878 - why?

From: Peter Gutmann <[email-masked]>
Date: Thu, 19 Sep 2013 08:55:46 +0000

Trevor Perrin <[email-masked]> writes:

>I assume that's why no-one reviewed it carefully.

[...]

>The "Experimental" marking wasn't enough to prevent people like CT, TACK,
>DTCP, and OpenSSL wasting a lot of time evaluating this and trying to use it
>in the last couple of years.

This seems to combine the worst of both worlds, no-one was really interested
in it so it passed without review, but then there was enough interest in it
later for people to try and implement it.  Can anyone who tried to implement
it explain why they did so?

Peter.

---

From: Ben Laurie <[email-masked]>
Date: Thu, 19 Sep 2013 11:26:03 +0100

> it explain why they did so?

In CT's case it was because it seemed convenient at the time - we need
to send authz data during the TLS handshake, and here was a way
already defined to do it. We debated allocating a new extension for
it, but decided against it. In the end, because 5878 had errors that
we did not have the power to correct, we decided to abandon it.

I notice that the authors have not responded to the corrections,
either. So I guess they've abandoned it, too.

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 19 Sep 2013 08:22:12 -0400

> I notice that the authors have not responded to the corrections, either. So I guess they've abandoned it, too.

I am always reluctant to take such passive response as sign of anything.

I suggest Travis contact the authors and/or submit an errata that says "we wish to mark this RFC as a failed experiment for the following reasons" or something like that.

	/r$

--  
Principal Security Engineer
Akamai Technology
Cambridge, MA