Subject: [TLS] Early code point assignment request for curve25519 and curve448

From: Adam Langley <[email-masked]>
Date: Sat, 14 Nov 2015 10:14:53 -0800

The IESG conflicts review for
https://datatracker.ietf.org/doc/draft-irtf-cfrg-curves/ has now
completed without issue[1].

The editor's copy of the 1.3 spec contains code points for these
curves[2], specifically:

      // ECDH functions.
       ecdh_x25519 (29), ecdh_x448 (30),

       // Signature curves.
       eddsa_ed25519 (31), eddsa_ed448 (32),

I'd like to request that these code points for early assignment.

[1] https://mailarchive.ietf.org/arch/msg/ietf-announce/MWmqSxBZxWPEt6glXJZvXg5lMS4
[2] https://tlswg.github.io/tls13-spec/#rfc.section.6.3.2.2

Cheers

AGL

-- 
Adam Langley [email-masked] https://www.imperialviolet.org

---

From: Eric Rescorla <[email-masked]>
Date: Sat, 14 Nov 2015 10:36:20 -0800

I support this code point assignment and we should also pull the same code
points into RFC 4492-bis.

On Sat, Nov 14, 2015 at 10:14 AM, Adam Langley <[email-masked]>
wrote:

> [1]
> https://mailarchive.ietf.org/arch/msg/ietf-announce/MWmqSxBZxWPEt6glXJZvXg5lMS4
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls
>

---

From: Yoav Nir <[email-masked]>
Date: Sat, 14 Nov 2015 20:40:01 +0200

+1

The IANA considerations section in the github copy has the same identifiers.
https://github.com/tlswg/rfc4492bis/blob/master/draft-ietf-tls-rfc4492bis.xml <https://github.com/tlswg/rfc4492bis/blob/master/draft-ietf-tls-rfc4492bis.xml>

Yoav

> On 14 Nov 2015, at 8:36 PM, Eric Rescorla <[email-masked]> wrote:
> 
> I support this code point assignment and we should also pull the same code points into RFC 4492-bis.
> 
> On Sat, Nov 14, 2015 at 10:14 AM, Adam Langley <[email-masked] <mailto:[email-masked]>> wrote:
> https://datatracker.ietf.org/doc/draft-irtf-cfrg-curves/ <https://datatracker.ietf.org/doc/draft-irtf-cfrg-curves/> has now
> [1] https://mailarchive.ietf.org/arch/msg/ietf-announce/MWmqSxBZxWPEt6glXJZvXg5lMS4 <https://mailarchive.ietf.org/arch/msg/ietf-announce/MWmqSxBZxWPEt6glXJZvXg5lMS4>
> [2] https://tlswg.github.io/tls13-spec/#rfc.section.6.3.2.2 <https://tlswg.github.io/tls13-spec/#rfc.section.6.3.2.2>
> 
> 
> Cheers
> 
> AGL
> 
> --
> Adam Langley [email-masked] <mailto:[email-masked]> https://www.imperialviolet.org <https://www.imperialviolet.org/>
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/tls <https://www.ietf.org/mailman/listinfo/tls>
>

---

From: Loganaden Velvindron <[email-masked]>
Date: Sat, 14 Nov 2015 18:41:31 +0000

> [2] https://tlswg.github.io/tls13-spec/#rfc.section.6.3.2.2

I support this code point assignment.

---

From: Viktor Dukhovni <[email-masked]>
Date: Sat, 14 Nov 2015 18:44:20 +0000

>        ecdh_x25519 (29), ecdh_x448 (30),

Thanks, good news.

>        eddsa_ed25519 (31), eddsa_ed448 (32),

AFAIK the signature detailes are not pinned down yet.  Is this
allocation in anticipation of the final details?

-- 
	Viktor.

---

From: Ilari Liusvaara <[email-masked]>
Date: Sat, 14 Nov 2015 20:47:03 +0200

> I'd like to request that these code points for early assignment.
 
Nothing against #29 and #30. Those are ready.

Regarding #31, one would need to pull eddsa codepoint (5 in TLS
1.3 editor's copy) and presumably fix OIDs 1.3.101.100 and
1.3.101.101 in order to get usable Ed25519 keys in PKIX.

Regarding #32, it has all of #31, plus no stable spec (due to
missing decision on "hash" to be used).

-Ilari

---

From: Adam Langley <[email-masked]>
Date: Sat, 14 Nov 2015 10:47:38 -0800

> allocation in anticipation of the final details?

It might well be that the X25519 and X448 code points are suitable for
early assignment while the signature code points are not since the
signature work in CFRG is ongoing. I'll leave that to the chairs.

(While we would use early code-point assignments for X25519/X448 we
don't have plans for using the signature code points at this time.)

Cheers

AGL

---

From: Eric Rescorla <[email-masked]>
Date: Sat, 14 Nov 2015 11:17:52 -0800

On Sat, Nov 14, 2015 at 10:47 AM, Adam Langley <[email-masked]>
wrote:

> don't have plans for using the signature code points at this time.

I'm fine either way. As Adam says, it wouldn't be harmful to wait for
the signature code point assignments for a bit, but I doubt it would
be that harmful not to. People who deploy the signature schemes
before they are stable do so at their own risk. Also, that risk seems
low since you're not going to have public certificates with these
schemes until they are stable.

-Ekr

---

From: Deirdre Connolly <[email-masked]>
Date: Sat, 14 Nov 2015 14:47:29 -0500

+1

-DC-