Subject: [TLS] TCP Keep Alive Question: draft-ietf-tls-tls13-11

From: <[email-masked]>
Date: Mon, 4 Jan 2016 15:45:56 +0000 (UTC)

Hello All,

Please excuse if this topic has been previously discussed.  I have a question about TCP Keep Alives.

Section 5 of draft-ietf-tls-tls13-11 reads:

"Three protocols that use the TLS Record Protocol are described in this document: the TLS Handshake Protocol, the Alert Protocol, and the application data protocol." 

Then continues with:

"Implementations MUST NOT send record types not defined in this document unless negotiated by some extension.  If a TLS implementation receives an unexpected record type, it MUST send an 
"unexpected_message" alert."

In the wild today, I see many TLS connections which use TCP Keep Alive (NOT TLS Heartbeat).   I take it that this will not work going forth?
 Thanks,

Nalini Elkins
Inside Products, Inc.
www.insidethestack.com
(831) 659-8360

---

From: Watson Ladd <[email-masked]>
Date: Mon, 4 Jan 2016 07:52:17 -0800

> In the wild today, I see many TLS connections which use TCP Keep Alive (NOT TLS Heartbeat).   I take it that this will not work going forth?

TCP Keep Alive is invisible to the TLS connection.

>  Thanks,
>
> Nalini Elkins
> Inside Products, Inc.
> www.insidethestack.com
> (831) 659-8360
>
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls

-- 
"Man is born free, but everywhere he is in chains".
--Rousseau.

---

From: <[email-masked]>
Date: Mon, 4 Jan 2016 15:59:55 +0000 (UTC)

>TCP Keep Alive is invisible to the TLS connection.

I see. Then, is it that PACKETS without the TLS record protocol may be sent on the TLS connection, but IF the TLS Record protocol IS used, then the record types must be one of those described? 

Or is it that TCP Keep Alive is taken out by the TCP stack and not passed to TLS?

---

From: Roland Zink <[email-masked]>
Date: Mon, 4 Jan 2016 17:32:03 +0100

TCP keep alives are handled by the TCP stack and not given to TLS or as 
Watson said invisible to TLS.

Roland

---

From: <[email-masked]>
Date: Mon, 4 Jan 2016 16:44:26 +0000 (UTC)

Thank you all for your help.
Nalini Elkins
Inside Products, Inc.
www.insidethestack.com
(831) 659-8360

----- Original Message -----
From: Roland Zink <[email-masked]>
To: [email-masked]
Sent: Monday, January 4, 2016 8:32 AM
Subject: Re: [TLS] TCP Keep Alive Question: draft-ietf-tls-tls13-11

Roland