Subject: [TLS] chacha/poly for http/2

From: "Salz, Rich" <[email-masked]>
Date: Wed, 13 Jan 2016 17:48:37 +0000

We (OpenSSL) have already tested interop of chacha/poly with other browsers and TLS stacks, and now it all works.  (The official IETF version, not the QUIC version).

We (Akamai) are planning on enabling it for our customers in a few weeks, in case anyone might be interested.

Thanks.

                /r$, a me who is part of both of the we's above :)

--
Senior Architect, Akamai Technologies
IM: [email-masked] Twitter: RichSalz

---

From: Wan-Teh Chang <[email-masked]>
Date: Wed, 13 Jan 2016 10:21:05 -0800

On Wed, Jan 13, 2016 at 9:48 AM, Salz, Rich <[email-masked]> wrote:
> We (OpenSSL) have already tested interop of chacha/poly with other browsers
> and TLS stacks, and now it all works.  (The official IETF version, not the
> QUIC version).

Hi Rich,

Did you test interop of chacha/poly with a developer build of Firefox?
The NSS patch is still being reviewed at
https://codereview.appspot.com/277090043/. So official Firefox
releases don't support chacha/poly cipher suite yet.

Wan-Teh Chang

---

From: David Benjamin <[email-masked]>
Date: Wed, 13 Jan 2016 18:38:43 +0000

Chrome is also expecting to ship the cipher in Chrome 49. It's available in
Canary and Dev channel right now. It should interop with OpenSSL's master
branch as of when I last tested this.

David

On Wed, Jan 13, 2016 at 12:48 PM Salz, Rich <[email-masked]> wrote:

> We (OpenSSL) have already tested interop of chacha/poly with other
> browsers and TLS stacks, and now it all works.  (The official IETF version,
> not the QUIC version).
>
>
>
>                 /r$, a me who is part of both of the we’s above J
>
>
>
> --
>
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls
>

---

From: Peter Dettman <[email-masked]>
Date: Mon, 18 Jan 2016 14:04:17 +0700

We (BouncyCastle) have just updated our TLS implementations to
draft-ietf-tls-chacha20-poly1305-04 and have confirmed interop with OpenSSL.

Regards,
Pete Dettman

On 14/01/2016 12:48 AM, Salz, Rich wrote:
> browsers and TLS stacks, and now it all works.  (The official IETF
> version, not the QUIC version).

---

From: Kurt Roeckx <[email-masked]>
Date: Mon, 18 Jan 2016 12:08:22 +0100

> draft-ietf-tls-chacha20-poly1305-04 and have confirmed interop with OpenSSL.

As far as I know, OpenSSL has an outstanding interop issue with
BoringSSL where OpenSSL would not follow the draft.

Kurt

---

From: Kurt Roeckx <[email-masked]>
Date: Mon, 18 Jan 2016 12:10:41 +0100

> BoringSSL where OpenSSL would not follow the draft.

Oh, it has been commited after all.

Kurt

---

From: Hubert Kario <[email-masked]>
Date: Tue, 19 Jan 2016 16:02:26 +0100

> version, not the QUIC version).

I was able to confirm interoperability between tlslite-ng[1] and current 
OpenSSL master (0e76014e584ba7), using draft-ietf-tls-chacha20-
poly1305-04 implementation.

 1 - https://github.com/tomato42/tlslite-ng/tree/chacha-ecdhe
-- 
Regards,
Hubert Kario
Senior Quality Engineer, QE BaseOS Security team
Web: www.cz.redhat.com
Red Hat Czech s.r.o., Purkyňova 99/71, 612 45, Brno, Czech Republic