Subject: [TLS] Length of a variable-length vector: zero-length case

From: =JeffH <[email-masked]>
Date: Fri, 22 Jan 2016 07:50:02 -0800

wrt https://tools.ietf.org/html/draft-ietf-tls-tls13-11#section-4.3

if we have..

   opaque foo<0..2^16-1>;

..with a floor length of zero, thus with an instantiation of foo of zero 
length, we actually will have in terms of encoded bytes on the wire (in hex)..

   00 00

..where this is the 2-byte length field, with length value zero, and a
zero-length (ie, absent, empty) vector content, correct ?

thanks,

=JeffH

---

From: Eric Rescorla <[email-masked]>
Date: Fri, 22 Jan 2016 08:50:53 -0800

> zero-length (ie, absent, empty) vector content, correct ?

Yes.

-Ekr

thanks,
>
> =JeffH
>
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls
>