Subject: [TLS] NewSessionTicketFormat - for PSK

From: "Jim Schaad" <[email-masked]>
Date: Mon, 25 Apr 2016 11:07:12 -0700

I was looking at how TLS 1.3 was going to fit into an upgrade from the
existing 1.2 version that is used for RADIUS and having vague memories of
what was going on during the F2F meeting and I ended up with the following
question.

We are planning to indicate in the NewSessionTicket items such as if early
data is going to be allowed.  Do we need to make some statements someplace
about if early data is going to be accepted for a pure PSK (or PSK-ECDH)
configuration either as an marker that it needs to be configured into the
client or as a indication sent back from the server to the client that it
will or will not accept early data when connecting?   Does this apply to
some of the other fields that were being discussed as being encoded into the
ticket as well?

Jim

---

From: Eric Rescorla <[email-masked]>
Date: Mon, 25 Apr 2016 11:09:51 -0700

On Mon, Apr 25, 2016 at 11:07 AM, Jim Schaad <[email-masked]> wrote:

> will or will not accept early data when connecting?

There is no way to do do early data with PSK-ECDH because the data is
encrypted under the PSK only.

-Ekr

 Does this apply to
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls
>

---

From: "Jim Schaad" <[email-masked]>
Date: Mon, 25 Apr 2016 12:13:11 -0700

From: TLS [mailto:[email-masked]] On Behalf Of Eric Rescorla
Sent: Monday, April 25, 2016 11:10 AM
To: Jim Schaad <[email-masked]>
Cc: [email-masked]
Subject: Re: [TLS] NewSessionTicketFormat - for PSK

On Mon, Apr 25, 2016 at 11:07 AM, Jim Schaad <[email-masked] <mailto:[email-masked]> > wrote:

-Ekr

What about the case of just pure PSK?  

I also assume that there is nothing to stop from getting a ticket if I connect using PSK to begin with.

Jim

 Does this apply to

Jim

_______________________________________________
TLS mailing list
[email-masked] <mailto:[email-masked]> 
https://www.ietf.org/mailman/listinfo/tls

---

From: Eric Rescorla <[email-masked]>
Date: Mon, 25 Apr 2016 13:06:54 -0700

On Mon, Apr 25, 2016 at 12:13 PM, Jim Schaad <[email-masked]> wrote:

>
>
>
>
> *From:* TLS [mailto:[email-masked]] *On Behalf Of *Eric Rescorla
> *Sent:* Monday, April 25, 2016 11:10 AM
> *To:* Jim Schaad <[email-masked]>
> *Cc:* [email-masked]
> *Subject:* Re: [TLS] NewSessionTicketFormat - for PSK
>
>
>
>
>
>
>

Yes... Maybe I'm missing your point

-Ekr