Subject: [TLS] Adoption of TLS-LTS

From: Peter Gutmann <[email-masked]>
Date: Mon, 6 Jun 2016 13:05:49 +0000

TLS-LTS, https://tools.ietf.org/html/draft-gutmann-tls-lts-03, has more or
less stabilised, incorporating all the feedback I've had for it (there's only
one open question still remaining), so I'd like to request that it now be
adopted as a WG item.

I'd also like to request an early/temporary assignment for an extension ID, to
provide something a bit more usable than the much-overloaded 0x42 that's
currently being used.

Peter.

---

From: Russ Housley <[email-masked]>
Date: Wed, 8 Jun 2016 14:18:14 -0400

Peter:

I skimmed this draft.  It is not just a profile of TLS 1.2.  It makes TLS 1.2 protocol changes.

I do not think the TLS WG should take on any document that makes changes to the TLS 1.2 protocol.

Russ

---

From: Peter Gutmann <[email-masked]>
Date: Wed, 8 Jun 2016 19:29:07 +0000

>I do not think the TLS WG should take on any document that makes changes to

So how is that different from any number of other TLS standards-track RFCs,
say, RFC 7627 (one of the ones referenced in the draft), which was adopted as
a WG document and standards-track RFC?  The tiny changes in this draft (adding
one field to the ServerDHParams, using the full MAC for finished, and hashing
the full hello instead of just one field in it) are pretty trivial in
comparison to the aforementioned RFC 7627, or any number of other ones.

Peter.

---

From: Yoav Nir <[email-masked]>
Date: Wed, 8 Jun 2016 22:47:50 +0300

> On 8 Jun 2016, at 10:29 PM, Peter Gutmann <[email-masked]> wrote:
> 

Mostly timing. The TLS working group is now working on TLS 1.3, so 1.2 should be considered stable by now. 

We’re not actively developing older versions.

Yoav

---

From: Peter Gutmann <[email-masked]>
Date: Wed, 8 Jun 2016 19:57:12 +0000

>be considered stable by now.

As the draft says, this is intended for long-term support (on the order of a
decade or more) of existing implementations, not an entirely new, unproven
protocol.

Didn't we already have this debate a few months ago?

Peter.

---

From: Yoav Nir <[email-masked]>
Date: Wed, 8 Jun 2016 23:07:40 +0300

> On 8 Jun 2016, at 10:57 PM, Peter Gutmann <[email-masked]> wrote:
> 

Sure. But then it was your individual draft, so you got to call how the debate turned out. Now you’re seeking WG adoption.

Yoav

---

From: Hubert Kario <[email-masked]>
Date: Thu, 09 Jun 2016 11:55:39 +0200

On Wednesday 08 June 2016 19:29:07 Peter Gutmann wrote:
> So how is that different from any number of other TLS standards-track
> RFCs, say, RFC 7627 (one of the ones referenced in the draft), which
> was adopted as a WG document and standards-track RFC?  The tiny
> changes in this draft (adding one field to the ServerDHParams, using
> the full MAC for finished, and hashing the full hello instead of just
> one field in it) are pretty trivial in comparison to the
> aforementioned RFC 7627, or any number of other ones.

<bikeshed>
to be pedantic, the RFC describes itself "a profile" while in reality it 
modifies the protocol in a way that will make it incompatible with 
"vanilla" TLS 1.2 implementations

(yes, I know it's negotiated using extension so it doesn't make it 
actually incompatible, just noting that the behavior with and without 
extension is significantly changed - it's not a strict subset of 
TLSv1.2)
</bikeshed>
-- 
Regards,
Hubert Kario
Senior Quality Engineer, QE BaseOS Security team
Web: www.cz.redhat.com
Red Hat Czech s.r.o., Purkyňova 99/71, 612 45, Brno, Czech Republic

---

From: Peter Gutmann <[email-masked]>
Date: Mon, 13 Jun 2016 19:51:42 +0000

Hubert Kario <[email-masked]> writes:

>modifies the protocol in a way that will make it incompatible with "vanilla"
>TLS 1.2 implementations

>modifies the protocol in a way that will make it incompatible with "vanilla"
>TLS 1.2 implementations

Oh, right.  Well that's easily fixed, I used "profile" because I couldn't
think of a better term, the best I could come up with is "plan", but it's not
really a plan either.  If people think "plan" is better than "profile", and it
deals with Russ' objection, I'll change it to that.  Alternatively, if you can
think of a better term than "plan", let me know (or forever hold your peace
:-).

Peter.

---

From: Hubert Kario <[email-masked]>
Date: Tue, 14 Jun 2016 12:23:05 +0200

On Monday 13 June 2016 19:51:42 Peter Gutmann wrote:
> >to be pedantic, the RFC describes itself "a profile" while in reality
> >it modifies the protocol in a way that will make it incompatible
> >with "vanilla" TLS 1.2 implementations
> >
> 
> Oh, right.  Well that's easily fixed, I used "profile" because I
> couldn't think of a better term, the best I could come up with is
> "plan", but it's not really a plan either.  If people think "plan" is
> better than "profile", and it deals with Russ' objection, I'll change
> it to that.  Alternatively, if you can think of a better term than
> "plan", let me know (or forever hold your peace
> :-).

"TLS refitting for Long Term Support"

"Adaptation of TLS for Long Term Support"

"LTS revision of TLS"

"LTS addendum to TLS 1.2" (amendment?)

If "revision" does not overload the word too much in this context, it's 
the one I would vote for.
-- 
Regards,
Hubert Kario
Senior Quality Engineer, QE BaseOS Security team
Web: www.cz.redhat.com
Red Hat Czech s.r.o., Purkyňova 99/71, 612 45, Brno, Czech Republic

---

From: Geoffrey Keating <[email-masked]>
Date: 14 Jun 2016 11:37:01 -0700

Peter Gutmann <[email-masked]> writes:

> "plan", but it's not really a plan either.  If people think "plan"
> is better than "profile", and it deals with Russ' objection, I'll
> change it to that.  Alternatively, if you can think of a better term
> than "plan", let me know (or forever hold your peace :-).

I think an appropriate title might be

 The Transport Layer Security (TLS) Protocol
 Version 1.2.1 Update

because that's what this is, isn't it?  It's a new version of the
protocol with minor but significant changes.

---

From: Peter Gutmann <[email-masked]>
Date: Thu, 16 Jun 2016 06:13:31 +0000

Hubert Kario <[email-masked]> writes:
>> "plan", let me know (or forever hold your peace :-).
>

So after some discussion with some of the people who'll be using this, we came
up with:

  TLS 1.2 Update for Long-term Support

among other suggestions, but that seemed to be the best one.  Other options
were things like "modernisation" or "improvement" (and one of them suggested
"adaptation" as well), but I think "update" says it best.  "Revision" is more
or less the same as "Update", so I guess either would fit, but I'm leaning
more towards "Update".

If no-one has any other suggestions I'll post an updated draft, I'm just
waiting for permission to include the details of the interop test server that
people can run their clients against.

Peter.

---

From: Aaron Zauner <[email-masked]>
Date: Sun, 19 Jun 2016 18:51:03 +0800

Hi,

> On 06 Jun 2016, at 21:05, Peter Gutmann <[email-masked]> wrote:
> 

Although I appreciate the effort, I have to agree with previous comments: we're working on TLS 1.3 -- I do not support the adoption of this draft.

Aaron