Subject: [TLS] DTLS: Multiple application records in a datagram

From: "Grehl Felix (ETAS-PSC/ECE1)" <[email-masked]>
Date: Mon, 12 Dec 2016 08:53:34 +0000

Hi,

I have a question regarding records in DTLS 1.2. RFC6347 says: "Multiple DTLS records may be placed in a single datagram. They are simply encoded consecutively".

However, what happens if one UDP datagram contains multiple records of type application? Which way should an implementation handle this case?

1)     Both records are merged such that the application layer gets them as a single message (message = UDP datagram), or

2)     Each record is passed as a separate message to the application layer (message = DTLS record)

Best regards,
Felix

---

From: Eric Rescorla <[email-masked]>
Date: Mon, 12 Dec 2016 03:12:41 -1000

Generally, the spec doesn't prescribe API behavior, but #2 seems like the
right one because otherwise an attacker could coalesce/split such records.

-Ekr

On Sun, Dec 11, 2016 at 10:53 PM, Grehl Felix (ETAS-PSC/ECE1) <
[email-masked]> wrote:

> Hi,
>
>
>
> I have a question regarding records in DTLS 1.2. RFC6347 says: “Multiple
> DTLS records may be placed in a single datagram. They are simply encoded
> consecutively”.
>
> However, what happens if one UDP datagram contains multiple records of
> type application? Which way should an implementation handle this case?
>
>
>
> 1)     Both records are merged such that the application layer gets them
> as a single message (message = UDP datagram), or
>
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls
>
>