Subject: Re: [TLS] [DTLS1.3]ACK message sent in -37

From: Eric Rescorla <[email-masked]>
Date: Tue, 10 Mar 2020 06:51:41 -0700

On Tue, Mar 10, 2020 at 6:48 AM Zhai Zhaoxuan <[email-masked]> wrote:

> Hi Eric,
>
>
> The new version(-37) says:
>
> After the handshake, ACKs SHOULD be sent once for each received
> and processed record (potentially subject to some delay) and MAY
> cover more than one flight.
>
>
> Does "received and processed record" including Application Data record?
>
> Since we don't provide reliability to applications, ACK does not seems
> necessary.
>

No, this is just bad writing. I meant handshake. Thanks for catching this.
I'll fix in the repo.

-Ekr

> Thanks,
>
> Zhai Zhaoxuan
>
>
> ------------------------------
> *OPPO*
>
> 本电子邮件及其附件含有OPPO
> 公司的保密信息，仅限于邮件指明的收件人使用（包含个人及群组）。禁止任何人在未经授权的情况下以任何形式使用。如果您错收了本邮件，
> 请立即以电子邮件通知发件人并删除本邮件及其附件。
>
> This e-mail and its attachments contain confidential information from OPPO
> , which is intended only for the person or entity whose address is listed
> above. Any use of the information contained herein in any way (including, but
> not limited to, total or partial disclosure, reproduction, or
> dissemination) by persons other than the intended recipient(s) is
> prohibited. If you receive this e-mail in error, please notify the sender
> by phone or email immediately and delete it!
>

---

From: Zhai Zhaoxuan <[email-masked]>
Date: Tue, 10 Mar 2020 21:48:24 +0800

Hi Eric,

Since we don't provide reliability to applications, ACK does not seems necessary.

Thanks,

Zhai Zhaoxuan

________________________________
OPPO

本电子邮件及其附件含有OPPO公司的保密信息，仅限于邮件指明的收件人使用（包含个人及群组）。禁止任何人在未经授权的情况下以任何形式使用。如果您错收了本邮件，请立即以电子邮件通知发件人并删除本邮件及其附件。

This e-mail and its attachments contain confidential information from OPPO, which is intended only for the person or entity whose address is listed above. Any use of the information contained herein in any way (including, but not limited to, total or partial disclosure, reproduction, or dissemination) by persons other than the intended recipient(s) is prohibited. If you receive this e-mail in error, please notify the sender by phone or email immediately and delete it!