Subject: [TLS] TLS WG GitHub interaction

From: "Christopher Wood" <[email-masked]>
Date: Wed, 21 Oct 2020 15:51:02 -0700

RFC 8874 describes several different methods for using GitHub, ranging from the lightweight "document management mode" [1] to more heavyweight "issue discussion mode" [2]. Most TLS documents are hosted and worked on in GitHub, though with varying levels of interaction. For example, some interact with GitHub in "issue tracking mode," wherein editors primarily use GitHub for tracking open issues. Others interact with GitHub in a way that resembles "issue discussion mode," wherein substantive issue discussion takes place on GitHub issues and consensus calls occur on the list.

This discrepancy has caused confusion in the past, especially with respect to how best to stay engaged in the continued development of WG documents. Moreover, with the rising rate at which other WGs and IETF participants adopt GitHub for document development, especially those formed in recent years, we have not made expectations for use of GitHub clear.

To that end, after observing what's been maximally productive for document development in TLS and related WGs, taking into account community engagement, document review support, and editor tools, we propose the following: the TLS WG interact with WG documents in "issue discussion mode," following the approach outlined in [3].

We'd like to hear whether folks are support or oppose this proposal. Please chime in (on the list!) and share your thoughts before November 4. We'll determine whether there is consensus to adopt this new approach moving forward at that time.

Thanks,
Chris, on behalf of the chairs

[1] https://www.ietf.org/rfc/rfc8874.html#name-document-management-mode
[2] https://www.ietf.org/rfc/rfc8874.html#name-issue-labeling-schemes
[3] https://www.ietf.org/rfc/rfc8874.html#name-issue-discussion-mode

---

From: Rob Sayre <[email-masked]>
Date: Wed, 21 Oct 2020 16:04:27 -0700

On Wed, Oct 21, 2020 at 3:51 PM Christopher Wood <[email-masked]>
wrote:

>
> We'd like to hear whether folks are support or oppose this proposal.
> Please chime in (on the list!) and share your thoughts before November 4.
> We'll determine whether there is consensus to adopt this new approach
> moving forward at that time.
>

I support this "issue discussion mode" as long as summaries are sent to the
list (as they are now). My github account is too noisy to be useful.

thanks,
Rob

---

From: Eric Rescorla <[email-masked]>
Date: Wed, 21 Oct 2020 16:07:07 -0700

On Wed, Oct 21, 2020 at 3:51 PM Christopher Wood <[email-masked]>
wrote:

> RFC 8874 describes several different methods for using GitHub, ranging
> from the lightweight "document management mode" [1] to more heavyweight
> "issue discussion mode" [2]. Most TLS documents are hosted and worked on in
> GitHub, though with varying levels of interaction. For example, some
> interact with GitHub in "issue tracking mode," wherein editors primarily
> use GitHub for tracking open issues. Others interact with GitHub in a way
> that resembles "issue discussion mode," wherein substantive issue
> discussion takes place on GitHub issues and consensus calls occur on the
> list.
>
> This discrepancy has caused confusion in the past, especially with respect
> to how best to stay engaged in the continued development of WG documents.
> Moreover, with the rising rate at which other WGs and IETF participants
> adopt GitHub for document development, especially those formed in recent
> years, we have not made expectations for use of GitHub clear.
>
> To that end, after observing what's been maximally productive for document
> development in TLS and related WGs, taking into account community
> engagement, document review support, and editor tools, we propose the
> following: the TLS WG interact with WG documents in "issue discussion
> mode," following the approach outlined in [3].
>

I am in favor of using "issue discussion mode". When we developed our
current structure, we had less experience with Github and it was reasonable
to be cautious, but I believe that now we have enough experience to support
the use of "issue discussion mode".

-Ekr

> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls
>

---

From: Carrick Bartle <[email-masked]>
Date: Wed, 21 Oct 2020 16:08:56 -0700

I support this proposal. GitHub offers a lot more tools for organization than emails do, which makes reviewing issues considerably easier.

> On Oct 21, 2020, at 3:51 PM, Christopher Wood <[email-masked]> wrote:
>

---

From: David Schinazi <[email-masked]>
Date: Wed, 21 Oct 2020 16:09:15 -0700

+1, issue discussion mode with email summaries sounds like the best option

On Wed, Oct 21, 2020 at 4:08 PM Eric Rescorla <[email-masked]> wrote:

>> This discrepancy has caused confusion in the past, especially with
>> respect to how best to stay engaged in the continued development of WG
>> documents. Moreover, with the rising rate at which other WGs and IETF
>> participants adopt GitHub for document development, especially those formed
>> in recent years, we have not made expectations for use of GitHub clear.
>>
>> To that end, after observing what's been maximally productive for
>> document development in TLS and related WGs, taking into account community

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 21 Oct 2020 23:15:21 +0000

I  can live with it :)

---

From: "Martin Thomson" <[email-masked]>
Date: Thu, 22 Oct 2020 14:31:38 +1100

On Thu, Oct 22, 2020, at 10:04, Rob Sayre wrote:
> On Wed, Oct 21, 2020 at 3:51 PM Christopher Wood <[email-masked]> wrote:
> > 

This is a fine plan.

> I support this "issue discussion mode" as long as summaries are sent to 
> the list (as they are now). My github account is too noisy to be 
> useful. 

I think that Rob's request is reasonable.  And I hope that this isn't just the digests, which I find useless.  Either way, even when discussing issues, it's often good to open a thread on the list for important topics.

On this point, I regard the ECH work as being effectively a self-selected design team.  I have been unable to keep tracking the work and lack the context to engage on the topics that do come back to the list for discussion.  Missing 3am meetings can't have helped, but it's mostly about the volume of traffic.

---

From: "Michael D'Errico" <[email-masked]>
Date: Thu, 22 Oct 2020 01:10:19 -0400

Hi,

I used to be very active in the development of TLS
specifications (version 1.2) and some of the extensions.  
At the time, all discussion was done on the mailing list.  
I don't know if I'll be active going forward, but the
trend to move everything to GitHub is a mistake, in my 
opinion.

First of all, GitHub is owned by Microsoft, a private 
for-profit company.  I don't think I need to point out 
past actions by the company which were not in the best 
interest of anybody other than their own shareholders 
(and then not even them in actuality).  GitHub is just a 
property to them, and who knows when they'll tire of it 
and shut it down or sell it off.  Bad idea to rely on it.

As an implementer of TLS, it was important to follow all 
of the discussions as they were happening, to understand 
the trade-offs being made, to check whether the result 
was even something you could implement!  (I'll point to 
the stateless HelloRetryRequest debacle which you can not 
implement correctly as an example.  I still owe Ilari a
response, if I go back to reading the spec for 1.3.)

I don't want to have to "Go To GitHub" to work on TLS.  I 
would want all of the messages to arrive in my email, as 
they used to.  The messages all go into a separate folder 
so I can ignore them if I want.  My inbox is not 
cluttered by them.  This is a fine system.

GitHub's issue tracking system is actually pretty nice.  
I took a look.  I'd guess that there's some free software
("free" as in "freedom") which could be run on the IETF
website which would provide the equivalent functionality.
Though I'd prefer to go back to the way it used to be.

Mike

On Wed, Oct 21, 2020, at 18:51, Christopher Wood wrote:
> "issue discussion mode" [2]. Most TLS documents are hosted and worked 
> on in GitHub, though with varying levels of interaction. For example, 
> some interact with GitHub in "issue tracking mode," wherein editors 
> primarily use GitHub for tracking open issues. Others interact with 
> GitHub in a way that resembles "issue discussion mode," wherein 
> substantive issue discussion takes place on GitHub issues and consensus 
> calls occur on the list.
> 
> participants adopt GitHub for document development, especially those 
> formed in recent years, we have not made expectations for use of GitHub 
> clear.
> 
> document development in TLS and related WGs, taking into account 
> community engagement, document review support, and editor tools, we 
> propose the following: the TLS WG interact with WG documents in "issue 
> discussion mode," following the approach outlined in [3].
> 
> Please chime in (on the list!) and share your thoughts before November 
> 4. We'll determine whether there is consensus to adopt this new 
> approach moving forward at that time.
> 
> Thanks,

---

From: <[email-masked]>
Date: Thu, 22 Oct 2020 07:50:47 +0200

> We'd like to hear whether folks are support or oppose this proposal.

Opposed.
I want to use my tools to follow a discussion,
not something someone else controls/"designs".

-- 
Address is valid for this mailing list only, please do not reply
to it direcly, but to the list.

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 22 Oct 2020 11:46:15 +0100

On 22/10/2020 04:31, Martin Thomson wrote:
> On this point, I regard the ECH work as being effectively a
> self-selected design team.  I have been unable to keep tracking the
> work and lack the context to engage on the topics that do come back
> to the list for discussion.
+many - I don't know if the proposed mode will be any
better than the status quo - with that volume, I don't
see how anyone could send a useful summary to the list

Maybe it'd be useful if the chairs or someone could
summarise the last N weeks of githubbery for ECH and
we can see if it has a chance of working?

S

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 22 Oct 2020 13:02:23 +0000

I don't find the weekly digests useful either.

In order to really participate I find that I have to "watch" all the repositories at one/document (which is the right way to do it), it's a lot of clicking around.  I wish GitHub had a way to watch an organization.