Subject: [TLS] ECH test server

From: "Chris Box (BT)" <[email-masked]>
Date: Tue, 27 Oct 2020 18:37:43 +0000

Hi,

I would like to test an ECH-enabled client, but am struggling to find a
public test server with a published ECHconfig in its HTTPS record.

Do any yet exist?

I've looked in all these places, but none are mentioned:
https://github.com/tlswg/draft-ietf-tls-esni/wiki/Implementation-Status
https://github.com/tlswg/tlswg-wiki/blob/master/IMPLEMENTATIONS.md
https://github.com/tlswg/tlswg-wiki/blob/master/TESTING.md

Or is everyone just spinning up private servers for now?

Thanks,
Chris

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 27 Oct 2020 20:33:22 +0000

> Or is everyone just spinning up private servers for now?

I got as far as draft-05 before falling behind sorry.
Will post when/if I get current.

See my other mail for the related whine:-)

Cheers,
S.

> 
> Thanks,
> Chris
> 
> 
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls
>

---

From: "Chris Box (BT)" <[email-masked]>
Date: Wed, 28 Oct 2020 10:39:12 +0000

Ok, so in summary (based on the other thread), I think there is no public
test server yet. And there won't be until the recent rate of change is seen
to slow and implementations have had a chance to catch up.

ECH is a useful privacy enhancement but I'm particularly interested in the
way HTTPS RRs are managed, and consumed by clients.

Chris