Subject: Re: [TLS] Moving the ECH interop target

From: "Martin Thomson" <[email-masked]>
Date: Wed, 03 Mar 2021 08:35:15 +1100

This should be fine.  Moving to HPKE-v1 will remove an awkward dependency problem now that we're starting to use HPKE for other things.

On Thu, Feb 25, 2021, at 05:07, Christopher Wood wrote:
> The WG previously decided to make draft-ietf-tls-esni-09 the official 
> target for interop. The diff between this version and the current 
> editor's copy of the draft is below:
> 
>    
> https://tools.ietf.org/rfcdiff?url1=https://tools.ietf.org/id/draft-ietf-tls-esni.txt&url2=https://tlswg.github.io/draft-ietf-tls-esni/draft-ietf-tls-esni.txt
> 
> Given the size of the diff, and the recent update to HPKE to prepare it 
> for IRSG review, I'd like to propose that we cut -10 (when the 
> datatracker opens) and use that as the new interop target. This will 
> resolve the moving HPKE target going forward and let that part of the 
> protocol stabilize.
> 
> What do other implementers think?
> 
> Thanks,
> Chris (no hat)
> 
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls
>

---

From: Carrick Bartle <[email-masked]>
Date: Tue, 2 Mar 2021 14:04:54 -0800

Fine by me.

> On Feb 24, 2021, at 10:07 AM, Christopher Wood <[email-masked]> wrote:
> 
> The WG previously decided to make draft-ietf-tls-esni-09 the official target for interop. The diff between this version and the current editor's copy of the draft is below:
> 
> Given the size of the diff, and the recent update to HPKE to prepare it for IRSG review, I'd like to propose that we cut -10 (when the datatracker opens) and use that as the new interop target. This will resolve the moving HPKE target going forward and let that part of the protocol stabilize.
>

---

From: "Christopher Wood" <[email-masked]>
Date: Mon, 08 Mar 2021 11:11:02 -0800

As discussed during today's call, -10 is now out. I'll update pointers in the interop matrix and related pages.

Stay tuned for a doodle to schedule the interim meetings!

Best,
Chris (no hat)