Subject: [TLS] Implementations of draft-ietf-tls-flags and draft-ietf-tls-cross-sni-resumption

From: Christopher Wood <[email-masked]>
Date: Thu, 27 Jan 2022 08:35:04 -0800

Hi folks,

In preparing to move draft-ietf-tls-flags and draft-ietf-tls-cross-sni-resumption forward in the process, I’m curious if anyone is aware of implementations of either specification. If you know of an implementation, can you please share it here?

Thanks,
Chris, for the chairs

---

From: Jens Guballa <[email-masked]>
Date: Fri, 28 Jan 2022 18:14:37 +0100

> In preparing to move draft-ietf-tls-flags and draft-ietf-tls-cross-sni-resumption forward in the process, I’m curious if anyone is aware of implementations of either specification. If you know of a…
I am not sure what your intention is. In case you are looking for a 
counterpart to test a server implementation, you can have a look at 
https://gitlab.com/guballa/tlsmate. With that tool you can create and 
execute arbitrary TLS handshake scenarios against TLS servers. The 
TLS-flags extension is not supported (yet), but setting up (or checking) 
any extension as a bytestring is possible. Basic python knowledge is 
required, though.

Thanks,
Jens