Subject: RE: Draft new TRADE WG Charter, two week comment period

From: "Lewis, Tony" <[email-masked]>
Date: Wed, 23 Aug 2000 17:29:11 -0700

Visa would like to see the inclusion of the following additional items in
version 2 requirements:
- Customer Payment Handler
- on-going payments
- the ability to add both fields and attributes to trading blocks

An example of the use of a "Customer Payment Handler" is subtracting value
from a purse on a chip card (stored value card).

An example of on-going payments is the playing of a game where there is a
charge for each five minutes of game time.

Please let me know if you need additional information.

Tony Lewis

-----Original Message-----
From: Eastlake Donald-LDE008 [mailto:[email-masked]]
Sent: Thursday, August 10, 2000 6:51 PM
To: [email-masked]'
Cc: Eastlake Donald-LDE008
Subject: Draft new TRADE WG Charter, two week comment period

Hi,

Here is the draft charter that was presented in Pittsburgh with some minor
edits.  I would like to send this in to our Area Director soon.  Please try
to get any comments or suggestions to me or posted to the list within two
weeks.

Thanks,
Donald

Chair: Donald Eastlake 3rd <[email-masked]>
Applications Area Advisor: Patrik Faltstrom

Mailing Lists:
	General Discussion:[email-masked] 
	To Subscribe: [email-masked]
	In Body: (un)subscribe
	Archive: http://www.eListX.com/archives/ietf-trade 

The Internet Open Trading Protocol is an interoperable framework
for Internet commerce. It is optimized for the case where the
buyer and the merchant do not have a prior acquaintance and is
payment system independent. It can encapsulate and support payment
systems such as SET, Mondex, secure channel card payment,
GeldKarte, etc. IOTP is able to handle cases where such merchant
roles as the shopping site, the payment handler, the deliverer of
goods or services, and the provider of customer support are
performed by different Internet sites.

The working group will document interoperability experience with
IOTP version 1 (which has been published as an Informational RFC)
and develop the requirements for IOTP version 2. Selection of
items for inclusion in version requirements 2 is to be from the
following: 
 - Separation of a content independent Messaging Layer 
 - Dynamic Definition of Trading Sequences 
 - Offer Request Block 
 - Improved Problem Resolution (extend to cover presentation of
 	signed receipt to customer support party, etc.)
 - Server to Server messages
 - Standardized XML Digital Signatures based on output from
 	the XMLDSIG working group
 
The following is out of scope for IOTP version 2:
 - legal or regulatory issues surrounding the implementation of
 	the protocol or information systems using it.
 - specification of an XML Messaging Layer

The working group will specify requirements for Digital-Rights
Trading.

The working group will specify requirements for and then a syntax
and processing model of ECML (Electronic Commerce Modeling
Language) V2.

Milestones

00 Sep  Internet Draft publication
	Secure Channel Credit/Debit

00 Sep  Working Group Last Call
	SET Supplement
	Architecture and Payment API
	
00 Oct  Submit to IESG
	SET Supplement (Informational)
	Architecture and Payment API (Informational)

00 Nov  Internet Draft publication
	IOTP V2.0 Requirements
	ECML V2.0 Requirements

00 Nov  Submit to IESG
	Secure Channel Credit/Debit (Proposed Standard?)
	"Digital Rights" Trading Requirements (Informational)

00 Dec  Internet Draft publication
	IOTP V2.0 Specification
	ECML V2.0 Specification

00 Dec  Submit to IESG
	ECML V2.0 Requirements (Informational)

01 Jan  Submit to IESG
	IOTP V2.0 Requirements (Informational)

01 Feb  Submit to IESG
	ECML V2.0 Specification (Proposed Standard)

01 Mar  Submit to IESG
	IOTP V2.0 Specification  (Proposed Standard)

---

From: David Burdett <[email-masked]>
Date: Thu, 24 Aug 2000 12:03:22 -0700

Donald

I agree that IOTP should not include a messaging layer as was planned some
time ago. However, to achieve interoperability, IOTP will need to specify
what (which?) messaging layer to use and how to use it.

Regards

David

-----Original Message-----
From: Donald E. Eastlake 3rd [mailto:[email-masked]]
Sent: Tuesday, August 22, 2000 5:40 AM
To: David Burdett
Cc: [email-masked]'
Subject: Re: Draft new TRADE WG Charter, two week comment period

Hi David,

The working group has decided not to do an XML messaging layer itself.

Among the deliverables in the proposed new charter, the one most likely
to refer to this would be the IOTP v2 requirements which should say
something about requirements for the Messaging Layer.

Thanks,
Donald

From:  David Burdett <[email-masked]>
Content-return:  allowed
Date:  Thu, 17 Aug 2000 10:20:44 -0700
To:  Eastlake Donald-LDE008 <[email-masked]>,
            "[email-masked]'" <[email-masked]>
Message-id:
<[email-masked]>

>Donald
>
>Apologies for not being able to make the last IETF meeting. However, I
think
>that work on version 2.0 of IOTP should consider use of ebXML Transport
>Routing and Packaging as meeting your first requirement for "Separation of
a
>content independent Messaging Layer".
>
>ebXML stands for electronic business XML and is a joint effort between
>UN/CEFACT who are owners of the EDIFACT standard and OASIS which is a
>non-profit organization with significant SGML & XML expertise. It includes
>the development of a content independent messaging layer.
>
>David
>