Subject: Working Group Last Call and naming for draft-ietf-trade-drt-requirements-01.txt

From: "Donald E. Eastlake 3rd" <[email-masked]>
Date: Wed, 03 Jan 2001 16:24:52 -0500

This is a working group last call announcement for the document
currently titled "Requirements for Generic Rights Trading".  The Last
Call is to run through January 22th.  As far as I know, the only point
in controversy is the name of the things for which trading
requirements are given.  Suggestions have included digital rights,
electronic rights, trading right, entitlement, coupon, and certificate
as well as generic rights.  But most suggestions have some particular
problem as well.  Unless there is a consensus to change, as show by
discussion on this mailing list, we will stick with the current
terminology.

Thanks,
Donald
=====================================================================
 Donald E. Eastlake 3rd                      [email-masked]
 155 Beaver Street                                +1 508-634-2066(h)
 Milford, MA 01757 USA                            +1 508-261-5434(w)

---

From: Renato Iannella <[email-masked]>
Date: Thu, 11 Jan 2001 16:19:07 +1000

--On 3/1/01 4:24 PM -0500 Donald E. Eastlake 3rd wrote:

> As far as I know, the only point

I still believe that using "rights" is misleading for this document.
A more appropriate term would be "voucher". (In fact, you should be
able to do a string find/replace through-out the whole document.)

All the examples in the document are focussed on the value of
an "exchange ticket" for an *arbitrary* good or service.

Use of "rights" implies intellectual/legal/social behaviours, such
as copyright, moral rights etc. The modelling, requirements, languages
for this type of right is significant (see [1] to [11]).

This leads me to the point in "Section 7. Q & A"

----
  - Is it possible to ensure digital "property" rights?

  Yes, since digital property rights can be considered as a kind of
  electronic-right. RTS, however, would need to be extended by adding
  some protected rendering system that would regenerate the original
  digital contents securely.
-----

I would say they answer is "No". You cannot _ensure_ this.
(see the references below)

Cheers...Renato                       <http://purl.net/net/renato>
Chief Scientist, IPR Systems Pty Ltd       <http://iprsystems.com>
W3C Workshop on Digital Rights <http://w3.org/2000/11/w3c-drm-cfp>

DRM Modelling
[1] http://www.indecs.org/
[2] http://www.propagate.net/
[3] http://www.openebook.org/framework/

DRM Background Papers
[4] http://www.oasis-open.org/cover/ericksonRT19990624.pdf
[5] http://www.iprsystems.com/whitepapers/Papers/Rights_Management.pdf
[6] http://www.cisp.org/imp/february_2000/02_00gladney.htm
[7] http://mjosa.stanford.edu/~roscheis/IMA/index.html

DRM Requirements
[8] http://www.publishers.org/home/drm.pdf
[9] http://www.cselt.it/leonardo/mpeg/public/mpeg-4_ipmp.zip

DRM Languages
[10] http:://odrl.net
[11] http://www.xrml.org

---

From: Ko Fujimura <[email-masked]>
Date: Wed, 24 Jan 2001 16:10:26 +0900

Thank you for your suggestions and links to the DRM resources.

> for this type of right is significant (see [1] to [11]).

I think that "rights" are often used for "access rights" as well as "IP rights". 
Example of such usage are found in RFC2086, 2820, and draft-ietf-ldapext-acl-model-06.txt

I also think that most of "tickets" are a kind of "access rights" for a physical
resources, and those concept are similar. I, therefore, think that the usage of 
"rights" in the draft is common, too.
I believes that what this draft describes is nothing more than "trading aspect of rights".

> (see the references below)

Right. I would like to change it to:

  - Is it possible to support "digital property right?"

  Digital property right can be considered as a kind of electronic-right and
  it can be traded using RTS.  However, some protected rendering system would 
  be required to regenerate the digital contents securely in order to support 
  digital property rights. These requirements are out of scope of RTS.

Regards,

Ko