Subject: IOTP Implementation

From: "Silke Holtmanns (EED)" <[email-masked]>
Date: Tue, 09 Jan 2001 12:47:25 +0100

Hello,

the Ecomeg group (Electronic expert group) in the 
WAP forum is in the moment developing a EFI Payment Class. 
This payment class shall take care of  the payment process as a whole.
It shall support a wide range of payment protocols.

This payment class has some strong similarities to IOTP.
It is structured differently, but on the other hand contains 
similar information (brand, payment protocol,..). I believe it
makes sense to make the EFI payment class very similar
to IOTP (or at least parts of it) to support the convergence between the 
"wireless wap world" and the internet.

Since I read the news about the implementation a few questions
turned up:
What has Hitachi implemented? (only some components or some block)
(If you can say)
It would be good for the "wireless people" to know the problems that occur, maybe we
can then avoid some of them ..... 

Greetings Silke 

Silke Holtmanns
Ericsson Eurolab Deutschland GmbH
Ericsson Allee 1
52134 Aachen
Tel. ++49 2407 575 7751
Fax ++49 2407 575 400
[email-masked]

---

From: TERAMURA Takeshi <[email-masked]>
Date: Fri, 12 Jan 2001 22:50:54 +0900

Hello,

> What has Hitachi implemented? (only some components or some block)

Hitachi implemented the following modules:
- IOTP application core:
  - Consumer Client
  - Merchant Server
  - Payment Handler Server
  - Delivery Handler Server
- IOTP payment bridge:
  - SET bridge( for client / server )
  - SECE bridge( for client / server )
    * SECE(Secure Electronic Commerce Environment) is the specification
      including debit protocol.
  - Mondex bridge( for client / server )

> can then avoid some of them ..... 

I think client size and performance will be issues when mobile phone 
is used as platform. Because the computer resources(CPU, memory) of 
the mobile phone may be less powerful than PC. 

Regards

---
Takeshi Teramura
5th department
Systems development laboratory
Hitachi, Ltd.