Subject: Comments on

From: Walt Houser <[email-masked]>
Date: Wed, 21 Mar 2001 11:05:58 -0800 (PST)

Why use attributes 

     <Provider Name="Voucher Wallet 2001">
       <vts:KeyInfo>...</vts:KeyInfo>
     </Provider>
     <Issuer Name="Alice Book Center, Ltd.">
       <vts:KeyInfo>...</vts:KeyInfo>
     </Issuer>

instead of elements?

     <Provider>
     <Name>Voucher Wallet 2001</Name>
       <vts:KeyInfo>...</vts:KeyInfo>
     </Provider>
     <Issuer>
     <Name>Alice Book Center, Ltd.</Name>
       <vts:KeyInfo>...</vts:KeyInfo>
     </Issuer>

__________________________________________________
Do You Yahoo!?
Get email at your own domain with Yahoo! Mail. 
http://personal.mail.yahoo.com/

---

From: Ko Fujimura <[email-masked]>
Date: Mon, 26 Mar 2001 18:25:52 +0900

Hi Walt,

There are a number of viewpoints regarding this question as you see:

  http://xml.coverpages.org/elementsAndAttrs.html

I have no strong preference, but I prefer attribute to element for 
describing short contents as we do in IOTP or ECML, e.g., BrandName, 
ProtocolName, WalletID, ...

>        <vts:KeyInfo>...</vts:KeyInfo>

Regards,

Ko
----------------------------------------------------------
Ko Fujimura, NTT Information Sharing Platform Laboratories
1-1 Hikarinooka, Yokosuka-shi, Kanagawa 239-0847, JAPAN
Tel: +81-(0)468-59-3814, Fax: +81-(0)468-59-2241
Email: [email-masked]