Subject: [rbridge] loops in trill networks

From: kreeger at cisco.com (Larry Kreeger (kreeger))
Date: Tue, 11 Oct 2005 14:47:42 -0700

Joe,

Sorry, but I totally missed the fact that Spanning Tree Protocol is
being used within the RBridged network!  All I had seen were references
to routing protocols such as IS-IS.

Nevermind...

 - Larry

-----Original Message-----
From: rbridge-bounces at postel.org [mailto:rbridge-bounces at postel.org] On
Behalf Of Joe Touch
Sent: Tuesday, October 11, 2005 2:22 PM
To: Developing a hybrid router/bridge.
Subject: Re: [rbridge] loops in trill networks

Larry Kreeger (kreeger) wrote:
> Joe,
> 
> As far as I know, all variations of STP guaranteed that bridged 
> networks never have temporary loops, so existing bridges never have
this problem.
> If they did, then I'd agree that it is no different. 

I'm confused. We are using STP for multicast/broadcast inside the
campus. Why then will that STP cause loops whereas current bridges do
not?

Joe

> 
>  - Larry
> 
> -----Original Message-----
> From: rbridge-bounces at postel.org [mailto:rbridge-bounces at postel.org] 
> On Behalf Of Joe Touch
> Sent: Tuesday, October 11, 2005 1:47 PM
> To: Developing a hybrid router/bridge.
> Subject: Re: [rbridge] loops in trill networks
> 
> Yes - but I think Radia pointed out that this is no different than how

> existing bridges would behave in that circumstance.
> 
> joe
> 
> 
> Larry Kreeger (kreeger) wrote:
> 
>>>Joe,
>>>
>>>The context was that during a topology change, there could be a 
>>>temporary loop.  While this temporary loop exists, 
>>>multicast/broadcasts would duplicate to edge ports each time they 
>>>came
> 
> 
>>>around - until the TTL reaches its limit.
>>>
>>> - Larry
>>>
>>>-----Original Message-----
>>>From: rbridge-bounces at postel.org [mailto:rbridge-bounces at postel.org]
>>>On Behalf Of Joe Touch
>>>Sent: Tuesday, October 11, 2005 1:02 PM
>>>To: Developing a hybrid router/bridge.
>>>Subject: Re: [rbridge] loops in trill networks
>>>
>>>
>>>
>>>Larry Kreeger (kreeger) wrote:
>>>
>>>
>>>>>OK, I can see how a TTL will stop loops, and would prevent 
>>>>>duplicate known unicasts from being delivered, but how does a TTL 
>>>>>stop broadcast/multicast/unknown unicast frames from being 
>>>>>duplicated to edge ports each time the frame comes round the loop?
>>>
>>>
>>>The multicast/broadcast packets are forwarded by one or more spanning

>>>trees. There should never be loops in those anyway as a result.
>>>
>>>Joe
>>>
>>>
>>>
>>>>>Or is this considered
>>>>>OK behavior in an RBridge network compared to an 802.1 bridged
>>>
>>>network?
>>>
>>>
>>>>>New to all this...  - Larry
>>>>>
>>>>>-----Original Message-----
>>>>>From: rbridge-bounces at postel.org 
>>>>>[mailto:rbridge-bounces at postel.org]
>>>>>On Behalf Of Joe Touch
>>>>>Sent: Tuesday, October 11, 2005 7:07 AM
>>>>>To: Developing a hybrid router/bridge.
>>>>>Subject: Re: [rbridge] loops in trill networks
>>>>>
>>>>>There is, and that's what it's there for.
>>>>>
>>>>>Joe
>>>>>
>>>>>Mike Hughes wrote:
>>>>>
>>>>>
>>>>>
>>>>>>--On 11 October 2005 15:23 +0200 Loa Andersson <loa at pi.se> wrote:
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>>>this might be an old discussion, but it is some time since it 
>>>>>>>look at
>>>
>>>
>>>>>>>it. What do we do in trill networks about transient loops, i.e. 
>>>>>>>if use
>>>>>
>>>>>
>>>>>>>link state protocols there is a possibility that we have 
>>>>>>>transient loops. With no TTL mechanisms those looping frames 
>>>>>>>could cause quite a
>>>>>
>>>>>
>>>>>>>bit of problem.
>>>>>>
>>>>>>
>>>>>>Unless I've missed something, or things have changed overnight, 
>>>>>>there is a TTL provided in the SHIM header.
>>>>>>
>>>>>>Mike
>>>>>
>>>>>_______________________________________________
>>>>>rbridge mailing list
>>>>>rbridge at postel.org
>>>>>http://www.postel.org/mailman/listinfo/rbridge
>>>
> _______________________________________________
> rbridge mailing list
> rbridge at postel.org
> http://www.postel.org/mailman/listinfo/rbridge
> _______________________________________________
> rbridge mailing list
> rbridge at postel.org
> http://www.postel.org/mailman/listinfo/rbridge
_______________________________________________
rbridge mailing list
rbridge at postel.org
http://www.postel.org/mailman/listinfo/rbridge
_______________________________________________
rbridge mailing list
rbridge at postel.org
http://www.postel.org/mailman/listinfo/rbridge
_______________________________________________
rbridge mailing list
rbridge at postel.org
http://www.postel.org/mailman/listinfo/rbridge

---

From: Radia.Perlman at sun.com (Radia Perlman)
Date: Tue, 11 Oct 2005 15:05:35 -0700

No. When Joe said "STP" he didn't mean the good old 802.1d STP that we 
all know and love...
instead it's a spanning tree topology calcuated from the link state 
database distributed by IS-IS.

Radia

Larry Kreeger (kreeger) wrote:

>-----BEGIN PGP SIGNED MESSAGE-----
>Hash: SHA1
>
>
>
>-----BEGIN PGP SIGNATURE-----
>Version: GnuPG v1.2.4 (MingW32)
>Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org
>
>iD8DBQFDTCz4E5f5cImnZrsRAupAAJ9uc9RO2M6nGvzxGY5UqzjYn0OafACgimKq
>R8mFDeQMzN6IdleEU574J4c=
>=F6gF
>-----END PGP SIGNATURE-----