Subject: [rbridge] loops in trill networks

From: michsmit at cisco.com (Michael Smith (michsmit))
Date: Tue, 11 Oct 2005 11:48:43 -0700

How about packet duplication ?  With unknown unicasts packets following
the spanning tree, there is the potential for unicast packets to be
duplicated and multiple copies received by the destination with or
without TTL.   I don't believe current routing introduces packet
duplication for unicast packets.  I'm not sure how non-IP protocols
would behave in this case.

Michael

> -----Original Message-----
> From: rbridge-bounces at postel.org 
> 
> I'm not sure what protocols there are that need absolute 
> ordering guarantees.
> RSTP can reorder sometimes after a topology change, so 
> apparently occasional reordering is not considered a problem.
> All the IETF protocols, I believe, are designed to withstand 
> some packet reordering (and should, in my opinion, any well 
> designed protocol).
> 
> Radia
> 
> Alia Atlas wrote:
> 
> > What about potential frame reordering
> > during the routing convergence?  Is this a concern?
> >
> > Alia
> >
> > On 10/11/05, *Radia Perlman* <Radia.Perlman at sun.com 
> > <mailto:Radia.Perlman at sun.com>> wrote:
> >
> >     There's nothing an RBridge can do about loops consisting of just
> >     bridges.
> >     Which is why it's good to partition the spanning trees 
> formed by the
> >     bridges so that the remaining spanning trees are as small, and
> >     therefore
> >     as stable, as possible.
> >
> >     RBridges are like routers. They sit at a layer above 
> bridges. The
> >     bridges
> >     form what looks like a single link to the RBridges. If 
> there are a
> >     bunch
> >     of bridges connecting a bunch of segments, all the RBridges
> >     attached to
> >     that portion of the network see that bridged segment as 
> a single link.
> >
> >     Radia
> >
> >     Loa Andersson wrote:
> >
> >     >Oh, yes it is true ...
> >     >
> >     >but I thought that a trill network could consist of a mixed
> >     >of rbridges and the type of bridges that exist today, if that
> >     >is the case you can possibly form the loop over only 
> non-rbridges
> >     >
> >     >but I'm not up to speed on this, there might be a way to handle
> >     >this also
> >     >
> >     >/Loa
> >     >
> >     >Joe Touch wrote:
> >     >
> >     >
> >     >>There is, and that's what it's there for.
> >     >>
> >     >>Joe
> >     >>
> >     >>Mike Hughes wrote:
> >     >>
> >     >>
> >     >>
> >     >>>--On 11 October 2005 15:23 +0200 Loa Andersson <loa at pi.se
> >     <mailto:loa at pi.se>> wrote:
> >     >>>
> >     >>>
> >     >>>
> >     >>>
> >     >>>
> >     >>>>this might be an old discussion, but it is some 
> time since it
> >     >>>>look at it. What do we do in trill networks about transient
> >     >>>>loops, i.e. if use link state protocols there is a 
> possibility
> >     >>>>that we have transient loops. With no TTL 
> mechanisms those looping
> >     >>>>frames could cause quite a bit of problem.
> >     >>>>
> >     >>>>
> >     >>>Unless I've missed something, or things have changed 
> overnight,
> >     there is a
> >     >>>TTL provided in the SHIM header.
> >     >>>
> >     >>>Mike
> >     >>>
> >     >>>
> >     
> >>>-----------------------------------------------------------
> -------------
> >     >>>
> >     >>>_______________________________________________
> >     >>>rbridge mailing list
> >     >>>rbridge at postel.org <mailto:rbridge at postel.org>
> >     >>> http://www.postel.org/mailman/listinfo/rbridge
> >     >>>
> >     >>>
> >     >
> >     >
> >     >
> >     >
> >
> >     _______________________________________________
> >     rbridge mailing list
> >     rbridge at postel.org <mailto:rbridge at postel.org>
> >     http://www.postel.org/mailman/listinfo/rbridge
> >
> >
> >-------------------------------------------------------------
> ----------
> >-
> >
> >_______________________________________________
> >rbridge mailing list
> >rbridge at postel.org
> >http://www.postel.org/mailman/listinfo/rbridge
> >  
> >
> 
> _______________________________________________
> rbridge mailing list
> rbridge at postel.org
> http://www.postel.org/mailman/listinfo/rbridge
>

---

From: Radia.Perlman at sun.com (Radia Perlman)
Date: Tue, 11 Oct 2005 12:08:28 -0700

Just like current bridges, if there were a temporary loop, would 
duplicate packets, RBridges
would also, but more safely because of the hop count.

Radia