Subject: [rbridge] loops in trill networks

From: petera at nortel.com (Peter Ashwood-Smith)
Date: Wed, 12 Oct 2005 16:20:18 -0400

What 'precisely' is the problem with a BPDU getting through an Rbriged
network ? It certainly does not break Rbridge so how does it break STP?

The designated Rbridge pretty much ensures that the STP on each side
only sees one link to it, the STP protocol should continue normally on
either side of the Rbridge. No?

Peter

-----Original Message-----
From: rbridge-bounces at postel.org [mailto:rbridge-bounces at postel.org] On
Behalf Of Gray, Eric
Sent: Wednesday, October 12, 2005 3:46 PM
To: 'Developing a hybrid router/bridge.'
Subject: Re: [rbridge] loops in trill networks

Dino,

	No, actually, it is not like saying that.

	Given that we expect to have bridges between Rbridges
(though they're supposed to be invisible to RBridges), and
the fact that we expect to have Rbridges connected to each other, it is
not at all bizarre to expect that we might end up with a bridge
connected to an RBridge on the same port that the RBridge is connected
to another RBridge.  Like this:

	RB-1 ---+--- RB-2
              |
              |
             B-3
              |
              |
      RB-4 ---+

Moreover, there should be nothing problematic about this 
topology either as it will look to the RBridges like this:

      RB-1 ---+--- RB-2
              |
              |
            RB-4

And to B-3 like this:

       H-1 ---+--- H-2
              |
              |
             B-3
              |
              |
             H-4

As you implied, the normal case is that enclosing RBridges
- like routers - will look to enclosed bridges like hosts.
I merely stated that RBridges - like hosts - can ignore any BPDUs they
receive.

--
Eric

--> -----Original Message-----
--> From: rbridge-bounces at postel.org
--> [mailto:rbridge-bounces at postel.org]On
--> Behalf Of Dino Farinacci
--> Sent: Wednesday, October 12, 2005 3:08 PM
--> To: rbridge at postel.org
--> Cc: rbridge at postel.org
--> Subject: Re: [rbridge] loops in trill networks
--> 
--> 
--> >> 	I believe that many of today's bridges can be configured to not 
--> >> send BPDUs on specific ports, but we do _not_ want to rely on 
--> >> this.  For example, what do we do if both a bridge and an RBridge

--> >> are connected to the same port of the bridge we are talking about

--> >> (imagine a simple Hub between three+ devices)?
--> 
-->     This is like saying if you run IS-IS on an interface
--> you should not run
-->     OSPF on the interface. And to make sure you don't the 
--> IS-IS standard
-->     states you must drop all other protocol messages. Which 
--> it does not!
--> 
--> Dino    
--> _______________________________________________
--> rbridge mailing list
--> rbridge at postel.org http://www.postel.org/mailman/listinfo/rbridge
--> 
_______________________________________________
rbridge mailing list
rbridge at postel.org http://www.postel.org/mailman/listinfo/rbridge

---

From: saikat at seas.upenn.edu (Saikat Ray)
Date: Wed, 12 Oct 2005 16:30:26 -0400

I think one wants to make the spanning tree fragments as small as possible.

-----Original Message-----
From: rbridge-bounces at postel.org [mailto:rbridge-bounces at postel.org] On
Behalf Of Peter Ashwood-Smith
Sent: Wednesday, October 12, 2005 4:20 PM
To: Developing a hybrid router/bridge.
Subject: Re: [rbridge] loops in trill networks

Peter

-----Original Message-----

Dino,

	RB-1 ---+--- RB-2
              |
              |
             B-3
              |
              |
      RB-4 ---+

      RB-1 ---+--- RB-2
              |
              |
            RB-4

And to B-3 like this:

       H-1 ---+--- H-2
              |
              |
             B-3
              |
              |
             H-4

--
Eric

_______________________________________________
rbridge mailing list
rbridge at postel.org
http://www.postel.org/mailman/listinfo/rbridge