Subject: [rbridge] Time to summarize "forward or block" BPDU thread

From: anoop.ghanwani at hp.com (Ghanwani, Anoop)
Date: Tue, 18 Oct 2005 10:47:11 -0700

> -----Original Message-----
> From: rbridge-bounces at postel.org 
> [mailto:rbridge-bounces at postel.org] On Behalf Of Radia Perlman
> Sent: Tuesday, October 18, 2005 9:46 AM
> To: saikat at seas.upenn.edu; Developing a hybrid router/bridge.
> Subject: Re: [rbridge] Time to summarize "forward or block" 
> BPDU thread
>
> If a broadcast goes to all links, then one spanning tree is 
> as good as another.

This is not necessarily true.  Depending on which ports
block, traffic sourced from some nodes will have to 
travel more hops to get to all of the links.  The tree 
is optimal only for the root node.

Anoop

---

From: Radia.Perlman at sun.com (Radia Perlman)
Date: Tue, 18 Oct 2005 11:17:01 -0700

Right. I wasn't saying something other than that.
What I'm saying is that if there's just a single shared tree, and 
multiple transmitters,
then it's not clear what the optimal tree would be...probably one would 
have to know the
volume of traffic between each pair of speakers.

So at any rate, I don't think we should be trying for "optimal", even if 
we knew what we were
optimizing, since it would be really expensive to try to get the extra 
tiny bit of possible
performance by going from simple, easy, and pretty good, to optimal.

But per-ingress trees is pretty close to optimal anyway. It will be a 
tree of shortest paths from
the sender to each receiver.

Radia

---

From: gibanez at it.uc3m.es (Guillermo Ibáñez)
Date: Tue, 18 Oct 2005 22:24:18 +0200

One way, although somewhat restrictive, to achieve optimality in paths 
and high performance, is to restrict the Rbridges to connect between 
themselves, forming the core of the campus network, sbridges not allowed 
inside the core, only outside. In this way, all paths in the core go 
throug per ingress bridge tree and are optimal. Besides this, the paths 
through the sbridges spanning tree  to the ingress and egress Rbridge 
are also optimal.
Guillermo

Radia Perlman wrote:

>_______________________________________________
>rbridge mailing list
>rbridge at postel.org
>http://www.postel.org/mailman/listinfo/rbridge
>
>  
>