Subject: [rbridge] Treating broadcast addresses

From: Radia.Perlman at sun.com ([email-masked])
Date: Mon, 17 Oct 2005 07:27:09 -0700

Yes, the intention is to do optimized distribution of IP-based multicast
by using
a) per-ingress Rbridge tree, and
b) filtering of that tree based on snooping on IGMP

Radia

----- Original Message -----
From: Ganesh CS <gsankara at cisco.com>
Date: Monday, October 17, 2005 6:14 am
Subject: Re: [rbridge] Treating broadcast addresses

> What about IP subnet based broadcasts, how will they be supported 
> by 
> rbridges ?
> Will it be more on lines of subnet based multicast instead of 
> broadcast 
> in rbridge network ?
> 
> -Ganesh
> 
> Vishwas Manral wrote:
> 
> > Hi Rute,
> >
> >  
> >
> > Thanks for the reply. I am clearer now.
> >
> >  
> >
> > If the root election is done at run time (like DR election in IS-
> IS), 
> > it could mean that the Root could change often. If we had a 
> sticky 
> > Root election (like a DR election in OSPF) it could mean that the 
> root 
> > selection would take time to converge.
> >
> >  
> >
> > Thanks again,
> >
> > Vishwas
> >
> > ------------------------------------------------------------------
> ------
> >
> > *From:* rbridge-bounces at postel.org [rbridge-bounces at postel.org] 
> > *On Behalf Of *Sofia, Rute
> > *Sent:* Monday, October 17, 2005 5:23 PM
> > *To:* Developing a hybrid router/bridge.
> > *Subject:* Re: [rbridge] Treating broadcast addresses
> >
> >  
> >
> > Vishwas,
> >
> >  
> >
> > Suppose you are speaking about the ST that Rbridges use to 
> perform 
> > broadcast. You don't need root election: the info provided by 
> LSPs is 
> > enough to build the ST.
> >
> >  
> >
> > Regards,
> >
> > Rute
> >
> >  
> >
> >      
> >
> >     --------------------------------------------------------------
> ----------
> >
> >     *From:* rbridge-bounces at postel.org
> >     [rbridge-bounces at postel.org] *On Behalf Of *Vishwas Manral
> >     *Sent:* Monday, October 17, 2005 1:27 PM
> >     *To:* Developing a hybrid router/bridge.
> >     *Subject:* Re: [rbridge] Treating broadcast addresses
> >
> >     Hi Rute,
> >
> >      
> >
> >     Would this also mean Root-Election? What about convergence of 
> this>     tree?
> >
> >      
> >
> >     Thanks,
> >
> >     Vishwas
> >
> >     --------------------------------------------------------------
> ----------
> >
> >     *From:* rbridge-bounces at postel.org
> >     [rbridge-bounces at postel.org] *On Behalf Of *Sofia, Rute
> >     *Sent:* Monday, October 17, 2005 4:36 PM
> >     *To:* Developing a hybrid router/bridge.
> >     *Subject:* Re: [rbridge] Treating broadcast addresses
> >
> >      
> >
> >     Vishwas,
> >
> >      
> >
> >     based on the information exchanged by LSPs you can simply 
> compute>     the ST locally. The key here is the choice of the 
> root. This can
> >     also be passed along by IS-IS...
> >
> >      
> >
> >     Regards,
> >
> >     Rute
> >
> >      
> >
> >         Hi,
> >
> >          
> >
> >         My question is more like, how would we build a spanning tree
> >         for broadcast using IS-IS?
> >
> >          
> >
> >         We need a globally coordinated tree like STP and not like 
> the>         way IS-IS computes it. Would we require, changes to the
> >         spanning tree computation itself?
> >
> >          
> >
> >         Thanks,
> >
> >         Vishwas
> >
> >         ----------------------------------------------------------
> --------------
> >
> >         *From:* rbridge-bounces at postel.org
> >         [rbridge-bounces at postel.org] *On Behalf Of *Vishwas Manral
> >         *Sent:* Monday, October 17, 2005 11:41 AM
> >         *To:* Developing a hybrid router/bridge.
> >         *Subject:* [rbridge] Treating broadcast addresses
> >
> >          
> >
> >         Hi,
> >
> >          
> >
> >         I had a doubt about treatment of broadcast addresses.
> >
> >          
> >
> >         Currently using STP we have one tree and ports are blocked/
> >         forwarding, so packets cannot loop irrespective of 
> destination>         addresses. In IS-IS protocol, we use ports 
> based on
> >         destination address and no ports are blocked or 
> unblocked. But
> >         if the destination address is FF-FF-FF-FF-FF-FF we could end
> >         in a forwarding loop. How would we get over it?
> >
> >          
> >
> >         Would we still allow broadcast destination address 
> packets to
> >         be forwarded? It is like preventing flooding loops in a case
> >         where we have a global broadcast IP address, which is
> >         forwarded to all attached routers. Am I missing the point 
> all>         together?
> >
> >          
> >
> >         Thanks,
> >
> >         Vishwas
> >
> >          
> >
> >-------------------------------------------------------------------
> -----
> >
> >_______________________________________________
> >rbridge mailing list
> >rbridge at postel.org
> >http://www.postel.org/mailman/listinfo/rbridge
> >  
> >
> _______________________________________________
> rbridge mailing list
> rbridge at postel.org
> http://www.postel.org/mailman/listinfo/rbridge
>

---

From: gsankara at cisco.com (Ganesh CS)
Date: Mon, 17 Oct 2005 20:30:01 +0530

Hi Radia,

>a) per-ingress Rbridge tree, and
Do you mean (ingress Rbridge, group) instead of (source, group) ?

>b) filtering of that tree based on snooping on IGMP
IGMP snooping is not applicable for IP subnet based broadcasts. 
Alternately will be based on host information ?

-Ganesh