Subject: [rbridge] loops in trill networks

From: Eric.Gray at marconi.com (Gray, Eric)
Date: Tue, 11 Oct 2005 16:31:05 -0300

Radia,

	If I am understanding what you are saying correctly,
there are some deployment issues with Rbridges into a 802.1
bridged environment.

	The deployment issues arise when individual RBridges
are installed, if this is not carefully planned in advance.
If an Rbridge is installed on a link where it is connected
to two or more 802.1 bridges and there is another L2 path
between those two bridges, the RBridge will either have to
forward BPDUs or - like a router - recognize that multiple
ports are connected to the same LAN.

	Is there an intention that the latter would be the 
default case until and unless the installed RBridge is able
to discover a connected RBridge peer?

--
Eric Gray

--> -----Original Message-----
--> From: rbridge-bounces at postel.org 
--> [mailto:rbridge-bounces at postel.org]On
--> Behalf Of Radia Perlman
--> Sent: Tuesday, October 11, 2005 12:44 PM
--> To: Developing a hybrid router/bridge.
--> Subject: Re: [rbridge] loops in trill networks
--> 
--> 
--> There's nothing an RBridge can do about loops consisting of 
--> just bridges.
--> Which is why it's good to partition the spanning trees formed by the
--> bridges so that the remaining spanning trees are as small, 
--> and therefore
--> as stable, as possible.
--> 
--> RBridges are like routers. They sit at a layer above 
--> bridges. The bridges
--> form what looks like a single link to the RBridges. If 
--> there are a bunch
--> of bridges connecting a bunch of segments, all the RBridges 
--> attached to
--> that portion of the network see that bridged segment as a 
--> single link.
--> 
--> Radia
--> 
--> Loa Andersson wrote:
--> 
--> >Oh, yes it is true ...
--> >
--> >but I thought that a trill network could consist of a mixed
--> >of rbridges and the type of bridges that exist today, if that
--> >is the case you can possibly form the loop over only non-rbridges
--> >
--> >but I'm not up to speed on this, there might be a way to handle
--> >this also
--> >
--> >/Loa
--> >
--> >Joe Touch wrote:
--> >  
--> >
--> >>There is, and that's what it's there for.
--> >>
--> >>Joe
--> >>
--> >>Mike Hughes wrote:
--> >>
--> >>    
--> >>
--> >>>--On 11 October 2005 15:23 +0200 Loa Andersson <loa at pi.se> wrote:
--> >>>
--> >>>
--> >>>
--> >>>      
--> >>>
--> >>>>this might be an old discussion, but it is some time since it
--> >>>>look at it. What do we do in trill networks about transient
--> >>>>loops, i.e. if use link state protocols there is a possibility
--> >>>>that we have transient loops. With no TTL mechanisms 
--> those looping
--> >>>>frames could cause quite a bit of problem.
--> >>>>        
--> >>>>
--> >>>Unless I've missed something, or things have changed 
--> overnight, there is a
--> >>>TTL provided in the SHIM header.
--> >>>
--> >>>Mike
--> >>>
--> >>>
--> >>>---------------------------------------------------------
--> ---------------
--> >>>
--> >>>_______________________________________________
--> >>>rbridge mailing list
--> >>>rbridge at postel.org
--> >>>http://www.postel.org/mailman/listinfo/rbridge
--> >>>      
--> >>>
--> >
--> >
--> >  
--> >
--> 
--> _______________________________________________
--> rbridge mailing list
--> rbridge at postel.org
--> http://www.postel.org/mailman/listinfo/rbridge
-->

---

From: Radia.Perlman at sun.com (Radia Perlman)
Date: Tue, 11 Oct 2005 12:46:27 -0700

The intention is that deployment not have to be careful. If two of an 
RBridge's ports are connected
to the same bridged broadcast domain (i.e., there is a bridge-connected 
path between the two
ports), then the RBridge will think it has two ports connected to the 
same link. Which is OK.
It won't forward any packets, including not BPDUs, between those ports. 
At most one of
its ports will become "designated" for sourcing/sinking unencapsulated 
traffic to/from that link.

It would be just like a router having two ports connected to the same 
link, which should work
with no problem.

Radia

Gray, Eric wrote:

>_______________________________________________
>rbridge mailing list
>rbridge at postel.org
>http://www.postel.org/mailman/listinfo/rbridge
>  
>