Subject: [rbridge] loops in trill networks

From: kreeger at cisco.com (Larry Kreeger (kreeger))
Date: Tue, 11 Oct 2005 11:49:19 -0700

OK, I can see how a TTL will stop loops, and would prevent duplicate
known unicasts from being delivered, but how does a TTL stop
broadcast/multicast/unknown unicast frames from being duplicated to edge
ports each time the frame comes round the loop?  Or is this considered
OK behavior in an RBridge network compared to an 802.1 bridged network?

New to all this...  - Larry  

-----Original Message-----
From: rbridge-bounces at postel.org [mailto:rbridge-bounces at postel.org] On
Behalf Of Joe Touch
Sent: Tuesday, October 11, 2005 7:07 AM
To: Developing a hybrid router/bridge.
Subject: Re: [rbridge] loops in trill networks

There is, and that's what it's there for.

Joe

Mike Hughes wrote:
> --On 11 October 2005 15:23 +0200 Loa Andersson <loa at pi.se> wrote:
> 
> 
>>this might be an old discussion, but it is some time since it look at 
>>it. What do we do in trill networks about transient loops, i.e. if use

>>link state protocols there is a possibility that we have transient 
>>loops. With no TTL mechanisms those looping frames could cause quite a

>>bit of problem.
> 
> 
> Unless I've missed something, or things have changed overnight, there 
> is a TTL provided in the SHIM header.
> 
> Mike

---

From: Radia.Perlman at sun.com (Radia Perlman)
Date: Tue, 11 Oct 2005 12:05:08 -0700

If there is a loop, then packets whether they are unicast or multicast, 
will be delivered multiple
times, within the limit of the TTL.

Radia

Larry Kreeger (kreeger) wrote:

>_______________________________________________
>rbridge mailing list
>rbridge at postel.org
>http://www.postel.org/mailman/listinfo/rbridge
>  
>

---

From: touch at ISI.EDU (Joe Touch)
Date: Tue, 11 Oct 2005 13:02:28 -0700

Larry Kreeger (kreeger) wrote:
> ports each time the frame comes round the loop? 

The multicast/broadcast packets are forwarded by one or more spanning
trees. There should never be loops in those anyway as a result.

Joe

> Or is this considered