Subject: [rbridge] loops in trill networks

From: Eric.Gray at marconi.com (Gray, Eric)
Date: Wed, 12 Oct 2005 12:09:19 -0300

Dino,

	I believe that many of today's bridges can be configured
to not send BPDUs on specific ports, but we do _not_ want to
rely on this.  For example, what do we do if both a bridge and
an RBridge are connected to the same port of the bridge we are
talking about (imagine a simple Hub between three+ devices)?

	Also, I am not sure that all bridges have this capability
- since it is not necessary even for hosts (hosts ignore BPDUs,
even if they get them).  If it is not necessary for any current
deployment, it is an unnecessary complication and may be left
out.

--
Eric

--> -----Original Message-----
--> From: rbridge-bounces at postel.org 
--> [mailto:rbridge-bounces at postel.org]On
--> Behalf Of Dino Farinacci
--> Sent: Tuesday, October 11, 2005 8:10 PM
--> To: rbridge at postel.org
--> Cc: rbridge at postel.org
--> Subject: Re: [rbridge] loops in trill networks
--> 
--> 
--> >> As for providing glue to two broadcast domains in order to merge 
--> >> them...yes, an RBridged "campus"
--> >> could be used to tunnel packets from the two broadcast 
--> domains in order 
--> >> to merge them.
--> 
-->     Yes, agree.
--> 
--> >> But in general an RBridge would not forward a native 
--> BPDU. It would 
--> >> recognize it as something
--> >> it shouldn't forward. Because RBridges intend to make 
--> the spanning trees 
--> 
-->     So we have to put special checks in the hardware 
--> forwarding plane? I
-->     would rather not put this in the architecture and just 
--> document that
-->     bridges should not send BPDUs on links where rBridges 
--> exist. Just like
-->     bridges don't generally send BPDUs on host ports today.
--> 
--> Dino
--> 
--> 
--> 
--> 
--> _______________________________________________
--> rbridge mailing list
--> rbridge at postel.org
--> http://www.postel.org/mailman/listinfo/rbridge
-->

---

From: dino at cisco.com (Dino Farinacci)
Date: Wed, 12 Oct 2005 12:08:11 -0700

>> talking about (imagine a simple Hub between three+ devices)?

    This is like saying if you run IS-IS on an interface you should not run
    OSPF on the interface. And to make sure you don't the IS-IS standard
    states you must drop all other protocol messages. Which it does not!

Dino