Subject: [rbridge] seeking input on abstractfor problemand applicabili tystatement

From: Eric.Gray at marconi.com (Gray, Eric)
Date: Fri, 14 Oct 2005 21:18:57 -0300

Guillermo,

	I agree with your comments to Joe, but I want to expand
on the last comment that you made (included below).

	One of the big problems with assuming that STP is used
across the entire RBridge campus is that this doesn't allow
us to take advantage of things we know now that were not known 
when STP was designed.  For example, VLANs.

	One of the proposals for creating a shortest path spanning
tree within the campus is to allow a spanning tree per VLAN.  A
set of 802 bridges cannot do that.  However, it is incredibly 
likely that small spanning trees at the edge of a campus will 
have significant non-intersecting VLAN membership.  This implies 
that there is a potentially significant benefit from having per
VLAN shortest path spanning trees within the RBridge campus.  In
this case, topology that must be correctly understood by RBridges
in order to correctly forward STP BPDUs from one edge spanning 
tree to other edge spanning trees is very complicated.  Also, in
this case, the root RBridges should not be the same for all VLAN
specific shortest path spanning trees.

--
Eric

--> >
--> There is no problem as there is only one Designated Rbridge in 
--> the bridges spanning tree, the only that forward frames to/from 
--> that tree into the rbridges region. IMMO, the Designated Rbridge 
--> should act as Root bridge of the bridges spanning tree, so the
--> path is optimum to all bridges of that tree.
-->

---

From: gibanez at it.uc3m.es (Guillermo Ibáñez)
Date: Sat, 15 Oct 2005 02:55:01 +0200

Eric,
       The difficulties you mention regarding per VLAN trees are among 
the reasons I would recommend (instead of per VLAN Rbridge trees) one 
spanning tree per Rbridge to all other Rbridges, carrying all VLANs, 
irrespective of VLAN membership. Rbridges in this way act as double root 
bridges, for the edge tree of bridges and (route wise) for the Rbridges 
tree.
       Guillermo

Gray, Eric wrote:

>_______________________________________________
>rbridge mailing list
>rbridge at postel.org
>http://www.postel.org/mailman/listinfo/rbridge
>
>  
>