Subject: [rbridge] loops in trill networks

From: kreeger at cisco.com (Larry Kreeger (kreeger))
Date: Tue, 11 Oct 2005 13:45:05 -0700

Joe,

The context was that during a topology change, there could be a
temporary loop.  While this temporary loop exists, multicast/broadcasts
would duplicate to edge ports each time they came around - until the TTL
reaches its limit.

 - Larry

-----Original Message-----
From: rbridge-bounces at postel.org [mailto:rbridge-bounces at postel.org] On
Behalf Of Joe Touch
Sent: Tuesday, October 11, 2005 1:02 PM
To: Developing a hybrid router/bridge.
Subject: Re: [rbridge] loops in trill networks

Larry Kreeger (kreeger) wrote:
> OK, I can see how a TTL will stop loops, and would prevent duplicate 
> known unicasts from being delivered, but how does a TTL stop 
> broadcast/multicast/unknown unicast frames from being duplicated to 
> edge ports each time the frame comes round the loop?

The multicast/broadcast packets are forwarded by one or more spanning
trees. There should never be loops in those anyway as a result.

Joe

> Or is this considered
> OK behavior in an RBridge network compared to an 802.1 bridged
network?
> 
> New to all this...  - Larry
> 
> -----Original Message-----
> From: rbridge-bounces at postel.org [mailto:rbridge-bounces at postel.org] 
> On Behalf Of Joe Touch
> Sent: Tuesday, October 11, 2005 7:07 AM
> To: Developing a hybrid router/bridge.
> Subject: Re: [rbridge] loops in trill networks
> 
> There is, and that's what it's there for.
> 
> Joe
> 
> Mike Hughes wrote:
> 
>>--On 11 October 2005 15:23 +0200 Loa Andersson <loa at pi.se> wrote:
>>
>>
>>
>>>this might be an old discussion, but it is some time since it look at

>>>it. What do we do in trill networks about transient loops, i.e. if 
>>>use
> 
> 
>>>link state protocols there is a possibility that we have transient 
>>>loops. With no TTL mechanisms those looping frames could cause quite 
>>>a
> 
> 
>>>bit of problem.
>>
>>
>>Unless I've missed something, or things have changed overnight, there 
>>is a TTL provided in the SHIM header.
>>
>>Mike
> 
> _______________________________________________
> rbridge mailing list
> rbridge at postel.org
> http://www.postel.org/mailman/listinfo/rbridge
_______________________________________________
rbridge mailing list
rbridge at postel.org
http://www.postel.org/mailman/listinfo/rbridge

---

From: touch at ISI.EDU (Joe Touch)
Date: Tue, 11 Oct 2005 13:46:50 -0700

Yes - but I think Radia pointed out that this is no different than how
existing bridges would behave in that circumstance.

joe