Subject: [rbridge] seeking input on abstractfor problemand applicabili tystatement

From: Eric.Gray at marconi.com (Gray, Eric)
Date: Fri, 14 Oct 2005 16:30:32 -0300

Michael,

	"What breaks" is - from the original context - the
assumption that an RBridge campus looks to the outside
world like a single bridge.

	As stated in other mail, I don't think this is a 
goal for the work we're doing.

	If BLOCKING is used - as I believe must be the case
by default - then an RBridge looks like "the rest of the 
world" to external bridges.  In other words, external 
bridges see and learn SA MAC addresses from all traffic 
the RBridge injects onto the shared link - just as if the 
devices corresponding to the addresses were also on that 
link.  As far as local bridges are concerned - in this 
case - the spanning tree ends (or starts, depending on 
perspective) with that link.

	The same is true for internal bridges - except 
that, owing to the encapsulation of frames in an extra
MAC header + shim, the internal bridges only see SA MAC
addresses for RBridges.

	The terms "internal" and "external" in this context
are not significant to the behavior of bridges or RBridges
in this mode.  I use them because they determine 1) the
scope of each STP and 2) SA MAC visibility at bridges.

	Note that this also works just fine if one RBridge
campus is attached to another.  In this case, no STP takes
place between the RBridges themselves (though STP may take
place between bridges on the link).  In this case, the 
term "external" is particularly "interesting".

--
Eric

--> -----Original Message-----
--> From: rbridge-bounces at postel.org 
--> [mailto:rbridge-bounces at postel.org]On
--> Behalf Of Michael Smith (michsmit)
--> Sent: Friday, October 14, 2005 1:39 PM
--> To: Developing a hybrid router/bridge.
--> Subject: Re: [rbridge] seeking input on abstractfor problemand
--> applicabilitystatement
--> 
--> 
-->  
--> > -----Original Message-----
--> > From: rbridge-bounces at postel.org 
--> > 
--> > My understanding is that PARTICIPATE is valid, if not required.
--> > TRANSPARENT seems like it turns the bridge into a hub. And 
--> > BLOCK would break things.
--> 
--> I think I missed something, what breaks if we block BPDUs ?
--> _______________________________________________
--> rbridge mailing list
--> rbridge at postel.org
--> http://www.postel.org/mailman/listinfo/rbridge
-->

---

From: Radia.Perlman at sun.com (Radia Perlman)
Date: Fri, 14 Oct 2005 13:44:24 -0700

Actually, thinking about it a bit more...it really scares me to have 
RBridges forwarding
spanning tree messages. RBridges would then be wormholing spanning tree 
messages, so
bridges might mysteriously get spanning tree messages from someone that 
is really several
hops away. This probably would only occur during transient states, but 
it seems scary.

So I see no advantage in RBridges forwarding spanning tree messages. In 
contrast, the
advantage of having them discard them is that then the little spanning 
trees formed by
bridged islands are smaller, and independent of each other.

Radia