Subject: [rbridge] RBridge/bridge interaction

From: petera at nortel.com (Peter Ashwood-Smith)
Date: Sat, 22 Oct 2005 16:23:26 -0400

Likewise.

> -----Original Message-----
> From: rbridge-bounces at postel.org 
> [mailto:rbridge-bounces at postel.org] On Behalf Of Gray, Eric
> Sent: Friday, October 21, 2005 6:16 PM
> To: 'Developing a hybrid router/bridge.'
> Subject: Re: [rbridge] RBridge/bridge interaction
> 
> 
> I also agree that this is a quite feasible approach.
> 
> --
> Eric
> 
> --> -----Original Message-----
> --> From: rbridge-bounces at postel.org
> --> [mailto:rbridge-bounces at postel.org]On
> --> Behalf Of Guillermo Ib??ez
> --> Sent: Friday, October 21, 2005 6:01 PM
> --> To: Developing a hybrid router/bridge.
> --> Subject: Re: [rbridge] RBridge/bridge interaction
> --> 
> --> 
> --> Right. In this way both views are covered. I fully agree. 
> Guillermo
> --> 
> --> Radia Perlman wrote:
> --> 
> --> >Actually, here's a suggestion that may make us all happy.
> --> >
> --> >Keep the design of RBridge independent of bridges. 
> RBridges do not
> --> >participate
> --> >in spanning tree (other than throwing away BPDUs).
> --> >
> --> >However, to get the functionality that Guillermo
> --> wants....allow someone
> --> >to build a device that's logically the
> --> >same as a bridge glued onto an RBridge. To the rest of the
> --> world it
> --> >would look
> --> >like this:
> --> >
> --> >bridged island----B1----RB1
> --> >
> --> >where B1 is a bridge with two ports...a pt-to-pt link to
> --> RBRidge RB1,
> --> >and a link to the
> --> >bridged LAN.
> --> >
> --> >The "RB1" portion of this box does what the architecture
> --> of an RBridge
> --> >does...it neither
> --> >forwards, nor initiates spanning tree messages.
> --> >
> --> >However, the "B1" portion of the box acts like a vanilla
> --> bridge, and
> --> >does participate in
> --> >spanning tree. And it can be configured to have whatever
> --> priority people
> --> >want.
> --> >
> --> >If it's commercially important for RBridges to have the
> --> capability of
> --> >participating in
> --> >the bridge protocol, it can be done this way without
> --> defining it into
> --> >either the RBridge
> --> >or bridge functionality.
> --> >
> --> >Radia
> --> >
> --> >
> --> >
> --> >Guillermo Ib??ez wrote:
> --> >
> --> >  
> --> >
> --> >>Root bridge planning is something required in campus
> --> networks, it just
> --> >>means configure the 16 bit priority of the preffered root
> --> bridge (and
> --> >>perhaps a root reserve) with a low enough value under the
> --> default value.
> --> >>
> --> >>    
> --> >>
> --> >
> --> >
> --> >_______________________________________________
> --> >rbridge mailing list
> --> >rbridge at postel.org http://www.postel.org/mailman/listinfo/rbridge
> --> >
> --> >  
> --> >
> --> _______________________________________________
> --> rbridge mailing list
> --> rbridge at postel.org http://www.postel.org/mailman/listinfo/rbridge
> --> 
> _______________________________________________
> rbridge mailing list
> rbridge at postel.org http://www.postel.org/mailman/listinfo/rbridge
> 
>

---

From: Radia.Perlman at sun.com (Radia Perlman)
Date: Sat, 22 Oct 2005 13:59:29 -0700

And another thought. Although I don't think we should include the notion of
a combined bridge/RBridge in the spec for RBridges,
just a suggestion for anyone that wants to build this beast...

It would be nice to minimize configuration, so especially if the reason 
for making a
bridge/RBridge is to
make an RBridge have higher priority for being bridge spanning tree 
Root, have the priority for
bridge Root be a function of the RBridge IS-IS DR priority, so you only 
have to set one
of them.

We don't have to debate this, since this if it's not in the RBridge 
spec, vendors can
do whatever they want. But it's perhaps good to have suggestions posted 
publicly.

Radia

Peter Ashwood-Smith wrote:

>rbridge at postel.org
>http://www.postel.org/mailman/listinfo/rbridge
>  
>