Subject: [rbridge] RBridge/bridge interaction

From: Eric.Gray at marconi.com (Gray, Eric)
Date: Fri, 21 Oct 2005 15:58:31 -0300

RBridge Folks,

	A way to look at the concept of a layer two device that
handles looping possibilities/concerns in some way other than 
by participating in STP - and is therefore not visible to STP
participants - is that it likely looks (to STP participants
- i.e. - 802/Ethernet bridges) like a single (possibly large)
bridged LAN segment. It is simply a link with a lot of MAC 
addresses on it. This is generally true for any device that 
lives in the Layer two world and is not an 802/Ethernet bridge, 
a host, or a router.

	In the RBridge case, there are two bridging scenarios to
consider: bridges between RBridges (or two, or more, interfaces 
of the same RBridge) and bridges attached to at most one RBridge 
interface.  We have loosely been referring to the former case as
"internal" bridges and the latter as "external" bridges, because 
of the assumption that RBridges merge into a single campus and
- therefore - having more than one RBridge interface on a single
bridged LAN segment puts that segment "inside" the campus.

	Consequently, we can assume that there are no stable back
connections between "external" bridged LAN segments because any 
such back connection will necessarily make affected "external" 
LAN segments "internal".

	For example, in the following simple network:

                            H1  H2 H3
                              \ | /
                               RB1
    H4 --.__                  /   \             __.-- H5
    H6 ----->-- B1 -- B2 -- RB2 -- RB3 -- B3 --<----- H7
    H8 ----^           |      \   /     ___|________
                      B4       \ /      |   |  |   |
                  _____|___    B5      L1  H9 H10 H11
                  |   |   |     |\
                 H12 H13  L2    | \
                              H14 H15

As shown, the LAN segment consisting of bridges B1, B2 and B4, hosts 
H4, H6, H8, H12 and H13, and currently unused link L2 are an external
bridged LAN segment.  The LAN segment consisting of bridge B3 and the
hosts H5, H7, H9, H10 and H11, and currently unused link L1 are also
an external bridged LAN segment.  The LAN segment consisting of bridge
B5 and hosts H14 and H15 is an internal bridged LAN segment, while 
hosts H1, H2 and H3 are on separate external LAN segments.

Connecting bridges B3 and B4, by connecting currently unused links L1
and L2 will make bridges B1-B4 and hosts H4-H13 all part of the same
_internal_ LAN segment.

Other things to note about this network, as is, if RBridges ignore STP:

o	to the RBridges, the network looks like this -

               H1  H2 H3
    H4 -+       |__|__|         +- H5
        |          |            |
    H6 -+         RB1           +- H7
        |        /   \          |
    H8 -+---- RB2 --- RB3 ------+- H9
        |        \___/          |
   H12 -+          |            +- H10
        |        __|__          |
   H13 -+        |   |          +- H11
                H14 H15

o	to bridges B1, B2 and B4, the network looks like this -

                           +------ H1
                           +- H2
                           +------ H3
    H4 -+                  +- H5
        |                  +------ H7
    H6 -+--- B1 -- B2 -----+- H9
        |           |      +------ H10
    H8 -+          B4      +- H11
                 ___|_     +------ H14
                 |   |     +- H15
                H12 H13

o	to bridge B3, the network looks like this - 
                           
    H1 ------+  
         H2 -+
    H3 ------+                +- H5
         H4 -+                |
    H6 ------+---- B3 --------+- H7
         H8 -+   ___|_____
   H12 ------+   |   |   |
        H13 -+   H9 H10 H11
   H14 ------+ 
        H15 -+

o	because B5 is on an internal LAN segment, its view of host 
and RBridge MAC addresses will be - at least in part - determined
by shortest path (spanning tree) computation; it might, for example
see the network like this (B5 rotated 45 degrees CCW) - 

    H1 ------+      +---------+------ H2         
         H4 -+      |         +- H3
    H6 ------+----- B5 --+    +------ H5
         H8 -+      |    |    +- H7
   H12 ------+      |    |    +------ H9
        H13 -+     H14  H15   +- H10
                              +------ H11

--
Eric Gray

---

From: gibanez at it.uc3m.es (Guillermo Ibáñez)
Date: Fri, 21 Oct 2005 23:25:23 +0200

Interesting. More scenarios like this are worth to analyze. With more 
internal bridges between RBridges.
Guillermo

Gray, Eric wrote:

>_______________________________________________
>rbridge mailing list
>rbridge at postel.org
>http://www.postel.org/mailman/listinfo/rbridge
>
>  
>