Subject: [rbridge] loops in trill networks

From: Eric.Gray at marconi.com (Gray, Eric)
Date: Thu, 13 Oct 2005 09:35:05 -0300

Dino,

	The argument that an RBridge network provides a layer 2 service
therefore any frames that are presented should be forwarded is a non
sequitur.

	This is not even true of bridges now.  Conditions under which a
bridge "should" forward frames are somewhat restricted, even if those
conditions are typically satisfied under steady-state conditions, for
most frames.  There are plenty of examples of situations in which a
bridge must not forward frames and other in which a bridge should not
forward frames.

--
Eric

--> -----Original Message-----
--> From: rbridge-bounces at postel.org 
--> [mailto:rbridge-bounces at postel.org]On
--> Behalf Of Dino Farinacci
--> Sent: Wednesday, October 12, 2005 5:46 PM
--> To: rbridge at postel.org
--> Cc: rbridge at postel.org
--> Subject: Re: [rbridge] loops in trill networks
--> 
--> 
--> >> 	No, actually, it is not like saying that.
--> 
-->     I think the fundamental question that needs to be 
--> answered is does an 
-->     RBridge network proivde a layer-2 serivce. And I think 
--> the answer should
-->     be yes. Therefore any frames that are sent on such a 
--> network should be 
-->     forwarded.
--> 
-->     Two bridges connected via a cable or an RBridge-based 
--> network should 
-->     look no different. The two bridges should be able to 
--> run STP over it and 
-->     decide if the ports leading to such a network are in 
--> Blocked or Forward 
-->     state.
--> 
-->     The RBridges should forward such packets like any other 
--> frames. The only
-->     frames that RBridges will consume and process are IS-IS 
--> packets (which
-->     will be multicasted on a *new MAC group address*).
--> 
--> Dino
--> _______________________________________________
--> rbridge mailing list
--> rbridge at postel.org
--> http://www.postel.org/mailman/listinfo/rbridge
-->

---

From: dino at cisco.com (Dino Farinacci)
Date: Thu, 13 Oct 2005 10:56:49 -0700

>> bridge must not forward frames and other in which a bridge should not

    I disagree. There are very few cases (I can think of only one standard
    case and one proprietary case) where architecturally a 802.1D bridge
    states "a bridge should not forward packet with ethertype foo or DA
    bar". 

    Now this is all modulo what vendors do for policy based forwarding/
    filtering. But that is an implementation extension and not an architectural
    specification.

Dino