Subject: [rbridge] loops in trill networks

From: kreeger at cisco.com (Larry Kreeger (kreeger))
Date: Tue, 11 Oct 2005 12:00:59 -0700

OK, it looks like I asked my previous question prematurely.

If I understand this response correctly, since an RBridge looks like a
single link to the 802.1 bridges, this implies that an RBridge receiving
a BPDU will flood the BPDU to all edge ports.

Now back to the previous message I sent about loops and TTL.  I think
this means that during an RBridge topology change, these BPDUs could get
duplicated as they loop around (before TTL expires).

How kindly will 802.1 bridges react to receiving duplicate BPDUs?

 - Larry

-----Original Message-----
From: rbridge-bounces at postel.org [mailto:rbridge-bounces at postel.org] On
Behalf Of Radia Perlman
Sent: Tuesday, October 11, 2005 9:44 AM
To: Developing a hybrid router/bridge.
Subject: Re: [rbridge] loops in trill networks

There's nothing an RBridge can do about loops consisting of just
bridges.
Which is why it's good to partition the spanning trees formed by the
bridges so that the remaining spanning trees are as small, and therefore
as stable, as possible.

RBridges are like routers. They sit at a layer above bridges. The
bridges form what looks like a single link to the RBridges. If there are
a bunch of bridges connecting a bunch of segments, all the RBridges
attached to that portion of the network see that bridged segment as a
single link.

Radia

Loa Andersson wrote:

>Oh, yes it is true ...
>
>but I thought that a trill network could consist of a mixed of rbridges

>and the type of bridges that exist today, if that is the case you can 
>possibly form the loop over only non-rbridges
>
>but I'm not up to speed on this, there might be a way to handle this 
>also
>
>/Loa
>
>Joe Touch wrote:
>  
>
>>There is, and that's what it's there for.
>>
>>Joe
>>
>>Mike Hughes wrote:
>>
>>    
>>
>>>--On 11 October 2005 15:23 +0200 Loa Andersson <loa at pi.se> wrote:
>>>
>>>
>>>
>>>      
>>>
>>>>this might be an old discussion, but it is some time since it look 
>>>>at it. What do we do in trill networks about transient loops, i.e. 
>>>>if use link state protocols there is a possibility that we have 
>>>>transient loops. With no TTL mechanisms those looping frames could 
>>>>cause quite a bit of problem.
>>>>        
>>>>
>>>Unless I've missed something, or things have changed overnight, there

>>>is a TTL provided in the SHIM header.
>>>
>>>Mike
>>>
>>>
>>>---------------------------------------------------------------------
>>>---
>>>
>>>_______________________________________________
>>>rbridge mailing list
>>>rbridge at postel.org
>>>http://www.postel.org/mailman/listinfo/rbridge
>>>      
>>>
>
>
>  
>

_______________________________________________
rbridge mailing list
rbridge at postel.org
http://www.postel.org/mailman/listinfo/rbridge

---

From: Radia.Perlman at sun.com (Radia Perlman)
Date: Tue, 11 Oct 2005 12:17:00 -0700

No. I think I managed to confuse you (Larry Kreeger). Sorry about that. 
RBridges see a whole bridge-connected
set of links as a single link. Bridges do not see RBridges that way. 
Bridges see RBridges as
just endnodes.

RBridges neither forward nor generate BPDUs.

Radia

---

From: dino at cisco.com (Dino Farinacci)
Date: Tue, 11 Oct 2005 13:09:43 -0700

>> RBridges neither forward nor generate BPDUs.

    Radia this implies that two bridges cannot use an RBridges network as
    transit? This is not true in the case where the two bridges were connected
    to a multi-access ethernet with real hosts on them. 

    I think the model could be the same and think is desirable to be the same.

Dino