Subject: [rbridge] How are packets/link without a VLAN tag handled in a bridged network today?

From: anoop.ghanwani at hp.com (Ghanwani, Anoop)
Date: Wed, 4 Jan 2006 09:56:15 -0800

> -----Original Message-----
> From: rbridge-bounces at postel.org 
> [mailto:rbridge-bounces at postel.org] On Behalf Of Harald Tveit 
> Alvestrand
> Sent: Wednesday, January 04, 2006 2:36 AM
> To: Developing a hybrid router/bridge.
> Subject: Re: [rbridge] How are packets/link without a VLAN 
> tag handled in a bridged network today?
> 
> 
> 
> --On torsdag, desember 29, 2005 20:03:10 -0800 "Ghanwani, Anoop" 
> <anoop.ghanwani at hp.com> wrote:
> 
> > As for (3), yes, a port can be a member of
> > multiple VLANs.  In that case, untagged traffic
> > arriving at the port gets assigned the PVID.
> > When you send traffic out, there is a parameter
> > to control whether or not a given VLAN should
> > be tagged/untagged before sending the frame
> > out.
> 
> Just to be sure I understand you correctly:
> 
> If an untagged frame arrives from the LAN to the switch, it 
> gets assigned 
> the PVID belonging to the port it arrives on (there can be only one).
> 
> The operator can configure the port to receive traffic for 
> multiple VLANs, 
> and can make the decision for each VLAN on the port whether 
> to send out the 
> frames on that port for that VLAN tagged or untagged.
> 
> Right?

Yes, that's right.

> 
> (I can imagine some cases where it would be useful to send 
> traffic from 
> more than one VLAN untagged (if one VLAN is used to distribute 
> unidirectional multicast traffic "broadcast-like" into all 
> segments, for 
> instance), but I agree that this could easily be confusing if 
> the operator 
> doesn't keeep things very straight in his head.... mixing tagged and 
> untagged traffic would chiefly be useful (I think) if a link 
> is used both 
> to connect end-stations to bridges and to connect bridges, much as we 
> imagine "internal" (in Joe's terms) traffic between RBridges 
> flowing over 
> the same physical LAN segments as "external" traffic.)
> 
> BTW... I couldn't find a place in 802.1Q that talks about 
> *changing* VLAN 
> IDs; is this a standard function or a "vendor extension"?

This is a vendor extension for 802.1Q.  For the provider
tag (or s-tag) in IEEE 802.1ad, this is an optional function
specified.  You basically have a VID translation table
that maps the VID in the frame to an "internal" VID,
and for outbound frames, you map the "internal" VID to
a VID in the frame.  The VID translation table is 
specifically disallowed for the customer tag (or C-tag)
which is the normal 802.1Q tag.

Anoop

---

From: saikat at seas.upenn.edu (Saikat Ray)
Date: Thu, 5 Jan 2006 14:56:42 -0500

A quick question: how often an RBridge would flood its link-state
information to the rest of the network? An order would do (e.g., once every
few seconds, or few minutes, or few hours, etc.).

Thanks.

---

From: Radia.Perlman at sun.com (Radia Perlman)
Date: Thu, 05 Jan 2006 13:20:38 -0800

For the inter-RBridge connectivity information this would only be 
flooded when
it changes (when a link goes up or comes down). Preferably to prevent a 
yo-yo link
from causing too many updates, there would be some hold-down, after a 
link has
been down, so that a router won't keep announcing a link has come up 
until it's
likely to be stable. I don't think the IS-IS spec actually specifies a 
hold-down, since
each router can have its own strategy and things will interwork. I'd 
assume that inter-RBridge
links would not change more quickly than, say, on the average once per 
hour. So I'd
think that in practice this information would average one announcement 
per RBridge
per hour. But this is just a guess. It would be good to hear from people 
who are
actually running link state networks.

For the endnode information, however, this is likely to be much more 
volatile.
Which is another reason to distribute the endnode information in a 
different instance
of IS-IS (the first reason being to limit the overhead of VLAN-specific 
knowledge
only to RBridges connected to that VLAN).

Radia

Saikat Ray wrote:

>_______________________________________________
>rbridge mailing list
>rbridge at postel.org
>http://www.postel.org/mailman/listinfo/rbridge
>  
>