Subject: [rbridge] Ready to accept as WG documents?

From: erik.nordmark at sun.com (Erik Nordmark)
Date: Mon, 03 Apr 2006 11:54:07 -0700

At the IETF meeting in Dallas we discussed the two documents below, but
when it came to asking whether we should accept them as WG documents
there was a very small number of people that had read them.

I know that some people read them and provided comments after the
meeting ended.

For those that haven't read them, I'd suggest you have a look whether
they are on the right path. They are not likely to be a finished product
now, but we want to understand whether they are in the right direction
before we accept them as WG documents and have them edited into shape.

So please read and comment on the mailing list, (and those that have
already read them can skip the first step  :-)

We'll look at the input a week from today and see how many have
commented. Thus it is IMPORTANT that you say "looks ok" if you've read 
it and thinks it is a good starting point for the WG's deliverable.

Note that this is NOT a WG last call - we just want to make sure that 
the WG is comfortable using these documents as starting points for the 
WG deliverables in question; I'm sure there are and will be open issues 
to resolve before the documents can be finished.

The documents are
	draft-gray-trill-rbridge-arch-00.txt
	draft-gray-trill-routing-reqs-00.txt

     Erik and Donald

---

From: Radia.Perlman at sun.com (Radia Perlman)
Date: Thu, 06 Apr 2006 20:20:40 -0700

There's two documents that Bill Fenner pointed me to, and I will put 
pointers into
the protocol draft (rather than duplicating all the mechanisms).

One document explains how to find multicast routers. This is important 
because
multicast packets and IGMP reports
must be sent to each every link on which there is a multicast router.

The multicast router discovery is explained in:

http://tools.ietf.org/html/rfc4286
Since this is an RFC, so we don't have to duplicate what's in it, and we can just
point to it.

The other document explains how to recognize IGMP packets of
various sorts.

http://tools.ietf.org/wg/magma/draft-ietf-magma-snoop/draft-ietf-magma-snoop-12.txt

It is unfortunately an internet draft, but hopefully it will become
an RFC. Does anyone know whether it will? If it will, then we can point to it, rather
than duplicating the content. I'll have to read it carefully, but it's possible RBridges
will want to distribute the IGMP messages slightly differently than bridges would,
for instance, by announcing receivers in link state information rather than
learning it from forwarding IGMP announcements. IGMP announcements still need to
be forwarded, but only to links with multicast routers. The magma draft says
to only filter at the last hop, but since RBridges will be informing each other of
the location of multicast routers, IGMP reports can be suppressed upstream, though
this isn't a large optimization.

Anyway, since RBridges can work a little differently from bridges,
we can't just point
to this document. On the other hand, it's real nice not to have to explain the
format of IGMP messages of various versions. If n documents in k different working
groups all try to do that, then if a new version of IGMP occurs, it will be very
difficult to find all affected documents.

I'll read this document carefully and as much as possible point to it rather than
duplicating its content, but others may also want to read it and think about what
differences we might want in the RBridge world.

Unless of course this isn't intended to ever be an RFC, in which case we'll have
to capture all the relevant content...I assume someone will let us know the intention
of the magma draft.

Radia

---

From: tme at multicasttech.com (Marshall Eubanks)
Date: Fri, 7 Apr 2006 00:09:32 -0400

Dear Radia;

> an RFC. Does anyone know whether it will? If it will, then we can  

The draft

draft-ietf-magma-snoop-12.txt

is in the RFC editor queue, and has been for a while (2003-11-24).

This was being held up because  of a reference to draft-ietf-magma- 
mrdisc AKA RFC 4286,
but this has now of course cleared up and I believe that now it's  
just  in the RFC ED backlog.

The co-chairs of MAGMA (cc'ed here) should know more, but I would  
guess it will be a numbered RFC very
soon now.

Regards
Marshall

> _______________________________________________
> rbridge mailing list
> rbridge at postel.org
> http://www.postel.org/mailman/listinfo/rbridge

---

From: narten at us.ibm.com (Thomas Narten)
Date: Thu, 13 Apr 2006 19:38:58 -0400

FYI, the current state (from http://www.rfc-editor.org/queue.html) is:

> 2003-11-24 draft-ietf-magma-snoop-12.txt
> RFC-EDITOR
> M. Christensen, K. Kimball, F. Solensky
> Considerations for IGMP and MLD Snooping Switches
> Bytes: 55086
> Working Group: Multicast and Anycast Group Membership

>From the key

 RFC-EDITOR = Pending rfc-editor final review before authors 48 hours

So, this doc really should be an RFC RSN.

Thomas