Subject: [rbridge] Ether-type question (was RE: And what should the outer header of an IS-IS packet be?)

From: Eric.Gray at marconi.com (Gray, Eric)
Date: Wed, 3 May 2006 10:21:15 -0400

Dino,

	I suspect that this is a reference to the possibility that
we will probably have to get a new Ether-type assigned to support
the SHIM encapsulation of frames forwarded between RBridges.

	This is a strong possibility, given that current choices
include:

	1) Using standard Ethernet re-encapsulation (allowing the
	   use of the various existing Ether-types, but requiring
	   more smarts in egress RBridges and using up more bits 
	   on the wire)
	2) Using MPLS label encapsulation as-is (potentially with
	   a boat-load of its own problems and complexities)
	3) Using a new Ether-type to distinguish an MPLS-like SHIM
	   from MPLS label encasulated traffic.

At the moment, I believe we are all assuming that we will end up
going with choice 3.

-->

--- [SNIP] ---

--> 
--> >> c) the same as the new Ethertype we will need assigned 
--> >>    to indicate that the frame is an RBridge-encapsulated 
--> >>    frame?
--> 
-->     I can't parse this. What do you mean? The same as what?
--> 

--- [SNIP] ---

--> 
--> Dino
--> 
-->     
--> _______________________________________________
--> rbridge mailing list
--> rbridge at postel.org
--> http://www.postel.org/mailman/listinfo/rbridge
-->

---

From: dino at cisco.com (Dino Farinacci)
Date: Wed, 3 May 2006 14:03:20 -0700

>> At the moment, I believe we are all assuming that we will end up

    So, you are saying IS-IS packets will be encapsulated with the shim
    header format. Okay.

Dino