Subject: [rbridge] maximumPathSplits

From: "Jeff Pickering" <[email-masked]>
Date: Thu, 30 Apr 2009 06:02:22 -0700

Both 10589 and RFC4444 specify a max for maximumPathsSplits of 32. In a datacenter environment, I
am hearing requests for values much larger than this. Is there any point in trying to modify this? We are
already doing non-standard 10589 stuff anyway. Just looking for feedback.

Jeff

_______________________________________________
rbridge mailing list
[email-masked]
http://mailman.postel.org/mailman/listinfo/rbridge

---

From: Ian Cox <[email-masked]>
Date: Thu, 30 Apr 2009 10:38:31 -0700

A lot of requests today are based around getting larger etherchannels
between switches to get more cross sectional bandwidth. If you use
etherchannels and TRILL ECMP together you have a way to build larger
connectivity between nodes.

Example

Max ECMP = 16 paths, etherchannel = 16 members, 256 total links

Question comes down to how much cross sectional bandwidth is enough?

Ian

Jeff Pickering wrote:
> ------------------------------------------------------------------------
>

---

From: Radia Perlman <[email-masked]>
Date: Thu, 30 Apr 2009 12:45:14 -0700

I can't think of any reason that IS-IS would preclude splitting on 
zillions of paths, and it wouldn't
affect any packet formats. It's just localized behavior, certainly as 
long as the paths are all
equal cost paths.

So it seems like all that's necessary is not to explicitly say that 
there is a limit to the number of choices
that an RBridge can choose.

And perhaps tweak the MIB not to explicitly preclude it as well.

I can't imagine why that limit was ever put in...I'm curious if anyone 
remembers what the reasoning was.
I don't remember it being there in DECnet.

Radia

---

From: "Anoop Ghanwani" <[email-masked]>
Date: Thu, 30 Apr 2009 17:32:43 -0700

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Ian Cox
> Sent: Thursday, April 30, 2009 10:39 AM
> To: Jeff Pickering
> Cc: [email-masked]
> Subject: Re: [rbridge] maximumPathSplits
> 

As with money, there is no such thing as enough bandwidth. :-D

> > Both 10589 and RFC4444 specify a max for maximumPathsSplits 
> of 32. In a
> > datacenter environment, I
> > am hearing requests for values much larger than this. Is 
> there any point
> > in trying to modify this? We are

What was the reason why this was limited to 32?
I don't see a similar variable for the FSPF (fabric
shortest path first) MIB.  I think it would make
sense to allow this to be more than 32.

Anoop