Subject: [rbridge] # of tree issues: default # of distribution trees, minimum acceptable supported # of trees

From: Radia Perlman <[email-masked]>
Date: Thu, 04 Jun 2009 13:58:33 -0700

Easy question: what do you prefer the default # of trees to calculate be?

Harder question: What is the minimum acceptable # of trees an implementation
is willing to compute? (this is currently not specified in the spec. 
Should it be?)

Ugly question: What happens if R3 can only support, say, 3 trees and
the highest priority guy specifies, say, 5 trees? There are various
potential answers to this:

a) if we ignore the question, it will go away
b) we should put "number of trees I support" into the LSP, and
the highest priority RBridge is not allowed to specify a number
greater than the minimum supported by any RBridge
c) require RBridges to support as many trees as the highest
priority RBridge demands
_______________________________________________
rbridge mailing list
[email-masked]
http://mailman.postel.org/mailman/listinfo/rbridge

---

From: Anoop Ghanwani <[email-masked]>
Date: Wed, 10 Jun 2009 14:40:11 -0700

The default number of trees should be 1.

I don't like (c) at all.

I would prefer that we go with the least capable
device's request; i.e. if even one RBridge says to 
compute only one tree, then only one tree should
get computed.

Anoop 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Radia Perlman
> Sent: Thursday, June 04, 2009 1:59 PM
> To: TRILL/RBridge Working Group
> Subject: [rbridge] # of tree issues: default # of 
> distribution trees, minimum acceptable supported # of trees
>

---

From: Dinesh G Dutt <[email-masked]>
Date: Wed, 10 Jun 2009 15:02:24 -0700

I don't like (c) at all. (b) is a fine solution and I believe it is 
already there.

I don't have a strong opinion on the min number of multicast trees that 
an Rbridge MUST support. But asking for anything more than 1 seems 
over-zealous,

Dinesh

-- 
We make our world significant by the courage of our questions and by 
the depth of our answers.                               - Carl Sagan

---

From: James Carlson <[email-masked]>
Date: Thu, 11 Jun 2009 09:37:18 -0400

> an Rbridge MUST support. But asking for anything more than 1 seems 

(b) sounds like the right answer, though it needs to be no greater
than the *maximum* supported by any RBridges (rather than the
minimum).

-- 
James Carlson, Solaris Networking              <[email-masked]>
Sun Microsystems / 35 Network Drive        71.232W   Vox +1 781 442 2084
MS UBUR02-212 / Burlington MA 01803-2757   42.496N   Fax +1 781 442 1677
_______________________________________________
rbridge mailing list
[email-masked]
http://mailman.postel.org/mailman/listinfo/rbridge