Subject: [rbridge] mib

From: "Jeff Pickering" <[email-masked]>
Date: Thu, 22 Oct 2009 07:08:18 -0700

Kate,

Glad to see this coming along! Just a couple of early comments.

- on read-only: I guess I should have responded earlier, but I do have some concerns here. Is there some
  way we can have both read-only and read-write? Like different levels of compliance?
- on isis mib: Ive already got requests for running both isis-l3 and trill. So I really think we need to replicate
  relevant isis objects under the rb-mib. If you are interested, I would be willing to hack on 4444 to come up with
  something matching your changes. This may also help get around issues with the isis-wg.

Jeff

_______________________________________________
rbridge mailing list
[email-masked]
http://mailman.postel.org/mailman/listinfo/rbridge

---

From: Kate Zebrose <[email-masked]>
Date: Thu, 22 Oct 2009 18:23:06 -0400

Jeff,

If you want to take on writing an isis subtree that would be helpful.  Thanks.

Regarding the read-only versus read-write I have been advised that
adding read-write entries makes the definition much more complicated
due to the security concerns.  I would like to get a read-only mib
completed before adding the read-write elements.

Kate

-- 
Kate Zebrose

STELLAR SWITCHES CONFIDENTIAL INFORMATION

---

From: "Jeff Pickering" <[email-masked]>
Date: Fri, 23 Oct 2009 10:09:33 -0700

Kate, 

I'd be happy to volunteer for this, but I'd like some consensus that this is
The right approach before diving in.

Jeff

-----Original Message-----
From: Kate Zebrose [mailto:[email-masked]] 
Sent: Thursday, October 22, 2009 6:23 PM
To: Jeff Pickering
Cc: [email-masked]; Thomas Nadeau; Donald Eastlake 3
Subject: Re: [rbridge] mib

Jeff,

Kate

-- 
Kate Zebrose

---

From: Caitlin Bestler <[email-masked]>
Date: Thu, 29 Oct 2009 21:55:47 -0700

Two thoughts on the read-only issue:

1) MIBs are a nuisance, but any limitation to read-only should really  
be for reasons that are RBridge specific.
      If the equivalent MIBs for a router, or a Bridge, are writable  
then the RBridge MIB should be writable as well.
      A general shift to read-only MIBs should be an IETF discussion,  
or perhaps tsvwg, not RBridge.

2) That said, information in the MIB that is derived from Bridge  
controls, ISIS or RBridge discovery where nothing
      in the protocol mandates that this field be configurable then an  
argument can be made that the MIB should
      not create the requirement that this information be editable  
just because it is in a MIB.

--
Caitlin Bestler
[email-masked]
http://www.asomi.com/CaitlinBestlerResume.html