Subject: Re: [rbridge] rbridge Digest, Vol 83, Issue 2 ESADI and end station learning

From: ROPITAL Guillaume <[email-masked]>
Date: Thu, 7 Apr 2011 10:54:00 +0200

I'm working on the rbridge draft and I'm asking myself this question about ESADI protocol:

How does the Rbridge populate it's MAC address table of local destinations while running ESADI protocol?

Is it a standard MAC address learning, by watching source MAC/VLAN addresses, or a particular protocol running to populate MAC address table?  

I haven't found these informations on the protocol draft nor in other documents

Regards

Guillaume

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de [email-masked]
Envoyé : mercredi 6 avril 2011 21:00
À : [email-masked]
Objet : rbridge Digest, Vol 83, Issue 2

Send rbridge mailing list submissions to
	[email-masked]

To subscribe or unsubscribe via the World Wide Web, visit
	http://mailman.postel.org/mailman/listinfo/rbridge
or, via email, send a message with subject or body 'help' to
	[email-masked]

You can reach the person managing the list at
	[email-masked]

When replying, please edit your Subject line so it is more specific
than "Re: Contents of rbridge digest..."

Today's Topics:

   1. Re: TRILL WG last call on draft-ietf-trill-adj (Jon Hudson)
   2. Fwd: New Version Notification for
      draft-perlman-trill-rbridge-multilevel-02 (Donald Eastlake)
   3.  TRILL WG last call on draft-ietf-trill-adj
      ([email-masked])
   4. Re: TRILL WG last call on draft-ietf-trill-adj (Vishwas Manral)
   5. Re: TRILL WG last call on draft-ietf-trill-adj (Yizhou Li)
   6. Re: TRILL WG last call on draft-ietf-trill-adj (Dinesh Dutt)
   7. Re: TRILL WG last call on draft-ietf-trill-adj (Jon Hudson)

----------------------------------------------------------------------

Message: 1
Date: Tue, 5 Apr 2011 13:02:55 -0700
From: Jon Hudson <[email-masked]>
Subject: Re: [rbridge] TRILL WG last call on draft-ietf-trill-adj
To: "[email-masked]" <[email-masked]>
Message-ID: <[email-masked]>
Content-Type: text/plain;	charset=us-ascii

Reviewing; No issues
.

On Apr 5, 2011, at 11:09 AM, "Erik Nordmark" <[email-masked]> wrote:

> 
> We've received last call comments from a few people, and as a result the 
> draft has been revised over the last three months, and we've also 
> created draft-perlman-trill-rbridge-af-00.txt with some separate 
> clarifications.
> 
> BUT I'd like to make sure we have sufficient number of reviewers for 
> draft-ietf-trill-adj. If you've read it during the last call process 
> (whether the -01 we started with, the most recent -05, or a version in 
> between), please send a note to the mailing list.
> Please do this even if you didn't find any issues with the document.
> 
> Thanks,
>     Erik
> 
> _______________________________________________
> rbridge mailing list
> [email-masked]
> http://mailman.postel.org/mailman/listinfo/rbridge

------------------------------

Message: 2
Date: Tue, 5 Apr 2011 19:16:33 -0400
From: Donald Eastlake <[email-masked]>
Subject: [rbridge] Fwd: New Version Notification for
	draft-perlman-trill-rbridge-multilevel-02
To: [email-masked]
Message-ID: <BANLkTikgbApzXZLh4A17_=[email-masked]>
Content-Type: text/plain; charset=ISO-8859-1

---------- Forwarded message ----------
From: IETF I-D Submission Tool <[email-masked]>
Date: Tue, Apr 5, 2011 at 4:43 PM
Subject: New Version Notification for
draft-perlman-trill-rbridge-multilevel-02

A new version of I-D, draft-perlman-trill-rbridge-multilevel-02.txt
has been successfully submitted and posted to the IETF repository.

Filename: ? ? ? ?draft-perlman-trill-rbridge-multilevel
Revision: ? ? ? ?02
Title: ? ? ? ? ? RBridges: Multilevel TRILL
Creation_date: ? 2011-04-05
WG ID: ? ? ? ? ? Independent Submission
Number_of_pages: 22

Abstract:
This is an informational document describing issues and comparing
advantages and disadvantages of various possible approaches to
extending TRILL to use multiple levels of IS-IS.

------------------------------

Message: 3
Date: Wed, 6 Apr 2011 02:53:20 +0200
From: [email-masked]
Subject: [rbridge]  TRILL WG last call on draft-ietf-trill-adj
To: Erik Nordmark <[email-masked]>
Cc: [email-masked], [email-masked], [email-masked]
Message-ID:
	<[email-masked]>
Content-Type: text/plain; charset="gb2312"

I've read the adjacency document(draft-ietf-trill-adj), and the document 
is fine.

Erik Nordmark <[email-masked]> 
??????:  [email-masked]
2011-04-05 19:51

??????
[email-masked], [email-masked]
????

????
[rbridge] TRILL WG last call on draft-ietf-trill-adj

We've received last call comments from a few people, and as a result the 
draft has been revised over the last three months, and we've also 
created draft-perlman-trill-rbridge-af-00.txt with some separate 
clarifications.

BUT I'd like to make sure we have sufficient number of reviewers for 
draft-ietf-trill-adj. If you've read it during the last call process 
(whether the -01 we started with, the most recent -05, or a version in 
between), please send a note to the mailing list.
Please do this even if you didn't find any issues with the document.

Thanks,
     Erik

_______________________________________________
rbridge mailing list
[email-masked]
http://mailman.postel.org/mailman/listinfo/rbridge

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.postel.org/pipermail/rbridge/attachments/20110406/d8aa8f60/attachment-0001.html

------------------------------

Message: 4
Date: Tue, 5 Apr 2011 19:15:15 -0700
From: Vishwas Manral <[email-masked]>
Subject: Re: [rbridge] TRILL WG last call on draft-ietf-trill-adj
To: Erik Nordmark <[email-masked]>
Cc: [email-masked], [email-masked]
Message-ID: <BANLkTi=[email-masked]>
Content-Type: text/plain; charset=ISO-8859-1

Looks great to me too!!!

-Vishwas

On Tue, Apr 5, 2011 at 10:51 AM, Erik Nordmark <[email-masked]> wrote:
>
> We've received last call comments from a few people, and as a result the
> draft has been revised over the last three months, and we've also
> created draft-perlman-trill-rbridge-af-00.txt with some separate
> clarifications.
>
> BUT I'd like to make sure we have sufficient number of reviewers for
> draft-ietf-trill-adj. If you've read it during the last call process
> (whether the -01 we started with, the most recent -05, or a version in
> between), please send a note to the mailing list.
> Please do this even if you didn't find any issues with the document.
>
> Thanks,
> ? ? Erik
>
> _______________________________________________
> rbridge mailing list
> [email-masked]
> http://mailman.postel.org/mailman/listinfo/rbridge
>

------------------------------

Message: 5
Date: Wed, 06 Apr 2011 10:58:10 +0800
From: Yizhou Li <[email-masked]>
Subject: Re: [rbridge] TRILL WG last call on draft-ietf-trill-adj
To: "'Erik Nordmark'" <[email-masked]>, [email-masked],
	[email-masked]
Message-ID: <032001cbf406$76fbddb0$64f39910$@com>
Content-Type: text/plain; charset=us-ascii

I am fine with -05.

Yizhou

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Erik Nordmark
Sent: Wednesday, April 06, 2011 1:51 AM
To: [email-masked]; [email-masked]
Subject: [rbridge] TRILL WG last call on draft-ietf-trill-adj

We've received last call comments from a few people, and as a result the 
draft has been revised over the last three months, and we've also 
created draft-perlman-trill-rbridge-af-00.txt with some separate 
clarifications.

BUT I'd like to make sure we have sufficient number of reviewers for 
draft-ietf-trill-adj. If you've read it during the last call process 
(whether the -01 we started with, the most recent -05, or a version in 
between), please send a note to the mailing list.
Please do this even if you didn't find any issues with the document.

Thanks,
     Erik

_______________________________________________
rbridge mailing list
[email-masked]
http://mailman.postel.org/mailman/listinfo/rbridge

------------------------------

Message: 6
Date: Wed, 06 Apr 2011 09:21:09 -0700
From: Dinesh Dutt <[email-masked]>
Subject: Re: [rbridge] TRILL WG last call on draft-ietf-trill-adj
To: [email-masked], [email-masked]
Message-ID: <[email-masked]>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed

I've read the draft and have no unresolved issues,

Dinesh
On 04/05/2011 10:51 AM, Erik Nordmark wrote:
> We've received last call comments from a few people, and as a result the
> draft has been revised over the last three months, and we've also
> created draft-perlman-trill-rbridge-af-00.txt with some separate
> clarifications.
>
> BUT I'd like to make sure we have sufficient number of reviewers for
> draft-ietf-trill-adj. If you've read it during the last call process
> (whether the -01 we started with, the most recent -05, or a version in
> between), please send a note to the mailing list.
> Please do this even if you didn't find any issues with the document.
>
> Thanks,
>       Erik
>
> _______________________________________________
> rbridge mailing list
> [email-masked]
> http://mailman.postel.org/mailman/listinfo/rbridge

------------------------------

Message: 7
Date: Wed, 6 Apr 2011 10:11:11 -0700
From: Jon Hudson <[email-masked]>
Subject: Re: [rbridge] TRILL WG last call on draft-ietf-trill-adj
To: "[email-masked]" <[email-masked]>
Message-ID: <[email-masked]>
Content-Type: text/plain;	charset=us-ascii

Reviewing. No issues.

On Apr 5, 2011, at 11:09 AM, "Erik Nordmark" <[email-masked]> wrote:

> 
> We've received last call comments from a few people, and as a result the 
> draft has been revised over the last three months, and we've also 
> created draft-perlman-trill-rbridge-af-00.txt with some separate 
> clarifications.
> 
> BUT I'd like to make sure we have sufficient number of reviewers for 
> draft-ietf-trill-adj. If you've read it during the last call process 
> (whether the -01 we started with, the most recent -05, or a version in 
> between), please send a note to the mailing list.
> Please do this even if you didn't find any issues with the document.
> 
> Thanks,
>     Erik
> 
> _______________________________________________
> rbridge mailing list
> [email-masked]
> http://mailman.postel.org/mailman/listinfo/rbridge

------------------------------

_______________________________________________
rbridge mailing list
[email-masked]
http://mailman.postel.org/mailman/listinfo/rbridge

End of rbridge Digest, Vol 83, Issue 2
**************************************

_______________________________________________
rbridge mailing list
[email-masked]
http://mailman.postel.org/mailman/listinfo/rbridge

---

From: James Carlson <[email-masked]>
Date: Thu, 07 Apr 2011 07:37:18 -0400

> I haven't found these informations on the protocol draft nor in other documents

ESADI is an optional feature that allows you to communicate end station
addresses if you have information about them that is separate from or in
addition to ordinary bridge learning.  For example, an 802.11 AP might
use it to advertise a list of registered local nodes.  Or a bridge might
allow local configuration of certain links whose learned address should
be copied into ESADI, such as links to important servers within the
broadcast domain.

It's just a mechanism.  How it's used in a given implementation is, I
think, mostly up to the implementer.

-- 
James Carlson         42.703N 71.076W         <[email-masked]>
_______________________________________________
rbridge mailing list
[email-masked]
http://mailman.postel.org/mailman/listinfo/rbridge

---

From: Anoop Ghanwani <[email-masked]>
Date: Thu, 7 Apr 2011 09:31:36 -0700

> Is it a standard MAC address learning, by watching source MAC/VLAN addresses, or a particular protocol running to populate MAC address table?

It could use any mechanism that a regular bridge would use to
learn those addresses -- standard MAC address learning, or
a protocol such as 802.1X.
_______________________________________________
rbridge mailing list
[email-masked]
http://mailman.postel.org/mailman/listinfo/rbridge

---

From: Vishwas Manral <[email-masked]>
Date: Thu, 7 Apr 2011 09:25:41 -0700

Hi Guillaume,

You can learn the addresses exchanged in ESADI by doing standard learning.

Thanks,
Vishwas

On Thu, Apr 7, 2011 at 1:54 AM, ROPITAL Guillaume <
[email-masked]> wrote:
> Is it a standard MAC address learning, by watching source MAC/VLAN
addresses, or a particular protocol running to populate MAC address table?

---

From: Anoop Ghanwani <[email-masked]>
Date: Thu, 7 Apr 2011 12:18:57 -0700

I had sent this to the list, but didn't see it.

---------- Forwarded message ----------
From: Anoop Ghanwani <[email-masked]>
Date: Thu, Apr 7, 2011 at 9:31 AM
Subject: Re: [rbridge] rbridge Digest, Vol 83, Issue 2 ESADI and end
station learning
To: ROPITAL Guillaume <[email-masked]>
Cc: "[email-masked]" <[email-masked]>