Subject: [trill] Question of TRILL header definition in "draft-ietf-fine-labeling-01"

From: Linda Dunbar <[email-masked]>
Date: Tue, 10 Jul 2012 19:38:25 +0000

Donald,

The Figure 2  in RFC 6325 shows that "TRILL Header" and "Inner Ethernet Header" are two separate fields. The Figure 5 of RFC6325 continues the view with "TRILL Header"  only including the fields of:

But on page 5 of  "draft-ietf-fine-labeling-01", the TRILL frame figure implies that TRILL Header includes the "Inner.MacDA" and "Inner.MacSA".

does the "Native Payload" in this figure include "Inner MAC-DA" and "inner MAC-SA"?

Thanks,
Linda Dunbar

---

From: Donald Eastlake <[email-masked]>
Date: Tue, 10 Jul 2012 21:44:07 -0400

Hi Linda,

On Tue, Jul 10, 2012 at 3:38 PM, Linda Dunbar <[email-masked]>wrote:

>  Donald, ****
>
> ** **
>
> The Figure 2  in RFC 6325 shows that “TRILL Header” and “Inner Ethernet
> Header” are two separate fields. The Figure 5 of RFC6325 continues the view
> with “TRILL Header”  only including the fields of:****
>
> ****
>
> ** **
>
> But on page 5 of  “draft-ietf-fine-labeling-01”, the TRILL frame figure
> implies that TRILL Header includes the “Inner.MacDA” and “Inner.MacSA”. **
> **
>
> ** **
>
> ** **
>
> does the “Native Payload” in this figure include “Inner MAC-DA” and “inner
> MAC-SA”?
>

No.

RFC 6325, the current IETF base protocol standard takes an IETF
"encapsulation" point of view. The current fine grained labeling draft
takes a more "sequence of tags" point of view. However, there is no
difference in the bits on the wire or behavior between the two. Just a
mental move of the end of the TRILL Header.

Thanks,
Donald
=============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA
 [email-masked]

> Thanks, ****
> Linda Dunbar****