Subject: Re: [trill] Call for WG adoption of draft-mizrahi-trill-loss-delay

From: Linda Dunbar <[email-masked]>
Date: Thu, 17 Oct 2013 19:27:42 +0000

RFC6374 has defined loss delay measurement for MPLS network. I think that TRILL should utilize the same message format. 

In particular, the loss count should include octet and delay should include time stamp, as defined by RFC6374: 
3.3.  Combined Loss/Delay Measurement Message Format & 
3.4.  Timestamp Field Formats

Linda

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Donald Eastlake
> Sent: Tuesday, September 03, 2013 9:57 PM
> To: [email-masked]
> Subject: [trill] Call for WG adoption of draft-mizrahi-trill-loss-delay
> 
> This is a call for WG comment on adopting
> draft-mizrahi-trill-loss-delay-01.txt as a TRILL WG draft. Please
> respond within two weeks. Comments suggesting improvements in the
> draft will, unless they say otherwise, be interpreted as favoring WG
> adoption.
> 
> Thanks,
> Donald, Co-Chair
> =============================
>  Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
>  155 Beaver Street, Milford, MA 01757 USA
>  [email-masked]
> _______________________________________________
> trill mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/trill

---

From: Tal Mizrahi <[email-masked]>
Date: Sat, 19 Oct 2013 23:13:23 +0200

Hi Linda,

Thanks for the feedback.
You are basically suggesting to rewrite the document.

As we know, there is more than one way to do performance monitoring. Even in MPLS-TP, in parallel to RFC6374/6375 there is also the ITU-T G.8113.1 (previously known as draft-bhh), which is based on ITU-T Y.1731. Both PM solutions for MPLS-TP address the same problem statement, yet each suggests a different solution.
As for TRILL, we chose to seek OAM tools that are as similar as possible to Ethernet OAM (IEEE 802.1ag and ITU-T Y.1731), in the hope that there could be some reuse with some of the mechanisms that were already defined or are being defined in 802.1. I believe this concept was presented and discussed in the TRILL WG quite a long time ago, and (it was my personal understanding that) the working group agreed on it.

Thanks,
Tal.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Linda Dunbar
Sent: Thursday, October 17, 2013 10:28 PM
To: Donald Eastlake; [email-masked]
Subject: Re: [trill] Call for WG adoption of draft-mizrahi-trill-loss-delay

In particular, the loss count should include octet and delay should include time stamp, as defined by RFC6374: 
3.3.  Combined Loss/Delay Measurement Message Format & 3.4.  Timestamp Field Formats

Linda

>  155 Beaver Street, Milford, MA 01757 USA  [email-masked]