Subject: [trill] WG notes

From: "Susan Hares" <[email-masked]>
Date: Thu, 27 Mar 2014 17:28:04 -0400

Attached are my minutes. Please send comments to me, and I will fix. 

Sue Hares

---

From: Mingui Zhang <[email-masked]>
Date: Fri, 28 Mar 2014 02:37:43 +0000

Hi Sue,

I found the mic did not record very well. Let me provide some notes FYI.

<notes>
draft-zhang-trill-aa-multi-attach-00
[draft-slides-trill-4.ppt [Audio: 1:05 - 1:17]
Discussion:
Tissa: I do not understand MAC information with a Data label - with the
claim that it does not need hardware. Can you please explain this point?
*Mingui*: The draft is now the starting point with suggestions asking
for discussion and help, rather than a detail solution. 

Tissa: If you are not addressing this in the draft, I do not understand how 
this works. Can you please help me understand this?
*Mingui*: Basically, the data label has to be configured per MC-LAG
in an Active/Active Edge group, so that it can be used to distinguish MC-LAGs.

Tissa: What is the definition of your data label?
*Mingui*: The data label is the Fined Grained Label/VLAN. 

......

Weiguo: How does the root RBRIDGE learn that a CMAC is associated
with multiple Ingress Rbridges ? Is it through the control plane or through
the data plane.
*Mingui*: It depends. If the remote RBridge chooses to store multiple locations
at the ESADI-LSDB while install only one location into the data plane.
Then it doesn't require new silicon. If the remote Rbridge chooses to store
the multiple locations at the data plane, it needs new hardware. 
</notes>

Thanks,
Mingui

>-----Original Message-----
>From: trill [mailto:[email-masked]] On Behalf Of Susan Hares
>Sent: Friday, March 28, 2014 5:28 AM
>To: [email-masked]
>Cc: Donald Eastlake; [email-masked]
>Subject: [trill] WG notes
>

---

From: "Susan Hares" <[email-masked]>
Date: Fri, 28 Mar 2014 07:50:19 -0400

Mingui:

Thank you for the update. I will revise the notes.  

Sue 

-----Original Message-----
From: Mingui Zhang [mailto:[email-masked]] 
Sent: Thursday, March 27, 2014 10:38 PM
To: Susan Hares; [email-masked]
Cc: Donald Eastlake; [email-masked]
Subject: RE: [trill] WG notes

Hi Sue,

<notes>
draft-zhang-trill-aa-multi-attach-00
[draft-slides-trill-4.ppt [Audio: 1:05 - 1:17]
Discussion:
Tissa: I do not understand MAC information with a Data label - with the
claim that it does not need hardware. Can you please explain this point?
*Mingui*: The draft is now the starting point with suggestions asking for
discussion and help, rather than a detail solution. 

Tissa: If you are not addressing this in the draft, I do not understand how
this works. Can you please help me understand this?
*Mingui*: Basically, the data label has to be configured per MC-LAG in an
Active/Active Edge group, so that it can be used to distinguish MC-LAGs.

......

Weiguo: How does the root RBRIDGE learn that a CMAC is associated with
multiple Ingress Rbridges ? Is it through the control plane or through the
data plane.
*Mingui*: It depends. If the remote RBridge chooses to store multiple
locations at the ESADI-LSDB while install only one location into the data
plane.
Then it doesn't require new silicon. If the remote Rbridge chooses to store
the multiple locations at the data plane, it needs new hardware. 
</notes>

Thanks,
Mingui

---

From: "Tissa Senevirathne (tsenevir)" <[email-masked]>
Date: Fri, 28 Mar 2014 15:08:37 +0000

Few more additions below see notes from [Tissa]

-----Original Message-----
From: trill [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Friday, March 28, 2014 4:50 AM
To: 'Mingui Zhang'; [email-masked]
Cc: 'Donald Eastlake'; [email-masked]
Subject: Re: [trill] WG notes

Mingui:

Sue 

-----Original Message-----
From: Mingui Zhang [mailto:[email-masked]]
Sent: Thursday, March 27, 2014 10:38 PM
To: Susan Hares; [email-masked]
Cc: Donald Eastlake; [email-masked]
Subject: RE: [trill] WG notes

Hi Sue,

<notes>
draft-zhang-trill-aa-multi-attach-00
[draft-slides-trill-4.ppt [Audio: 1:05 - 1:17]
Discussion:
Tissa: I do not understand MAC information with a Data label - with the claim that it does not need hardware. Can you please explain this point?
*Mingui*: The draft is now the starting point with suggestions asking for discussion and help, rather than a detail solution. 

Tissa: If you are not addressing this in the draft, I do not understand how this works. Can you please help me understand this?
*Mingui*: Basically, the data label has to be configured per MC-LAG in an Active/Active Edge group, so that it can be used to distinguish MC-LAGs.

Notes from Tissa

[Tissa] In that case I do not understand how you are claiming the solution is hardware independent

[John] Yes sounds like pre-mature and need more investigation.
......

Weiguo: How does the root RBRIDGE learn that a CMAC is associated with multiple Ingress Rbridges ? Is it through the control plane or through the data plane.
*Mingui*: It depends. If the remote RBridge chooses to store multiple locations at the ESADI-LSDB while install only one location into the data plane.
Then it doesn't require new silicon. If the remote Rbridge chooses to store the multiple locations at the data plane, it needs new hardware. 
</notes>

Thanks,
Mingui

>Attached are my minutes. Please send comments to me, and I will fix.

_______________________________________________
trill mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/trill

---

From: "Susan Hares" <[email-masked]>
Date: Fri, 28 Mar 2014 11:36:52 -0400

Tissa:

Thank you for the corrections.  It's really helpful.

Sue 

-----Original Message-----
From: trill [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Friday, March 28, 2014 4:50 AM
To: 'Mingui Zhang'; [email-masked]
Cc: 'Donald Eastlake'; [email-masked]
Subject: Re: [trill] WG notes

Mingui:

Sue 

-----Original Message-----
From: Mingui Zhang [mailto:[email-masked]]
Sent: Thursday, March 27, 2014 10:38 PM
To: Susan Hares; [email-masked]
Cc: Donald Eastlake; [email-masked]
Subject: RE: [trill] WG notes

Hi Sue,

<notes>

Notes from Tissa

[Tissa] In that case I do not understand how you are claiming the solution
is hardware independent

Thanks,
Mingui

---

From: Mingui Zhang <[email-masked]>
Date: Sat, 29 Mar 2014 01:12:15 +0000

Hi Tissa,

Thanks for your comments. Actually, three suggestions had been made
in the 01 version. For option C, it's possible to make the proposal
hardware independent using ESADI protocol.

I have moved on to stage 2 to design the detail. Will work together with
coauthors and come up with a new version very soon.

Thanks,
Mingui

>Sent: Friday, March 28, 2014 11:09 PM
>To: Susan Hares; Mingui Zhang; [email-masked]
>Tissa: I do not understand MAC information with a Data label - with the claim
>that it does not need hardware. Can you please explain this point?
>Tissa: If you are not addressing this in the draft, I do not understand how this
>works. Can you please help me understand this?
>multiple Ingress Rbridges ? Is it through the control plane or through the data
>plane.
>Then it doesn't require new silicon. If the remote Rbridge chooses to store the
>multiple locations at the data plane, it needs new hardware.
></notes>
>
>Thanks,
>Mingui
>
>
>