Subject: [trill] comments on draft-dunbar-trill-directory-assisted-encap-06:

From: "Xialiang (Frank)" <[email-masked]>
Date: Thu, 13 Mar 2014 02:29:19 +0000

Hi Authors:
I think this draft provides a easily scalable trill solution in large-scale virtualized data center based on directory service mechanism. I also have some comments as followed:
1. Several typos:
1) At page header: Chaining Legacy Layer 4-7 SF;
2) FDB definition can be deleted for it's not used in the later draft;
3) Please check the draft for using the same consistent term -- "TRILL campus"

2. In section 3, the sentence "Under this scheme, an RBridge with multiple ports connected to a bridged LAN won't be encapsulated data packets what are received from the TRILL domain, decapsulated, forwarded to the bridged LAN via one port, and flooded back via another port." is not clear to me. Do you mean that by using directory assistance, RBridge won't flood the unknown unicast to the connected LAN via another port?

3. A general question: In the environment with complete directory information, does ingress and egress RBridges all need not flood the unknown unicast packets? If they cannot find the target mac, the just simply discard it?

Hoping for your feedback!

B.R.
Frank

---

From: Donald Eastlake <[email-masked]>
Date: Sat, 15 Mar 2014 23:12:14 -0400

Hi,

Thanks for you comments. See below

On 3/12/14, Xialiang (Frank) <[email-masked]> wrote:
> Hi Authors:
> I think this draft provides a easily scalable trill solution in large-scale
> virtualized data center based on directory service mechanism. I also have
> some comments as followed:
> 1. Several typos:

There will probably be a revised version posted ast some point with
things fixed up.

> 2. In section 3, the sentence "Under this scheme, an RBridge with multiple
> ports connected to a bridged LAN won't be encapsulated data packets what are
> received from the TRILL domain, decapsulated, forwarded to the bridged LAN
> via one port, and flooded back via another port." is not clear to me. Do you
> mean that by using directory assistance, RBridge won't flood the unknown
> unicast to the connected LAN via another port?

The sentence does seem to be a bit garbled. I think it is talking
about the possible problem of a multi-destination frame in a TRILL
Data packet being egressed through a TRILL switch onto to a bridged
LAN and then re-ingressed via some other TRILL switch port connected
to that bridged LAN.

> 3. A general question: In the environment with complete directory
> information, does ingress and egress RBridges all need not flood the unknown
> unicast packets? If they cannot find the target mac, the just simply discard
> it?

I think that if you actually have complete directory information, it
should never be necessary to flood ingressed unicast frames. If you
don't know the destination, you discard the framae.

If the "complete" directory information includes the TRILL switch port
by which a MAC is reachable, as well as just the TRILL switch by which
a MAC is reachable, then it seems to me you should not need to flood
on egress. You either output through the correct port or discard the
decapsulated frame.

> Hoping for your feedback!

Thanks,
Donald
=============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA
 [email-masked]

---

From: Linda Dunbar <[email-masked]>
Date: Sun, 16 Mar 2014 10:58:07 +0000

Frank,

Thank you very much for the comments.  Replies are inserted below:

From: trill [mailto:[email-masked]] On Behalf Of Xialiang (Frank)
Sent: Wednesday, March 12, 2014 9:29 PM
To: [email-masked]
Cc: [email-masked]
Subject: [trill] comments on draft-dunbar-trill-directory-assisted-encap-06:

Hi Authors:
I think this draft provides a easily scalable trill solution in large-scale virtualized data center based on directory service mechanism. I also have some comments as followed:
1. Several typos:
1) At page header: Chaining Legacy Layer 4-7 SF;
[Linda] thanks for catching it.

[Linda] good catch.

[Linda] Is it better to call it “TRILL domain” or “TRILL campus”?

[Linda] Yes. The intent is to say that there won’t be a situation that packets received from TRILL domain are looped back to TRILL domain after decapsulation and flooded to the attached LAN.

[Linda] This draft doesn’t require egress RBridge to use directory. Therefore, egress RBridge will flood unknown unicast frames to its attached LAN.

Thanks, Linda

B.R.
Frank