Subject: [trill] active-active solution comparison question

From: "Tissa Senevirathne (tsenevir)" <[email-masked]>
Date: Fri, 7 Mar 2014 14:15:10 +0000

Hi Haoweguo

In your presentation you indicated  CMT scalability is Medium and Centralized replicator scalability is high. Can you please explain the reasoning behind this ?

Thanks
Tissa

---

From: Jon Hudson <[email-masked]>
Date: Fri, 7 Mar 2014 15:52:28 +0000

<rant>

In general if anyone in a presentation is going to make subjective qualitative statements about X is easier that Y, or Z is less complicated than W, or A is faster than B.

Please show your work/logic. 

These items are some of the most likely to upset folks, cause ego challenges etc. 

No where else can you make performance or complexity a compare value without giving a data reference. If you did that in front of a customer many would just laugh.

And do not to pick this case, as I have seen _much_ worse. But it's a good example because I think there was a very real attempt to be fair and open. I don't think there was a hidden agenda here as there sometimes is. And even with that good intention we end up with statements like:

CMT scalability = Medium
Centralized replication = High

That's marketing not engineering in my opinion. 

But most importantly it is inflammatory and not helpful in encouraging mature debate.

</rant> 

(If you really read this far, thank you)

J

> On Mar 7, 2014, at 2:15 PM, "Tissa Senevirathne (tsenevir)" <[email-masked]> wrote:
> 
> Hi Haoweguo
>  
>  
> _______________________________________________
> trill mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/trill

---

From: [email-masked]
Date: Fri, 7 Mar 2014 08:58:07 -0800

I agree with Jon. I like this statement from Dragnet "Just the facts
ma'am, nothing but the facts." And, although this is my opinion, I believe
that facts and examples are the easiest way to convince other people that
one has a valid point.
gayle

<rant>
In general if anyone in a presentation is going to make subjective
qualitative statements about X is easier that Y, or Z is less complicated
than W, or A is faster than B.

These items are some of the most likely to upset folks, cause ego
challenges etc.

No where else can you make performance or complexity a compare value
without giving a data reference. If you did that in front of a customer
many would just laugh.

And do not to pick this case, as I have seen _much_ worse. But it's a good
example because I think there was a very real attempt to be fair and open.
I don't think there was a hidden agenda here as there sometimes is. And
even with that good intention we end up with statements like:

CMT scalability = Medium

But most importantly it is inflammatory and not helpful in encouraging
mature debate.

</rant>

> In your presentation you indicated  CMT scalability is Medium and
> Centralized replicator scalability is high. Can you please explain the
> reasoning behind this ?
> Thanks
> Tissa

---

From: "Tissa Senevirathne (tsenevir)" <[email-masked]>
Date: Fri, 7 Mar 2014 23:24:20 +0000

We should not take our eyes away from key points. Like I stated during the meeting,

1. Active-active is one of the most important enhancements to TRILL, without that TRILL has no story in data centers
2. We started serious discussions of Active-Active in Taipei and now almost 3 years later we are still having the same discussion and no acceptable solution, which means we are at least 2 years late.

Fine print: OAM discussions also started in Taipei, during this time we have delivered, Requirement Document, Frame work document, Completed Liaison with IEEE 8021, Fault Management , Loss Delay drafts are on Last call and MIB document is a WG document. Active-Active still on discussion. (borrowing from John), if you have read this far it is no longer fine print, it is big bold letters that "we, as a working group have failed to deliver on active-active edge solution". Let's leave differences, theoretical discussions a side , let's get the work done.

-----Original Message-----
From: trill [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, March 07, 2014 8:58 AM
To: [email-masked]
Subject: Re: [trill] active-active solution comparison question

I agree with Jon. I like this statement from Dragnet "Just the facts ma'am, nothing but the facts." And, although this is my opinion, I believe that facts and examples are the easiest way to convince other people that one has a valid point.
gayle

<rant>

And do not to pick this case, as I have seen _much_ worse. But it's a good example because I think there was a very real attempt to be fair and open.
I don't think there was a hidden agenda here as there sometimes is. And even with that good intention we end up with statements like:

CMT scalability = Medium

</rant>
(If you really read this far, thank you) J

---

From: Jon Hudson <[email-masked]>
Date: Fri, 7 Mar 2014 23:55:02 +0000

+1  

> On Mar 7, 2014, at 11:24 PM, "Tissa Senevirathne (tsenevir)" <[email-masked]> wrote:
>

---

From: gayle noble <[email-masked]>
Date: Fri, 07 Mar 2014 19:11:14 -0800

Make that +2  Thank you Tissa!!

At 03:55 PM 3/7/2014, Jon Hudson wrote:
> > 1. Active-active is one of the most important enhancements to 
> TRILL, without that TRILL has no story in data centers
> > 2. We started serious discussions of Active-Active in Taipei and 
> now almost 3 years later we are still having the same discussion 
> and no acceptable solution, which means we are at least 2 years late.
> > Fine print: OAM discussions also started in Taipei, during this 
> time we have delivered, Requirement Document, Frame work document, 
> Completed Liaison with IEEE 8021, Fault Management , Loss Delay 
> drafts are on Last call and MIB document is a WG document. 
> Active-Active still on discussion. (borrowing from John), if you 
> have read this far it is no longer fine print, it is big bold 
> letters that "we, as a working group have failed to deliver on 
> active-active edge solution". Let's leave differences, theoretical 
> discussions a side , let's get the work done.
> >[email-masked]
> > I agree with Jon. I like this statement from Dragnet "Just the 
> facts ma'am, nothing but the facts." And, although this is my 
> opinion, I believe that facts and examples are the easiest way to 
> convince other people that one has a valid point.
> > gayle
> >
> > <rant>
> > In general if anyone in a presentation is going to make 
> subjective qualitative statements about X is easier that Y, or Z is 
> less complicated than W, or A is faster than B.
> > No where else can you make performance or complexity a compare 
> value without giving a data reference. If you did that in front of 
> a customer many would just laugh.
> > > And do not to pick this case, as I have seen _much_ worse. But 
> it's a good example because I think there was a very real attempt 
> to be fair and open.
> > I don't think there was a hidden agenda here as there sometimes 
> is. And even with that good intention we end up with statements like:
> > CMT scalability = Medium

---

From: Haoweiguo <[email-masked]>
Date: Tue, 11 Mar 2014 06:35:36 +0000

Hi Tissa and Jon,

Sorry, these two days i am in the flight, so i have just read your mail and reply slowly. Thanks for your comments!

The original description in the draft of "draft-hao-trill-analysis-active-active-02" that compares scalability between CMT,centralized replication and Tunneling among edge RBs is from the angle of distribution tree required

In CMT solution, it’s required to establish multiple distribution trees in a TRILL campus, i.e. if a CE is active-active accessed to 4 edge RBridges, at least 4 distribution trees are required.
In Tunneling among edge RBs solution, only one distribution tree is needed. In centralized replicaiton, ingress RB sends all BUM traffic to the centralized node, the centralized node replicated the traffic and sends each copy to all
other egress RBs through unicast TRILL encapsulation,no distribution tree is needed in whole TRILL campus(but i don't mean the solution is better than other two solutions, it has other shortcomings,such as it consumes more bandwidth. But in Tie-2 fat tree scenario, it doesn't need consume more network bandwidth, so it has its own applicable scenario.)

I agree with Jon's opinon, i should discribe more accurately about this point to reduce misunderstanding, scalability dimension camprison is more similar to marketing, not engineering. So i want to modify the scalability into "distribution tree required".
Assuming CE is active-active to N edge RBs, the comparison from "Distribution tree required" angle is as follows:

                                                     CMT                     Centralized replication     Tunneling among edge RBs

Distribution tree required                N                        0(alternative method)        1

All current solutions for TRILL active-active connection are all described in the draft of "draft-hao-trill-analysis-active-active-02", i think it can satisfy trill active-active requirements now.
Maybe some words or discription are not accurate, i can solicit all your experts opinon and revise that.

weiguo

________________________________

发件人: Jon Hudson [[email-masked]]
发送时间: 2014年3月7日 23:52
收件人: Tissa Senevirathne (tsenevir); [email-masked]
主题: Re: [trill] active-active solution comparison question

<rant>

CMT scalability = Medium

</rant>

J

On Mar 7, 2014, at 2:15 PM, "Tissa Senevirathne (tsenevir)" <[email-masked]<mailto:[email-masked]>> wrote:

Hi Haoweguo

Thanks
Tissa
_______________________________________________
trill mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/trill

---

From: Haoweiguo <[email-masked]>
Date: Tue, 11 Mar 2014 06:47:23 +0000

Hi Jon, Windy and Tissa,
I think TRILL active-active solutions have been fully discussed, in the draft of  "Analysis of Active-Active Connection Solutions" ,all related current solutions are discribed and it can satisfy the TRILL active-active connection scenario.
Based on this draft, we can discuss further to give further comparison between different parallel solutions, and give detail applicable scenarios.
thanks
weiguo

________________________________________
发件人: Jon Hudson [[email-masked]]
发送时间: 2014年3月8日 7:55
收件人: Tissa Senevirathne (tsenevir)
抄送: [email-masked]; [email-masked]
主题: Re: [trill] active-active solution comparison question

+1

---

From: Liyizhou <[email-masked]>
Date: Tue, 11 Mar 2014 08:44:22 +0000

OAM related work started from October 18, 2010 by draft-bond-trill-rbridge-oam-00 which turned into draft-ietf-trill-rbridge-oam later. Then TRILL WG reached consensus to start over from requirement, framework, etc.

Active-Active work also encounters re-writing the problem statement, requirement and online/offline multiple solutions debates. It is progressing.
There are multiple solutions available and analyzed in the document repository. 

I agree active-active is very important and should be given the highest priority currently in WG. 
So we should start on the technical discussion about how to make the whole solution work ASAP.

Yizhou

> From: trill [mailto:[email-masked]] On Behalf Of Tissa
> Senevirathne (tsenevir)
> Sent: Saturday, March 08, 2014 7:24 AM
> To: [email-masked]; [email-masked]
> 1. Active-active is one of the most important enhancements to TRILL,
> without that TRILL has no story in data centers 2. We started serious
> discussions of Active-Active in Taipei and now almost 3 years later we
> are still having the same discussion and no acceptable solution, which
> means we are at least 2 years late.
> 
> Fine print: OAM discussions also started in Taipei, during this time we
> have delivered, Requirement Document, Frame work document, Completed
> Liaison with IEEE 8021, Fault Management , Loss Delay drafts are on
> Last call and MIB document is a WG document. Active-Active still on
> discussion. (borrowing from John), if you have read this far it is no
> longer fine print, it is big bold letters that "we, as a working group
> have failed to deliver on active-active edge solution". Let's leave
> differences, theoretical discussions a side , let's get the work done.
> 
> ma'am, nothing but the facts." And, although this is my opinion, I
> believe that facts and examples are the easiest way to convince other
> people that one has a valid point.
> gayle
> 
> <rant>
> qualitative statements about X is easier that Y, or Z is less
> complicated than W, or A is faster than B.
> 
> And do not to pick this case, as I have seen _much_ worse. But it's a
> good example because I think there was a very real attempt to be fair
> and open.

---

From: Haoweiguo <[email-masked]>
Date: Tue, 11 Mar 2014 09:18:33 +0000

The draft "draft-hao-trill-analysis-active-active-02" lists all current possible solutions to solve TRILL active-active connection problems.  We may start from there.
Thanks
weiguo

________________________________________
发件人: Liyizhou [[email-masked]]
发送时间: 2014年3月11日 16:44
收件人: Tissa Senevirathne (tsenevir); [email-masked]; [email-masked]
主题: Re: [trill] active-active solution comparison question

Yizhou

---

From: [email-masked]
Date: Wed, 12 Mar 2014 09:33:10 +0800

This draft gives an analysis of the current solutions for TRILL 
active-active, I think it is useful for us to learn about the advantages 
and disadvantange of those solutions fastly and to analysize them 
objectively, although there is something required to be perfected. I hope 
it can become much more better in the next version.

Thanks,
Hongjun Zhai
---------------------------------------------
Add: No.68 Zijinghua Road, Yuhuatai District,
Nanjing City, R.P. China, 210012

Tel: +86 025 52877345
Email: [email-masked]
---------------------------------------------

Haoweiguo <[email-masked]> 
发件人:  "trill" <[email-masked]>
2014-03-11 17:18

收件人
Liyizhou <[email-masked]>, "Tissa Senevirathne (tsenevir)" 
<[email-masked]>, "[email-masked]" <[email-masked]>, 
"[email-masked]" <[email-masked]>
抄送

主题
[trill] 答复:  active-active solution comparison question

The draft "draft-hao-trill-analysis-active-active-02" lists all current 
possible solutions to solve TRILL active-active connection problems.  We 
may start from there.
Thanks
weiguo

________________________________________
发件人: Liyizhou [[email-masked]]
发送时间: 2014年3月11日 16:44
收件人: Tissa Senevirathne (tsenevir); [email-masked]; 
[email-masked]
主题: Re: [trill] active-active solution comparison question

OAM related work started from October 18, 2010 by 
draft-bond-trill-rbridge-oam-00 which turned into 
draft-ietf-trill-rbridge-oam later. Then TRILL WG reached consensus to 
start over from requirement, framework, etc.

Active-Active work also encounters re-writing the problem statement, 
requirement and online/offline multiple solutions debates. It is 
progressing.
There are multiple solutions available and analyzed in the document 
repository.

I agree active-active is very important and should be given the highest 
priority currently in WG.
So we should start on the technical discussion about how to make the whole 
solution work ASAP.

Yizhou

---

From: Donald Eastlake <[email-masked]>
Date: Tue, 11 Mar 2014 23:32:11 -0400

I agree that active-active is very important but, a while ago, the
TRILL WG decided that its two highest priority areas were Fine Grained
Labeling and OAM. We have completed Fine Grained Labeling. I have no
problem with the idea that Active-Active and OAM are now the highest
priority areas now.

Thanks,
Donald
=============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA
 [email-masked]

---

From: Mingui Zhang <[email-masked]>
Date: Wed, 12 Mar 2014 05:50:02 +0000

+1 support.

The problem statement itself did cost us some time. It's time to detail the solution(s).

Thanks,
Mingui

>From: trill [mailto:[email-masked]] On Behalf Of Donald Eastlake
>Sent: Wednesday, March 12, 2014 11:32 AM
>To: [email-masked]
>I agree that active-active is very important but, a while ago, the TRILL WG
>decided that its two highest priority areas were Fine Grained Labeling and OAM.
>We have completed Fine Grained Labeling. I have no problem with the idea that
>Active-Active and OAM are now the highest priority areas now.
>
>Thanks,
>Donald
> 155 Beaver Street, Milford, MA 01757 USA  [email-masked]
>
>
>discussions of Active-Active in Taipei and now almost 3 years later we are still
>having the same discussion and no acceptable solution, which means we are at
>least 2 years late.
>>
>> Fine print: OAM discussions also started in Taipei, during this time we have
>delivered, Requirement Document, Frame work document, Completed Liaison
>with IEEE 8021, Fault Management , Loss Delay drafts are on Last call and MIB
>document is a WG document. Active-Active still on discussion. (borrowing from
>John), if you have read this far it is no longer fine print, it is big bold letters that
>"we, as a working group have failed to deliver on active-active edge solution".
>Let's leave differences, theoretical discussions a side , let's get the work done.
>>
>> I agree with Jon. I like this statement from Dragnet "Just the facts ma'am,
>nothing but the facts." And, although this is my opinion, I believe that facts and
>examples are the easiest way to convince other people that one has a valid
>point.
>> gayle
>>
>> <rant>
>> In general if anyone in a presentation is going to make subjective qualitative
>statements about X is easier that Y, or Z is less complicated than W, or A is
>faster than B.
>>
>without giving a data reference. If you did that in front of a customer many
>would just laugh.
>>
>> I don't think there was a hidden agenda here as there sometimes is. And even
>with that good intention we end up with statements like:
>>
>> CMT scalability = Medium
>>> Centralized replicator scalability is high. Can you please explain
>>> the reasoning behind this ?
>>> Thanks
>>> Tissa
>>
>>

---

From: "Xialiang (Frank)" <[email-masked]>
Date: Thu, 13 Mar 2014 07:47:31 +0000

Agreed. Active-active is now becoming the hot issue in TRILL. 
My personal view, current problem statement and solution analysis drafts are all very good start covering all related problems. We can work together to improve these drafts and specify different solutions for different problems based on them.

B.R.
Frank

> decided that its two highest priority areas were Fine Grained Labeling and
> OAM. We have completed Fine Grained Labeling. I have no problem with the
> idea that Active-Active and OAM are now the highest priority areas now.
> 
> Thanks,
> Donald
> having the same discussion and no acceptable solution, which means we are
> at least 2 years late.
> >
> delivered, Requirement Document, Frame work document, Completed
> Liaison with IEEE 8021, Fault Management , Loss Delay drafts are on Last call
> and MIB document is a WG document. Active-Active still on discussion.
> (borrowing from John), if you have read this far it is no longer fine print, it is
> big bold letters that "we, as a working group have failed to deliver on
> active-active edge solution". Let's leave differences, theoretical discussions a
> side , let's get the work done.
> >
> nothing but the facts." And, although this is my opinion, I believe that facts
> and examples are the easiest way to convince other people that one has a
> valid point.
> > gayle
> >
> > <rant>
> qualitative statements about X is easier that Y, or Z is less complicated than W,
> or A is faster than B.
> >