Subject: [trill] Poll for WG adoption of draft-zhang-trill-aa-multi-attach

From: Donald Eastlake <[email-masked]>
Date: Tue, 8 Jul 2014 00:30:12 -0400

This message starts a poll for adoption of
draft-zhang-trill-aa-multi-attach-04 as a TRILL WG draft. This poll
will run through the TRILL WG meeting later this month in Toronto.
Suggestions for improvement in the draft will, unless otherwise
stated, be assumed to favor adoption.

Thanks,
Donald
=============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA
 [email-masked]

---

From: "Zhangxudong (zhangxudong, VRP)" <[email-masked]>
Date: Fri, 11 Jul 2014 05:00:45 +0000

I have read this draft. It solves the MAC flip-flop issue at the control plane. 
It does not rely on new hardware. The solution looks implementable. Support as an implementer.

-----邮件原件-----
发件人: trill [mailto:[email-masked]] 代表 Donald Eastlake
发送时间: 2014年7月8日 12:30
收件人: [email-masked]
主题: [trill] Poll for WG adoption of draft-zhang-trill-aa-multi-attach

This message starts a poll for adoption of
draft-zhang-trill-aa-multi-attach-04 as a TRILL WG draft. This poll will run through the TRILL WG meeting later this month in Toronto.
Suggestions for improvement in the draft will, unless otherwise stated, be assumed to favor adoption.

Thanks,
Donald
=============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA  [email-masked]

_______________________________________________
trill mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/trill

---

From: Sujay Gupta <[email-masked]>
Date: Mon, 14 Jul 2014 17:53:40 +0530

Support this as a co-author and implementer.
Regds,
-Sujay

---

From: Donald Eastlake <[email-masked]>
Date: Tue, 15 Jul 2014 13:05:08 -0400

Active-active is an important effort for TRILL in high demand by
customers who want better service at the campus edge. Speaking as a
participant in the WG, I support adoption of this draft. The wording
should be changed to be more consistent with
draft-ietf-trill-active-active-connection-prob. (The method in this
document optionally works with draft-ietf-trill-easdi, currently in
the RFC Editor queue for publication.)

Thanks,
Donald

---

From: Haoweiguo <[email-masked]>
Date: Thu, 17 Jul 2014 00:58:26 +0000

Support. MAC learning in this draft relies on control plane rather than data plane, it is useful in some cases.
This mechanism also are briefly described in "Analysis of Active-Active Connection Solutions".
Thanks
weiguo
________________________________________
发件人: Donald Eastlake [[email-masked]]
发送时间: 2014年7月16日 1:05
收件人: [email-masked]
主题: Re: [trill] 答复: Poll for WG adoption of draft-zhang-trill-aa-multi-attach

Thanks,
Donald

---

From: Donald Eastlake <[email-masked]>
Date: Mon, 21 Jul 2014 15:06:10 -0400

Hi,

Based on the mailing list and the meeting today, this draft is adopted
as a TRILL WG draft.

The plan is to repost this draft as an WG draft with minimum changes
and then work on updating and improving it.

Thanks,
Donald and Jon

---

From: [email-masked]
Date: Mon, 21 Jul 2014 19:46:11 +0800

Hi authors,

 I have some questions about this draft：

1、How to check all the RBs'MC-LAG-GROUP-RBRIDGES tlvs are received by 
remote RBs？

2、If the MC-LAG-GROUP-RBRIDGES tlvs of one member are lost, the remote RB 
how to install the MAC tabel will have issues.

3、Section 5.5, load balance on remote RB, does the fib on the hardware 
only install one entry？Then how to differ the flip-flop if it can be 
randomly selected.

4、As shown in Figure 3.1, RB1/RB2/RB3 learn the MAC of H1-4, if each RB 
in the same MC-LAG has to advertise the MC-LAG-GROUP-MAC tlv, 
   it seems unnecessary and adds the difficulty of RB4's control plane 
processing; alternatively, we could let only one RB advertises the 
MC-LAG-GROUP-MAC tlv, 
   as described in question 2, how to install the MAC table arises. 

Thanks&BR.
Ting

---

From: Mingui Zhang <[email-masked]>
Date: Tue, 22 Jul 2014 19:50:32 +0000

Hi Ting

Thanks for the comments. Please find the responses inline.

Mingui

From: trill [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, July 21, 2014 7:46 PM
To: [email-masked]; trill
Subject: Re: [trill] Poll for WG adoption of draft-zhang-trill-aa-multi-attach

Hi authors,

1、How to check all the RBs'MC-LAG-GROUP-RBRIDGES tlvs are received by remote RBs？

2、If the MC-LAG-GROUP-RBRIDGES tlvs of one member are lost, the remote RB how to install the MAC tabel will have issues.

[Mingui] These TLVs are carried in ISIS LSPs and ISIS provides the _reliable_ flooding to its peers. As we know, PSNP and CSNP are designed for this purpose.

3、Section 5.5, load balance on remote RB, does the fib on the hardware only install one entry？

[Mingui] Yes, it does.

Then how to differ the flip-flop if it can be randomly selected.

[Mingui] Exactly, it is a pseudo-random selection method (See bullet 1, Section 5.3 of draft-ietf-trill-esadi-09 ). For this method, the output (i.e., the egress RBridge) for each MACx  at a specific ingress RBridge is unique. This is why we don’t worry about the flip-flop. Having said that, for different MACx in a specific DL, the egress RBridge can be different. So the load balance is achieved.

4、As shown in Figure 3.1, RB1/RB2/RB3 learn the MAC of H1-4, if each RB in the same MC-LAG has to advertise the MC-LAG-GROUP-MAC tlv,
   it seems unnecessary and adds the difficulty of RB4's control plane processing; alternatively, we could let only one RB advertises the MC-LAG-GROUP-MAC tlv,

[Mingui] Due to the hashing function, MACx may only be learned by a unique receiver RBridge rather than all of them. So each RBridge has to advertise the MC-LAG-GROUP-MAC tlv. For those MACy that has already been advertised, implementations could let only one member RBridge to advertise it. But it will undermine the reliability and introduce the complexity on the selection of the one RBridge.

This is actually not new for this draft. For a MACz which is attached to multiple edge RBridges, the plain ESADI will let those multiple edge RBridges advertise it as well.

[Mingui] I think this issue had been cleared  above.

Thanks&BR.
Ting