Subject: [trill] review of Trill over UDP/IP

From: Zongning <[email-masked]>
Date: Tue, 15 Jul 2014 00:40:52 +0000

Hi, folks,

(Re-send after subscription, sorry for potentially duplicated message...)

I've briefly reviewed the draft mainly from transport consideration's perspective, and have a question on congestion control.
It says "When a TRILL over IP flow carries primarily IP-based traffic, the aggregate traffic is assumed to be TCP friendly... and no additional congestion avoidance action is necessary". I'd like to see more discussion about whether the adoption of UDP encapsulation by RBridges between the end-hosts will negate such conclusion? Another word, even if the end-hosts use TCP for congestion control, should there be some congestion consideration between the RBridges that talk UDP?
Plus, I'd know the reason why choosing UDP? I cannot find any in the draft - but I am sure there are reasons discussed in the group. :)

Sorry if I misunderstood any point, and thanks for your clarification in advance!

-Ning

---

From: Donald Eastlake <[email-masked]>
Date: Tue, 15 Jul 2014 03:52:16 -0400

Hi,

On Mon, Jul 14, 2014 at 8:40 PM, Zongning <[email-masked]> wrote:
> Hi, folks,
>
> (Re-send after subscription, sorry for potentially duplicated message…)
>
> I’ve briefly reviewed the draft mainly from transport consideration’s
> perspective, and have a question on congestion control.
>
> It says “When a TRILL over IP flow carries primarily IP-based traffic, the
> aggregate traffic is assumed to be TCP friendly… and no additional
> congestion avoidance action is necessary”. I’d like to see more discussion
> about whether the adoption of UDP encapsulation by RBridges between the
> end-hosts will negate such conclusion? Another word, even if the end-hosts
> use TCP for congestion control, should there be some congestion
> consideration between the RBridges that talk UDP?

Congestion control has been a very active area of discussion for other
drafts. The congestion control text in the current version of
draft-ietf-trill-over-ip was just copied with minor edits from an
earlier version of draft-ietf-mpls-in-udp. That mpls draft has since
been updated with substantial changes to its congestion section so I'm
sure some work will be needed here.

> Plus, I’d know the reason why choosing UDP? I cannot find any in the draft –
> but I am sure there are reasons discussed in the group. :-)

This was discussed at IETF 89 and the consensus there was confirmed on
the mailing list. See
http://www.ietf.org/mail-archive/web/trill/current/msg06206.html
You could look at the minutes at
http://www.ietf.org/proceedings/89/minutes/minutes-89-trill or listen
to the audio recording.

Thanks,
Donald
=============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA
 [email-masked]

> _______________________________________________
> trill mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/trill
>

---

From: Zongning <[email-masked]>
Date: Tue, 15 Jul 2014 09:00:06 +0000

Hi, Donald,

Thank you for the prompt reply. Please see inline.

-----邮件原件-----
发件人: Donald Eastlake [mailto:[email-masked]] 
发送时间: 2014年7月15日 15:52
收件人: Zongning
抄送: [email-masked]
主题: Re: [trill] review of Trill over UDP/IP

Hi,

On Mon, Jul 14, 2014 at 8:40 PM, Zongning <[email-masked]> wrote:
> It says “When a TRILL over IP flow carries primarily IP-based traffic, 
> the aggregate traffic is assumed to be TCP friendly… and no additional 
> congestion avoidance action is necessary”. I’d like to see more 
> discussion about whether the adoption of UDP encapsulation by RBridges 
> between the end-hosts will negate such conclusion? Another word, even 
> if the end-hosts use TCP for congestion control, should there be some 
> congestion consideration between the RBridges that talk UDP?

Congestion control has been a very active area of discussion for other drafts. The congestion control text in the current version of draft-ietf-trill-over-ip was just copied with minor edits from an earlier version of draft-ietf-mpls-in-udp. That mpls draft has since been updated with substantial changes to its congestion section so I'm sure some work will be needed here.

[Ning] Then I'd suggest to add reference to [RFC5405] "Unicast UDP Usage Guidelines for Application Designers", which provides several cases in 3.1.3 about whether the UDP tunnel user should consider additional congestion control mechanism or not. Moreover, similar to draft-ietf-mpls-in-udp, I think it would be beneficial to add some brief text to clarify which case(s) in [RFC5405] that the draft-ietf-trill-over-ip belongs to, based on the specific features (if any) of Trill traffic.

> Plus, I’d know the reason why choosing UDP? I cannot find any in the 
> draft – but I am sure there are reasons discussed in the group. :-)

This was discussed at IETF 89 and the consensus there was confirmed on the mailing list. See http://www.ietf.org/mail-archive/web/trill/current/msg06206.html
You could look at the minutes at
http://www.ietf.org/proceedings/89/minutes/minutes-89-trill or listen to the audio recording.

Thanks,
Donald
=============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA  [email-masked]

---

From: Caitlin Bestler <[email-masked]>
Date: Tue, 15 Jul 2014 09:49:06 -0700

> http://www.ietf.org/proceedings/89/minutes/minutes-89-trill or listen
Shouldn't that rationale be captured in the draft itself?

---

From: Joe Touch <[email-masked]>
Date: Tue, 15 Jul 2014 09:55:20 -0700

> Shouldn't that rationale be captured in the draft itself?

What rationale? I asked why we needed another "X over IP draft" during 
this email consensus check, and got dead air in response.

Also, apparently the IESG agreed to make this a WG item. I'd recommend 
asking them for their specific rationale too.

Joe

---

From: Caitlin Bestler <[email-masked]>
Date: Tue, 15 Jul 2014 11:30:56 -0700

> asking them for their specific rationale too.

We're in violent agreement here.

At first glance, generic mechanism for tunneling Ethernet should be applicable without the need for any additional RFCs.

If there is a justificatiaon for standardizing a speciallized method of tunneling then the rationale as to why this is superior to generic tunneling should be presented in the draft/RFC itself.

What is not at all clear to me is whether there are special factors that make a distributed L2 campus unified over long-haul L3 tunnels special just because the L2 campus is using Trill.

I'm not violently opposed to such an idea, but I would expect to find a succint justification in-line in the draft .

---

From: Donald Eastlake <[email-masked]>
Date: Tue, 15 Jul 2014 14:45:00 -0400

Hi,

See below.

> 主题: Re: [trill] review of Trill over UDP/IP
...
> [Ning] Then I'd suggest to add reference to [RFC5405] "Unicast UDP Usage Guidelines for Application Designers", which provides several cases in 3.1.3 about whether the UDP tunnel user should consid…

I agree. RFC 5405 is a good reference to include.

Thanks,
Donald