Subject: [trill] question to draft-ietf-trill-active-active-connection-prob-05

From: Linda Dunbar <[email-masked]>
Date: Tue, 15 Jul 2014 22:03:39 +0000

Dear Editors,

A few questions to this draft:

Section 2 second paragraph stated that " TRILL AF provides both per Data Label active-standby traffic spreading and loop avoidance".

TRILL AF requires one and only one appointed RBridge to ingress/egress native frames, so it doesn't provides "traffic spreading", correct?

What is "flow rather than VLAN based load balancing"? does it mean the CE has to  distribute load based on non-VLAN header fields of the packets?

Section 2.1:  What does it mean by "at exactly one edge group RBridge"?
a) The LAALP will deliver a frame from an endnode to TRILL at exactly one edge group RBridge.

Why can't LAALP assume ""these are all the MAC addresses attached""?

Section 3.3: Address Flip-Flop
Why current TRILL switches behave badly when same MAC-SA is associated with different TRILL nicknames? Why can't TRILL switches be configured to allow different TRILL nicknames to be associated with the same MAC-SA?

Section 3.4:
The flooding described in this section is no different from the "flooding" caused by aged out MAC entry in FDB, isn't it?

Thanks,
Linda

---

From: Liyizhou <[email-masked]>
Date: Wed, 16 Jul 2014 01:32:43 +0000

Hi Linda,

Pls see inlines with [yz].

From: trill [mailto:[email-masked]] On Behalf Of Linda Dunbar
Sent: Wednesday, July 16, 2014 6:04 AM
To: [email-masked]
Cc: [email-masked]
Subject: [trill] question to draft-ietf-trill-active-active-connection-prob-05

Dear Editors,

TRILL AF requires one and only one appointed RBridge to ingress/egress native frames, so it doesn't provides "traffic spreading", correct?
[yz] It provides the traffic spreading based on VLAN. E.g. RB1 and RB2 are connected to the same local Ethernet. RB1 may be appointed as AF for VLAN 10 and RB2 appointed as VLAN 11. This is considered as vlan based traffic spreading for traffic  ingressing into TRILL campus.

What is "flow rather than VLAN based load balancing"? does it mean the CE has to  distribute load based on non-VLAN header fields of the packets?
[yz] VLAN based traffic spreading was explained previously. Flow based loading balancing basically talks about the MC-LAG like behaviors. Bundled links have their own way to decide which traffic sends to which member link. Mostly packets from a flow always go through the same link. Therefore traffic injecting to trill campus is considered as flow based spreading among the edge RBridges.
Please refer to section 2.1:
c)The LAALP will attempt to send all frames for a given flow on the
   same uplink. To do this, it has some unknown rule for which frames
   get sent to which  uplinks (typically based on a simple hash function
   of Layer 2 through 4 header fields).

Section 2.1:  What does it mean by "at exactly one edge group RBridge"?
a) The LAALP will deliver a frame from an endnode to TRILL at exactly one edge group RBridge.
[yz] It means a single packet will never be delivered by two or more member links of a single MC-LAG simultaneously.

Section 3.3: Address Flip-Flop
Why current TRILL switches behave badly when same MAC-SA is associated with different TRILL nicknames? Why can't TRILL switches be configured to allow different TRILL nicknames to be associated with the same MAC-SA?
[yz] MAC-nickname correspondence is learned through the data frame received at the data plane. A new learning will replace the old one if source MAC-SA are the same. Current silicon is working in this way.
Different TRILL nicknames to be associated with the same MAC-SA can be implemented using control plane learning by disabling the data plane learning. You may refer to draft-zhang-trill-aa-multi-attach for details.

Section 3.4:
The flooding described in this section is no different from the "flooding" caused by aged out MAC entry in FDB, isn't it?
[yz] Right. The flooding referred here is TRILL campus flooding.

Thanks,
Yizhou

Thanks,
Linda