Subject: [trill] Splitting some material out of draft-ietf-trill-directory-assist-mechanisms

From: Donald Eastlake <[email-masked]>
Date: Fri, 25 Jul 2014 14:52:29 -0400

Hi,

As in the Directory Assist presentation to theTRILL WG earlier this
week, draft-ietf-trill-directory-assist-mechanisms is almost entirely
about specifying how push and pull directories work and communicate on
the wire. However, the current -00 draft has two sections, 4 and 5,
that don't really fit. There was no objection in the room to splitting
out Section 5 most of Section 4 (subsections 4.3, 4.4, and 4.5) into a
separate ARP/ND optimization draft. This message is just to check with
the mailing list on doing that.

Thanks,
Donald
=============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA
 [email-masked]

---

From: Linda Dunbar <[email-masked]>
Date: Tue, 29 Jul 2014 15:21:49 +0000

Donald, 

I agree that Section 5 doesn't really fit. The current content of Section 4.3/4.4/4.5 can be separated to another draft. 
However, we need some text to describe how Directory service is used to eliminate or reduce the ARP/ND traffic across TRILL domain. 

Linda

-----Original Message-----
From: trill [mailto:[email-masked]] On Behalf Of Donald Eastlake
Sent: Friday, July 25, 2014 1:52 PM
To: [email-masked]
Subject: [trill] Splitting some material out of draft-ietf-trill-directory-assist-mechanisms

Hi,

As in the Directory Assist presentation to theTRILL WG earlier this week, draft-ietf-trill-directory-assist-mechanisms is almost entirely about specifying how push and pull directories work and communicate on the wire. However, the current -00 draft has two sections, 4 and 5, that don't really fit. There was no objection in the room to splitting out Section 5 most of Section 4 (subsections 4.3, 4.4, and 4.5) into a separate ARP/ND optimization draft. This message is just to check with the mailing list on doing that.

Thanks,
Donald
=============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA  [email-masked]

_______________________________________________
trill mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/trill

---

From: Donald Eastlake <[email-masked]>
Date: Tue, 29 Jul 2014 14:19:14 -0400

Hi Linda,

> I agree that Section 5 doesn't really fit. The current content of Section 4.3/4.4/4.5 can be separated to another draft.

Thanks.

> However, we need some text to describe how Directory service is used to eliminate or reduce the ARP/ND traffic across TRILL domain.

Yes, some brief summary of 4.3/4.4/4.5 should still be included,
probably in the Introduction, or it could be left in Section 4 which
still has 4.1 and 4.2.

Donald

---

From: Liyizhou <[email-masked]>
Date: Fri, 1 Aug 2014 02:42:42 +0000

Hi Donald and Linda,

I feel it is ok to split out a new draft for ARP optimization.

Original section 4.3-4.5 also covers some events to trigger the updating of Directory too, e.g. gratuitous ARP. So the title "Events That May Cause Directory Use" does not fit all. When we split out the draft, I suggest we clearly describe the two categories, to use and to update.

Thanks,

Yizhou

-----Original Message-----
From: trill [mailto:[email-masked]] On Behalf Of Donald Eastlake
Sent: Wednesday, July 30, 2014 2:19 AM
To: Linda Dunbar
Cc: [email-masked]
Subject: Re: [trill] Splitting some material out of draft-ietf-trill-directory-assist-mechanisms

Hi Linda,

Thanks.

> However, we need some text to describe how Directory service is used to eliminate or reduce the ARP/ND traffic across TRILL domain.

Yes, some brief summary of 4.3/4.4/4.5 should still be included, probably in the Introduction, or it could be left in Section 4 which still has 4.1 and 4.2.

Donald

155 Beaver Street, Milford, MA 01757 USA  [email-masked]<mailto:[email-masked]>

> From: trill [mailto:[email-masked]] On Behalf Of Donald

> Eastlake

> To: [email-masked]<mailto:[email-masked]>

> Subject: [trill] Splitting some material out of

> draft-ietf-trill-directory-assist-mechanisms

>  155 Beaver Street, Milford, MA 01757 USA  [email-masked]<mailto:[email-masked]>

> [email-masked]<mailto:[email-masked]>

trill mailing list

[email-masked]<mailto:[email-masked]>