Subject: [trill] 答复: New Version Notification for draft-hao-trill-irb-05.txt

From: Haoweiguo <[email-masked]>
Date: Wed, 15 Oct 2014 03:31:23 +0000

Hi All,

We have updated the draft of "TRILL Distributed Layer 3 Gateway". 
Comments and suggestions are appreciated.

Thanks
weiguo

________________________________________
发件人: [email-masked] [[email-masked]]
发送时间: 2014年10月15日 11:10
收件人: Andrew Qu; Liyizhou; Xialiang (Frank); Haoweiguo; Muhammad Durrani; Donald E. Eastlake; Liyizhou; Andrew Qu; [email-masked]; Xialiang (Frank); Donald E. Eastlake 3rd; Haoweiguo
主题: New Version Notification for draft-hao-trill-irb-05.txt

A new version of I-D, draft-hao-trill-irb-05.txt
has been successfully submitted by Weiguo Hao and posted to the
IETF repository.

Name:           draft-hao-trill-irb
Revision:       05
Title:          TRILL Distributed Layer 3 Gateway
Document date:  2014-10-15
Group:          Individual Submission
Pages:          20
URL:            http://www.ietf.org/internet-drafts/draft-hao-trill-irb-05.txt
Status:         https://datatracker.ietf.org/doc/draft-hao-trill-irb/
Htmlized:       http://tools.ietf.org/html/draft-hao-trill-irb-05
Diff:           http://www.ietf.org/rfcdiff?url2=draft-hao-trill-irb-05

Abstract:
   Currently TRILL protocol provides optimal pair-wise data frame forwarding
for    layer 2 intra-subnet traffic but not for layer 3 inter-subnet traffic.
A    centralized gateway solution is typically used for layer 3 inter-subnet
traffic    forwarding but has following issues:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Donald Eastlake <[email-masked]>
Date: Wed, 15 Oct 2014 14:41:20 -0400

Note that a presentation was made on this ideas behind this draft at the
last IETF meeting:
http://www.ietf.org/proceedings/90/slides/slides-90-trill-2.pdf

Thanks,
Donald
=============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA
 [email-masked]

On Tue, Oct 14, 2014 at 11:31 PM, Haoweiguo <[email-masked]> wrote:

> 收件人: Andrew Qu; Liyizhou; Xialiang (Frank); Haoweiguo; Muhammad Durrani;
> Donald E. Eastlake; Liyizhou; Andrew Qu; [email-masked]; Xialiang
> (Frank); Donald E. Eastlake 3rd; Haoweiguo
> URL:
> http://www.ietf.org/internet-drafts/draft-hao-trill-irb-05.txt

---

From: Mingui Zhang <[email-masked]>
Date: Fri, 17 Oct 2014 03:41:44 +0000

The distributed gateways can help to increase the scalability and improve the non-optimal forwarding issue. I think this is a good starting point to be worked on. 

Thanks,
Mingui

>-----Original Message-----
>From: trill [mailto:[email-masked]] On Behalf Of Donald Eastlake
>Sent: Thursday, October 16, 2014 2:41 AM
>To: [email-masked]
>Subject: Re: [trill] 答复: New Version Notification for draft-hao-trill-irb-05.txt
>
>Note that a presentation was made on this ideas behind this draft at the last
>IETF meeting:
>	收件人: Andrew Qu; Liyizhou; Xialiang (Frank); Haoweiguo; Muhammad
>Durrani; Donald E. Eastlake; Liyizhou; Andrew Qu; [email-masked];
>Xialiang (Frank); Donald E. Eastlake 3rd; Haoweiguo

---

From: Muhammad Durrani <[email-masked]>
Date: Fri, 17 Oct 2014 01:31:50 -0700

I agree with Andrew – suggested distributed model will solve scale issues as seen with centralized model for ARP/VRRP etc. This is essential for large deployments with massive hosts targeted for scale out fabric.
The proposed draft will help product implementing TRILL based fabric for hyper scale data center.

Regards,
Muhammad

From: Xiaorong (Andrew) Qu [mailto:[email-masked]]
Sent: Friday, October 17, 2014 12:43 AM
To: [email-masked]; [email-masked]
Cc: Li Yizhou; Liang Xia; Weiguo Hao; Muhammad Durrani; Donald E. Eastlake 3rd
Subject: Re: New Version Notification for draft-hao-trill-irb-05.txt

Hi Weiguo,

Thanks a lot.

This distributed gateway proposal helps resolve ARP storm kind of issues, architect is more clean than centralized
model.  solving VRRP scalability issue when centralized model is utilized for large number L2 segments.

Specially when TRILL is used to form network fabric that is more than large L2 network,  distributed gateway
works seemlessly like one system with each interface configured as L3 interface.  To servers,  each L3 interface is
a nature default gateway that is distributed manner.

Andrew

On Tue, Oct 14, 2014 at 8:10 PM, <[email-masked]<mailto:[email-masked]>> wrote:

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

The IETF Secretariat