Subject: Re: [trill] New Version Notification for draft-ietf-trill-irb-03.txt

From: Donald Eastlake <[email-masked]>
Date: Mon, 13 Apr 2015 21:31:59 -0400

Hi,

I did a pass over the document. See attached. Almost entirely
editorial / nits / typos suggestions but I did have one real question.
See my note on page 10, Section 5.3.

Thanks,
Donald
=============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA
 [email-masked]

On Mon, Mar 9, 2015 at 9:15 AM, Haoweiguo <[email-masked]> wrote:
> Hi Folks,
> A new version of TRILL distributed gateway was posted. Main changes:
>  In previous version, an edge RB only advertises one gateway MAC to TRILL campus. In this version,Tenant gateway MAC for each tenant is advertised.
>
> Appreciate any further comments and suggestions.
>
> Thanks,
> weiguo
>
> ________________________________________
> From: [email-masked] [[email-masked]]
> Sent: Monday, March 09, 2015 21:11
> To: Andrew Qu; Liyizhou; Ponkarthick Sivamurugan; Xialiang (Frank); Haoweiguo; Muhammad Durrani; Xialiang (Frank); Ponkarthick Sivamurugan; Liyizhou; Andrew Qu; Muhammad Durrani; Haoweiguo
> Subject: New Version Notification for draft-ietf-trill-irb-03.txt
>
> A new version of I-D, draft-ietf-trill-irb-03.txt
> has been successfully submitted by Weiguo Hao and posted to the
> IETF repository.
>
> Name:           draft-ietf-trill-irb
> Revision:       03
> Title:          TRILL Distributed Layer 3 Gateway
> Document date:  2015-03-09
> Group:          trill
> Pages:          20
> URL:            http://www.ietf.org/internet-drafts/draft-ietf-trill-irb-03.txt
> Status:         https://datatracker.ietf.org/doc/draft-ietf-trill-irb/
> Htmlized:       http://tools.ietf.org/html/draft-ietf-trill-irb-03
> Diff:           http://www.ietf.org/rfcdiff?url2=draft-ietf-trill-irb-03
>
> Abstract:
>    Currently TRILL protocol provides optimal pair-wise data frame
>    forwarding for layer 2 intra-subnet traffic but not for layer 3
>    inter-subnet traffic. A centralized gateway solution is typically
>    used for layer 3 inter-subnet traffic forwarding but has following
>    issues:
>
>
>
>
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
>
> The IETF Secretariat

---

From: Haoweiguo <[email-masked]>
Date: Tue, 14 Apr 2015 02:05:51 +0000

Hi Donald,
Thanks for your detail suggestions. Will check and update it ASAP. As for the question in section 5.3:

[[[ I do not understand the paragraph above. How would RB1, say, learn the “IP Prefix” of IPv4 CE using ARP? ]]]
[weiguo]: My meaning is:  Because RB1 and RB2 are layer 3 gateway for CE1, RB1 and RB2 connect to CE1 through MC-LAG, so RB1 and RB2 will learn CE1's IP through ARP protocol. Then RB1 and RB2 announce the CE1's IP address to other RB to generate IP routing entries. Do you think the explanation is reasonable?

Thanks,
weiguo
________________________________________
From: Donald Eastlake [[email-masked]]
Sent: Tuesday, April 14, 2015 9:31
To: Haoweiguo
Cc: [email-masked]; Muhammad Durrani; Xialiang (Frank); Andrew Qu; Liyizhou; Ponkarthick Sivamurugan
Subject: Re: [trill] New Version Notification for draft-ietf-trill-irb-03.txt

Hi,

Thanks,
Donald