Subject: [trill] I-D Action: draft-ietf-trill-irb-04.txt

From: [email-masked]
Date: Fri, 17 Apr 2015 20:58:40 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Transparent Interconnection of Lots of Links Working Group of the IETF.

        Title           : TRILL Distributed Layer 3 Gateway
        Authors         : Weiguo Hao
                          Yizhou Li
                          Andrew Qu
                          Muhammad Durrani
                          Ponkarthick Sivamurugan
                          Liang Xia
	Filename        : draft-ietf-trill-irb-04.txt
	Pages           : 20
	Date            : 2015-04-17

Abstract:
   Currently TRILL protocol provides optimal pair-wise data frame
   forwarding for layer 2 intra-subnet traffic but not for layer 3
   inter-subnet traffic. A centralized gateway solution is typically
   used for layer 3 inter-subnet traffic forwarding but has
   the following issues:

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-trill-irb/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-trill-irb-04

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-trill-irb-04

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: gayle noble <[email-masked]>
Date: Tue, 21 Apr 2015 17:58:41 -0700

Some things I noticed in draft-ietf-trill-irb-04.txt that I think are 
actual errors::

1.   page 1 and page 2
[There is a question mark after the line containing [Page (number)] 
on pages one and two]
Hao & Li,etc         Expires October 18, 2015              [Page 1]
?
---------------

2.   page 9 third paragraph third sentence
["nickname" should be "nicknames"]
(as written)
If the edge RBridge doesn't specify the nickname, the ingress RBridge 
can use any one of the nickname as egress nickname for inter-subnet 
traffic forwarding.
(should be)
If the edge RBridge doesn't specify the nickname, the ingress RBridge 
can use any one of the nicknames as egress nickname for inter-subnet 
traffic forwarding.

------------------------------
3.   page 10 second paragraph
[sentence awkward with the phrasing "two TRILL RBridges of RB1 and RB2"]
(as written)
   If an ES is connected to two TRILL RBridges of RB1 and RB2 in 
active-active mode, RB1 and RB2 will learn the CE's IP prefix through 
ARP/ND process and then they announce the IP prefix to the TRILL 
campus independently.
(I'd write)
   If an ES is connected to two TRILL RBridges, RB1 and RB2 in 
active-active mode, RB1 and RB2, will learn the CE's IP prefix 
through ARP/ND process and then they announce the IP prefix to the 
TRILL campus independently.
---------------------------------

4.   page 14  TRILL Protocol Extensions second paragraph second sentence
["RBridges" is plural. "It" is singular. "receives" is also singular. 
So I would change "it receives" to "they receive"]
(as written)
These RBridges use the nickname, tenant gateway MAC and tenant Label 
of RB1 to perform inter-subnet traffic TRILL encapsulation when it 
receives inter-subnet traffic from a local ES.
(I'd write)
These RBridges use the nickname, tenant gateway MAC and tenant Label 
of RB1 to perform inter-subnet traffic TRILL encapsulation when they 
receive inter-subnet traffic from a local ES.
---------------------------------

5.   page 14 second paragraph third sentence
[nit pick: the comma is a space after "Inner.MacDA" rather than right after it]
(as written)
  The nickname is used as egress nickname, the tenant gateway MAC is 
used as the Inner.MacDA , and the tenant Data Label is used as the Inner.Label.
(I'd write)
  The nickname is used as egress nickname, the tenant gateway MAC is 
used as the Inner.MacDA, and the tenant Data Label is used as the Inner.Label.
--------------------------

6.   page 15 (second point)
["Label1 and Label2" become plural so :field" should be "fields" and 
add a "the" before Label1 in the second sentence.]
(as written)
        o Length: If Label1 field is used to represent a VLAN, the 
value of the length field is 12. If Label1 and Label2 field are used 
to represent an FGL, the value of the length field is 14.
(I'd write)
        o Length: If Label1 field is used to represent a VLAN, the 
value of the length field is 12. If the Label1 and Label2 fields are 
used to represent an FGL, the value of the length field is 14.
---------------------------

7.   page 15
[I'd put a "the" between "identify" and " higher" and re-write the 
sentence for clarity]
(as written)
  Label1: If the value of length field is 12, the field is to 
identify tenant VLAN ID. If the value of length field is 14, the 
field is to identify higher 12 bits of tenant FGL.
(I'd write)
  Label1: If the value of the length field is 12, it identifies a 
tenant VLAN ID, If the value of the length field is 14, it identifies 
the higher 12 bits of a tenant FGL.
---------------------

8.   page 16
[Instead of a lot of "and"s I'd use a comma]
(as written)
          o Total Length: This 2-byte unsigned integer indicates the 
total length of the Tenant ID and the Prefix Length and Prefix fields 
in octets.
(I'd write)
          o Total Length: This 2-byte unsigned integer indicates the 
total length of the Tenant ID, the Prefix Length, and the Prefix 
fields in octets.
--------------

9.   page 17
[Something as above :) Instead of a lot of "and"s I'd use a comma]
(as written)
          o Total Length: This 2-byte unsigned integer indicates the 
total length of the Tenant ID and the Prefix Length and Prefix fields 
in octets.
(I'd write)
          o Total Length: This 2-byte unsigned integer indicates the 
total length of the Tenant ID, the Prefix Length, and the Prefix 
fields in octets.
--------------

10. Author Addresses
Some emails are labeled Email and some are labeled EMail. Perhaps 
they should all be the same :)

=============
Where I got confused::
page 7:
[I did not know what the M is in the following sentence. I do not see 
M defined anywhere before this statement. In Figure 2, the inner box 
on the left has Virtual Networks (VN) from VN1 through VNm. So, maybe 
the N and M need to be lower case .]
(as written)
Figure 2 depicts the model where there are N VRFs corresponding to N 
tenants with each tenant having up to M segments/subnets (virtual network).
(I'd write)
Figure 2 depicts the model where there are n VRFs corresponding to n 
tenants with each tenant having up to m Virtual Networks (segments/subnets).

---

From: Haoweiguo <[email-masked]>
Date: Thu, 23 Apr 2015 06:06:22 +0000

Thanks Gayle. I will accept all your suggestions except a little change of the 3rd one.

3.   page 10 second paragraph
[sentence awkward with the phrasing "two TRILL RBridges of RB1 and RB2"]
(as written)
  If an ES is connected to two TRILL RBridges of RB1 and RB2 in active-active mode, RB1 and RB2 will learn the CE's IP prefix through ARP/ND process and then they announce the IP prefix to the TRILL campus independently.
(I'd write)
  If an ES is connected to two TRILL RBridges, RB1 and RB2 in active-active mode, RB1 and RB2, will learn the CE's IP prefix through ARP/ND process and then they announce the IP prefix to the TRILL campus independently.
---------------------------------
[weiguo]: I'd wirte:

    If an ES is connected to two TRILL RBridges, RB1 and RB2 in active-active mode, RB1 and RB2 act as distributed layer 3 gateway for the ES, RB1 and RB2 will learn the ES's IP address through ARP/ND process and then they announce the IP address to the TRILL campus independently.

Thanks,

weiguo

________________________________
From: gayle noble [[email-masked]]
Sent: Wednesday, April 22, 2015 8:58
To: [email-masked]
Subject: [trill] Some things I noticed in this document->Re: I-D Action: draft-ietf-trill-irb-04.txt

Some things I noticed in draft-ietf-trill-irb-04.txt that I think are actual errors::

1.   page 1 and page 2
[There is a question mark after the line containing [Page (number)] on pages one and two]
Hao & Li,etc         Expires October 18, 2015              [Page 1]
?
---------------

2.   page 9 third paragraph third sentence
["nickname" should be "nicknames"]
(as written)
If the edge RBridge doesn't specify the nickname, the ingress RBridge can use any one of the nickname as egress nickname for inter-subnet traffic forwarding.
(should be)
If the edge RBridge doesn't specify the nickname, the ingress RBridge can use any one of the nicknames as egress nickname for inter-subnet traffic forwarding.

------------------------------
3.   page 10 second paragraph
[sentence awkward with the phrasing "two TRILL RBridges of RB1 and RB2"]
(as written)
  If an ES is connected to two TRILL RBridges of RB1 and RB2 in active-active mode, RB1 and RB2 will learn the CE's IP prefix through ARP/ND process and then they announce the IP prefix to the TRILL campus independently.
(I'd write)
  If an ES is connected to two TRILL RBridges, RB1 and RB2 in active-active mode, RB1 and RB2, will learn the CE's IP prefix through ARP/ND process and then they announce the IP prefix to the TRILL campus independently.
---------------------------------

4.   page 14  TRILL Protocol Extensions second paragraph second sentence
["RBridges" is plural. "It" is singular. "receives" is also singular. So I would change ?it receives? to ?they receive?]
(as written)
These RBridges use the nickname, tenant gateway MAC and tenant Label of RB1 to perform inter-subnet traffic TRILL encapsulation when it receives inter-subnet traffic from a local ES.
(I'd write)
These RBridges use the nickname, tenant gateway MAC and tenant Label of RB1 to perform inter-subnet traffic TRILL encapsulation when they receive inter-subnet traffic from a local ES.
---------------------------------

5.   page 14 second paragraph third sentence
[nit pick: the comma is a space after "Inner.MacDA" rather than right after it]
(as written)
 The nickname is used as egress nickname, the tenant gateway MAC is used as the Inner.MacDA , and the tenant Data Label is used as the Inner.Label.
(I'd write)
 The nickname is used as egress nickname, the tenant gateway MAC is used as the Inner.MacDA, and the tenant Data Label is used as the Inner.Label.
--------------------------

6.   page 15 (second point)
["Label1 and Label2" become plural so :field" should be "fields" and add a "the" before Label1 in the second sentence.]
(as written)
       o Length: If Label1 field is used to represent a VLAN, the value of the length field is 12. If Label1 and Label2 field are used to represent an FGL, the value of the length field is 14.
(I'd write)
       o Length: If Label1 field is used to represent a VLAN, the value of the length field is 12. If the Label1 and Label2 fields are used to represent an FGL, the value of the length field is 14.
---------------------------

7.   page 15
[I'd put a "the" between "identify" and " higher" and re-write the sentence for clarity]
(as written)
 Label1: If the value of length field is 12, the field is to identify tenant VLAN ID. If the value of length field is 14, the field is to identify higher 12 bits of tenant FGL.
(I'd write)
 Label1: If the value of the length field is 12, it identifies a tenant VLAN ID, If the value of the length field is 14, it identifies the higher 12 bits of a tenant FGL.
---------------------

8.   page 16
[Instead of a lot of "and"s I'd use a comma]
(as written)
         o Total Length: This 2-byte unsigned integer indicates the total length of the Tenant ID and the Prefix Length and Prefix fields in octets.
(I'd write)
         o Total Length: This 2-byte unsigned integer indicates the total length of the Tenant ID, the Prefix Length, and the Prefix fields in octets.
--------------

9.   page 17
[Something as above :) Instead of a lot of "and"s I'd use a comma]
(as written)
         o Total Length: This 2-byte unsigned integer indicates the total length of the Tenant ID and the Prefix Length and Prefix fields in octets.
(I'd write)
         o Total Length: This 2-byte unsigned integer indicates the total length of the Tenant ID, the Prefix Length, and the Prefix fields in octets.
--------------

10. Author Addresses
Some emails are labeled Email and some are labeled EMail. Perhaps they should all be the same :)

=============
Where I got confused::
page 7:
[I did not know what the M is in the following sentence. I do not see M defined anywhere before this statement. In Figure 2, the inner box on the left has Virtual Networks (VN) from VN1 through VNm. So, maybe the N and M need to be lower case .]
(as written)
Figure 2 depicts the model where there are N VRFs corresponding to N tenants with each tenant having up to M segments/subnets (virtual network).
(I'd write)
Figure 2 depicts the model where there are n VRFs corresponding to n tenants with each tenant having up to m Virtual Networks (segments/subnets).