Subject: [trill] corrections draft-ietf-trill-resilient-trees-03

From: gayle noble <[email-masked]>
Date: Tue, 08 Sep 2015 13:01:35 -0700

draft-ietf-trill-resilient-trees-03.txt

acronyms used but not defined::

BFD             Bidirectional Forwarding Detection
CMT             Coordinated Multicast Trees
LSP             Link State Packet
mLDP           Multicast Label Distribution Protocol ??
MPLS           Multi-Protocol Label Switching
PIM 
<https://en.wikipedia.org/wiki/Protocol_Independent_Multicast>Protocol 
Independent Multicast
Td               failure detection timer

(Section 5.2.1).grammar and spelling errors

1.   page 1 abstract: third sentence
["recovergence " should be "reconvergence "]
(as written)
When a link on the distribution tree fails, a campus-wide 
recovergence of this distribution tree will take place, which can be 
time consuming and may cause considerable disruption to the ongoing 
multicast service.
(should be)
When a link on the distribution tree fails, a campus-wide 
reconvergence of this distribution tree will take place, which can be 
time consuming and may cause considerable disruption to the ongoing 
multicast service.

2.   page 1 abstract: second paragraph - second sentence
["recovergence " should be "reconvergence "]
(as written)
Since the backup distribution tree is built up ahead of the link 
failure, when a link on the primary distribution tree fails, the 
pre-installed backup forwarding table will be utilized to deliver 
multicast packets without waiting for the campus-wide recovergence.
(should be)
Since the backup distribution tree is built up ahead of the link 
failure, when a link on the primary distribution tree fails, the 
pre-installed backup forwarding table will be utilized to deliver 
multicast packets without waiting for the campus-wide reconvergence.

3.   page 9 and 10 last paragraph - last sentence
["used" should be "use"]
(as written)
When the backup DT is calculated, each RBridge increases the metric 
of these links by a proper value (for safety, it's recommended to 
used the summation of all original link metrics in the campus but not 
more than 2**23), which gives these links a lower priority being 
chosen by the backup DT by performing Shortest Path First calculation.
(should be)
When the backup DT is calculated, each RBridge increases the metric 
of these links by a proper value (for safety, it's recommended to use 
the summation of all original link metrics in the campus but not more 
than 2**23), which gives these links a lower priority being chosen by 
the backup DT by performing Shortest Path First calculation.

4.   page 13  Global 1:1 Protection: third paragraph - Fifth sentence
["RBridge need to" should be "RBridge needs to" as RBridge is 
singular. And "as response" would read better "as the response"]
(as written)
In [RBmBFD], ingress RBridge need to send BFD control packets to poll 
each receiver, and receivers return BFD control packets to the 
ingress as response.
(should be)
In [RBmBFD], ingress RBridge needs to send BFD control packets to 
poll each receiver, and receivers return BFD control packets to the 
ingress as the response.

5.   page 14 Failure Detection: Point one - second sentence
["Timer Td are" should be "Timer Td is" as Timer Td is singular]
(as written)
A failure detection timer Td are set as the interval between two 
continuous packets.
(should be)
A failure detection timer Td is set as the interval between two 
continuous packets.

6.   page 14 Traffic Forking and Merging: second paragraph - third sentence
["In normal case" should be "In the normal case"]
(as written)
In normal case, egress RBridges activate the primary RPF filter.
(should be)
In the normal case, egress RBridges activate the primary RPF filter.

7.   page 14 Traffic Forking and Merging: second paragraph - forth sentence
["fails, ingress RBridge" should be "fails, the ingress RBridge"]
(as written)
When a link on the pruned primary DT fails, ingress RBridge cannot 
reach some of the receivers.
(should be)
When a link on the pruned primary DT fails, the ingress RBridge 
cannot reach some of the receivers.

8.   page 16 Switching Back to the Primary Distribution Tree #b
["the new backup DT" should be "the new Primary DT"  This section is 
talking about switching to the new primary -- ]
(as written)
   b) For the global 1+1 protection, the ingress RBridge stops
      replicating the multicast packets onto the old backup DT at t1+Ts.
      The backup DT is updated at t1+2*Ts. It MUST wait for another Ts,
      during which time period all RBridges converge to the new backup
      DT. At t1+3*Ts, it's safe for the ingress RBridge start to
      replicate multicast packets onto the new backup DT.
(should be)
   b) For the global 1+1 protection, the ingress RBridge stops
      replicating the multicast packets onto the old backup DT at t1+Ts.
      The backup DT is updated at t1+2*Ts. It MUST wait for another Ts,
      during which time period all RBridges converge to the new backup
      DT. At t1+3*Ts, it's safe for the ingress RBridge start to
      replicate multicast packets onto the new Primary DT.

Grammar tweaks for better readability:

1.   page 10 first paragraph - third sentence
[I'd add a "the" between "by conventional" so the sentence reads smoother]
(as written)
In order to reduce the amount of Affinity Sub-TLVs flooded across the 
campus, only those NOT picked by conventional DT calculation 
process  ought to be recognized as Affinity Links.
(I'd write)
In order to reduce the amount of Affinity Sub-TLVs flooded across the 
campus, only those NOT picked by the conventional DT calculation 
process  ought to be recognized as Affinity Links.

2.   page ten Affinity Links Advertisement: first paragraph - second sentence
[I would add a comma after "Sub-TLV"]
(as written)
When this RBridge plays the role of parent RBridge for several 
Affinity Links,  it is natural to have them advertised together in 
the same Affinity Sub-TLV and each Affinity Link is structured as one 
Affinity Record.
(I'd write)
When this RBridge plays the role of parent RBridge for several 
Affinity Links,  it is natural to have them advertised together in 
the same Affinity Sub-TLV, and each Affinity Link is structured as 
one Affinity Record.

3.   page ten Backup DT Calculation without Affinity Links: third 
paragraph - first sentence
[I'd replace "similar as that" with "similar to that"]
(as written)
The above algorithm is similar as that defined in Section 3.2.1.1.
(I'd write)
The above algorithm is similar to that defined in Section 3.2.1.1.

4.   page 11 Pruning the Backup Distribution Tree: second paragraph - 
first sentence
["is probably that" should probably >*grin*< be "is probable that"]
(as written)
It is probably that the primary DT is not optimally pruned in practice.
(I'd write)
It is probable that the primary DT is not optimally pruned in practice.

5.   page 14 Traffic Forking and Merging: second paragraph - fifth sentence
[I would reword this to make what "it" means exceedingly clear]
(as written)
When these unreachable receivers realize it, they SHOULD update their 
RPF filters to receive packets sent on the backup DT.
(I'd write)
When these unreachable receivers realize the link failed, they SHOULD 
update their RPF filters to receive packets sent on the backup DT.

6.   page 15 An example to walk though: second paragraph - first sentence
["distribution on primary DT" should be "distribution on the primary DT"]
(as written)
In the normal case, multicast frames ingressed by RB7 with pruned 
distribution on primary DT rooted at RB1 are being received by RB9 and RB10.
(I'd write)
In the normal case, multicast frames ingressed by RB7 with pruned 
distribution on the primary DT rooted at RB1 are being received by 
RB9 and RB10.

7.   page 16 first paragraph - last sentence
[Note that in this walk though there are now packets arriving at RB9 
on both the Distribution Tree and the Backup Distribution Tree. RB9 
should drop the packets from the Distribution Tree due to the reverse 
path forwarding check the filters provide that this sentence said RB9 
is now using. YET this description does NOT say the RB9 drops the 
Distribution Tree packets due to the filter. It is making an 
assumption those reading this section will KNOW this. I think it 
should be mentioned.]
(as written)
Multicast packets will finally reach RB9 where the RPF filter is 
updated from {DT=RB1, ingress=RB7, receiving link=RB5-RB9} to 
{DT=RB2, ingress=RB7, receiving link=RB6-RB9}. RB9 will egress the 
multicast packets on to the local link.
  (I'd write)
Multicast packets will finally reach RB9 where the RPF filter is 
updated from {DT=RB1, ingress=RB7, receiving link=RB5-RB9} to 
{DT=RB2, ingress=RB7, receiving link=RB6-RB9}. RB9 will egress the 
multicast packets from the Backup Distribution Tree on to the local 
link and drop those from the Distribution Tree based on the reverse 
path forwarding filter.

---

From: Mingui Zhang <[email-masked]>
Date: Wed, 9 Sep 2015 02:01:13 +0000

Hi Gayle,

Your corrections are much appreciated! Will incorporate them in the next version.

Thanks,
Mingui

From: trill [mailto:[email-masked]] On Behalf Of gayle noble
Sent: Wednesday, September 09, 2015 4:02 AM
To: [email-masked]
Subject: [trill] corrections draft-ietf-trill-resilient-trees-03

PIM             Protocol Independent Multicast<https://en.wikipedia.org/wiki/Protocol_Independent_Multicast>

1.   page 1 abstract: third sentence
["recovergence " should be "reconvergence "]
(as written)
When a link on the distribution tree fails, a campus-wide recovergence of this distribution tree will take place, which can be time consuming and may cause considerable disruption to the ongoing multicast service.
(should be)
When a link on the distribution tree fails, a campus-wide reconvergence of this distribution tree will take place, which can be time consuming and may cause considerable disruption to the ongoing multicast service.

2.   page 1 abstract: second paragraph - second sentence
["recovergence " should be "reconvergence "]
(as written)
Since the backup distribution tree is built up ahead of the link failure, when a link on the primary distribution tree fails, the pre-installed backup forwarding table will be utilized to deliver multicast packets without waiting for the campus-wide recovergence.
(should be)
Since the backup distribution tree is built up ahead of the link failure, when a link on the primary distribution tree fails, the pre-installed backup forwarding table will be utilized to deliver multicast packets without waiting for the campus-wide reconvergence.

3.   page 9 and 10 last paragraph - last sentence
["used" should be "use"]
(as written)
When the backup DT is calculated, each RBridge increases the metric of these links by a proper value (for safety, it's recommended to used the summation of all original link metrics in the campus but not more than 2**23), which gives these links a lower priority being chosen by the backup DT by performing Shortest Path First calculation.
(should be)
When the backup DT is calculated, each RBridge increases the metric of these links by a proper value (for safety, it's recommended to use the summation of all original link metrics in the campus but not more than 2**23), which gives these links a lower priority being chosen by the backup DT by performing Shortest Path First calculation.

4.   page 13  Global 1:1 Protection: third paragraph - Fifth sentence
["RBridge need to" should be "RBridge needs to" as RBridge is singular. And "as response" would read better "as the response"]
(as written)
In [RBmBFD], ingress RBridge need to send BFD control packets to poll each receiver, and receivers return BFD control packets to the ingress as response.
(should be)
In [RBmBFD], ingress RBridge needs to send BFD control packets to poll each receiver, and receivers return BFD control packets to the ingress as the response.

5.   page 14 Failure Detection: Point one - second sentence
["Timer Td are" should be "Timer Td is" as Timer Td is singular]
(as written)
A failure detection timer Td are set as the interval between two continuous packets.
(should be)
A failure detection timer Td is set as the interval between two continuous packets.

7.   page 14 Traffic Forking and Merging: second paragraph - forth sentence
["fails, ingress RBridge" should be "fails, the ingress RBridge"]
(as written)
When a link on the pruned primary DT fails, ingress RBridge cannot reach some of the receivers.
(should be)
When a link on the pruned primary DT fails, the ingress RBridge cannot reach some of the receivers.

["the new backup DT" should be "the new Primary DT"  This section is talking about switching to the new primary -- ]

1.   page 10 first paragraph - third sentence
[I'd add a "the" between "by conventional" so the sentence reads smoother]
(as written)
In order to reduce the amount of Affinity Sub-TLVs flooded across the campus, only those NOT picked by conventional DT calculation process  ought to be recognized as Affinity Links.
(I'd write)
In order to reduce the amount of Affinity Sub-TLVs flooded across the campus, only those NOT picked by the conventional DT calculation process  ought to be recognized as Affinity Links.

2.   page ten Affinity Links Advertisement: first paragraph - second sentence
[I would add a comma after "Sub-TLV"]
(as written)
When this RBridge plays the role of parent RBridge for several Affinity Links,  it is natural to have them advertised together in the same Affinity Sub-TLV and each Affinity Link is structured as one Affinity Record.
(I'd write)
When this RBridge plays the role of parent RBridge for several Affinity Links,  it is natural to have them advertised together in the same Affinity Sub-TLV, and each Affinity Link is structured as one Affinity Record.

3.   page ten Backup DT Calculation without Affinity Links: third paragraph - first sentence
[I'd replace "similar as that" with "similar to that"]
(as written)
The above algorithm is similar as that defined in Section 3.2.1.1.
(I'd write)
The above algorithm is similar to that defined in Section 3.2.1.1.

4.   page 11 Pruning the Backup Distribution Tree: second paragraph - first sentence
["is probably that" should probably >*grin*< be "is probable that"]
(as written)
It is probably that the primary DT is not optimally pruned in practice.
(I'd write)
It is probable that the primary DT is not optimally pruned in practice.

5.   page 14 Traffic Forking and Merging: second paragraph - fifth sentence
[I would reword this to make what "it" means exceedingly clear]
(as written)
When these unreachable receivers realize it, they SHOULD update their RPF filters to receive packets sent on the backup DT.
(I'd write)
When these unreachable receivers realize the link failed, they SHOULD update their RPF filters to receive packets sent on the backup DT.

6.   page 15 An example to walk though: second paragraph - first sentence
["distribution on primary DT" should be "distribution on the primary DT"]
(as written)
In the normal case, multicast frames ingressed by RB7 with pruned distribution on primary DT rooted at RB1 are being received by RB9 and RB10.
(I'd write)
In the normal case, multicast frames ingressed by RB7 with pruned distribution on the primary DT rooted at RB1 are being received by RB9 and RB10.

7.   page 16 first paragraph - last sentence
[Note that in this walk though there are now packets arriving at RB9 on both the Distribution Tree and the Backup Distribution Tree. RB9 should drop the packets from the Distribution Tree due to the reverse path forwarding check the filters provide that this sentence said RB9 is now using. YET this description does NOT say the RB9 drops the Distribution Tree packets due to the filter. It is making an assumption those reading this section will KNOW this. I think it should be mentioned.]
(as written)
Multicast packets will finally reach RB9 where the RPF filter is updated from {DT=RB1, ingress=RB7, receiving link=RB5-RB9} to {DT=RB2, ingress=RB7, receiving link=RB6-RB9}. RB9 will egress the multicast packets on to the local link.
 (I'd write)
Multicast packets will finally reach RB9 where the RPF filter is updated from {DT=RB1, ingress=RB7, receiving link=RB5-RB9} to {DT=RB2, ingress=RB7, receiving link=RB6-RB9}. RB9 will egress the multicast packets from the Backup Distribution Tree on to the local link and drop those from the Distribution Tree based on the reverse path forwarding filter.